self-build-mpg123-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112
  1. %define pkgname mpg123
  2. %define name self-build-%{pkgname}
  3. %define version 1.22.1
  4. %define release 1%{?_dist_release}
  5. %define sourceurl0 http://downloads.sourceforge.net/mpg123/%{pkgname}-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: LGPLv2
  13. Group: Restricted Software
  14. Requires(post): alsa-lib-devel
  15. Requires(post): jack-audio-connection-kit-devel
  16. Requires(post): libtool-ltdl-devel
  17. Requires(post): pulseaudio-libs-devel
  18. Requires(post): self-build-setup >= 0.9.9
  19. BuildArch: noarch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: inagaki
  24. %description
  25. Real time command line MPEG audio player for Layer 1, 2 and Layer3.
  26. If you install this package, it automaticaly downloads source
  27. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  28. And the created rpm packages are automatically installed
  29. if installation is executed by apt-get command or synaptic
  30. package manager.
  31. [Note]
  32. This package requires many other packages to compile
  33. targetsoftware. So it consume more disk space than usual.
  34. Also installation takes logner time because of compilation.
  35. (This will take a few minutes to quarter or half of an hour,
  36. depends on building environment)
  37. [About self-build package]
  38. For some kind of software, distributing of binary package
  39. may viorate the patent or law. Therefore we chose self-build
  40. packge, create binary package on your machine, for such kind
  41. of softwares instead of distributing binary package.
  42. Please obey the national law when you use the created binary
  43. packages. And if you want to use the softwares using patented
  44. thechnology, it may be required to get a permission, make an
  45. agreement or purchas a license. Please consider it with your
  46. purpose or way of use and take appropriate action.
  47. %description -l ja
  48. MPEG-1 レイヤー 1, 2, 3(=MP3) 向けのコマンドライン型 MPEG
  49. オーディオプレイヤーです。
  50. このパッケージをインストールすると、自動的にソースコードを
  51. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  52. パッケージを作成します。
  53. また apt-get コマンドや synaptic パッケージマネージャから実行
  54. した場合は、作成された rpm パッケージのインストールも自動的に
  55. 行います。
  56. [注意]
  57. コンパイルに必要な多くの関連パッケージを要求するので通常より
  58. ディスクの領域を多く消費します。
  59. またインストール時にコンパイルを行うため、通常より時間がかか
  60. る場合があります。(環境にもよりますが数分から数十分程度)
  61. [self-build パッケージについて]
  62. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  63. 違反する可能性があるものがあります。その為、このような問題が
  64. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  65. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  66. ジという方法を採っています。
  67. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  68. アのライセンス、および利用する国の各種法令に従ってください。
  69. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  70. センスの購入などが必要となる場合がありますので、利用する目的
  71. や形態に応じて各自で判断し適切な対応を取ってください。
  72. %prep
  73. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  74. %install
  75. %{__rm} -rf ${RPM_BUILD_ROOT}
  76. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  77. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  78. %clean
  79. %{__rm} -rf ${RPM_BUILD_ROOT}
  80. %posttrans
  81. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 20000
  82. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  83. %{pkgname}-devel-%{version}-%{release}
  84. %files
  85. %defattr(-,root,root)
  86. %{_datadir}/%{name}
  87. %changelog
  88. * Sat Apr 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.22.1-1
  89. - initial bulid for self-build