mariadb-mroonga-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260
  1. %{!?use_system_mysql:%define use_system_mysql 0}
  2. %define mysql_base_version %{__mariadb_base_version}
  3. %define mysql_version %{__mariadb_version}
  4. %define mysql_release %{__mariadb_release}
  5. %define groonga_required_version 4.0.6
  6. Name: mariadb-mroonga
  7. Version: 4.06
  8. Release: 1%{?_dist_release}
  9. Summary: A fast fulltext searchable storage engine for MariaDB.
  10. Group: Applications/Databases
  11. License: LGPLv2.1
  12. URL: http://mroonga.github.com/
  13. Source0: http://github.com/downloads/mroonga/mroonga/mroonga-%{version}.tar.gz
  14. ### the next release may include the follwing patches.
  15. #Patch0: 4a3d6c77a9.patch
  16. #Patch1: 171fa019d4.patch
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
  18. BuildRequires: groonga-devel >= %{groonga_required_version}
  19. BuildRequires: groonga-normalizer-mysql-devel pcre-devel
  20. BuildRequires: mariadb-source
  21. %if "%{?mysql_version}" != ""
  22. Requires: mariadbserver-%{mysql_base_version}
  23. Requires: mariadbclient-%{mysql_base_version}
  24. %endif
  25. Requires: groonga-libs >= %{groonga_required_version}
  26. Requires: groonga-normalizer-mysql
  27. Obsoletes: MySQL-mroonga < 4.00
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. Packager: tomop
  31. %description
  32. Mroonga is a fast fulltext searchable storage plugin for MariaDB.
  33. It is based on groonga that is a fast fulltext search engine and
  34. column store. Groonga is good at real-time update.
  35. %package doc
  36. Summary: Documentation for mroonga
  37. Group: Documentation
  38. License: LGPLv2.1
  39. %description doc
  40. Documentation for mroonga
  41. %prep
  42. %setup -q -n mroonga-%{version}
  43. #%patch0 -p1 -b .private
  44. #%patch1 -p1 -b .LOCK_open
  45. %build
  46. mysql_source=%{_datadir}/mariadb-source/mariadb-%{mysql_version}
  47. %configure --disable-static --with-mysql-source=${mysql_source} \
  48. %{?mroonga_configure_options}
  49. make %{?_smp_mflags}
  50. %install
  51. rm -rf %{buildroot}
  52. make install DESTDIR=%{buildroot}
  53. rm -f %{buildroot}%{_libdir}/mysql/plugin/*.la
  54. mv -f %{buildroot}%{_datadir}/doc/mroonga/ mysql-mroonga-doc/
  55. %clean
  56. rm -rf %{buildroot}
  57. %post
  58. if [ "$1" = 1 ] ; then
  59. /usr/bin/mysql -u root < %{_datadir}/mroonga/install.sql || cat <<EOF
  60. An error occured when to register plugin.
  61. Please run a command below:
  62. /usr/bin/mysql -u root < %{_datadir}/mroonga/install.sql
  63. EOF
  64. fi
  65. %preun
  66. /usr/bin/mysql -u root < %{_datadir}/mroonga/uninstall.sql || cat <<EOF
  67. An error occured when to register plugin.
  68. Please run a command below:
  69. /usr/bin/mysql -u root < %{_datadir}/mroonga/uninstall.sql
  70. EOF
  71. if [ "$1" != 0 ]; then
  72. /usr/bin/mysql -u root < %{_datadir}/mroonga/install.sql || cat <<EOF
  73. An error occured when to register plugin.
  74. Please run a command below:
  75. /usr/bin/mysql -u root < %{_datadir}/mroonga/install.sql
  76. EOF
  77. fi
  78. %files
  79. %defattr(-,root,root,-)
  80. %{_libdir}/mysql/plugin/*
  81. %{_datadir}/man/man1/*
  82. %{_datadir}/man/*/man1/*
  83. %{_datadir}/mroonga
  84. %files doc
  85. %defattr(-,root,root,-)
  86. %doc README COPYING
  87. %doc mysql-mroonga-doc/*
  88. %changelog
  89. * Mon Sep 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.06-1
  90. - new upstream release.
  91. * Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.03-1
  92. - new upstream release.
  93. - removed Patch0 and Patch1.
  94. * Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.01-2
  95. - fixed %%post and %%preun scripts.
  96. * Fri Apr 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.01-1
  97. - new upstream release.
  98. - added Patch0 and Patch1.
  99. * Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.00-2
  100. - rebuilt with mariadb-10.0.9.
  101. * Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.00-1
  102. - new upstream release.
  103. * Wed Dec 18 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.10-2
  104. - added "BR: groonga-normalizer-mysql-devel".
  105. * Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.10-1
  106. - new upstream release.
  107. - built with MariaDB.
  108. * Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.00-1
  109. - new upstream release.
  110. - fixed dates of old %%changelog.
  111. * Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.08-1
  112. - new upstream release.
  113. * Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.06-1
  114. - initial build for Vine Linux.
  115. * Wed Aug 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.06-0
  116. - new upstream release.
  117. - make MySQL spec file name customizable.
  118. - make mroonga configure options customizable.
  119. - add missing mysql-devel BuildRequires. Reported by wing. Thanks!!!
  120. - use MySQL 5.5.27.
  121. * Sun Jul 29 2012 HAYASHI Kentaro <hayashi@clear-code.com> - 2.05-0
  122. - new upstream release.
  123. - use MySQL 5.5.25a.
  124. * Fri Jun 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.04-0
  125. - new upstream release.
  126. - ensure deleting mroonga plugin before install.
  127. Suggested by Kazuhiro Isobe. Thanks!!!
  128. - use MySQL 5.5.25.
  129. * Tue May 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.03-0
  130. - new upstream release.
  131. - use MySQL 5.5.24.
  132. - make mysql_* variables customizable
  133. - require groonga 2.0.3 or later.
  134. * Sun Apr 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.02-0
  135. - new upstream release.
  136. - use MySQL 5.5.23.
  137. - require groonga 2.0.2 or later.
  138. * Thu Mar 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.01-0
  139. - new upstream release.
  140. - ensure plugin is uninstalled by closing all tables use mroonga.
  141. * Wed Feb 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.00-0
  142. - new upstream release.
  143. - always install/uninstall plugin.
  144. - use MySQL 5.1.61 and 5.5.21.
  145. - require groonga 2.0.0 or later.
  146. * Sun Jan 29 2012 Kouhei Sutou <kou@clear-code.com> - 1.20-0
  147. - new upstream release.
  148. - require groonga 1.3.0.
  149. - groonga -> mroonga.
  150. - use MySQL 5.5.20.
  151. * Thu Dec 29 2011 Kouhei Sutou <kou@clear-code.com> - 1.11-0
  152. - new upstream release.
  153. * Sat Oct 29 2011 Kouhei Sutou <kou@clear-code.com> - 1.10-0
  154. - new upstream release.
  155. - groonga storage engine -> mroonga.
  156. * Thu Sep 29 2011 Kouhei Sutou <kou@clear-code.com> - 1.0.0-0
  157. - new upstream release.
  158. * Mon Aug 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.9-0
  159. - new upstream release.
  160. * Fri Jul 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.8-0
  161. - new upstream release.
  162. * Wed Jun 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.7-0
  163. - new upstream release.
  164. * Sun May 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.6-0
  165. - new upstream release.
  166. * Tue May 17 2011 Kouhei Sutou <kou@clear-code.com> - 0.5-2
  167. - use MySQL 5.5.12.
  168. * Tue Mar 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.5-1
  169. - new upstream release.
  170. * Sat Jan 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.4-4
  171. - do not remove plugin on upgrade.
  172. * Wed Jan 12 2011 Kouhei Sutou <kou@clear-code.com> - 0.4-3
  173. - rebuild without debug symbol.
  174. * Thu Dec 30 2010 Kouhei Sutou <kou@clear-code.com> - 0.4-2
  175. - use MySQL 5.5.8-1.
  176. - fix SQL literal notation.
  177. * Mon Nov 29 2010 Kouhei Sutou <kou@clear-code.com> - 0.4-1
  178. - use the latest MySQL.
  179. - new upstream release.
  180. * Sun Nov 21 2010 Kouhei Sutou <kou@clear-code.com> - 0.3-2
  181. - install user define function.
  182. * Fri Oct 29 2010 Kouhei Sutou <kou@clear-code.com> - 0.3-1
  183. - new upstream release.
  184. * Fri Oct 08 2010 Kouhei Sutou <kou@clear-code.com> - 0.2-2
  185. - specify target MySQL version.
  186. - use %{version}.
  187. * Wed Sep 29 2010 Kouhei Sutou <kou@clear-code.com> - 0.2-1
  188. - new upstream release.
  189. * Sun Sep 12 2010 Kouhei Sutou <kou@clear-code.com> - 0.1-3
  190. - require MySQL-client-community.
  191. * Fri Sep 10 2010 Kouhei Sutou <kou@clear-code.com> - 0.1-2
  192. - use MySQL-devel-community.
  193. * Fri Sep 03 2010 Kouhei Sutou <kou@clear-code.com> - 0.1-1
  194. - initial packaging for CentOS.