gpgme-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246
  1. %define _gnupg_ver 1.4.0
  2. %define _libgpg_error_ver 1.4
  3. %define _unpackaged_files_terminate_build 1
  4. Name: gpgme
  5. Summary: GPGME - GnuPG Made Easy
  6. Summary(ja): GPGME - GnuPG Made Easy
  7. Version: 1.13.1
  8. Release: 1%{?_dist_release}
  9. Group: System Environment/Libraries
  10. License: LGPL
  11. URL: https://gnupg.org/software/gpgme/index.html
  12. Source: https://gnupg.org/ftp/gcrypt/gpgme/%{name}-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: gnupg >= %{_gnupg_ver}
  15. BuildRequires: libgpg-error-devel >= %{_libgpg_error_ver}
  16. BuildRequires: libassuan-devel >= 2.0.2
  17. BuildRequires: chrpath
  18. BuildRequires: swig
  19. BuildRequires: python-devel
  20. BuildRequires: python-setuptools
  21. BuildRequires: python-rpm-macros
  22. BuildRequires: python3-devel
  23. BuildRequires: python3-setuptools
  24. BuildRequires: python3-rpm-macros
  25. Requires: gnupg >= %{_gnupg_ver}
  26. Requires: libgpg-error >= %{_libgpg_error_ver}
  27. Obsoletes: gpgme10
  28. Provides: gpgme10
  29. Vendor: Project Vine
  30. Distribution: Vine Linux
  31. %description
  32. GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
  33. for applications. It provides a High-Level Crypto API for encryption,
  34. decryption, signing, signature verification and key management. Currently it
  35. uses GnuPG as it's backend but the API isn't restricted to this engine; in
  36. fact it is planned to add other backends to it.
  37. %description -l ja
  38. GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
  39. るように設計されたライブラリです。暗号化や復号、署名、署名の検証、鍵の管理の
  40. ための高レベルの暗号 API を提供します。
  41. 現在のところ、バックエンドとして GnuPG を使用しますが、API はこのエンジンに限
  42. 定されません。実際、他のバックエンドを追加することが計画されています。
  43. %package devel
  44. Summary: GnuPG Made Easy (GPGME) Header files and libraries for development
  45. Summary(ja): GnuPG Made Easy (GPGME) 開発用ヘッダーファイル・ライブラリ
  46. Group: Development/Libraries
  47. Requires: %{name} = %{version}
  48. Requires: libgpg-error-devel >= 0.5
  49. Requires: libassuan-devel >= 2.0.2
  50. Requires(post): install-info
  51. Requires(preun): install-info
  52. Obsoletes: %{name} < 0.3.16-0vl2
  53. Obsoletes: gpgme10-devel
  54. Provides: gpgme10-devel
  55. %description devel
  56. GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier
  57. for applications.
  58. Install this package if you want to develop applications that will use the
  59. gpgme library.
  60. %description -l ja devel
  61. GnuPG Made Easy (GPGME) は、アプリケーションがより簡単に GnuPG にアクセスでき
  62. るように設計されたライブラリです。
  63. GPGME ライブラリを使用するアプリケーションを開発するのであれば、このパッケー
  64. ジをインストールしてください。
  65. %package -n python-gpg
  66. Summary: %{name} bindings for Python 2
  67. %{?python_provide:%python_provide python2-gpg}
  68. Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
  69. %description -n python-gpg
  70. %{summary}.
  71. %package -n python3-gpg
  72. Summary: %{name} bindings for Python 3
  73. %{?python_provide:%python_provide python3-gpg}
  74. Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
  75. %description -n python3-gpg
  76. %{summary}.
  77. %prep
  78. %setup -q
  79. %build
  80. %configure --disable-gpgsm-test
  81. %__make
  82. %install
  83. %__rm -rf %{buildroot}
  84. %{makeinstall}
  85. # remove unneeded files
  86. %__rm -rf %{buildroot}%{_datadir}/common-lisp
  87. %__rm -f %{buildroot}%{_libdir}/*.la
  88. %__rm -f %{buildroot}%{_infodir}/dir
  89. chrpath -d %{buildroot}%{_bindir}/%{name}-tool
  90. chrpath -d %{buildroot}%{_libdir}/lib%{name}*.so*
  91. # autofoo installs useless stuff for uninstall
  92. rm -vf %{buildroot}%{python2_sitelib}/gpg/install_files.txt
  93. rm -vf %{buildroot}%{python3_sitelib}/gpg/install_files.txt
  94. %clean
  95. %__rm -rf %{buildroot}
  96. %post -p /sbin/ldconfig
  97. %postun -p /sbin/ldconfig
  98. %triggerun -- %{name} < 0.3.16-0vl2
  99. /sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
  100. %post devel
  101. /sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
  102. %preun devel
  103. if [ "$1" = 0 ] ; then
  104. /sbin/install-info --delete %{_infodir}/gpgme.info.gz %{_infodir}/dir
  105. fi
  106. %triggerpostun devel -- %{name} < 0.3.16-0vl2, gpgme10-devel
  107. /sbin/install-info %{_infodir}/gpgme.info.gz %{_infodir}/dir
  108. %files
  109. %defattr(-,root,root)
  110. %license COPYING*
  111. %doc AUTHORS ChangeLog NEWS README* THANKS TODO VERSION
  112. %{_bindir}/gpgme-json
  113. %{_libdir}/libgpgme*.so.*
  114. %files devel
  115. %defattr(-,root,root)
  116. %{_bindir}/gpgme-config
  117. %{_bindir}/gpgme-tool
  118. %{_libdir}/libgpgme*.so
  119. %{_libdir}/cmake/*
  120. %{_libdir}/pkgconfig/*
  121. %{_datadir}/aclocal/gpgme.m4
  122. %{_includedir}/*
  123. %{_infodir}/*
  124. %files -n python-gpg
  125. %doc lang/python/README
  126. %{python_sitearch}/gpg-*.egg-info
  127. %{python_sitearch}/gpg/
  128. %files -n python3-gpg
  129. %doc lang/python/README
  130. %{python3_sitearch}/gpg-*.egg-info
  131. %{python3_sitearch}/gpg/
  132. %changelog
  133. * Thu Mar 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.1-1
  134. - new upstream release.
  135. * Fri Nov 30 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-2
  136. - enabled python{2,3} bindings.
  137. * Mon Nov 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.0-1
  138. - new upstream release.
  139. * Fri Jul 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-1
  140. - new upstream release.
  141. * Tue Apr 5 2011 IWAI, Masaharu <iwai@alib.jp> 1.3.0-1
  142. - new upstream release
  143. - add BuildRequires: libassuan-devel >= 2
  144. - add Requires: libassuan-devel >= 2 for devel subpackage
  145. - update GnuPG min version
  146. * Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.8-1
  147. - new upstream release
  148. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-2vl5
  149. - removed *.la
  150. - spec in utf-8
  151. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.4-1vl5
  152. - applied new versioning policy
  153. * Fri Mar 09 2007 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.1.4-0vl1
  154. - upstream release
  155. - add new macros: %%_gnupg_ver, %%_libgpg_error_ver
  156. - update %%_gnupg_ver to 1.3.0
  157. - update %%_libgpg_error_ver to 1.4
  158. * Tue Sep 27 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.3-0vl1
  159. - upstream release
  160. * Sat Mar 12 2005 KAZUKI SHIMURA <kazukipma.ccnw.ne.jp> 1.0.2-0vl3
  161. - add Obsoletes/Provides: gpgme10{,-devel}
  162. * Sun Feb 13 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  163. - fix spec file's encoding from iso-2022-jp to euc-jp
  164. - add PreReq: ldconfig
  165. - add PreReq: install-info (devel)
  166. - change group to System Environment/Libraries (main)
  167. - add poor Japanese description
  168. * Tue Feb 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  169. - upstream release
  170. - change license from GPL to LGPL
  171. - update {Build,}Requires for GnuPG (>= 1.2.2)
  172. - add (Build)Requires: libgpg-error(-devel) >= 0.5
  173. - add docs
  174. - run ldconfig at post/postun
  175. - separate devel package
  176. - Requires: libgpg-error-devel
  177. - Obsoletes: gpgme <= 0.3.16
  178. * Sun Apr 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.3.16-0vl1
  179. - update to 0.3.16
  180. - s/Copyright/License/
  181. - update URL
  182. * Fri Mar 7 2003 IWAI Masaharu <iwai@alib.jp> 0.3.15-0vl1
  183. - update to 0.3.15
  184. - update {Build,}Requires for GnuPG
  185. * Mon Sep 23 2002 IWAI Masaharu <iwai@alib.jp> 0.3.11-0vl1
  186. - update to 0.3.11
  187. - added {Build,}Requires: gnupg = 1.0.7
  188. - added info files
  189. - added %%post and %%preun section for info files
  190. - fixed %%install section (executing rm command)
  191. * Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.2.1-0vl1
  192. - initial release