gnome-bluetooth-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431
  1. %define _unpackaged_files_terminate_build 1
  2. %global _vpath_srcdir .
  3. %global _vpath_builddir build
  4. %global __global_cflags %{optflags}
  5. %global __global_ldflags ""
  6. Summary: GNOME Bluetooth Subsystem
  7. Summary(ja): GNOME Bluetooth サブシステム
  8. Name: gnome-bluetooth
  9. Version: 3.28.2
  10. Release: 1%{?_dist_release}
  11. License: GPLv2+
  12. Group: System Environment/Libraries
  13. URL: http://live.gnome.org/GnomeBluetooth
  14. Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/3.20/%{name}-%{version}.tar.xz
  15. Source1: 61-gnome-bluetooth-rfkill.rules
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: meson
  18. BuildRequires: bluez-libs-devel >= 2.8
  19. BuildRequires: libbonobo-devel >= 2.32.0
  20. BuildRequires: libbonoboui-devel >= 2.24.4
  21. BuildRequires: unique3-devel
  22. BuildRequires: libnotify-devel
  23. BuildRequires: eudev-libudev-devel
  24. BuildRequires: libcanberra-gtk3-devel
  25. BuildRequires: gnome-doc-utils
  26. BuildRequires: intltool, automake, libtool, gettext
  27. BuildRequires: itstool
  28. Requires: %{name}-libs = %{version}-%{release}
  29. Requires: bluez >= 4.42
  30. Requires: obexd
  31. Requires(post): desktop-file-utils
  32. Requires(postun): desktop-file-utils
  33. ExcludeArch: s390 s390x
  34. Obsoletes: bluez-gnome < 1.9
  35. Obsoletes: nautilus-sendto-gnome-bluetooth < 3.7
  36. # virtual package
  37. Provides: dbus-bluez-pin-helper
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. %description
  41. This package contains a library with widgets for Bluetooth applications.
  42. %description -l ja
  43. このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
  44. ライブラリが含まれます。
  45. %package libs
  46. Summary: Libraries for applications, which use gnome-bluetooth
  47. Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
  48. Group: Development/Libraries
  49. %description libs
  50. This package contains the libraries for applications,
  51. which use gnome-bluetooth.
  52. %description libs -l ja
  53. このパッケージには Gnome-bluetoothを使用するアプリケーション用の
  54. ライブラリが含まれています。
  55. %package devel
  56. Summary: Files for the development of applications, which use gnome-bluetooth
  57. Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
  58. Group: Development/Libraries
  59. License: LGPLv2+
  60. Requires: %{name}-libs = %{version}-%{release}
  61. Requires: pkgconfig
  62. Requires: gtk3-devel
  63. %description devel
  64. This package contains the files for the development of applications,
  65. which will use gnome-bluetooth.
  66. %description devel -l ja
  67. このパッケージにはGnome-bluetoothを使用するアプリケーションを
  68. 開発するためのヘッダーファイルなどが含まれています(develパッケージ)
  69. %prep
  70. %setup -q -n gnome-bluetooth-%{version}
  71. %build
  72. %meson \
  73. -Dicon_update=false \
  74. -Dgtk_doc=true
  75. %meson_build
  76. %install
  77. rm -rf $RPM_BUILD_ROOT
  78. %meson_install
  79. install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
  80. %find_lang gnome-bluetooth2
  81. %clean
  82. rm -rf $RPM_BUILD_ROOT
  83. %post
  84. update-desktop-database -q
  85. %postun
  86. update-desktop-database -q
  87. if [ $1 -eq 0 ] ; then
  88. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  89. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  90. fi
  91. %post libs
  92. /sbin/ldconfig
  93. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  94. %posttrans libs
  95. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  96. %postun libs
  97. /sbin/ldconfig
  98. if [ $1 -eq 0 ] ; then
  99. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  100. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  101. fi
  102. %files -f gnome-bluetooth2.lang
  103. %defattr(-, root, root)
  104. %doc README NEWS COPYING
  105. %{_bindir}/bluetooth-*
  106. %{_datadir}/applications/*.desktop
  107. %{_datadir}/gnome-bluetooth/
  108. %{_mandir}/man1/*
  109. /lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
  110. %files libs
  111. %defattr(-,root,root,-)
  112. %doc COPYING.LIB
  113. %{_libdir}/libgnome-bluetooth.so.*
  114. %{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
  115. %{_datadir}/icons/hicolor/*/apps/*
  116. %{_datadir}/icons/hicolor/*/status/*
  117. %files devel
  118. %defattr(-,root,root,-)
  119. %{_includedir}/gnome-bluetooth/
  120. %{_libdir}/libgnome-bluetooth.so
  121. %{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
  122. %{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
  123. %{_datadir}/gtk-doc/html/gnome-bluetooth/
  124. %changelog
  125. * Fri Dec 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.28.2-1
  126. - new upstream release.
  127. * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.0-1
  128. - new upstream release
  129. * Sun Jan 24 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
  130. - new upstream release
  131. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
  132. - new upstream release
  133. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.0-1
  134. - new upstream release
  135. - add BuildRequires: libcanberra-gtk3-devel
  136. * Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
  137. - new upstream release
  138. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  139. - new upstream release
  140. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
  141. - new upstream release
  142. - add BuildRequires: eudev-libudev-devel
  143. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-2
  144. - rebuild with VineSeed environment
  145. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
  146. - new upstream release
  147. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
  148. - new upstream release
  149. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.0-1
  150. - new upstream release
  151. - remove BuildRequires: nautilus-sendto-devel
  152. * Fri Nov 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
  153. - new upstream release
  154. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
  155. - new upstream release
  156. - add Obsoletes: bluez-gnome < 1.9
  157. - add BuildRequires: itstool
  158. * Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-2
  159. - fix spec file
  160. * Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  161. - new upstream release
  162. * Fri Jun 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  163. - new upstream release
  164. - add BuildRequires: nautilus-sendto-devel
  165. - create nautilus-sendto-gnome-bluetooth package
  166. * Sun Apr 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.0-1
  167. - new upstream release
  168. - remove BuildRequires: GConf2-devel
  169. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
  170. - new upstream release
  171. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  172. - new upstream release
  173. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  174. - new upstream release
  175. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  176. - new upstream release
  177. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  178. - new upstream release
  179. - change BuildRequires: unique3-devel instead of unique-devel
  180. - add BuildRequires: control-center-devel
  181. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  182. - new upstream release
  183. - remove BuildRequires: gir-repository-devel
  184. - add Requires(post) and Requires(postun): desktop-file-utils
  185. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
  186. - rebuild with rpm-4.8.1 for pkg-config file
  187. * Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  188. - new upstream release
  189. - add BuildRequires: gir-repository-devel
  190. - add configure option (--disable-nautilus-sendto)
  191. * Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
  192. - new upstream release
  193. - merge spec file from FC package
  194. * Fri Oct 24 2008 Seiichirou Babasaki 0.11.0-6
  195. - Update to 0.11.0 (VineSeed)
  196. - added "# Maintainers: " comments.
  197. - changed UTF-8 encode at gnome-bluetooth.vsc.spec
  198. - FedoraCore - LOGS
  199. -- 0.11.0-5
  200. -- Rebuild against new bluez-libs
  201. -- 0.11.0-4
  202. -- Changed name of icon file(#444811)
  203. -- 0.11.0-3
  204. -- Remove gnome-obex-server, we should use gnome-user-share now
  205. -- 0.11.0-1
  206. -- gcc43 rebuild
  207. -- 0.11.0 - Update to 0.11.0
  208. -- 0.10.0 - Update to 0.10.0
  209. -- 0.9.1-4
  210. -- marked gnome-obex-server.schemas as config file
  211. -- changed upstream URL
  212. -- 0.9.1-3
  213. -- fixed wrong source URL
  214. -- 0.9.1-2
  215. -- rebuilt for F8
  216. -- changed license tag to GPLv2 and LGPLv2+
  217. -- 0.9.1-1
  218. -- Upgrade to 0.9.1 to fix a crasher in the server
  219. -- 0.9.0-1
  220. -- Update for 0.9.0
  221. -- Fix installation of the python bindings
  222. -- 0.8.0-4
  223. -- Remove unncessary gconfd killing from scripts (#224561)
  224. -- 0.8.0-3
  225. -- corrected BuildRoot
  226. -- smp flags added
  227. -- specfile cleanup
  228. -- fixed desktop file
  229. - Updated specfile
  230. * Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
  231. - Updated specfile
  232. * Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
  233. - Import gnome-bluetooth - Packager: Babasaki
  234. - Updated specfile (downgrade -> 0.8.0-0vl1)
  235. #----------------------------------------------------------------------------
  236. * Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
  237. - version 0.8.0
  238. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
  239. - rebuild
  240. * Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
  241. - bump for new openobex
  242. * Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
  243. - Missing automake, libtool, gettext BR
  244. * Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
  245. - Bump for new libbluetooth
  246. * Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
  247. - add dependency on bluez-utils, cosmetic tweaks (bug #190280)
  248. * Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
  249. - install schemata correctly (bug #193518)
  250. * Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
  251. - more build requires (bug #193374)
  252. * Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
  253. - pydir fixes for lib64
  254. * Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
  255. - version 0.7.0
  256. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
  257. - bump again for double-long bug on ppc(64)
  258. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
  259. - rebuilt for new gcc4.1 snapshot and glibc changes
  260. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  261. - rebuilt
  262. * Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
  263. - Fix relative path for the icons in desktop files which no longer works
  264. with the icon cache.
  265. * Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
  266. - new version 0.6.0
  267. * Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
  268. - rebuild for new cairo
  269. * Thu Jul 7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
  270. - Minor spec file cleanups.
  271. - Fix relative path for the icons in desktop files which no longer works
  272. with the icon cache.
  273. - Remove useless zero epochs.
  274. - Remove explicit python abi requirement, it's automatic for FC4 and up.
  275. * Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
  276. - removed base requirement from libs
  277. * Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
  278. - devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
  279. * Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
  280. - rebuilt
  281. * Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
  282. - added gnome hbox patch for bug rh#149215
  283. * Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
  284. - added requires for python-abi
  285. * Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
  286. - split package into app, libs and devel
  287. * Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
  288. - fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
  289. * Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
  290. - buildrequire pygtk2-devel (bug 135032)
  291. - fixed gnome-bluetooth-manager script for 64bit (bug 134864)
  292. - fixed segfault on file receive (bug 133041)
  293. * Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
  294. - buildrequire libbtctl-devel
  295. - buildrequire openobex-devel >= 1.0.1
  296. - pythondir -> pyexecdir
  297. * Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
  298. - added build dependency for librsvg2-devel
  299. * Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
  300. - added pydir patch
  301. * Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
  302. - version 0.5.1
  303. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  304. - rebuilt
  305. * Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
  306. - corrected BuildRequires
  307. * Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
  308. - added EggToolBar patch for gcc34
  309. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  310. - rebuilt
  311. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  312. - rebuilt
  313. * Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
  314. - added autofoo patch
  315. * Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
  316. - add .so to gnome-vfs module, if libtool does not!
  317. * Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
  318. - call libtool finish
  319. * Wed Aug 6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
  320. - new version 0.4.1
  321. * Thu Jun 5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
  322. - initial RPM