fuse-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261
  1. Summary: File System in Userspace (FUSE) utilities
  2. Summary(ja): ユーザスペースファイルシステム(FUSE)用のユーティリティ
  3. Name: fuse
  4. Version: 2.9.9
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Base
  7. License: GPL
  8. URL: https://github.com/libfuse/libfuse
  9. Source0: https://github.com/libfuse/libfuse/releases/download/fuse-%{version}/fuse-%{version}.tar.gz
  10. Source1: fuse-udev.nodes
  11. Source2: fuse-makedev.d-fuse
  12. Patch0: fuse-udev_rules.patch
  13. Patch1: fuse-openfix.patch
  14. Patch10: fuse-2.8.3-chkconfig.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. Requires(pre): shadow-utils
  17. Requires(post): MAKEDEV
  18. Requires(postun): shadow-utils
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. Packager: daisuke, shaolin
  22. %description
  23. With FUSE it is possible to implement a fully functional filesystem in a
  24. userspace program. This package contains the FUSE userspace tools to
  25. mount a FUSE filesystem.
  26. %description -l ja
  27. FUSE を用いることでユーザ空間のプログラムでファイルシステムを実装することが
  28. 可能になります。このパッケージには FUSEファイルシステムをマウントするための
  29. ユーザ空間ツールが含まれています。
  30. %package devel
  31. Summary: File System in Userspace (FUSE) devel files
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: pkgconfig
  35. License: LGPL
  36. %description devel
  37. With FUSE it is possible to implement a fully functional filesystem in a
  38. userspace program. This package contains development files (headers,
  39. pgk-config) to develop FUSE based applications/filesystems.
  40. %prep
  41. %setup -q
  42. #disable device creation during build/install
  43. sed -i 's|mknod|echo Disabled: mknod |g' util/Makefile.in
  44. %patch0 -b .udev-rules
  45. %patch1 -b .openfix
  46. %patch10 -p1 -b .chkconfig
  47. %build
  48. %configure \
  49. --bindir=/bin \
  50. --libdir=/%{_lib} \
  51. --exec-prefix=/ \
  52. --disable-static \
  53. --disable-kernel-module
  54. make %{?_smp_mflags}
  55. %install
  56. rm -rf $RPM_BUILD_ROOT
  57. make install DESTDIR=$RPM_BUILD_ROOT
  58. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  59. # FIXME change from 60 to 99
  60. install -D -p -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/udev/makedev.d/99-fuse.nodes
  61. install -D -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/makedev.d/z-fuse
  62. # change from 4755 to 0755 to allow stripping -- fixed later in files
  63. chmod 0755 $RPM_BUILD_ROOT/bin/fusermount
  64. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  65. mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
  66. # copmat symlinks
  67. mkdir -p $RPM_BUILD_ROOT%{_bindir}
  68. cd $RPM_BUILD_ROOT%{_bindir}
  69. ln -s /bin/fusermount fusermount
  70. ln -s /bin/ulockmgr_server ulockmgr_server
  71. # drop unneeded initscript
  72. rm -f $RPM_BUILD_ROOT%{_sysconfdir}/init.d/fuse
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75. %preun
  76. if [ -f /etc/init.d/fuse ] ; then
  77. /sbin/service fuse stop >/dev/null 2>&1 ||:
  78. /sbin/chkconfig --del fuse ||:
  79. fi
  80. %post
  81. /sbin/ldconfig
  82. %postun
  83. /sbin/ldconfig
  84. %files
  85. %defattr(-,root,root,-)
  86. %license COPYING COPYING.LIB
  87. %doc AUTHORS ChangeLog FAQ Filesystems NEWS README README.NFS
  88. /sbin/mount.fuse
  89. %attr(4755,root,root) /bin/fusermount
  90. /bin/ulockmgr_server
  91. %{_bindir}/fusermount
  92. %{_bindir}/ulockmgr_server
  93. %{_sysconfdir}/makedev.d/z-fuse
  94. %config %{_sysconfdir}/udev/rules.d/99-fuse.rules
  95. %{_sysconfdir}/udev/makedev.d/99-fuse.nodes
  96. /%{_lib}/libfuse.so.*
  97. /%{_lib}/libulockmgr.so.*
  98. %{_mandir}/man1/fusermount.1.gz
  99. %{_mandir}/man1/ulockmgr_server.1.gz
  100. %{_mandir}/man8/mount.fuse.8.gz
  101. %files devel
  102. %defattr(-,root,root,-)
  103. /%{_lib}/libfuse.so
  104. /%{_lib}/libulockmgr.so
  105. %{_libdir}/pkgconfig/*.pc
  106. %{_includedir}/fuse.h
  107. %{_includedir}/ulockmgr.h
  108. %{_includedir}/fuse
  109. %changelog
  110. * Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.9.9-1
  111. - new upstream release.
  112. * Sun Dec 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.9.3-1
  113. - new upstream release
  114. * Mon Nov 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.2-1
  115. - new upstream release
  116. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.9.1-1
  117. - new upstream release
  118. * Mon Jan 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-1
  119. - new upstream release
  120. * Sat Oct 09 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-1
  121. - new upstream release
  122. - drop fuse group, change fusermount mode to 4755
  123. - move fusermount/ulockmgr_server to /bin
  124. - move libs to /%%{_lib}
  125. - drop unneeded initscript
  126. * Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.3-3
  127. - rebuilt with rpm-4.8.1 for pkg-config
  128. * Sat May 29 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.8.3-2
  129. - fix Patch0 to avoid udev warning (NAME="%k" is superfluous etc.)
  130. - add Patch1 to fix open issue (rhbz #265321)
  131. - add Patch2 for CVE-2009-3297 (rhbz #558833)
  132. * Wed Apr 14 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.3-1
  133. - new upstream release
  134. - remove upstreamed patch10
  135. - add patch10 to support chkconfig
  136. * Mon Mar 1 2010 IWAI, Masaharu <iwai@alib.jp> 2.7.4-3
  137. - SECURITY FIX: CVE-2009-3297
  138. - patch from Debian 5.0 fuse_2.7.4-1.1+lenny1 (Patch10)
  139. * Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-2
  140. - update Source2 and Patch0
  141. - change udev rules to create /dev/fuse with mode 0666, group root.
  142. - do not create fuse group in %%pre
  143. - stop and delete fuse service in %%preun
  144. * Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-1
  145. - new upstream release
  146. - spec in utf-8
  147. * Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.3-1
  148. - new upstream release
  149. * Tue May 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
  150. - new upstream release
  151. * Mon Apr 02 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
  152. - initial build for Vine Linux based on ATrpms package
  153. * Sun Feb 4 2007 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.6.3-0_3
  154. - Update to 2.6.3.
  155. * Thu Feb 1 2007 Axel Thimm <Axel.Thimm@ATrpms.net> - 2.6.2-0_2
  156. - Update to 2.6.2.
  157. * Sun Jan 07 2007 Paulo Roma <roma@lcg.ufrj.br> 2.6.1-1_1
  158. - Adapted for building kernel module.
  159. * Tue Dec 26 2006 Peter Lemenkov <lemenkov@gmail.com> 2.6.1-1
  160. - Ver. 2.6.1
  161. * Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.6.0-2
  162. - fixed nasty typo (see bug #217075)
  163. * Fri Nov 3 2006 Peter Lemenkov <lemenkov@gmail.com> 2.6.0-1
  164. - Ver. 2.6.0
  165. * Sun Oct 29 2006 Peter Lemenkov <lemenkov@gmail.com> 2.5.3-5
  166. - Fixed udev-rule again
  167. * Sat Oct 7 2006 Peter Lemenkov <lemenkov@gmail.com> 2.5.3-4
  168. - Fixed udev-rule
  169. * Tue Sep 12 2006 Peter Lemenkov <lemenkov@gmail.com> 2.5.3-3%{?dist}
  170. - Rebuild for FC6
  171. * Wed May 03 2006 Peter Lemenkov <lemenkov@newmail.ru> 2.5.3-1%{?dist}
  172. - Update to 2.5.3
  173. * Thu Mar 30 2006 Peter Lemenkov <lemenkov@newmail.ru> 2.5.2-4%{?dist}
  174. - rebuild
  175. * Mon Feb 13 2006 Peter Lemenkov <lemenkov@newmail.ru> - 2.5.2-3
  176. - Proper udev rule
  177. * Mon Feb 13 2006 Peter Lemenkov <lemenkov@newmail.ru> - 2.5.2-2
  178. - Added missing requires
  179. * Tue Feb 07 2006 Peter Lemenkov <lemenkov@newmail.ru> - 2.5.2-1
  180. - Update to 2.5.2
  181. - Dropped fuse-mount.fuse.patch
  182. * Wed Nov 23 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.2-1
  183. - Use dist
  184. * Wed Nov 23 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.2-1
  185. - Update to 2.4.2 (solves CVE-2005-3531)
  186. - Update README.fedora
  187. * Sat Nov 12 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.1-3
  188. - Add README.fedora
  189. - Add hint to README.fedora and that you have to be member of the group "fuse"
  190. in the description
  191. - Use groupadd instead of fedora-groupadd
  192. * Fri Nov 04 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.1-2
  193. - Rename packages a bit
  194. - use makedev.d/40-fuse.nodes
  195. - fix /sbin/mount.fuse
  196. - Use a fuse group to restict access to fuse-filesystems
  197. * Fri Oct 28 2005 Thorsten Leemhuis <fedora[AT]leemhuis[DOT]info> - 2.4.1-1
  198. - Initial RPM release.