flex-vl.spec 6.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215
  1. Summary: A tool for creating scanners (text pattern recognizers).
  2. Summary(ja): スキャナ (テキストパターン認識器) 作成ツール
  3. Name: flex
  4. Version: 2.6.4
  5. Release: 1%{?_dist_release}
  6. Group: Development/Tools
  7. License: BSD
  8. URL: https://github.com/westes/flex
  9. Source: https://github.com/westes/flex/releases/download/v%{version}/flex-%{version}.tar.gz
  10. Patch0: flex-rh1389575.patch
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: gettext bison m4 help2man
  13. Requires: m4
  14. Requires(post): /sbin/install-info
  15. Requires(preun): /sbin/install-info
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. %description
  19. The flex program generates scanners. Scanners are programs which can
  20. recognize lexical patterns in text. Flex takes pairs of regular
  21. expressions and C code as input and generates a C source file as
  22. output. The output file is compiled and linked with a library to
  23. produce an executable. The executable searches through its input for
  24. occurrences of the regular expressions. When a match is found, it
  25. executes the corresponding C code. Flex was designed to work with
  26. both Yacc and Bison, and is used by many programs as part of their
  27. build process.
  28. You should install flex if you are going to use your system for
  29. application development.
  30. %description -l ja
  31. flex はスキャナを生成するプログラムです.スキャナとは,
  32. テキストの語彙を認識するプログラムです.flex は正規表現と
  33. C のコードを入力とし,C のソースファイルを出力します.
  34. 出力されたファイルはコンパイルされ,ライブラリとリンクされて
  35. 実行ファイルが作られます.この実行ファイルは入力を調べ,正規表現に
  36. マッチするものがないか探します.もしマッチするものが見付かれば,
  37. 対応する C コードが実行されます.flex は yacc と bison と共に
  38. 動作する様設計されており,多くのプログラムを作成する際に使われます.
  39. アプリケーション開発を行う場合は flex をインストールして下さい.
  40. %prep
  41. %setup -q
  42. %patch0 -p1
  43. autoreconf -ivf
  44. %build
  45. %configure --disable-dependency-tracking CFLAGS="-fPIC $RPM_OPT_FLAGS"
  46. make %{?_smp_mflags}
  47. %install
  48. rm -rf %{buildroot}
  49. make DESTDIR=%{buildroot} install
  50. rm -f %{buildroot}/%{_infodir}/dir
  51. ( cd %{buildroot}
  52. strip .%{_bindir}/flex
  53. ln -sf flex .%{_bindir}/lex
  54. ln -s flex.1 .%{_mandir}/man1/lex.1
  55. ln -s flex.1 .%{_mandir}/man1/flex++.1
  56. ln -s libfl.a .%{_libdir}/libl.a
  57. )
  58. rm -f %{buildroot}%{_libdir}/libfl.so*
  59. rm -f %{buildroot}%{_libdir}/libfl.la
  60. %find_lang %{name}
  61. rm -rf %{buildroot}%{_docdir}/%{name}
  62. %check
  63. echo ============TESTING===============
  64. make check
  65. echo ============END TESTING===========
  66. %clean
  67. rm -rf %{buildroot}
  68. %post
  69. /sbin/install-info %{_infodir}/flex.info.gz --dir-file=%{_infodir}/dir ||:
  70. %preun
  71. if [ $1 = 0 ]; then
  72. /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir ||:
  73. fi
  74. %files -f %{name}.lang
  75. %defattr(-,root,root)
  76. %license COPYING
  77. %doc NEWS README.md
  78. %{_bindir}/*
  79. %{_mandir}/man1/*
  80. %{_libdir}/*.a
  81. %{_includedir}/FlexLexer.h
  82. %{_infodir}/flex.info*
  83. %changelog
  84. * Mon Feb 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.4-1
  85. - updated to 2.6.4.
  86. - dropped Patch0.
  87. - imported Patch0 (flex-rh1389575.patch) from rawhide.
  88. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.5.37-1
  89. - update to 2.5.37
  90. - remove old patches
  91. - add Patch0 (flex-2.5.36-bison-2.6.1.patch) from Fedora
  92. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.35-3
  93. - rebuilt with current VineSeed
  94. - inserted the "-fPIC" on configure command-line and dropt the -fPIC patch.
  95. - removed BR: info
  96. - added Patch0-3 from Fedora
  97. * Tue Jul 13 2010 Petr Machata <pmachata@redhat.com> - 2.5.35-10
  98. - Declare yyget_column and yyset_column in reentrant mode.
  99. - Resolves: #612465
  100. * Mon Apr 20 2009 Debarshi Ray <rishi@fedoraproject.org> - 2.5.35-5
  101. - Resolves: #496548.
  102. * Mon Apr 20 2009 Petr Machata <pmachata@redhat.com> - 2.5.35-4
  103. - Get rid of warning caused by ignoring return value of fwrite() in
  104. ECHO macro. Debian patch.
  105. - Resolves: #484961
  106. * Mon May 12 2008 Petr Machata <pmachata@redhat.com> - 2.5.35-2
  107. - Resolves: #445950
  108. * Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.35-2
  109. - spec in utf-8
  110. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.35-1
  111. - new upstream release
  112. - updated Patch0, dropped Patch1
  113. * Tue Nov 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.33-5vl1
  114. - rebuilt with new toolchains
  115. - updated to 2.5.33 based on Fedora packages
  116. * Fri Mar 30 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-5
  117. - Make yy-prefixed variables available to scanner even with -P.
  118. * Fri Feb 2 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-4
  119. - Use %%find_lang to package locale files.
  120. * Wed Jan 31 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-3
  121. - Compile with -fPIC.
  122. * Fri Jan 19 2007 Petr Machata <pmachata@redhat.com> - 2.5.33-1
  123. - Rebase to 2.5.33
  124. * Sat Jan 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl2
  125. - rebuild with gcc 3.3.6
  126. * Sun Jul 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.5.4a-30vl1
  127. - rebuild with new toolchains
  128. - based on Redhat Rawhide 2.5.4-30
  129. - Mon Nov 4 2002 Than Ngo <than@redhat.com> 2.5.4a-27
  130. - YY_NO_INPUT patch from Jean Marie
  131. - Tue Apr 2 2002 Than Ngo <than@redhat.com> 2.5.4a-23
  132. - More ISO C++ 98 fixes (#59670)
  133. - Wed Feb 20 2002 Bernhard Rosenkraenzer <bero@redhat.com> 2.5.4a-21
  134. - More ISO C++ 98 fixes (#59670)
  135. - s/Copyright/License/
  136. * Mon Feb 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  137. - 2.5.4a-13vl1
  138. - based on 2.5.4a-13 from Rawhide
  139. - use better macros (%%{_tmppath})
  140. - added Japanese summary and description
  141. * Sat Sep 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  142. - Fix generation of broken code (conflicting isatty() prototype w/ glibc 2.2)
  143. This broke, among other things, the kdelibs 2.0 build
  144. - Fix source URL
  145. * Thu Sep 7 2000 Jeff Johnson <jbj@redhat.com>
  146. - FHS packaging (64bit systems need to use libdir).
  147. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  148. - automatic rebuild
  149. * Tue Jun 6 2000 Bill Nottingham <notting@redhat.com>
  150. - rebuild, FHS stuff.
  151. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  152. - handle compressed man pages
  153. * Fri Jan 28 2000 Bill Nottingham <notting@redhat.com>
  154. - add a libl.a link to libfl.a
  155. * Wed Aug 25 1999 Jeff Johnson <jbj@redhat.com>
  156. - avoid uninitialized variable warning (Erez Zadok).
  157. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  158. - auto rebuild in the new build environment (release 6)
  159. * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
  160. - build for 6.0 tree
  161. * Mon Aug 10 1998 Jeff Johnson <jbj@redhat.com>
  162. - build root
  163. * Mon Apr 27 1998 Prospector System <bugs@redhat.com>
  164. - translations modified for de, fr, tr
  165. * Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
  166. - updated from 2.5.4 to 2.5.4a
  167. * Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
  168. - built against glibc
  169. * Thu Mar 20 1997 Michael Fulbright <msf@redhat.com>
  170. - Updated to v. 2.5.4