bash-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604
  1. %define bashversion 5.0
  2. %define patchlevel 16
  3. Summary: The GNU Bourne Again shell (bash).
  4. Summary(ja): GNU Bourne Again シェル (bash).
  5. Name: bash
  6. Version: %{bashversion}.%{patchlevel}
  7. Release: 1%{?_dist_release}
  8. Group: System Environment/Shells
  9. License: GPLv3+
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. Packager: daisuke
  13. Source0: http://ftp.gnu.org/pub/gnu/bash/bash-%{bashversion}.tar.gz
  14. Source10: bashrc-vine
  15. # Official upstream patches
  16. Patch1: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-001
  17. Patch2: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-002
  18. Patch3: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-003
  19. Patch4: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-004
  20. Patch5: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-005
  21. Patch6: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-006
  22. Patch7: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-007
  23. Patch8: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-008
  24. Patch9: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-009
  25. Patch10: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-010
  26. Patch11: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-011
  27. Patch12: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-012
  28. Patch13: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-013
  29. Patch14: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-014
  30. Patch15: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-015
  31. Patch16: http://ftp.gnu.org/gnu/bash/bash-5.0-patches/bash50-016
  32. # Other patches
  33. #Patch101: bash-2.02-security.patch
  34. Patch102: bash-2.03-paths.patch
  35. Patch103: bash-2.03-profile.patch
  36. Patch104: bash-2.05a-interpreter.patch
  37. Patch105: bash-2.05b-debuginfo.patch
  38. #Patch106: bash-2.05b-manso.patch
  39. Patch107: bash-2.05b-pgrp_sync.patch
  40. #Patch108: bash-2.05b-readline-oom.patch
  41. #Patch109: bash-2.05b-xcc.patch
  42. Patch110: bash-3.2-audit.patch
  43. Patch111: bash-3.2-ssh_source_bash.patch
  44. #Patch112: bash-bashbug.patch
  45. Patch113: bash-infotags.patch
  46. Patch114: bash-requires.patch
  47. Patch115: bash-setlocale.patch
  48. Patch116: bash-tty-tests.patch
  49. # 484809, check if interp section is NOBITS
  50. Patch117: bash-4.0-nobits.patch
  51. # Do the same CFLAGS in generated Makefile in examples
  52. Patch118: bash-4.1-examples.patch
  53. # Builtins like echo and printf won't report errors
  54. # when output does not succeed due to EPIPE
  55. Patch119: bash-4.1-broken_pipe.patch
  56. # Enable system-wide .bash_logout for login shells
  57. Patch120: bash-4.2-rc2-logout.patch
  58. # Static analyzis shows some issues in bash-2.05a-interpreter.patch
  59. Patch121: bash-4.2-coverity.patch
  60. # Don't call malloc in signal handler
  61. #Patch122: bash-4.1-defer-sigchld-trap.patch
  62. # 799958, updated info about trap
  63. Patch123: bash-4.2-manpage_trap.patch
  64. # https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  65. Patch125: bash-4.2-size_type.patch
  66. # 1112710 - mention ulimit -c and -f POSIX block size
  67. Patch128: bash-4.3-man-ulimit.patch
  68. # A series of patches emitted by upstream since 4.3-18
  69. #Patch134: bash-4.3-pathexp-globignore-delim.patch
  70. # 1102815 - fix double echoes in vi visual mode
  71. Patch135: bash-4.3-noecho.patch
  72. # 1182278 - bash crashes on `select' if REPLY is readonly
  73. #Patch137: bash-4.3-select-readonly.patch
  74. #1241533,1224855 - bash leaks memory when LC_ALL set
  75. Patch138: bash-4.3-memleak-lc_all.patch
  76. #1245233 - old memleak reappeared, taken from upstream
  77. #Patch139: bash-4.3-old-memleak.patch
  78. # bash-4.4 builds loadable builtin examples by default
  79. # this patch disables it
  80. Patch140: bash-4.4-no-loadable-builtins.patch
  81. Buildroot: %{_tmppath}/%{name}-%{version}-root
  82. BuildRequires: texinfo, bison, ncurses-devel, autoconf, gettext
  83. Obsoletes: bash <= 1.14.7
  84. Obsoletes: bash2
  85. %description
  86. Bash is a GNU project sh-compatible shell or command language
  87. interpreter. Bash (Bourne Again shell) incorporates useful features
  88. from the Korn shell (ksh) and the C shell (csh). Most sh scripts
  89. can be run by bash without modification.
  90. Bash offers several improvements over sh, including command line
  91. editing, unlimited size command history, job control, shell
  92. functions and aliases, indexed arrays of unlimited size and
  93. integer arithmetic in any base from two to 64. Bash is ultimately
  94. intended to conform to the IEEE POSIX P1003.2/ISO 9945.2 Shell and
  95. Tools standard.
  96. %package doc
  97. Summary: Documentation for the GNU Bourne Again shell (bash).
  98. Summary(ja): GNU Bourne Again シェル向けドキュメント
  99. Group: Applications/Documentation
  100. Requires: %{name} = %{version}-%{release}
  101. Obsoletes: bash2-doc
  102. %description doc
  103. This is a separate documentation package for the GNU Bourne
  104. Again shell.
  105. %prep
  106. %setup -q -n %{name}-%{bashversion}
  107. # Official upstream patches
  108. %patch1 -p0 -b .001
  109. %patch2 -p0 -b .002
  110. %patch3 -p0 -b .003
  111. %patch4 -p0 -b .004
  112. %patch5 -p0 -b .005
  113. %patch6 -p0 -b .006
  114. %patch7 -p0 -b .007
  115. %patch8 -p0 -b .008
  116. %patch9 -p0 -b .009
  117. %patch10 -p0 -b .010
  118. %patch11 -p0 -b .011
  119. %patch12 -p0 -b .012
  120. %patch13 -p0 -b .013
  121. %patch14 -p0 -b .014
  122. %patch15 -p0 -b .015
  123. %patch16 -p0 -b .016
  124. # Other patches
  125. %patch102 -p1 -b .paths
  126. %patch103 -p1 -b .profile
  127. %patch104 -p1 -b .interpreter
  128. %patch105 -p1 -b .debuginfo
  129. %patch107 -p1 -b .pgrp_sync
  130. %patch110 -p1 -b .audit
  131. %patch111 -p1 -b .ssh_source_bash
  132. %patch113 -p1 -b .infotags
  133. %patch114 -p1 -b .requires
  134. %patch115 -p1 -b .setlocale
  135. %patch116 -p1 -b .tty_tests
  136. %patch117 -p1 -b .nobits
  137. %patch118 -p1 -b .examples
  138. %patch119 -p1 -b .broken_pipe
  139. %patch120 -p1 -b .logout
  140. %patch121 -p1 -b .coverity
  141. %patch123 -p1
  142. %patch125 -p1 -b .size_type
  143. %patch128 -p1 -b .ulimit
  144. %patch135 -p1 -b .noecho
  145. %patch138 -p1 -b .lc_all
  146. %patch140 -p1 -b .no_loadable_builtin
  147. echo %{version} > _distribution
  148. echo %{release} |sed 's/vl.*//' > _patchlevel
  149. %build
  150. %configure --with-bash-malloc=no
  151. make CPPFLAGS="-D_GNU_SOURCE -DRECYCLES_PIDS `getconf LFS_CFLAGS`"
  152. %install
  153. rm -rf %{buildroot}
  154. # Fix bug #83776
  155. perl -pi -e 's,bashref\.info,bash.info,' doc/bashref.info
  156. make DESTDIR=$RPM_BUILD_ROOT install
  157. pushd $RPM_BUILD_ROOT
  158. mkdir ./bin
  159. mv ./usr/bin/bash ./bin/bash
  160. ln -s bash ./bin/sh
  161. rm -f .%{_infodir}/dir
  162. popd
  163. ln -s bash.1 %{buildroot}%{_mandir}/man1/sh.1
  164. # make manpages for bash builtins as per suggestion in DOC/README
  165. pushd doc
  166. sed -e '
  167. /^\.SH NAME/, /\\- bash built-in commands, see \\fBbash\\fR(1)$/{
  168. /^\.SH NAME/d
  169. s/^bash, //
  170. s/\\- bash built-in commands, see \\fBbash\\fR(1)$//
  171. s/,//g
  172. b
  173. }
  174. d
  175. ' builtins.1 > man.pages
  176. for i in echo pwd test kill; do
  177. perl -pi -e "s,$i,,g" man.pages
  178. perl -pi -e "s, , ,g" man.pages
  179. done
  180. install -c -m 644 builtins.1 %{buildroot}%{_mandir}/man1/builtins.1
  181. for i in `cat man.pages` ; do
  182. echo .so man1/builtins.1 > %{buildroot}%{_mandir}/man1/$i.1
  183. chmod 0644 ${RPM_BUILD_ROOT}%{_mandir}/man1/$i.1
  184. done
  185. mkdir -p $RPM_BUILD_ROOT/etc/profile.d/
  186. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/bashrc
  187. # Not for printf, false and true (conflict with coreutils)
  188. rm -f $RPM_BUILD_ROOT%{_mandir}/man1/printf.1
  189. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/true.1
  190. rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/false.1
  191. popd
  192. %find_lang %{name}
  193. rm -rf $RPM_BUILD_ROOT/%{_docdir}/bash
  194. %clean
  195. rm -rf %{buildroot}
  196. # ***** bash doesn't use install-info. It's always listed in %{_infodir}/dir
  197. # to prevent prereq loops
  198. # post is in lua so that we can run it without any external deps. Helps
  199. # for bootstrapping a new install.
  200. # Jesse Keating 2009-01-29 (code from Ignacio Vazquez-Abrams)
  201. %post -p <lua>
  202. bashfound = false;
  203. shfound = false;
  204. f = io.open("/etc/shells", "r");
  205. if f == nil
  206. then
  207. f = io.open("/etc/shells", "w");
  208. else
  209. repeat
  210. t = f:read();
  211. if t == "/bin/bash"
  212. then
  213. bashfound = true;
  214. end
  215. if t == "/bin/sh"
  216. then
  217. shfound = true;
  218. end
  219. until t == nil;
  220. end
  221. f:close()
  222. f = io.open("/etc/shells", "a");
  223. if not bashfound
  224. then
  225. f:write("/bin/bash\n")
  226. end
  227. if not shfound
  228. then
  229. f:write("/bin/sh\n")
  230. end
  231. f:close()
  232. %files -f %{name}.lang
  233. %defattr(-,root,root)
  234. %license COPYING
  235. %doc CHANGES
  236. %doc examples
  237. %config(noreplace) /etc/bashrc
  238. /bin/bash
  239. /bin/sh
  240. %{_infodir}/bash.info*
  241. %{_mandir}/*/*
  242. %{_mandir}/*/..1*
  243. %{_bindir}/bashbug
  244. %files doc
  245. %defattr(-,root,root)
  246. %doc COMPAT NEWS NOTES POSIX RBASH
  247. %doc examples/functions/ examples/misc/
  248. %doc examples/scripts*/
  249. %doc examples/startup-files/ examples/complete/ examples/loadables/
  250. %doc doc/*.ps doc/*.0 doc/*.html doc/article.txt
  251. %doc doc/FAQ doc/INTRO doc/article.ms doc/README
  252. %changelog
  253. * Sat Feb 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.16-1
  254. - updated to 5.0 patch level 16.
  255. * Thu Sep 12 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.11-1
  256. - updated to 5.0 patch level 11.
  257. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.9-1
  258. - updated to 5.0 patch level 9.
  259. - dropped Patch101, 106, 108, 109, 112, 122, 134, 137 and 139.
  260. - imported Patch140 from rawhide.
  261. * Tue Jul 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.46-1
  262. - updated to 4.3 patch level 46.
  263. * Sat Sep 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.42-1
  264. - updated to 4.3 patch level 42.
  265. - imported patch 128-139 from RawHide.
  266. * Fri Oct 3 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.29-1
  267. - updated to 4.3 patch level 29.
  268. - removed patch1000 (included in 4.3.26).
  269. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-2
  270. - added patch1000 to fix CVE-2014-7169.
  271. * Thu Sep 25 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.25-1
  272. - updated to 4.3 patch level 25.
  273. * Tue Jun 10 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.18-1
  274. - update to 4.3 patch level 18
  275. * Wed May 14 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3.11-1
  276. - update to 4.3 patch level 11
  277. * Mon Mar 18 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.45-1
  278. - update to 4.2 patch level 45
  279. - import some patch from fedora package (122-127)
  280. - patch122: Don't call malloc in signal handler
  281. - patch123: #799958, updated info about trap
  282. - patch124: #695656, block the signal and unblock it after the
  283. new handler is installed
  284. - patch125: Use unsigned type for size
  285. https://www.securecoding.cert.org/confluence/display/seccode/INT32-C.+Ensure+that+operations+on+signed+integers+do+not+result+in+overflow
  286. - patch126: #903833, Fix missing close(), fixes fd leaks
  287. * Sat Oct 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.37-2
  288. - remove postun lua script because bash will be never uninstalled
  289. * Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.37-1
  290. - update to 4.2 patch level 37
  291. * Fri Feb 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.20-1
  292. - update to 4.2 patch level 20
  293. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.8-1
  294. - update to 4.2 patch level 8
  295. - use lua script in post/postun
  296. - update patches from fedora
  297. * Fri Sep 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  298. - update to 4.1 patch level 7
  299. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-9
  300. - check if /bin/grep exists on %%post script
  301. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-8
  302. - rebuilt with gcc-4.4.3-3 on ppc
  303. * Tue Feb 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-7
  304. - rebuilt with new toolchain
  305. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-6
  306. - revert changes on 3.2-5 (avoid a nasty dependency loop on bootstrapping)
  307. * Fri Dec 4 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-5
  308. - add Requires(post): grep
  309. * Sat Oct 24 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 3.2-4
  310. - remove obsolete /bin/bash2 entry from /etc/shells
  311. * Mon Apr 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-3
  312. - add Requires(post): ncurses (should be added by find-requires..)
  313. * Sun Mar 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-2
  314. - add upstream patch (from 040 to 048)
  315. - build against ncurses-devel (libtinfo)
  316. - spec in utf-8
  317. * Mon May 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.2-1vl5
  318. - added upstream patch (from 026 to 039)
  319. - added Japanese summary
  320. - applied new versioning policy
  321. * Fri Jan 18 2008 Shu KONNO <owa@bg.wakwak.com> 3.2-0vl2
  322. - rebuilt with libtermcap-devel
  323. * Fri Oct 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2-0vl1
  324. - new upstream release
  325. - add upstream patch (from 001 to 025)
  326. - remove Provides: bash2
  327. * Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.05b-0vl4
  328. - rebuilt with new toolchain
  329. * Mon Sep 11 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.05b-0vl3
  330. - change doc Group to Applications/Documentation. <BTS:VineLinux:163>
  331. - quote CPPFLAGS to avoid configure error. <BTS:VineLinux:173>
  332. * Mon Jun 28 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05b-0vl2
  333. - Don't read /etc/profile.d/*.sh in /etc/bashrc; done in /etc/profile
  334. * Wed Mar 10 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.05b-0vl1
  335. - update to 2.05b
  336. - rebuild with new toolchains
  337. - add make check
  338. - add %postun script based on Fedora development
  339. - README file moved doc package
  340. - update Patch5 and Patch8 from Fedora development
  341. - change Patch6
  342. - remove Patch2 and Patch100 (bash-2.05b supports multibyte string)
  343. - add Patch11--39 from Fedora development 2.05b-36
  344. * Tim Waugh <twaugh@redhat.com>
  345. - Fix parameter expansion in multibyte locales (bug #112657).
  346. - Speed up UTF-8 command-line redrawing in the common case (bug #102353,
  347. bug #110777).
  348. - Apply upstream patches (bug #109269 among others).
  349. - Fix bash.info (bug #83776).
  350. - Add bash205b-007 patch to fix bug #106876.
  351. - Avoid crashing on multibyte input when locale is set incorrectly
  352. (bug #74266).
  353. - LFS support (bug #103627).
  354. - Fix completion display when multibyte or control characters are to be
  355. shown (bug #90201).
  356. - Fix a warning message (bug #79629).
  357. - Don't build with AFS support (bug #86514).
  358. - Don't explicitly strip binaries (bug #85995).
  359. - Really fix bug #83331 for good.
  360. - Fix builtins.1.
  361. - Actually apply the patch (bug #83331).
  362. - Fix history/UTF-8 bug (bug #83331).
  363. - More tab-completion fixing (bug #72512).
  364. - Force pgrp synchronization (bug #81653).
  365. - Prevent prompt overwriting output (bug #74383).
  366. - Fix '-rbash' (bug #78455).
  367. - Add readline-init patch (bug #74925).
  368. - Add the (4) patches from ftp.gnu.org (bug #75888, bug #72512).
  369. - Ship '.' man page, which doesn't get picked up by glob.
  370. - Locale shell variables fix (bug #74701).
  371. * Elliot Lee <sopwith@redhat.com>
  372. - (patch26) Don't call 'size' in makefile. Pointless, and interferes with
  373. cross compiles.
  374. * Wed Oct 9 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.05-0vl1
  375. - update to 2.05
  376. - add README.jpatch to %doc
  377. - remove patch4 (bash2): revert command name in man pages to "bash"
  378. - fix perl command to remove man pages conflict with sh-utils
  379. - remove section of config.h.in from patch0 to prevent remake of configure
  380. - change patch9: define in config-top.h to avoid conflict with patch100
  381. - remove patches 7, 10 & 101
  382. * Mon Apr 8 2002 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 2.04-1vl14
  383. - made a link for man sh
  384. * Thu Nov 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.04-1vl13
  385. - added missing %%post and %%triggerpostun section
  386. * Sun Jul 15 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  387. - 2.04-1vl12
  388. - now bash2 is finally bash
  389. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.04-1vl11
  390. - build for Playstation2
  391. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  392. - 2.04-1vl10
  393. - Provides: bash = %%{version}
  394. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl9
  395. - added Provides: bash
  396. * Thu Jun 07 2001 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl8
  397. - Obsoletes: bash
  398. - changed Copyright to License
  399. * Fri Dec 29 2000 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  400. - 2.04-1vl7
  401. - deleted: /etc/profile.d/alias.sh (which we have in /etc/skel/.bashrc)
  402. - corrected: bashrc-vine -> bashrc
  403. * Sat Dec 16 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl6
  404. - combined bash-1.x and bash-2.x packages
  405. - added some patches from bash-2.04-13mdk
  406. * Sun Dec 10 2000 Jun Nishii <jun@vinelinux.org> 2.04-1vl5
  407. - fix spec macros
  408. - added tests
  409. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.04-1vl5
  410. - build with gcc-2.95.3
  411. - partially used rpmmacros
  412. * Fri Sep 8 2000 Jun Nishii <jun@vinelinux.org>
  413. - minor bug fix in spec file
  414. * Sun Aug 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  415. - 2.04-1vl3
  416. - modified %install and %files section to handle compressed man page(s)
  417. * Thu Mar 23 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  418. - added pcomplete patch to fix complete if the candidate list is NULL.
  419. * Wed Mar 22 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  420. - updated to 2.04
  421. * Tue Sep 14 1999 Dale Lovelace <dale@redhat.com>
  422. - Remove annoying ^H's from documentation
  423. * Fri Jul 16 1999 Ken Estes <kestes@staff.mail.com>
  424. - patch to detect what executables are required by a script.
  425. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  426. - auto rebuild in the new build environment (release 4)
  427. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  428. - strip binaries.
  429. - include bash-doc correctly.
  430. * Thu Mar 18 1999 Preston Brown <pbrown@redhat.com>
  431. - fixed post/postun /etc/shells work.
  432. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  433. - updated again text in the spec file
  434. * Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
  435. - updated text in spec file.
  436. - update to 2.03.
  437. * Fri Feb 12 1999 Cristian Gafton <gafton@redhat.com>
  438. - build it as bash2 instead of bash
  439. * Tue Feb 9 1999 Bill Nottingham <notting@redhat.com>
  440. - set 'NON_INTERACTIVE_LOGIN_SHELLS' so profile gets read
  441. * Thu Jan 14 1999 Jeff Johnson <jbj@redhat.com>
  442. - rename man pages in bash-doc to avoid packaging conflicts (#606).
  443. * Wed Dec 02 1998 Cristian Gafton <gafton@redhat.com>
  444. - patch for the arm
  445. - use $RPM_ARCH-redhat-linux as the build target
  446. * Tue Oct 6 1998 Bill Nottingham <notting@redhat.com>
  447. - rewrite %pre, axe %postun (to avoid prereq loops)
  448. * Wed Aug 19 1998 Jeff Johnson <jbj@redhat.com>
  449. - resurrect for RH 6.0.
  450. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  451. - update to 2.02.1
  452. * Thu Jun 11 1998 Jeff Johnson <jbj@redhat.com>
  453. - Package for 5.2.
  454. * Mon Apr 20 1998 Ian Macdonald <ianmacd@xs4all.nl>
  455. - added POSIX.NOTES doc file
  456. - some extraneous doc files removed
  457. - minor .spec file changes
  458. * Sun Apr 19 1998 Ian Macdonald <ianmacd@xs4all.nl>
  459. - upgraded to version 2.02
  460. - Alpha, MIPS & Sparc patches removed due to lack of test platforms
  461. - glibc & signal patches no longer required
  462. - added documentation subpackage (doc)
  463. * Fri Nov 07 1997 Donnie Barnes <djb@redhat.com>
  464. - added signal handling patch from Dean Gaudet <dgaudet@arctic.org> that
  465. is based on a change made in bash 2.0. Should fix some early exit
  466. problems with suspends and fg.
  467. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  468. - added %clean
  469. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  470. - added comment explaining why install-info isn't used
  471. - added mips patch
  472. * Fri Oct 17 1997 Donnie Barnes <djb@redhat.com>
  473. - added BuildRoot
  474. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  475. - built against glibc