VFlib-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define version 2.25.6
  3. %define release 0vl2
  4. %define vfontcaps vine-vfontcaps-3.0
  5. %define fortest fortest-1.1
  6. Summary: Vector Font Library
  7. Summary(ja): ベクトルフォント・ライブラリ
  8. Name: VFlib
  9. Version: %{version}
  10. Release: %{release}
  11. Group: System Environment/Libraries
  12. License: GPL
  13. URL: http://typehack.aial.hiroshima-u.ac.jp/VFlib/
  14. Source0: ftp://TypeHack.aial.hiroshima-u.ac.jp/pub/TypeHack/VFlib2-2.25.6.tar.gz
  15. Source1: %{vfontcaps}.tar.bz2
  16. Source2: install-sh
  17. Source3: config.sub
  18. Source4: %{fortest}.tar.gz
  19. Patch9: VFlib2-2.25.6-gcc33.patch
  20. Patch20: VFlib2-2.25.6-config.sub-x86_64.patch
  21. Patch21: VFlib2-2.25.6-ltconfig-compat32.patch
  22. BuildPreReq: freetype-devel >= 1.2, XFree86-devel
  23. Requires: freetype >= 1.2, TrueTypeFonts_jp
  24. Buildroot: %{_tmppath}/%{name}-%{version}-root
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. %description
  28. A package of VFlib, a library to use vector fonts. It is used by xdvi,
  29. GhostScript, etc...
  30. %description -l ja
  31. ベクタフォントを利用するためのライブラリVFlib の日本語対応版です。
  32. xdvi, Ghostscript 等で利用されます。
  33. %package utils
  34. Summary: Several utilities to manipulate and examine VFlib.
  35. Summary(ja): VFlib を操作したり実行したりするユーティリティ集
  36. Group: Applications/Publishing
  37. Requires: XFree86-libs
  38. %description utils
  39. This package contains several utilities which allow you to manupulate
  40. VFlib. They are mainly useful for debugging and testing purposes,
  41. and are not required for using the VFlib.
  42. %description utils -l ja
  43. このパッケージには、VFlib を操作したり実行したりするユーティリティが
  44. いくつか含まれています。デバッグやテストに便利ですが、VFlib の使用に
  45. 必要なものではありません。
  46. %package devel
  47. Summary: Header files and library for development with VFlib.
  48. Summary(ja): VFlib の開発キット
  49. Group: Development/Libraries
  50. %description devel
  51. This package is only needed if you intend to develop or
  52. compile applications which rely on the VFlib.
  53. If you simply want to run existing applications, you won't
  54. need this package.
  55. %description -l devel
  56. このパッケージはVFlibを用いたアプリケーションを開発したりコンパイル
  57. したりするときにのみ必要になります。VFlib を用いたアプリケーション
  58. を単に実行する時には必要ありません。
  59. ## to build compat32 for x86_64 architecture support
  60. %package -n compat32-%{name}
  61. Summary: Vector Font Library
  62. Group: System Environment/Libraries
  63. Requires: freetype >= 1.2, TrueTypeFonts_jp
  64. %description -n compat32-%{name}
  65. A package of VFlib, a library to use vector fonts. It is used by xdvi,
  66. GhostScript, etc...
  67. %package -n compat32-%{name}-devel
  68. Summary: Header files and library for development with VFlib.
  69. Group: Development/Libraries
  70. Requires: compat32-%{name} = %{version}
  71. %description -n compat32-%{name}-devel
  72. This package is only needed if you intend to develop or
  73. compile applications which rely on the VFlib.
  74. If you simply want to run existing applications, you won't
  75. need this package.
  76. %prep
  77. %setup -q -a 1 4 -n VFlib2-%{version}
  78. %patch9 -p1 -b .gcc33
  79. %patch20 -p1 -b .x86_64
  80. %if %{build_compat32}
  81. %patch21 -p1 -b .compat32
  82. %endif
  83. find . -type d -name CVS | xargs -r rm -frv
  84. #cp $RPM_SOURCE_DIR/{install-sh,config.sub} .
  85. #chmod 755 install-sh config.sub
  86. %build
  87. %if %{build_compat32}
  88. export CC='gcc -m32'
  89. %endif
  90. %ifarch alpha
  91. ./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} \
  92. --with-freetype --host=alpha-pc-linux
  93. %else
  94. ##./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --with-freetype
  95. ./configure \
  96. --prefix=%{_prefix} \
  97. --libdir=%{_libdir} \
  98. --exec-prefix=%{_prefix} \
  99. --enable-static \
  100. --enable-shared \
  101. --with-freetype \
  102. --with-freetype-libdir=%{_libdir} \
  103. --with-x \
  104. --x-libraries=/usr/X11R6/%{_lib}
  105. %endif
  106. %if %{build_compat32}
  107. # to be changed imake result
  108. pushd src
  109. make default_vfontcap=/etc/vfontcap
  110. popd
  111. pushd tools
  112. imake -DUseInstalled -I/usr/X11R6/lib/X11/config
  113. mv Makefile Makefile.x64_86
  114. sed "s|lib64|lib|g" Makefile.x64_86 > Makefile
  115. make default_vfontcap=/etc/vfontcap
  116. popd
  117. make default_vfontcap=/etc/vfontcap
  118. %else
  119. make default_vfontcap=/etc/vfontcap
  120. %endif
  121. %install
  122. rm -rf $RPM_BUILD_ROOT
  123. #make prefix=$RPM_BUILD_ROOT%{_prefix} exec_prefix=$RPM_BUILD_ROOT%{_prefix} install
  124. make \
  125. prefix=$RPM_BUILD_ROOT%{_prefix} \
  126. exec_prefix=$RPM_BUILD_ROOT%{_prefix} \
  127. libdir=$RPM_BUILD_ROOT%{_libdir} \
  128. install
  129. # /usr/share/VFlib contains only documents
  130. rm -rf $RPM_BUILD_ROOT%{_datadir}/VFlib
  131. # install vfontcaps
  132. (cd %{vfontcaps}
  133. make DESTDIR=$RPM_BUILD_ROOT install
  134. )
  135. # prepare docs
  136. cp -p tools/README README.ktest
  137. rm -f doc/*~
  138. %post -p /sbin/ldconfig
  139. %postun -p /sbin/ldconfig
  140. %if %{build_compat32}
  141. %post -n compat32-%{name} -p /sbin/ldconfig
  142. %postun -n compat32-%{name} -p /sbin/ldconfig
  143. %endif
  144. %clean
  145. rm -rf $RPM_BUILD_ROOT
  146. %if !%{build_compat32}
  147. %files
  148. %defattr(-,root,root)
  149. %doc CHANGES COPYING{,.LIB} DISTRIB.txt INSTALL README.txt{,.JP_EUC}
  150. #%doc README.ktest dynafont doc fortest
  151. %doc README.ktest dynafont doc
  152. # vfontcap is included in truetype-fonts-ja
  153. %config /etc/vfontcap
  154. %{_datadir}/fonts/TrueType/vfontcap.ttf
  155. %{_datadir}/fonts/zeit/vfontcap.zeit
  156. %{_libdir}/libVFlib2.la
  157. %{_libdir}/libVFlib2.so.*
  158. %files utils
  159. %defattr(-,root,root)
  160. %{_bindir}/ttindex
  161. %{_bindir}/bdfindex
  162. %{_bindir}/fwindex
  163. %{_bindir}/ktest
  164. %files devel
  165. %defattr(-,root,root)
  166. %{_includedir}/VF.h
  167. %{_libdir}/libVFlib2.so
  168. %endif
  169. ## to build compat32 for x86_64 architecture support
  170. %if %{build_compat32}
  171. %files -n compat32-%{name}
  172. %defattr(-,root,root)
  173. %{_libdir}/libVFlib2.la
  174. %{_libdir}/libVFlib2.so.*
  175. %files -n compat32-%{name}-devel
  176. %defattr(-,root,root)
  177. %{_libdir}/libVFlib2.so
  178. %endif
  179. %changelog
  180. * Wed Feb 15 2006 Shu KONNO <owa@bg.wakwak.com> 2.25.6-0vl2
  181. - dropt fortest in %doc (because which is not found)
  182. - added VFlib2-2.25.6-config.sub-x86_64.patch
  183. - added --with-freetype-libdir, --x-libraries to configure
  184. - added compat32-* packages for x86_64 architecture support
  185. - added VFlib2-2.25.6-ltconfig-compat32.patch
  186. - added current updating scripts of tools/Makefile for compat32
  187. * Sun Jan 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.25.6-0vl1
  188. - new upstream release
  189. - added entry for dynacomware fonts in vfontcap
  190. - use License tag instead of Copyright
  191. * Mon Mar 25 2002 Jun Nishii <jun@vinelinux.org> 2.25.2-0vl2
  192. - added entry for ricoh fonts in vfontcap
  193. - update fortest
  194. * Sat Jan 13 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  195. - 2.24.2-8
  196. * Sat Jan 13 2001 Lisa Sagami <czs14350@mb.infoweb.ne.jp>
  197. - minor spec fixes
  198. - dont pack CVS directory
  199. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.24.2-7
  200. - build with gcc-2.95.3
  201. - partially used rpmmacros
  202. * Fri Jan 21 2000 Jun Nishii <jun@vinelinux.org>
  203. - rel.6
  204. - modify vine-vfontcaps-1.0
  205. - merge vfontcaps for dyna and free
  206. - more Japanese Summary and description
  207. * Tue Nov 23 1999 Norihito Ohmori <ohmori@flatout.org>
  208. - modified for Vine Linux.
  209. * Thu Nov 18 1999 Toru Hoshina <t@kondara.org>
  210. - add alphaev6 support.
  211. * Thu Nov 18 1999 Norihito Ohmori <nono@kondara.org>
  212. - add defattr(-,root,root) in utils & devel (jitter #108)
  213. * Mon Nov 8 1999 Toru Hoshina <t@kondara.org>
  214. - be a NoSrc :-P
  215. * Sat Oct 30 1999 Norihito Ohmori <ohmori@flatout.org>
  216. - change dependency from TrueTypeFonts_jp to truetype-fonts-ja
  217. * Fri Oct 29 1999 Norihito Ohmori <ohmori@flatout.org>
  218. - add defattr.
  219. * Fri Oct 15 1999 Norihito Ohmori <ohmori@flatout.org>
  220. - sprit VFlib, VFlib-devel and VFlib-utils
  221. * Mon Oct 11 1999 Norihito Ohmori <ohmori@flatout.org>
  222. - rebuild for FreeType-1.3
  223. * Sat Sep 4 1999 Norihito Ohmori <ohmori@flatout.org>
  224. - Add BuildPreReq: Tag for FreeType
  225. * Mon Jul 26 1999 Jun Nishii <jun@flatout.org>
  226. - updated to 2.24.2
  227. - build for Vine-1.9
  228. * Fri Jul 9 1999 Norihito Ohmori <ohmori@flatout.org>
  229. - spec file fix (patch rejected).
  230. * Tue Jun 29 1999 Norihito Ohmori <ohmori@flatout.org>
  231. - if DynaFont was already installed, use it
  232. * Mon May 24 1999 Norihito Ohmori <ohmori@flatout.org>
  233. - Comment "GS-" entry in vfontcap
  234. * Tue May 19 1999 Norihito Ohmori <ohmori@flatout.org>
  235. - add "GS-" entry for Ghostscript xfont extention
  236. * Fri Dec 11 1998 Hideya Hane <pje@linux.or.jp>
  237. - Requires TrueTypeFonts_jp(change from xtt_fonts)
  238. * Sun Nov 29 1998 Jun Nishii <jun@flatout.org>
  239. - dynamic link libttf to libVFlib
  240. * Wed Nov 25 1998 Jun Nishii <jun@flatout.org>
  241. - fix wrong symbolic link of /etc/vfontcap
  242. * Tue Nov 24 1998 Jun Nishii <jun@flatout.org>
  243. - use ttf as default fonts
  244. * Tue Nov 10 1998 Jun Nishii <jun@flatout.org>
  245. - for version 2.24 release 1
  246. * Tue Nov 10 1998 Jun Nishii <jun@flatout.org>
  247. - add descrption -l ja
  248. - tiny bug fix when building vflib
  249. * Fri Sep 25 1998 Jun Nishii <jun@flatout.org>
  250. - first release