gnucash-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281
  1. %define ver 2.6.6
  2. %define rel 2%{?_dist_release}
  3. %define __libtoolize /bin/true
  4. Name: gnucash
  5. Summary: GnuCash is an application to keep track of your finances.
  6. Summary(ja): 個人用財務管理アプリケーション
  7. Version: %{ver}
  8. Release: %{rel}
  9. License: GPL/LGPL/GFDL
  10. Group: Applications/Productivity
  11. URL: http://www.gnucash.org/
  12. Source: %{name}-%{version}.tar.bz2
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: aqbanking-devel >= 3.7.2
  15. BuildRequires: bzip2-devel
  16. BuildRequires: expat-devel
  17. BuildRequires: gettext
  18. BuildRequires: goffice08-devel >= 0.8
  19. BuildRequires: gtk2-devel
  20. BuildRequires: WebKit-gtk-devel
  21. BuildRequires: guile-devel
  22. BuildRequires: libofx-devel
  23. BuildRequires: libgnomeui-devel
  24. BuildRequires: libdbi-devel
  25. BuildRequires: libjpeg-devel
  26. BuildRequires: libtool-ltdl-devel
  27. BuildRequires: pcre-devel
  28. BuildRequires: popt-devel
  29. BuildRequires: swig
  30. #BuildRequires: slib
  31. BuildRequires: gwenhywfar-devel
  32. BuildRequires: desktop-file-utils
  33. BuildRequires: libdbi-dbd-pgsql
  34. BuildRequires: libdbi-dbd-mysql
  35. BuildRequires: libdbi-dbd-sqlite
  36. Requires: aqbanking
  37. Requires: perl-DateManip
  38. Requires: yelp
  39. Requires(post,postun): gtk2
  40. Requires(postun,posttrans): glib2
  41. Obsoletes: gnucash-backend-postgres
  42. Vendor: Project Vine
  43. Distribution: Vine Linux
  44. Packager: kenta, inagaki
  45. %description
  46. GnuCash is a personal finance manager. A check-book like
  47. register GUI allows you to enter and track bank accounts,
  48. stocks, income and even currency trades. The interface is
  49. designed to be simple and easy to use, but is backed with
  50. double-entry accounting principles to ensure balanced books.
  51. %description -l ja
  52. GnuCashは 個人用財務管理をするアプリケーションです.
  53. 預金, 株式, 所得そして通貨取引さえ入力し、追跡することができる
  54. グラフィカルな小切手帖です.インターフェスはシンプルかつ簡単に
  55. 使用できるようにデザインされています.
  56. %prep
  57. %setup -q
  58. %build
  59. %configure \
  60. --enable-error-on-warning=no \
  61. --disable-sql \
  62. --enable-ofx \
  63. --enable-aqbanking \
  64. --disable-static \
  65. --enable-dbi \
  66. --with-html-engine=webkit \
  67. --docdir=%{_datadir}/doc/gnucash-%{version}
  68. make LIBTOOL=%{_bindir}/libtool
  69. %configure
  70. make
  71. %install
  72. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  73. make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
  74. %find_lang %name
  75. # vfolder desktop file install stuff
  76. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/applications/
  77. desktop-file-install --vendor gnome --delete-original \
  78. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  79. --add-category X-Red-Hat-Extra \
  80. --add-category Application \
  81. --add-category Office \
  82. $RPM_BUILD_ROOT%{_datadir}/applications/gnucash.desktop
  83. echo "StartupWMClass=GnuCash" >> $RPM_BUILD_ROOT%{_datadir}/applications/gnome-gnucash.desktop
  84. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  85. rm -rf $RPM_BUILD_ROOT/%{_infodir} \
  86. $RPM_BUILD_ROOT/%{_includedir} \
  87. $RPM_BUILD_ROOT/%{_libdir}/lib*.a \
  88. $RPM_BUILD_ROOT/%{_libdir}/gnucash/lib*.a
  89. %clean
  90. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  91. %post
  92. /sbin/ldconfig
  93. touch --no-create %{_datadir}/icons/hicolor || :
  94. gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
  95. %postun
  96. if [ $1 -eq 0 ] ; then
  97. /sbin/ldconfig
  98. touch --no-create %{_datadir}/icons/hicolor || :
  99. gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
  100. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  101. fi
  102. %posttrans
  103. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  104. %files -f %{name}.lang
  105. %defattr(-,root,root,755)
  106. %config %{_sysconfdir}/%{name}
  107. %{_bindir}/*
  108. %{_libexecdir}/%{name}
  109. %{_libdir}/*
  110. %{_datadir}/appdata/%{name}.appdata.xml
  111. %{_datadir}/applications/*
  112. %{_datadir}/glib-2.0/schemas/*.xml
  113. %{_datadir}/%{name}
  114. %{_datadir}/icons/hicolor/*/apps/*
  115. %{_docdir}/%{name}
  116. %{_mandir}/man*/*
  117. %doc AUTHORS COPYING ChangeLog* DOCUMENTERS HACKING NEWS README
  118. %doc doc/README.german doc/README.francais doc/guile-hackers.txt
  119. %doc doc/README.OFX
  120. %changelog
  121. * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-2
  122. - remove *.la files
  123. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.6-1
  124. - new upstream release
  125. - add BuildRequires: libtool-ltdl-devel
  126. * Mon Mar 9 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.6.5-2
  127. - rebuilt with libofx 0.9.10
  128. - added Vendor and Distribution tag
  129. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
  130. - update to 2.6.5
  131. - remove old patches
  132. - add BuildRequires: libdbi-devel
  133. - change BuildRequires: goffice08-devel instead of goffice-devel
  134. * Tue Sep 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.9-3
  135. - rebuilt with new toolchain, aqbanking-4.2.4, goffice-0.8.10
  136. - added Patch1 for building with aqbanking-4.2.4
  137. - added Patch2 for building with goffice-0.8.10
  138. * Fri Jul 24 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-2
  139. - added slib to BuildRequires: and Requires:
  140. * Sat May 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.9-1
  141. - new upstream release
  142. * Wed Jan 14 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.8-1
  143. - new upstream release
  144. * Mon Jan 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.2.7-2
  145. - rebuild with guile-1.8.6
  146. - add BuildRequires: gwenhywfar-devel
  147. * Sun Oct 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.7-1
  148. - new upstream release
  149. - applied new versioning policy
  150. - built with aqbanking-3.7.2, gwenheyfar-3.4.1, libofx-0.9.0
  151. * Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4-0vl1
  152. - new upstream release
  153. - rebuilt with goffice-0.6.0
  154. * Tue Jan 22 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.3-0vl1
  155. - new upstream release
  156. * Sun Jan 20 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.2-0vl1
  157. - new upstream release
  158. - enable HBCI (Home Banking Computer Interface)
  159. * Tue Jan 08 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl2
  160. - rebuild with libofx-0.8.3 (libofx.so.3)
  161. * Sun Dec 30 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.0-0vl1
  162. - new upstream release
  163. - disable postgresql backend, as it is unmaintained upstream
  164. - added Patch0: gnucash-2.2.0-quiet.patch
  165. * Sun Oct 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.12-0vl1
  166. - new upstream release
  167. - remove BuildRequiers: autoconf213
  168. - update ja.po
  169. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
  170. - new upstream release
  171. - added BuildPrereq: libtool-ltdl-devel
  172. * Fri Jan 2 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl2
  173. - rebuild with new toolchains
  174. - update ja.po
  175. * Sun Nov 23 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.8-0vl1
  176. - new upstream release
  177. * Sun Oct 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-1vl1
  178. - merged gnucash-docs-1.8.3
  179. - added patch from Redhat Rawhide 1.8.7-1
  180. - changed Group, License
  181. * Mon Oct 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.7-0vl1
  182. - updated to 1.8.7
  183. - updated print.patch
  184. - overwrite prefs.scm
  185. - s/Copyright/License/
  186. * Tue May 13 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.3-0vl1
  187. - updated to 1.8.3
  188. - added datelength.patch
  189. - separated devel packages
  190. (and ofx, hbci, backend-postgres. But default is off)
  191. * Wed Jan 16 2002 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl3
  192. - Build against with new gal.
  193. * Fri Dec 28 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl2
  194. - Fixed printing issue.
  195. * Tue Dec 25 2001 Akira TAGOH <tagoh@gnome.gr.jp> 1.6.5-0vl1
  196. - New upstream release.
  197. * Thu Jul 26 2001 <sagami@vinelinux.org>
  198. - 1.6.0-0vl3: fix to not to own mandir itself, use %%{find_lang}
  199. * Tue Jun 12 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  200. - %%make line is now commented out (bash2 complains it)
  201. (BTW, what the hell is the macro %%make anyway? I don't even know...)
  202. * Tue Jun 12 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
  203. - update to 1.6.0 (stable release version)
  204. * Thu May 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.96-0vl1
  205. - update to 1.5.96 ( pre beta for 1.6.0 )
  206. * Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl2
  207. - added japanese patch for reporting and printing (thanx tagoh-san)
  208. * Mon Apr 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1vl1
  209. - updated to 1.5.6
  210. * Thu Apr 05 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.4-1vl2
  211. - added translation messages to ja.po
  212. - enable guppi
  213. * Mon Apr 2 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.4-1vl1
  214. - upstream update
  215. - fixed broken ja.po
  216. * Wed Mar 28 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl2
  217. - fixed registor window cursor position problem(gnucash-cursor_pos.patch)
  218. * Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org> 1.5.2-1vl1
  219. - initial relese package