OpenIPMI-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458
  1. # TODO: uses private copy of libedit, should be modified to use system one
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Summary: IPMI (Intelligent Platform Management Interface) library and tools
  4. Summary(ja): IPMI (Intelligent Platform Management Interface) ライブラリおよびツール
  5. Name: OpenIPMI
  6. Version: 2.0.21
  7. Release: 2%{?_dist_release}
  8. License: LGPLv2+ and GPLv2+ or BSD
  9. Group: System Environment/Base
  10. URL: http://sourceforge.net/projects/openipmi/
  11. Source: http://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
  12. Source1: openipmi.sysconf
  13. Source2: openipmi.initscript
  14. Source3: openipmigui.desktop
  15. Source4: README.initscript
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: desktop-file-utils
  18. BuildRequires: gdbm-devel
  19. BuildRequires: glib2-devel
  20. BuildRequires: ncurses-devel
  21. BuildRequires: net-snmp-devel
  22. BuildRequires: openssl-devel
  23. BuildRequires: perl
  24. BuildRequires: popt-devel
  25. BuildRequires: python-devel
  26. BuildRequires: swig
  27. BuildRequires: tcl
  28. BuildRequires: tkinter
  29. Requires(post): chkconfig
  30. Requires(preun): chkconfig
  31. Patch1: OpenIPMI-2.0.18-pthread-pkgconfig.patch
  32. Vendor: Project Vine
  33. Distribution: Vine Linux
  34. %description
  35. The Open IPMI project aims to develop an open code base to allow access to
  36. platform information using Intelligent Platform Management Interface (IPMI).
  37. This package contains the tools of the OpenIPMI project.
  38. %package libs
  39. Summary: The OpenIPMI runtime libraries
  40. Summary(ja): OpenIPMI ランタイムライブラリ
  41. Group: System Environment/Libraries
  42. %description libs
  43. The OpenIPMI-libs package contains the runtime libraries for shared binaries
  44. and applications.
  45. %package perl
  46. Summary: IPMI Perl language bindings
  47. Summary(ja): IPMI Perl 言語バインディング
  48. Group: Development/Libraries
  49. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  50. %description perl
  51. The OpenIPMI-perl package contains the Perl language bindings for OpenIPMI.
  52. %package python
  53. Group: Development/Libraries
  54. Summary: IPMI Python language bindings
  55. Summary(ja): IPMI Python 言語バインディング
  56. Requires: python
  57. %description python
  58. The OpenIPMI-python package contains the Python language bindings for OpenIPMI.
  59. %package devel
  60. Summary: The development environment for the OpenIPMI project
  61. Summary(ja): OpenIPMI の開発キット
  62. Group: Development/Libraries
  63. Requires: %{name} = %{version}-%{release}
  64. Requires: pkgconfig
  65. %description devel
  66. The OpenIPMI-devel package contains the development libraries and header files
  67. of the OpenIPMI project.
  68. %package gui
  69. Summary: IPMI graphical user interface tool
  70. Summary(ja): IPMI GUI ツール
  71. Group: System Environment/Base
  72. Requires: tix
  73. Requires: tkinter
  74. Requires: %{name}-python = %{version}-%{release}
  75. %description gui
  76. The OpenIPMI-gui package contains the graphical user interface to monitor
  77. and control IPMI-enabled devices.
  78. %prep
  79. %setup -q
  80. %patch1 -p1
  81. %build
  82. export CFLAGS="-fPIC $RPM_OPT_FLAGS"
  83. %configure \
  84. --with-pythoninstall=%{python_sitearch} \
  85. --disable-dependency-tracking \
  86. --with-tcl=no \
  87. --with-glib12=no \
  88. --disable-static
  89. # get rid of rpath
  90. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  91. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  92. make # not %{?_smp_mflags} safe
  93. %install
  94. rm -rf $RPM_BUILD_ROOT
  95. make install DESTDIR=$RPM_BUILD_ROOT
  96. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  97. install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
  98. install -m 644 %SOURCE1 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/ipmi
  99. install -d ${RPM_BUILD_ROOT}%{_initrddir}
  100. install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_initrddir}/ipmi
  101. desktop-file-install --vendor="fedora" --dir=${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
  102. install -m 644 %SOURCE4 .
  103. %post
  104. /sbin/chkconfig --add ipmi
  105. %preun
  106. if [ $1 = 0 ]; then
  107. service ipmi stop >/dev/null 2>&1
  108. /sbin/chkconfig --del ipmi
  109. fi
  110. %postun
  111. if [ "$1" -ge "1" ]; then
  112. service ipmi condrestart >/dev/null 2>&1 || :
  113. fi
  114. %post libs -p /sbin/ldconfig
  115. %postun libs -p /sbin/ldconfig
  116. %clean
  117. rm -rf $RPM_BUILD_ROOT
  118. %files
  119. %defattr(-,root,root)
  120. %doc CONFIGURING_FOR_LAN COPYING COPYING.BSD COPYING.LIB FAQ README README.Force README.MotorolaMXP README.initscript
  121. %config(noreplace) %{_sysconfdir}/ipmi/ipmisim1.emu
  122. %config(noreplace) %{_sysconfdir}/ipmi/lan.conf
  123. %config(noreplace) %{_sysconfdir}/sysconfig/ipmi
  124. %{_initrddir}/ipmi
  125. %{_bindir}/ipmicmd
  126. %{_bindir}/ipmilan
  127. %{_bindir}/ipmish
  128. %{_bindir}/ipmi_sim
  129. %{_bindir}/ipmi_ui
  130. %{_bindir}/openipmicmd
  131. %{_bindir}/openipmish
  132. %{_bindir}/rmcp_ping
  133. %{_bindir}/sdrcomp
  134. %{_bindir}/solterm
  135. %{_mandir}/man1/ipmi_*
  136. %{_mandir}/man1/openipmicmd*
  137. %{_mandir}/man1/openipmish*
  138. %{_mandir}/man1/rmcp_ping*
  139. %{_mandir}/man1/solterm*
  140. %{_mandir}/man5/ipmi_*
  141. %{_mandir}/man7/ipmi_cmdlang*
  142. %{_mandir}/man7/openipmi_conparms*
  143. %{_mandir}/man8/ipmilan*
  144. %files perl
  145. %defattr(-,root,root)
  146. %attr(644,root,root) %{perl_vendorarch}/OpenIPMI.pm
  147. %{perl_vendorarch}/auto/OpenIPMI/
  148. %files python
  149. %defattr(-,root,root)
  150. %{python_sitearch}/*OpenIPMI*
  151. %files libs
  152. %defattr(-,root,root)
  153. %{_libdir}/*.so.*
  154. %files devel
  155. %defattr(-,root,root)
  156. %{_includedir}/OpenIPMI
  157. %{_libdir}/*.so
  158. %{_libdir}/pkgconfig/*.pc
  159. %files gui
  160. %defattr(-,root,root)
  161. %{_bindir}/openipmigui
  162. %{_mandir}/man1/openipmigui*
  163. %{python_sitearch}/openipmigui
  164. %{_datadir}/applications/fedora-openipmigui.desktop
  165. %changelog
  166. * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-2
  167. - remove *.la files
  168. * Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0.21-1
  169. - updated to 2.0.21
  170. - rebuilt with perl-5.16.3
  171. * Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-5
  172. - rebuild with net-snmp-5.7.1
  173. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-4
  174. - rebuild with python-2.7.2
  175. * Sat May 21 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.18-3
  176. - build with perl 5.12.3
  177. - add Vendor and Distribution tags
  178. * Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-2
  179. - rebuild with openssl-1.0.0d
  180. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.18-1
  181. - initial build for Vine Linux
  182. * Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.0.18-2
  183. - Mass rebuild with perl-5.12.0
  184. * Wed May 5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.18-1
  185. - updated to OpenIPMI-2.0.18
  186. - fixed OpenIPMIpthread pkgconfig file (#468067)
  187. * Mon May 3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.17-1
  188. - updated to OpenIPMI-2.0.17
  189. * Thu Mar 18 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-12
  190. - implemented mandatory 'force-reload' command in ipmi service
  191. * Thu Mar 11 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-11
  192. - rebuild against new gdbm
  193. * Wed Mar 3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-10
  194. - add README.initscript describing /etc/init.d/ipmi initscript exit codes
  195. (#562151)
  196. * Mon Feb 22 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-9
  197. - fix package License: field, there *are* sources with BSD header
  198. - distribute README files and COPYING in package
  199. * Tue Jan 5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-8
  200. - fix package License: field, there is no source with BSD header
  201. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 2.0.16-7
  202. - rebuild against perl 5.10.1
  203. * Tue Dec 1 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-6
  204. - fix package compilation to remove rpmlint errors
  205. * Wed Sep 30 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-5
  206. - rebuilt with new net-snmp
  207. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.16-4
  208. - rebuilt with new openssl
  209. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.16-3
  210. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  211. * Wed Apr 15 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-2
  212. - fix compilation flags, debuginfo package is correctly generated now
  213. * Thu Mar 19 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-1
  214. - new upstream release
  215. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.14-11
  216. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  217. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.14-10
  218. - rebuild with new openssl
  219. * Thu Dec 11 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-9
  220. - fix linking without rpath, prelink won't screw up the libraries
  221. anymore (#475265)
  222. * Wed Dec 10 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-8
  223. - shorter probe interval is used in init script, making the service startup
  224. quicker in most situations (#475101)
  225. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.14-7
  226. - Rebuild for Python 2.6
  227. * Thu Oct 30 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-6
  228. - removed static libraries from the -devel subpackage
  229. - fixed openipmigui.desktop file
  230. * Thu Oct 23 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-5
  231. - fixed typos in the descriptions
  232. - added .desktop file for openipmigui tool
  233. * Mon Oct 20 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-4
  234. - fixed description of the package
  235. * Thu Oct 16 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-3
  236. - split ipmitool to separate package
  237. - added 'reload' functionality to init script
  238. - added seraparate -gui subpackage
  239. * Wed Jul 30 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-2
  240. - Fixed rpath problem in libOpenIPMIposix.so.0.0.1
  241. * Tue Jul 29 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-1
  242. - Fixed several specfile problems (#453751)
  243. - Update to OpenIPMI-2.0.14
  244. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.13-2
  245. - Autorebuild for GCC 4.3
  246. * Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.13-1
  247. - Updated to OpenIPMI-2.0.13
  248. - Rebuild due to new openssl
  249. * Wed Oct 10 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-3
  250. - Added missing perl-devel buildrequires
  251. * Mon Sep 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
  252. - Added missing popt-devel buildrequires
  253. * Fri Aug 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
  254. - Fix rebuild problems due to glibc change
  255. - License review and fixes
  256. * Tue Apr 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-1
  257. - Update to OpenIPMI-2.0.11
  258. * Tue Feb 27 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-8
  259. - Update for ipmitool-1.8.9
  260. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 2.0.6-7
  261. - rebuild for python 2.5
  262. * Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-6.fc7
  263. - Update due to new net-snmp-5.4
  264. - Some specfile updates
  265. * Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-5
  266. - Fixed check for udev in initscript (#197956)
  267. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.6-4.1
  268. - rebuild
  269. * Fri Jun 16 2006 Bill Nottingham <notting@redhat.com> 2.0.6-4
  270. - don't include <linux/compiler.h>
  271. * Fri Jun 16 2006 Jon Masters <jcm@redhat.com> 2.0.6-3
  272. - Fix a build requires (needs glibc-kernheaders)
  273. * Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> 2.0.6-2
  274. - Bump for new glib2
  275. * Tue May 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.0.6-1
  276. - Fixed bug with type conversion in ipmitool (#191091)
  277. - Added python bindings
  278. - Split off perl and python bindings in separate subpackages
  279. - Dropped obsolete patches
  280. - Added missing buildprereq on readline-devel
  281. - Made it install the python bindings properly on 64bit archs
  282. * Mon May 15 2006 Phil Knirsch <pknirsch@redhat.com>
  283. - Updated ipmitool to 1.8.8
  284. - Updated OpenIPMI to 2.0.6
  285. * Fri Feb 17 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-19
  286. - Added missing PreReq for chkconfig
  287. * Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2.1
  288. - rebump for build order issues during double-long bump
  289. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2
  290. - bump again for double-long bug on ppc(64)
  291. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.1
  292. - rebuilt for new gcc4.1 snapshot and glibc changes
  293. * Mon Feb 06 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-18
  294. - Updated ipmitool to latest upstream version.
  295. - Removed 3 patches for already fixed bugs in latest ipmitool.
  296. - Adapted warning message fix for ipmitool for latest version.
  297. * Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-17
  298. - Fixed some minor things in initscripts.
  299. * Mon Jan 09 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-16
  300. - Included FRU fix for displaying FRUs with ipmitool
  301. - Included patch for new option to specify a BMC password for IPMI 2.0 sessions
  302. * Tue Jan 03 2006 Radek Vokal <rvokal@redhat.com> 1.4.14-15
  303. - Rebuilt against new libnetsnmp
  304. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  305. - rebuilt
  306. * Wed Nov 23 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-14
  307. - Some more initscript and sysconfig updates from Dell.
  308. * Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-13
  309. - Rebuilt to link against latest openssl libs.
  310. - Fixed ipmitool not setting session privilege level (#172312)
  311. * Wed Nov 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-11
  312. - Rebuild to link against new net-snmp libs.
  313. * Tue Oct 11 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-10
  314. - Updated initscript to fix missing redhat-lsb bug (#169901)
  315. * Thu Sep 08 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-9
  316. - Another update to latest initscripts from Dell
  317. - Fixed some missing return statements for non-void functions (#164138)
  318. * Thu Sep 01 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-8
  319. - Updated initscript to latest version from Dell
  320. * Fri Aug 12 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-7
  321. - Fixed the unwanted output of failed module loading of the initscript. Behaves
  322. now like all our other initscripts (#165476)
  323. * Fri Aug 05 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-6
  324. - Fixed build problem on 64bit machines
  325. * Fri Jul 15 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-5
  326. - Fixed missing change to not autostart in the initscript
  327. * Wed Jul 06 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-4
  328. - Made the initscript a replacing configfile
  329. * Mon Jul 04 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-3
  330. - Updated versions of the initscripts and sysconf files
  331. - Fixed typo in preun script and changelog
  332. * Mon Jun 27 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-2
  333. - Updated to OpenIPMI-1.4.14
  334. - Split the main package into normal and libs package for multilib support
  335. - Added ipmitool-1.8.2 to OpenIPMI and put it in tools package
  336. - Added sysconf and initscript (#158270)
  337. - Fixed oob subscripts (#149142)
  338. * Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-5
  339. - Correctly put libs in the proper packages
  340. * Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-4
  341. - gcc4 rebuild fixes
  342. - Added missing gdbm-devel buildprereq
  343. * Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-3
  344. - bump release and rebuild with gcc 4
  345. * Tue Feb 08 2005 Karsten Hopp <karsten@redhat.de> 1.4.11-2
  346. - update
  347. * Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
  348. - Initial version