libxcrypt-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613
  1. %bcond_with fipstest
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. # Build with new api?
  4. %bcond_without new_api
  5. # Build the compat package?
  6. %bcond_without compat_pkg
  7. # Run memcheck?
  8. # Valgrind does not work well on %%{power64} arches.
  9. %ifnarch %{power64}
  10. %bcond_without memcheck
  11. %else
  12. %bcond_with memcheck
  13. %endif
  14. # Shared object version of libcrypt.
  15. %if %{with new_api}
  16. %global soc 2
  17. %global sol 0
  18. %global sof 0
  19. %global sov %{soc}.%{sol}.%{sof}
  20. %if %{with compat_pkg}
  21. %global csoc 1
  22. %global csol 1
  23. %global csof 0
  24. %global csov %{csoc}.%{csol}.%{csof}
  25. %endif
  26. %else
  27. %global soc 1
  28. %global sol 1
  29. %global sof 0
  30. %global sov %{soc}.%{sol}.%{sof}
  31. %endif
  32. # Hash methods and API supported by libcrypt.
  33. # NEVER EVER touch this, if you do NOT know what you are doing!
  34. %if %{with new_api}
  35. %global hash_methods fedora,glibc,strong
  36. %global obsolete_api no
  37. %if %{with compat_pkg}
  38. %global compat_methods glibc
  39. %global compat_api glibc
  40. %endif
  41. %else
  42. %global hash_methods all
  43. %global obsolete_api glibc
  44. %endif
  45. # Needed for the distribution README file.
  46. %global distname .vine
  47. # Needed for out-of-tree builds.
  48. %global _configure ../"configure"
  49. # Common configure options.
  50. %global common_configure_options \\\
  51. --libdir=/%{_lib} \\\
  52. --disable-failure-tokens \\\
  53. --disable-silent-rules \\\
  54. --enable-shared \\\
  55. --enable-static \\\
  56. %if %{with memcheck} \
  57. --enable-valgrind \\\
  58. %else \
  59. --disable-valgrind \\\
  60. %endif \
  61. --srcdir=.. \\\
  62. --with-pkgconfigdir=%{_libdir}/pkgconfig
  63. %if %{with fipstest}
  64. # Add generation of HMAC checksums of the final stripped
  65. # binaries. %%define with lazy globbing is used here
  66. # intentionally, because using %%global does not work.
  67. BuildRequires: fipscheck
  68. %define __spec_install_post \
  69. %{?__debug_package:%{__debug_install_post}} \
  70. %{__arch_install_post} \
  71. %{__os_install_post} \
  72. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.a \
  73. %{__ln_s} .libcrypt.a.hmac \\\
  74. %{buildroot}/%{_lib}/.libxcrypt.a.hmac \
  75. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.so.%{sov} \
  76. %{__ln_s} .libcrypt.so.%{sov}.hmac \\\
  77. %{buildroot}/%{_lib}/.libcrypt.so.%{soc}.hmac \
  78. if [[ %{with new_api} == 1 && %{with compat_pkg} == 1 ]]; then \
  79. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.so.%{csov} \
  80. %{__ln_s} .libcrypt.so.%{csov}.hmac \\\
  81. %{buildroot}/%{_lib}/.libcrypt.so.%{csoc}.hmac \
  82. fi \
  83. %{nil}
  84. %endif
  85. Name: libxcrypt
  86. Version: 4.4.15
  87. Release: 1%{?_dist_release}
  88. Summary: Extended crypt library for descrypt, md5crypt, bcrypt, and others
  89. Group: System Environment/Libraries
  90. Vendor: Project Vine
  91. Distribution: Vine Linux
  92. # For explicit license breakdown, see the
  93. # LICENSING file in the source tarball.
  94. License: LGPLv2+ and BSD and Public Domain
  95. URL: https://github.com/besser82/%{name}
  96. Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
  97. # Patch 0000 - 2999: Backported patches from upstream.
  98. # Patch 3000 - 5999: Backported patches from pull requests.
  99. # Patch 6000 - 9999: Downstream patches.
  100. BuildRequires: libtool
  101. %if %{with memcheck}
  102. BuildRequires: valgrind
  103. %endif
  104. # We do not need to keep this forever.
  105. # We need a version of glibc, that doesn't build libcrypt anymore.
  106. Requires: glibc%{?_isa} >= 2.26.9000-46
  107. %if 0%{?fedora} >= 30
  108. Recommends: mkpasswd
  109. %endif
  110. %description
  111. libxcrypt is a modern library for one-way hashing of passwords. It
  112. supports a wide variety of both modern and historical hashing methods:
  113. yescrypt, gost-yescrypt, scrypt, bcrypt, sha512crypt, sha256crypt,
  114. %if %{with new_api}
  115. md5crypt, and descrypt.
  116. %else
  117. md5crypt, SunMD5, sha1crypt, NT, bsdicrypt, bigcrypt, and descrypt.
  118. %endif
  119. It provides the traditional Unix crypt and crypt_r interfaces, as well
  120. as a set of extended interfaces pioneered by Openwall Linux, crypt_rn,
  121. crypt_ra, crypt_gensalt, crypt_gensalt_rn, and crypt_gensalt_ra.
  122. libxcrypt is intended to be used by login(1), passwd(1), and other
  123. similar programs; that is, to hash a small number of passwords during
  124. an interactive authentication dialogue with a human. It is not suitable
  125. for use in bulk password-cracking applications, or in any other situation
  126. where speed is more important than careful handling of sensitive data.
  127. However, it is intended to be fast and lightweight enough for use in
  128. servers that must field thousands of login attempts per minute.
  129. %if %{with new_api}
  130. This version of the library does not provide the legacy API functions
  131. that have been provided by glibc's libcrypt.so.1.
  132. %endif
  133. %if %{with new_api} && %{with compat_pkg}
  134. %package compat
  135. Summary: Compatibility library providing legacy API functions
  136. Requires: %{name}%{?_isa} == %{version}-%{release}
  137. %description compat
  138. This package contains the library providing the compatibility API
  139. for applications that are linked against glibc's libxcrypt, or that
  140. are still using the unsafe and deprecated, encrypt, encrypt_r,
  141. setkey, setkey_r, and fcrypt functions, which are still required by
  142. recent versions of POSIX, the Single UNIX Specification, and various
  143. other standards.
  144. All existing binary executables linked against glibc's libcrypt should
  145. work unmodified with the library supplied by this package.
  146. %endif
  147. %package devel
  148. Summary: Development files for %{name}
  149. Group: Development/Libraries
  150. Conflicts: man-pages < 4.15-3
  151. Requires: %{name}%{?_isa} == %{version}-%{release}
  152. Requires: glibc-devel%{?_isa}
  153. %description devel
  154. The %{name}-devel package contains libraries and header files for
  155. developing applications that use %{name}.
  156. %package static
  157. Summary: Static library for -static linking with %{name}
  158. Group: Development/Libraries
  159. Requires: %{name}-devel%{?_isa} == %{version}-%{release}
  160. Requires: glibc-static%{?_isa}
  161. %description static
  162. This package contains the libxcrypt static library for -static
  163. linking.
  164. You don't need this, unless you link statically, which is highly
  165. discouraged.
  166. %package -n compat32-%{name}
  167. Summary: Extended crypt library for descrypt, md5crypt, bcrypt, and others
  168. Group: System Environment/Libraries
  169. %description -n compat32-%{name}
  170. libxcrypt is a modern library for one-way hashing of passwords. It
  171. supports a wide variety of both modern and historical hashing methods:
  172. yescrypt, gost-yescrypt, scrypt, bcrypt, sha512crypt, sha256crypt,
  173. %if %{with new_api}
  174. md5crypt, and descrypt.
  175. %else
  176. md5crypt, SunMD5, sha1crypt, NT, bsdicrypt, bigcrypt, and descrypt.
  177. %endif
  178. It provides the traditional Unix crypt and crypt_r interfaces, as well
  179. as a set of extended interfaces pioneered by Openwall Linux, crypt_rn,
  180. crypt_ra, crypt_gensalt, crypt_gensalt_rn, and crypt_gensalt_ra.
  181. libxcrypt is intended to be used by login(1), passwd(1), and other
  182. similar programs; that is, to hash a small number of passwords during
  183. an interactive authentication dialogue with a human. It is not suitable
  184. for use in bulk password-cracking applications, or in any other situation
  185. where speed is more important than careful handling of sensitive data.
  186. However, it is intended to be fast and lightweight enough for use in
  187. servers that must field thousands of login attempts per minute.
  188. %if %{with new_api}
  189. This version of the library does not provide the legacy API functions
  190. that have been provided by glibc's libcrypt.so.1.
  191. %endif
  192. %package -n compat32-%{name}-devel
  193. Summary: Development files for cpmpat32-%{name}
  194. Group: Development/Libraries
  195. Requires: %{name}-devel == %{version}-%{release}
  196. Requires: compat32-glibc-devel
  197. %description -n compat32-%{name}-devel
  198. The compat32-%{name}-devel package contains libraries and header files for
  199. developing applications that use compat32-%{name}.
  200. %prep
  201. %autosetup -p 1
  202. ./autogen.sh
  203. %if %{with new_api}
  204. %{__cat} << EOF >> README%{distname}
  205. This version of the %{name} package ships the libcrypt.so.2
  206. library and does not provide the legacy API functions that have
  207. been provided by glibc's libcrypt.so.1. The removed functions
  208. by name are encrypt, encrypt_r, setkey, setkey_r, and fcrypt.
  209. %if %{with compat_pkg}
  210. If you are using a third-party application that links against
  211. those functions, or that is linked against glibc's libcrypt,
  212. you may need to install the %{name}-compat package manually.
  213. All existing binary executables linked against glibc's libcrypt
  214. should work unmodified with the libcrypt.so.1 library supplied
  215. by the %{name}-compat package.
  216. %endif
  217. EOF
  218. %endif
  219. %{__mkdir_p} %{_vpath_builddir}{,-compat}
  220. %build
  221. # Build the default system library.
  222. pushd %{_vpath_builddir}
  223. %configure \
  224. %{common_configure_options} \
  225. --enable-hashes=%{hash_methods} \
  226. --enable-obsolete-api=%{obsolete_api}
  227. %make_build
  228. popd
  229. %if %{with new_api} && %{with compat_pkg}
  230. # Build the compatibility library.
  231. pushd %{_vpath_builddir}-compat
  232. %configure \
  233. %{common_configure_options} \
  234. --enable-hashes=%{compat_methods} \
  235. --enable-obsolete-api=%{compat_api}
  236. %make_build
  237. popd
  238. %endif
  239. %install
  240. rm -rf %{buildroot}
  241. %if %{with new_api} && %{with compat_pkg}
  242. # Install the compatibility library.
  243. %make_install -C %{_vpath_builddir}-compat
  244. # Cleanup everything we do not need from the compatibility library.
  245. %{__rm} -fr %{buildroot}%{_bindir} \
  246. %{buildroot}%{_includedir} \
  247. %{buildroot}/%{_lib}/lib{,x}crypt.{a,so} \
  248. %{buildroot}%{_libdir}/pkgconfig \
  249. %{buildroot}%{_mandir} \
  250. %{buildroot}%{_sbindir}
  251. %endif
  252. # Install the default system library.
  253. %make_install -C %{_vpath_builddir}
  254. # Get rid of libtool crap.
  255. %{_bindir}/find %{buildroot} -name '*.la' -print -delete
  256. %check
  257. %if %{with new_api} && %{with compat_pkg}
  258. for dir in %{_vpath_builddir} %{_vpath_builddir}-compat; do
  259. %else
  260. for dir in %{_vpath_builddir}; do
  261. %endif
  262. %make_build -C ${dir} check || \
  263. {
  264. rc=$?;
  265. echo "-----BEGIN TESTLOG: ${dir}-----";
  266. %{__cat} ${dir}/test-suite.log;
  267. echo "-----END TESTLOG: ${dir}-----";
  268. exit $rc;
  269. }
  270. %if %{with memcheck}
  271. %make_build -C ${dir} check-valgrind-memcheck || \
  272. {
  273. rc=$?;
  274. echo "-----BEGIN TESTLOG: ${dir}-----";
  275. %{__cat} ${dir}/test-suite-memcheck.log;
  276. echo "-----END TESTLOG: ${dir}-----";
  277. exit $rc;
  278. }
  279. %endif
  280. done
  281. %post -p /sbin/ldconfig
  282. %postun -p /sbin/ldconfig
  283. %if %{with new_api} && %{with compat_pkg}
  284. %post compat -p /sbin/ldconfig
  285. %postun compat -p /sbin/ldconfig
  286. %endif
  287. %if 0%{?build_compat32}
  288. %post -n compat32-%{name} -p /sbin/ldconfig
  289. %postun -n compat32-%{name} -p /sbin/ldconfig
  290. %endif
  291. %files
  292. %doc NEWS README* THANKS
  293. %license AUTHORS COPYING.LIB LICENSING
  294. %if %{with fipstest}
  295. /%{_lib}/.libcrypt.so.%{soc}.hmac
  296. /%{_lib}/.libcrypt.so.%{sov}.hmac
  297. %endif
  298. /%{_lib}/libcrypt.so.%{soc}
  299. /%{_lib}/libcrypt.so.%{sov}
  300. %{_mandir}/man5/crypt.5.*
  301. %if %{with new_api} && %{with compat_pkg}
  302. %files compat
  303. %if %{with fipstest}
  304. /%{_lib}/.libcrypt.so.%{csoc}.hmac
  305. /%{_lib}/.libcrypt.so.%{csov}.hmac
  306. %endif
  307. /%{_lib}/libcrypt.so.%{csoc}
  308. /%{_lib}/libcrypt.so.%{csov}
  309. %endif
  310. %files devel
  311. %doc ChangeLog TODO
  312. /%{_lib}/lib*crypt.so
  313. %{_includedir}/*crypt.h
  314. %{_libdir}/pkgconfig/libcrypt.pc
  315. %{_libdir}/pkgconfig/%{name}.pc
  316. %{_mandir}/man3/crypt*.3*
  317. %files static
  318. %if %{with fipstest}
  319. /%{_lib}/.lib*crypt.a.hmac
  320. %endif
  321. /%{_lib}/lib*crypt.a
  322. %if 0%{?build_compat32}
  323. %files -n compat32-%{name}
  324. %if %{with fipstest}
  325. /%{_lib}/.libcrypt.so.%{soc}.hmac
  326. /%{_lib}/.libcrypt.so.%{sov}.hmac
  327. %endif
  328. /%{_lib}/libcrypt.so.%{soc}
  329. /%{_lib}/libcrypt.so.%{sov}
  330. %files -n compat32-%{name}-devel
  331. /%{_lib}/lib*crypt.so
  332. %{_libdir}/pkgconfig/libcrypt.pc
  333. %{_libdir}/pkgconfig/%{name}.pc
  334. %endif
  335. %changelog
  336. * Sat Mar 28 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.15-1
  337. - new upstream release.
  338. * Sat Jan 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.2-6
  339. - initial build for Vine Linux.
  340. * Mon Jan 14 2019 Björn Esser <besser82@fedoraproject.org> - 4.4.2-5
  341. - Build the compat package with glibc hashing methods only
  342. - Add an option to disable the compat-package for future use
  343. * Mon Jan 14 2019 Björn Esser <besser82@fedoraproject.org> - 4.4.2-4
  344. - Bump SO-name for Fedora >= 30 and enable compat package (#1666033)
  345. - Add distribution README file
  346. - Update description of the compat package
  347. - Conditionally remove non-built hashing methods from description
  348. * Sun Dec 23 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-3
  349. - Remove architecture bits from Recommends
  350. * Sun Dec 23 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-2
  351. - Update summary
  352. * Sat Dec 22 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-1
  353. - New upstream release
  354. * Thu Dec 06 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.1-1
  355. - New upstream release
  356. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-5
  357. - Sync -fno-plt patch with upstream commit
  358. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-4
  359. - Backport upstream commit to fix a memory leak from a static pointer
  360. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-3
  361. - Backport upstream PR to build with -fno-plt optimization
  362. * Mon Nov 26 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-2
  363. - Backport upstream commit to use a safer strcpy for the NT method
  364. - Backport upstream generating base64 encoded output for NT gensalt
  365. - Backport upstream commit to require less rbytes for NT gensalt
  366. - Backport upstream commit to test incremental hmac-sha256 computation
  367. - Add Recommends: mkpasswd for Fedora >= 30
  368. * Tue Nov 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-1
  369. - New upstream release
  370. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.4-1
  371. - New upstream release
  372. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-4
  373. - Bump release for proper obsoletion of former common sub-package
  374. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-3
  375. - Add two upstream patches with minor fixes
  376. - Add HMAC checksum file for the static library
  377. - Drop the common sub-package
  378. - Some spec-file optimizations
  379. * Tue Nov 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-2
  380. - Add a patch to define crypt_gensalt_r as macro, so applications
  381. link the identical crypt_gensalt_rn directly
  382. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-1
  383. - New upstream release
  384. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.2-1
  385. - New upstream release
  386. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.1-2
  387. - Backport two patches from upstream fixing the gensalt function for
  388. NT to properly terminate its returned output
  389. * Sat Nov 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.1-1
  390. - New upstream release
  391. * Sat Nov 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.0-1
  392. - New upstream release
  393. * Fri Oct 26 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.3-1
  394. - New upstream release
  395. * Thu Oct 25 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.2-2
  396. - Add patch updating to recent development version
  397. - Run valgrind-memcheck
  398. - Use bootstrap script
  399. * Thu Oct 18 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.2-1
  400. - New upstream release
  401. * Mon Oct 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-3
  402. - Drop compat-devel package
  403. - Set configure options from globals
  404. * Sun Sep 30 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-2
  405. - Build out-of-tree
  406. - Split off noarch-bits into common sub-package
  407. - Update %%description
  408. - Prepare to remove legacy API from library and to provide a compatibilty
  409. package for the legacy API
  410. * Sat Sep 29 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-1
  411. - New upstream release
  412. - Add new manpages
  413. * Sat Sep 29 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.0-1
  414. - New upstream release
  415. * Fri Aug 24 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.2-1
  416. - New upstream release
  417. * Wed Aug 08 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-4
  418. - Move *.3 manpages to devel subpackage (#1613762)
  419. - Add needed Conflicts: man-pages < 4.15-3
  420. * Wed Aug 08 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-3
  421. - Make crypt{,_r} return NULL on failure (#1611784)
  422. * Sat Aug 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-2
  423. - Add manpages for crypt{,_r,_ra}.3 (#1610307)
  424. * Wed Aug 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-1
  425. - New upstream release
  426. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.0-1
  427. - New upstream release
  428. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-6
  429. - Make testsuite fail on error again
  430. - Update patch0 with more upstream fixes
  431. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-5
  432. - Add patch to update to recent development branch
  433. - Re-enable SUNMD5 support as it is BSD licensed now
  434. - Build compatibility symbols for glibc only
  435. - Skip failing testsuite once
  436. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.1-4
  437. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  438. * Fri Jun 29 2018 Florian Weimer <fweimer@redhat.com> - 4.0.1-3
  439. - Remove CDDL from license list (#1592445)
  440. * Fri Jun 29 2018 Florian Weimer <fweimer@redhat.com> - 4.0.1-2
  441. - Remove SUNMD5 support (#1592445)
  442. * Wed May 16 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-1
  443. - New upstream release
  444. * Sat Feb 17 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-5
  445. - Switch to %%ldconfig_scriptlets
  446. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.0-4
  447. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  448. * Thu Feb 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-3
  449. - Add patch to fix unintialize value in badsalt test
  450. * Wed Jan 31 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-2
  451. - Add patch to fix bcrypt test with GCC8
  452. * Sat Jan 27 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-1
  453. - New upstream release
  454. * Mon Jan 22 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.0.0-0.204.20180120git3436e7b
  455. - Fix Obsoletes
  456. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.203.20180120git3436e7b
  457. - Update to new snapshot fixing cast-align
  458. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.202.20180120gitde99d27
  459. - Update to new snapshot (rhbz#1536752)
  460. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.201.20171109git15447aa
  461. - Use archful Obsoletes for libcrypt
  462. - Add versioned Requires on glibc packages not shipping libcrypt
  463. - Add comments about the packaging logic for replacing former libcrypt
  464. * Fri Jan 12 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.200.20171109git15447aa
  465. - Initial import (rhbz#1532794)
  466. - Add Obsoletes/Provides for libcrypt
  467. * Wed Jan 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.101.20171109git15447aa
  468. - Fix style of %%git_{rel,ver}
  469. * Tue Jan 09 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.100.git20171109.15447aa
  470. - Initial rpm release (rhbz#1532794)
  471. - Start revision at 0.100 to superseed builds from COPR