123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348 |
- Name: libmariadb
- Version: 3.1.7
- Release: 1%{?_dist_release}
- Epoch: 1
- Summary: The MariaDB Native Client library (C driver)
- Group: System Environment/Libraries
- License: LGPLv2+
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: tomop
- Source: https://downloads.mariadb.com/Connectors/c/connector-c-%{version}/mariadb-connector-c-%{version}-src.tar.gz
- Source2: my.cnf
- Source3: client.cnf
- Url: http://mariadb.org/
- # More information: https://mariadb.com/kb/en/mariadb/building-connectorc-from-source/
- Requires: mariadb-common
- BuildRequires: zlib-devel cmake openssl-devel gcc-c++
- # Remote-IO plugin
- BuildRequires: curl-devel
- %description
- The MariaDB Native Client library (C driver) is used to connect applications
- developed in C/C++ to MariaDB and MySQL databases.
- %package devel
- Summary: Development files for mariadb-connector-c
- Group: Development/Libraries
- Provides: libmysqlclient-devel = %{epoch}:%{version}-%{release}
- Obsoletes: libmysqlclient-devel
- Requires: %{name} = %{epoch}:%{version}-%{release}
- Requires: openssl-devel
- %description devel
- Development files for mariadb-connector-c.
- Contains everything needed to build against libmariadb.so >=3 client library.
- %package -n mariadb-common
- Summary: Configuration files for packages that use /etc/my.cnf as a configuration file
- BuildArch: noarch
- %description -n mariadb-common
- This package delivers /etc/my.cnf that includes other configuration files
- from the /etc/my.cnf.d directory and ships this directory as well.
- Other packages should only put their files into /etc/my.cnf.d directory
- and require this package, so the /etc/my.cnf file is present.
- %prep
- %setup -q -n mariadb-connector-c-%{version}-src
- # Remove unsused parts
- rm -r win zlib win-iconv examples
- %build
- # https://jira.mariadb.org/browse/MDEV-13836:
- # The server has (used to have for ages) some magic around the port number.
- # If it's 0, the default port value will use getservbyname("mysql", "tcp"), that is, whatever is written in /etc/services.
- # If it's a positive number, say, 3306, it will be 3306, no matter what /etc/services say.
- # I don't know if that behavior makes much sense, /etc/services wasn't supposed to be a system configuration file.
- # The INSTALL_xxx macros have to be specified relative to CMAKE_INSTALL_PREFIX
- # so we can't use %%{_datadir} and so forth here.
- %cmake . \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_SYSTEM_PROCESSOR="%{_arch}" \
- \
- -DMARIADB_UNIX_ADDR=%{_sharedstatedir}/mysql/mysql.sock \
- -DMARIADB_PORT=3306 \
- \
- -DWITH_EXTERNAL_ZLIB=YES \
- -DWITH_SSL=OPENSSL \
- -DWITH_MYSQLCOMPAT=ON \
- \
- -DINSTALL_LAYOUT=RPM \
- -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
- -DINSTALL_BINDIR="bin" \
- -DINSTALL_LIBDIR="%{_lib}" \
- -DINSTALL_INCLUDEDIR="include/mysql" \
- -DINSTALL_PLUGINDIR="%{_lib}/mariadb/plugin" \
- \
- -DWITH_UNITTEST=ON
- #cmake -LAH
- make %{?_smp_mflags}
- %install
- rm -rf %{buildroot}
- make install DESTDIR=%{buildroot}
- #multilib_fix_c_header --file %{_includedir}/mysql/mariadb_version.h
- sed -e 's/libmariadb/libmysqlclient/' < %{buildroot}%{_libdir}/pkgconfig/libmariadb.pc > %{buildroot}%{_libdir}/pkgconfig/libmysqlclient.pc
- # Remove static linked libraries and symlinks to them
- rm %{buildroot}%{_libdir}/lib*.a
- # Add a compatibility symlinks
- ln -s mariadb_config %{buildroot}%{_bindir}/mysql_config
- ln -s mariadb_version.h %{buildroot}%{_includedir}/mysql/mysql_version.h
- # Install config files
- install -D -p -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/my.cnf
- install -D -p -m 0644 %{SOURCE3} %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
- %check
- # Check the generated configuration on the actual machine
- %{buildroot}%{_bindir}/mariadb_config
- # Run the unit tests
- # - don't run mytap tests
- # - ignore the testsuite result for now. Enable tests now, fix them later.
- pushd unittest/libmariadb/
- ctest || :
- popd
- # https://fedoraproject.org/wiki/Packaging:Directory_Replacement
- %pretrans -p <lua>
- path = "%{_libdir}/mariadb"
- st = posix.stat(path)
- if st and st.type == "link" then
- os.remove(path)
- end
- path = "%{_libdir}/mysql"
- st = posix.stat(path)
- if st and st.type == "link" then
- os.remove(path)
- end
- %files
- %{_libdir}/libmariadb.so.*
- %dir %{_libdir}/mariadb
- %dir %{_libdir}/mariadb/plugin
- %{_libdir}/mariadb/plugin/*
- %doc README
- %license COPYING.LIB
- %files devel
- # Binary which provides compiler info for software compiling against this library
- %{_bindir}/mariadb_config
- %{_bindir}/mysql_config
- # Symlinks to the versioned library
- %{_libdir}/libmariadb.so
- %{_libdir}/libmysqlclient.so
- %{_libdir}/libmysqlclient_r.so
- # pkgconfig files
- %dir %{_libdir}/pkgconfig
- %{_libdir}/pkgconfig/*
- # Header files
- %dir %{_includedir}/mysql
- %{_includedir}/mysql/*
- %license COPYING.LIB
- %files -n mariadb-common
- %dir %{_sysconfdir}/my.cnf.d
- %config(noreplace) %{_sysconfdir}/my.cnf
- %config(noreplace) %{_sysconfdir}/my.cnf.d/client.cnf
- # RPMLint issues from 2.3.2 release tracked on the upstream JIRA:
- # https://jira.mariadb.org/browse/CONC-232
- # https://jira.mariadb.org/browse/CONC-234
- # RPMLint issues from 3.0.2 release tracked on the upstream JIRA:
- # https://jira.mariadb.org/browse/CONC-287
- # https://jira.mariadb.org/browse/CONC-291
- %changelog
- * Fri Feb 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.7-1
- - new upstream release.
- * Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.3-1
- - new upstream release.
- * Tue Nov 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.7-1
- - new upstream release.
- - dropped Patch0: fixed in upstream.
- * Mon Nov 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.6-3
- - initial built for Vine Linux.
- * Tue Sep 04 2018 Michal Schorm <mschorm@redhat.com> - 3.0.6-2
- - Fix parallel installability of x86_64 and i686 devel package
- * Fri Aug 03 2018 Michal Schorm <mschorm@redhat.com> - 3.0.6-1
- - Rebase to 3.0.6
- * Tue Jul 17 2018 Honza Horak <hhorak@redhat.com> - 3.0.5-3
- - Add -config sub-package that delivers system-wide /etc/my.cnf and
- /etc/my.cnf.d directory, that other packages should use
- This package also obsoletes mariadb-config
- * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.5-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
- * Fri Jun 08 2018 Michal Schorm <mschorm@redhat.com> - 3.0.5-1
- - Rebase to 3.0.5
- * Thu Apr 26 2018 Michal Schorm <mschorm@redhat.com> - 3.0.4-1
- - Rebase to 3.0.4
- * Mon Apr 23 2018 Michal Schorm <mschorm@redhat.com> - 3.0.3-4
- - Further fix of the '--plugindir' output from the config binary
- Realted: #1569159
- * Wed Mar 21 2018 Richard W.M. Jones <rjones@redhat.com> - 3.0.3-3
- - Fix plugin install directory (INSTALL_PLUGINDIR not PLUGIN_INSTALL_DIR).
- * Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.3-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
- * Fri Jan 19 2018 Michal Schorm <mschorm@redhat.com> - 3.0.3-1
- - Rebase to 3.0.3
- * Mon Nov 27 2017 Honza Horak <hhorak@redhat.com> - 3.0.2-21
- - Remove unneeded dependency on xmlto
- * Tue Nov 14 2017 Pavel Raiskup <praiskup@redhat.com> - 3.0.2-19
- - drop misleading provides
- * Wed Nov 08 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-19
- - Move the scriptlet to the correct package
- * Thu Nov 02 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-18
- - Fix typo in require
- * Wed Nov 01 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-17
- - Use correct require for OpenSSL
- * Wed Nov 01 2017 Merlin Mathesius <mmathesi@redhat.com> - 3.0.2-16
- - Correct typo in spec file conditional
- * Tue Oct 31 2017 Merlin Mathesius <mmathesi@redhat.com> - 3.0.2-15
- - Cleanup spec file conditionals
- * Tue Oct 31 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-14
- - Remove Requires for openssl. Managed by RPM.
- * Mon Oct 30 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-13
- - Update scriplet dealing with symlinks as Guidelines suggests
- Related: #1501933
- * Thu Oct 26 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-12
- - Move library directly to libdir, don't create any symlinks to directories
- - Update scritplets, so they only check for old symlinks to directories
- Related: #1501933
- - Add 'Conflicts' with mariadb package on F<28
- Related: #1506441
- * Mon Oct 09 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-11
- - Fix ldconfig path
- * Wed Oct 04 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-10
- - Add scriptlets to handle errors in /usr/lib64/ created by older versions
- of mariadb and mariadb-connector-c pakages
- * Wed Sep 20 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-9
- - Add symlinks so more packages will build succesfully
- - Change libdir from .../lib64/mariadb to mysql
- Related: #1497234
- * Wed Sep 13 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-7
- - Move header files to the same location, as they would be in mariadb-server
- - Add provides "libmysqlclient.so"
- * Tue Sep 05 2017 Honza Horak <hhorak@redhat.com> - 3.0.2-5
- - Remove a symlink /usr/lib64/mysql that conflicts with mariadb-libs
- * Mon Aug 14 2017 Honza Horak <hhorak@redhat.com> - 3.0.2-4
- - Add compatibility symlinks
- * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
- * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
- * Wed Jun 07 2017 Michal Schorm <mschorm@redhat.com> - 3.0.2-1
- - Rebase to version 3.0.2
- - Library libmariadb.so.3 introduced
- - Plugin Remote-IO enabled
- * Wed Jun 07 2017 Michal Schorm <mschorm@redhat.com> - 2.3.3-1
- - Rebase to version 2.3.3
- - Patch dropped, solved by upstream; https://jira.mariadb.org/browse/CONC-231
- * Tue Feb 07 2017 Michal Schorm <mschorm@redhat.com> - 2.3.2-2
- - Fix based on output from RPMLint in previous version
- * Tue Jan 24 2017 Michal Schorm <mschorm@redhat.com> - 2.3.2-1
- - Rebase to version 2.3.2, patch needed (fixed by upstream in later versions)
- - Plugin dir moved from /libdir/plugin to /libdir/mariadb/plugin
- * Thu Oct 27 2016 Michal Schorm <mschorm@redhat.com> - 2.3.1-3
- - Fixed ownership of {_libdir}/mariadb (this dir must me owned by package)
- - Fixed ownership of {_sysconfigdir}/ld.so.conf.d (this dir must me owned by package)
- - Fixed redundnace on lines with {_sysconfigdir}/ld.so.conf.d
- - Fixed ownership of {_bindir} (only one program is owned, so let's be accurate)
- - Some comments added, for me and future maintainers
- * Mon Oct 17 2016 Michal Schorm <mschorm@redhat.com> - 2.3.1-2
- - Fixed ownership of {_libdir}/mariadb directory and cosmetic specfile changes
- * Tue Sep 13 2016 Michal Schorm <mschorm@redhat.com> - 2.3.1-1
- - Rebase to version 2.3.1
- * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
- * Thu Jul 23 2015 Matej Mužila <mmuzila@redhat.com> - 2.1.0-1
- - Rebase to version 2.1.0
- * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
- * Wed Sep 24 2014 Matej Mužila <mmuzila@redhat.com> - 2.0.0-2
- - Fixed html IDs in documentation
- * Tue Aug 26 2014 Matej Mužila <mmuzila@redhat.com> - 2.0.0-2
- - Initial version for 2.0.0
|