brltty-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582
  1. %define pkg_version 5.2
  2. %define api_version 0.6.3
  3. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  4. %{!?pyver: %define pyver %(%{__python} -c "import sys; v=sys.version_info[:2]; print '%d.%d'%v")}
  5. %{!?tcl_version: %global tcl_version %(echo 'puts $tcl_version' | tclsh)}
  6. #define _exec_prefix %{nil}
  7. #define _libdir /%{_lib}
  8. # with speech dispatcher iff on Fedora:
  9. %define with_speech_dispatcher 1
  10. %define with_ocaml 1
  11. Name: brltty
  12. Version: %{pkg_version}
  13. Release: 1%{?_dist_release}
  14. Summary: Braille display driver for Linux/Unix
  15. License: GPLv2+
  16. Group: System Environment/Daemons
  17. URL: http://mielke.cc/brltty/
  18. Source: http://mielke.cc/brltty/releases/%{name}-%{version}.tar.xz
  19. Patch4: brltty-loadLibrary.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. BuildRequires: bluez-libs-devel
  22. BuildRequires: byacc
  23. BuildRequires: gettext
  24. BuildRequires: glibc-kernheaders
  25. # work around a bug in the install process:
  26. Requires(post): coreutils
  27. %description
  28. BRLTTY is a background process (daemon) which provides
  29. access to the Linux/Unix console (when in text mode)
  30. for a blind person using a refreshable braille display.
  31. It drives the braille display and provides complete
  32. screen review functionality.
  33. %if %{with_speech_dispatcher}
  34. BRLTTY can also work with speech synthetizers; if you want to use it with
  35. Speech Dispatcher, please install also package %{name}-speech-dispatcher.
  36. %package speech-dispatcher
  37. Summary: Speech Dispatcher driver for BRLTTY
  38. Group: System Environment/Daemons
  39. License: GPLv2+
  40. BuildRequires: speech-dispatcher-devel
  41. Requires: %{name} = %{pkg_version}-%{release}
  42. %description speech-dispatcher
  43. This package provides the Speech Dispatcher driver for BRLTTY.
  44. %endif
  45. %package docs
  46. Summary: Documentation for BRLTTY
  47. Summary(ja): BRLTTY のドキュメント
  48. Group: Documentation
  49. License: GPLv2+
  50. Requires: %{name} = %{pkg_version}-%{release}
  51. BuildArch: noarch
  52. %description docs
  53. This package provides the documentation for BRLTTY.
  54. %package xw
  55. Summary: XWindow driver for BRLTTY
  56. Group: System Environment/Daemons
  57. License: GPLv2+
  58. BuildRequires: libSM-devel
  59. BuildRequires: libICE-devel
  60. BuildRequires: libX11-devel
  61. BuildRequires: libXaw-devel
  62. BuildRequires: libXext-devel
  63. BuildRequires: libXt-devel
  64. BuildRequires: libXtst-devel
  65. Requires: %{name} = %{pkg_version}-%{release}
  66. %description xw
  67. This package provides the XWindow driver for BRLTTY.
  68. %package at-spi
  69. Summary: AtSpi driver for BRLTTY
  70. Group: System Environment/Daemons
  71. # The data files are licensed under LGPLv2+, see the README file.
  72. License: GPLv2+ and LGPLv2+
  73. BuildRequires: at-spi-devel
  74. Requires: %{name} = %{pkg_version}-%{release}
  75. %description at-spi
  76. This package provides the AtSpi driver for BRLTTY.
  77. %package -n brlapi
  78. Summary: Appliation Programming Interface for BRLTTY
  79. Summary(ja): BRLTTY の API
  80. Version: %{api_version}
  81. Group: Applications/System
  82. License: LGPLv2+
  83. Requires: %{name} = %{pkg_version}-%{release}
  84. %description -n brlapi
  85. This package provides the run-time support for the Application
  86. Programming Interface to BRLTTY.
  87. Install this package if you have an application which directly accesses
  88. a refreshable braille display.
  89. %package -n brlapi-devel
  90. Summary: Headers, static archive, and documentation for BrlAPI
  91. Summary(ja): BrlAPI の開発用ファイル
  92. Version: %{api_version}
  93. Group: Development/Libraries
  94. License: LGPLv2+
  95. Requires: brlapi = %{api_version}-%{release}
  96. %description -n brlapi-devel
  97. This package provides the header files, static archive, shared object
  98. linker reference, and reference documentation for BrlAPI (the
  99. Application Programming Interface to BRLTTY). It enables the
  100. implementation of applications which take direct advantage of a
  101. refreshable braille display in order to present information in ways
  102. which are more appropriate for blind users and/or to provide user
  103. interfaces which are more specifically atuned to their needs.
  104. Install this package if you are developing or maintaining an application
  105. which directly accesses a refreshable braille display.
  106. %package -n tcl-brlapi
  107. Summary: Tcl binding for BrlAPI
  108. Summary(ja): BrlAPI の Tcl バインディング
  109. Version: %{api_version}
  110. Group: Development/Libraries
  111. License: LGPLv2+
  112. BuildRequires: tcl-devel
  113. Requires: brlapi = %{api_version}-%{release}
  114. %description -n tcl-brlapi
  115. This package provides the Tcl binding for BrlAPI.
  116. %package -n python-brlapi
  117. Summary: Python binding for BrlAPI
  118. Summary(ja): BrlAPI の Python バインディング
  119. Version: %{api_version}
  120. Group: Development/Libraries
  121. License: LGPLv2+
  122. BuildRequires: Cython
  123. BuildRequires: python-devel
  124. BuildRequires: python-setuptools
  125. Requires: brlapi = %{api_version}-%{release}
  126. %description -n python-brlapi
  127. This package provides the Python binding for BrlAPI.
  128. %package -n brlapi-java
  129. Summary: Java binding for BrlAPI
  130. Summary(ja): BrlAPI の Java バインディング
  131. Version: %{api_version}
  132. Group: Development/Libraries
  133. License: LGPLv2+
  134. Requires: brlapi = %{api_version}-%{release}
  135. ## temporary work around, java-devel is not resolved consistently acrss archs
  136. BuildRequires: java-devel
  137. #BuildRequires: java-1.5.0-gcj-devel
  138. %description -n brlapi-java
  139. This package provides the Java binding for BrlAPI.
  140. %if %{with_ocaml}
  141. %package -n ocaml-brlapi
  142. Summary: OCaml binding for BrlAPI
  143. Summary(ja): BrlAPI の OCaml バインディング
  144. Version: %{api_version}
  145. Group: Development/Libraries
  146. License: LGPLv2+
  147. Requires: brlapi = %{api_version}-%{release}
  148. BuildRequires: ocaml
  149. BuildRequires: ocaml-findlib
  150. %description -n ocaml-brlapi
  151. This package provides the OCaml binding for BrlAPI.
  152. %endif
  153. %define version %{pkg_version}
  154. %prep
  155. %setup -q
  156. %patch4 -p1 -b .loadLibrary
  157. #patch5 -p1
  158. %build
  159. # If MAKEFLAGS=-jN is set it would break local builds.
  160. unset MAKEFLAGS
  161. # Add the openjdk include directories to CPPFLAGS
  162. for i in -I/usr/lib/jvm/java/include{,/linux}; do
  163. java_inc="$java_inc $i"
  164. done
  165. export CPPFLAGS="$java_inc"
  166. export CFLAGS="%{optflags} -I%{_includedir}/speech-dispatcher -fno-strict-aliasing"
  167. export CXXFLAGS="%{optflags} -I%{_includedir}/speech-dispatcher -fno-strict-aliasing"
  168. # there is no curses packages in BuildRequires, so the package builds
  169. # without them in mock; let's express this decision explicitly
  170. %configure \
  171. --disable-stripping \
  172. --without-curses \
  173. %if %{with_speech_dispatcher}
  174. --with-speechd=%{_prefix} \
  175. %endif
  176. --with-install-root=$RPM_BUILD_ROOT \
  177. JAVA_JAR_DIR=%{_jnidir} \
  178. JAVA_JNI_DIR=%{_libdir}/brltty \
  179. JAVA_JNI=yes \
  180. PYTHON=%{__python}
  181. # Parallel build seems broken, thus disabling it
  182. make
  183. find . \( -path ./doc -o -path ./Documents \) -prune -o \
  184. \( -name 'README*' -o -name '*.txt' -o -name '*.html' -o \
  185. -name '*.sgml' -o -name '*.patch' -o \
  186. \( -path './Bootdisks/*' -type f -perm /ugo=x \) \) -print |
  187. while read file; do
  188. mkdir -p doc/${file%/*} && cp -rp $file doc/$file || exit 1
  189. done
  190. find . -name '*.sgml' |
  191. while read file; do
  192. iconv -f iso8859-1 -t utf-8 $file > $file.conv && mv -f $file.conv $file
  193. done
  194. find . -name '*.txt' |
  195. while read file; do
  196. iconv -f iso8859-1 -t utf-8 $file > $file.conv && mv -f $file.conv $file
  197. done
  198. find . -name 'README*' |
  199. while read file; do
  200. iconv -f iso8859-1 -t utf-8 $file > $file.conv && mv -f $file.conv $file
  201. done
  202. # backup Documents
  203. cp -a Documents Documents.buildsnap
  204. %install
  205. rm -rf $RPM_BUILD_ROOT
  206. rm -rf Documents
  207. cp -a Documents.buildsnap Documents
  208. %if %{with_ocaml}
  209. mkdir -p $RPM_BUILD_ROOT%{_libdir}/ocaml/stublibs
  210. %endif
  211. make install JAVA_JAR_DIR=%{_jnidir} \
  212. JAVA_JNI_DIR=%{_libdir}/brltty \
  213. JAVA_JNI=yes
  214. install -d -m 755 $RPM_BUILD_ROOT%{_sysconfdir} $RPM_BUILD_ROOT%{_mandir}/man5
  215. install -m 644 Documents/brltty.conf ${RPM_BUILD_ROOT}%{_sysconfdir}
  216. echo ".so man1/brltty.1" > $RPM_BUILD_ROOT%{_mandir}/man5/brltty.conf.5
  217. # clean up the manuals:
  218. rm Documents/Manual-*/*/{*.mk,*.made,Makefile*}
  219. mv Documents/BrlAPIref/{html,BrlAPIref}
  220. # Don't want static lib
  221. rm -rf $RPM_BUILD_ROOT%{_libdir}/libbrlapi.a
  222. # ghost brlapi.key
  223. touch $RPM_BUILD_ROOT%{_sysconfdir}/brlapi.key
  224. # disable xbrlapi gdm autostart, there is already orca
  225. rm -f $RPM_BUILD_ROOT%{_datadir}/gdm/greeter/autostart/xbrlapi.desktop
  226. # handle locales
  227. %find_lang %{name}
  228. %clean
  229. rm -rf $RPM_BUILD_ROOT
  230. %post
  231. devices="/dev/vcsa /dev/vcsa0 /dev/vcc/a"
  232. install=true
  233. for device in ${devices}
  234. do
  235. if [ -c "${device}" ]
  236. then
  237. install=false
  238. break
  239. fi
  240. done
  241. if $install
  242. then
  243. device="$(set -- ${devices} && echo "${1}")"
  244. mkdir -p "${device%/*}"
  245. mknod -m o= "${device}" c 7 128
  246. chmod 660 "${device}"
  247. chown root.tty "${device}"
  248. fi
  249. exit 0
  250. %pre -n brlapi
  251. getent group brlapi >/dev/null || groupadd -r brlapi >/dev/null
  252. %post -n brlapi
  253. if [ ! -e %{_sysconfdir}/brlapi.key ]; then
  254. mcookie > %{_sysconfdir}/brlapi.key
  255. chgrp brlapi %{_sysconfdir}/brlapi.key
  256. chmod 0640 %{_sysconfdir}/brlapi.key
  257. fi
  258. /sbin/ldconfig
  259. %postun -n brlapi -p /sbin/ldconfig
  260. %files -f %{name}.lang
  261. %defattr(-,root,root)
  262. %doc LICENSE-GPL LICENSE-LGPL
  263. %config(noreplace) %{_sysconfdir}/brltty.conf
  264. %{_sysconfdir}/brltty/
  265. %{_bindir}/brltty
  266. %{_bindir}/brltty-*
  267. %{_libdir}/brltty/
  268. %exclude %{_libdir}/brltty/libbrlttybba.so
  269. %exclude %{_libdir}/brltty/libbrlttybxw.so
  270. %exclude %{_libdir}/brltty/libbrlapi_java.so
  271. %if %{with_speech_dispatcher}
  272. %exclude %{_libdir}/brltty/libbrlttyssd.so
  273. %endif
  274. %exclude %{_libdir}/brltty/libbrlttyxas.so
  275. %{_mandir}/man[15]/brltty.*
  276. %if %{with_speech_dispatcher}
  277. %files speech-dispatcher
  278. %defattr(-,root,root)
  279. %doc Drivers/Speech/SpeechDispatcher/README
  280. %{_libdir}/brltty/libbrlttyssd.so
  281. %endif
  282. %files docs
  283. %defattr(-,root,root)
  284. %doc Documents/ChangeLog Documents/TODO
  285. %doc Documents/Manual-BRLTTY/
  286. %doc doc/*
  287. %files xw
  288. %defattr(-,root,root)
  289. %doc Drivers/Braille/XWindow/README
  290. %{_libdir}/brltty/libbrlttybxw.so
  291. %files at-spi
  292. %defattr(-,root,root)
  293. %{_libdir}/brltty/libbrlttyxas.so
  294. %files -n brlapi
  295. %defattr(-,root,root)
  296. %doc Drivers/Braille/XWindow/README
  297. %doc Documents/Manual-BrlAPI/
  298. %ghost %{_sysconfdir}/brlapi.key
  299. %{_bindir}/vstp
  300. %{_bindir}/eutp
  301. %{_bindir}/xbrlapi
  302. %{_libdir}/brltty/libbrlttybba.so
  303. %{_libdir}/libbrlapi.so.*
  304. %{_mandir}/man1/xbrlapi.*
  305. %{_mandir}/man1/vstp.*
  306. %{_mandir}/man1/eutp.*
  307. %files -n brlapi-devel
  308. %defattr(-,root,root)
  309. %doc Documents/BrlAPIref/BrlAPIref/
  310. %{_libdir}/libbrlapi.so
  311. %{_includedir}/brltty
  312. %{_includedir}/brlapi*.h
  313. %{_mandir}/man3/brlapi_*.3*
  314. %files -n tcl-brlapi
  315. %defattr(-,root,root)
  316. %{_libdir}/tcl%{tcl_version}/brlapi-%{api_version}
  317. %files -n python-brlapi
  318. %defattr(-,root,root)
  319. %{python_sitearch}/brlapi.so
  320. %{python_sitearch}/Brlapi-%{api_version}-py%{pyver}.egg-info
  321. %files -n brlapi-java
  322. %defattr(-,root,root)
  323. %{_libdir}/brltty/libbrlapi_java.so
  324. %{_jnidir}/brlapi.jar
  325. %if %{with_ocaml}
  326. %files -n ocaml-brlapi
  327. %defattr(-,root,root)
  328. %{_libdir}/ocaml/brlapi/
  329. %{_libdir}/ocaml/stublibs/
  330. %endif
  331. %changelog
  332. * Tue Feb 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.2-1
  333. - updated to 5.2
  334. - added speech-dispatcher, doc, and ocaml subpackages
  335. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2-2
  336. - rebuild with python-2.7.2
  337. * Sat Nov 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2-1
  338. - initial build for Vine Linux
  339. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2-4
  340. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  341. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 4.2-3
  342. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  343. * Fri May 21 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 4.2-2
  344. - rework parallel patch slightly and reapply
  345. * Fri May 21 2010 Tom "spot" Callaway <tcallawa@redhat.com> - 4.2-1
  346. - update to 4.2
  347. - drop static lib (bz 556041)
  348. - fix undefined S_ISCHR call
  349. * Wed Jan 20 2010 Stepan Kasal <skasal@redhat.com> - 4.1-5
  350. - requires(post): coreutils to work around an installator bug
  351. - Resolves: #540437
  352. * Wed Jan 13 2010 Stepan Kasal <skasal@redhat.com> - 4.1-4
  353. - limit building against speech-dispatcher to Fedora
  354. - Resolves: rhbz#553795
  355. * Sun Nov 1 2009 Stepan Kasal <skasal@redhat.com> - 4.1-3
  356. - build the TTY driver (it was disabled since it first appered in 3.7.2-1)
  357. - build with speech-dispatcher, packed into a separate sub-package
  358. * Fri Oct 30 2009 Stepan Kasal <skasal@redhat.com> - 4.1-2
  359. - move data-directory back to default: /etc/brltty
  360. - move brltty to /bin and /lib, so that it can be used to repair the system
  361. without /usr mounted (#276181)
  362. - move vstp and libbrlttybba.so to brlapi
  363. - brltty no longer requires brlapi
  364. - brlapi now requires brltty from the same build
  365. * Wed Oct 28 2009 Stepan Kasal <skasal@redhat.com> - 4.1-1
  366. - new upstream version
  367. - use --disable-stripping instead of make variable override
  368. - install the default brltty-pm.conf to docdir only (#526168)
  369. - remove the duplicate copies of rhmkboot and rhmkroot from docdir
  370. - patch configure so that the dirs in summary are not garbled:
  371. brltty-autoconf-quote.patch
  372. - move data-directory to ${datadir}/brltty
  373. * Tue Oct 20 2009 Stepan Kasal <skasal@redhat.com> - 4.0-2
  374. - escape rpm macros in the rpm change log
  375. - add requires to bind subpackages from one build together
  376. * Wed Oct 7 2009 Stepan Kasal <skasal@redhat.com> - 4.0-1
  377. - new upstream version
  378. - drop upstreamed patches; ./autogen not needed anymore
  379. - pack the xbrlapi server; move its man page to brlapi package
  380. - add man-page for brltty.conf (#526168)
  381. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10-6
  382. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  383. * Tue May 12 2009 Stepan Kasal <skasal@redhat.com> - 3.10-5
  384. - rebuild after java-1.5.0-gcj rebuild
  385. * Thu Apr 30 2009 Stepan Kasal <skasal@redhat.com> - 3.10-4
  386. - own the tcl subdirectory (#474032)
  387. - set CPPFLAGS to java include dirs, so that the java bindings build with
  388. any java implementation (#498964)
  389. - add --without-curses; there is no curses package BuildRequired anyway
  390. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10-3
  391. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  392. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.10-2
  393. - Rebuild for Python 2.6
  394. * Sat Sep 13 2008 Stepan Kasal <skasal@redhat.com> - 3.10-1
  395. - new upstream release
  396. - drop brltty-3.9-java-svn.patch, brltty-3.9-tcl85path.patch,
  397. and brltty-3.9-pyxfix.patch, they are upstream
  398. - fix BuildRoot
  399. - fix many sub-packages' Requires on brlapi
  400. * Wed Sep 10 2008 Stepan Kasal <skasal@redhat.com> - 3.9-3
  401. - add brltty-3.9-autoconf.patch to fix to build with Autoconf 2.62
  402. - add brltty-3.9-parallel.patch to fix race condition with parallel make
  403. - add brltty-3.9-pyxfix.patch to fix build with current pyrex
  404. - Summary lines shall not end with a dot
  405. * Thu Feb 28 2008 Tomas Janousek <tjanouse@redhat.com> - 3.9-2.2
  406. - glibc build fixes
  407. - applied java reorganisations from svn
  408. * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 3.9-2.1
  409. - Autorebuild for GCC 4.3
  410. * Wed Jan 09 2008 Tomas Janousek <tjanouse@redhat.com> - 3.9-1.1
  411. - specfile update to comply with tcl packaging guidelines
  412. * Mon Jan 07 2008 Tomas Janousek <tjanouse@redhat.com> - 3.9-1
  413. - update to latest upstream (3.9)
  414. * Tue Sep 18 2007 Tomas Janousek <tjanouse@redhat.com> - 3.8-2.svn3231
  415. - update to r3231 from svn
  416. - added java binding subpackage
  417. * Wed Aug 29 2007 Tomas Janousek <tjanouse@redhat.com> - 3.8-2.svn3231
  418. - update to r3231 from svn
  419. * Tue Aug 21 2007 Tomas Janousek <tjanouse@redhat.com> - 3.8-1
  420. - update to latest upstream
  421. - added the at-spi driver, tcl and python bindings
  422. - fixed the license tags
  423. * Mon Mar 05 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-3
  424. - added the XWindow driver
  425. - build fix for newer byacc
  426. * Tue Jan 30 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-2.1
  427. - quiet postinstall scriptlet, really fixes #224570
  428. * Tue Jan 30 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-2
  429. - failsafe postinstall script, fixes #224570
  430. - makefile fix - debuginfo extraction now works
  431. * Thu Jan 25 2007 Tomas Janousek <tjanouse@redhat.com> - 3.7.2-1.1
  432. - fix building with newer kernel-headers (#224149)
  433. * Wed Jul 12 2006 Petr Rockai <prockai@redhat.com> - 3.7.2-1
  434. - upgrade to latest upstream version
  435. - split off brlapi and brlapi-devel packages
  436. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 3.2-12.1
  437. - rebuild
  438. * Sun Jul 02 2006 Florian La Roche <laroche@redhat.com>
  439. - for the post script require coreutils
  440. * Mon Jun 05 2006 Jesse Keating <jkeating@redhat.com> - 3.2-11
  441. - Added byacc BuildRequires, removed prereq, coreutils is always there
  442. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 3.2-10.2.1
  443. - bump again for double-long bug on ppc(64)
  444. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 3.2-10.2
  445. - rebuilt for new gcc4.1 snapshot and glibc changes
  446. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  447. - rebuilt
  448. * Wed Mar 16 2005 Bill Nottingham <notting@redhat.com> 3.2-10
  449. - rebuild
  450. * Fri Nov 26 2004 Florian La Roche <laroche@redhat.com>
  451. - add a %%clean into .spec
  452. * Thu Oct 14 2004 Adrian Havill <havill@redhat.com> 3.2-5
  453. - chmod a-x for conf file (#116244)
  454. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  455. - rebuilt
  456. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  457. - rebuilt
  458. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  459. - rebuilt
  460. * Tue Sep 30 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  461. - prereq coreutils for mknod/chown/chmod
  462. * Mon Jul 07 2003 Adrian Havill <havill@redhat.com> 3.2-2
  463. - changed spec "Copyright" to "License"
  464. - use %%configure macro, %%{_libdir} for non-ia32 archs
  465. - removed unnecessary set and unset, assumed/default spec headers
  466. - fixed unpackaged man page, duplicate /bin and /lib entries
  467. - use plain install vs scripts for non-i386 buildsys