libexo-vl.spec 5.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193
  1. %define srcname exo
  2. Summary: extension library to Xfce
  3. Summary(ja): Xfce の拡張ライブラリ
  4. Name: libexo
  5. Version: 0.6.0
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Libraries
  8. License: LGPLv2
  9. URL: http://www.xfce.org/
  10. Source0: http://www.xfce.org/archive/xfce-%{version}/src/%{srcname}-%{version}.tar.bz2
  11. # FIXME: upstream this patch
  12. Patch0: exo-0.5.4-x86_64-build.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: glib2-devel >= 2.27.0
  15. BuildRequires: gtk2-devel >= 2.14.0
  16. BuildRequires: intltool >= 0.31
  17. BuildRequires: libxfce4util-devel >= 4.8.0
  18. BuildRequires: libnotify-devel >= 0.4.0
  19. BuildRequires: python-devel
  20. BuildRequires: pygtk2-devel
  21. BuildRequires: perl-URI
  22. BuildRequires: chrpath
  23. Requires(post): gtk2
  24. Requires(postun): gtk2
  25. Provides: %{srcname} = %{version}-%{release}
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. %description
  29. libexo is the extension library to Xfce developed by os-cillation.
  30. While Xfce ships with quite a few libraries that are primarly targeted
  31. at desktop development, libexo is targeted at application development,
  32. with a focus on applications for Xfce.
  33. %description -l ja
  34. libexo は os-cillation により開発された Xfce の拡張ライブラリです.
  35. Xfce はデスクトップ環境の開発を第一の目的としたごくわずかのライブラリ
  36. と共に作成されていますが,libexo はアプリケーションの開発,それも
  37. Xfce 用のアプリケーション開発に焦点を定めています.
  38. %package -n %{name}-devel
  39. Summary: Header files and libraries for developing apps which will use %{name}
  40. Summary(ja): libexo の開発用ヘッダファイル及びライブラリ
  41. Group: Development/Libraries
  42. Requires: %{name} = %{version}-%{release}
  43. Requires: gtk2-devel >= 2.6.0
  44. Requires: libxfce4util-devel >= 4.2.2
  45. Provides: %{srcname}-devel = %{version}-%{release}
  46. %description -n %{name}-devel
  47. The libexo-devel package contains the header files and libraries needed
  48. to develop programs that use the libexo library.
  49. %description -n %{name}-devel -l ja
  50. libexo-develはlibexoライブラリを用いるプログラムの開発に
  51. 必要なヘッダファイル及びライブラリを含むパッケージです。
  52. %prep
  53. %setup -q -n %{srcname}-%{version}
  54. %patch0 -p1 -b .x86_64-build
  55. %build
  56. %configure --disable-static
  57. %__make
  58. %install
  59. rm -rf $RPM_BUILD_ROOT
  60. make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
  61. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  62. rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  63. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/exo-desktop-item-edit
  64. chrpath --delete $RPM_BUILD_ROOT%{_bindir}/exo-open
  65. chrpath --delete $RPM_BUILD_ROOT%{_libdir}/xfce4/exo-*/exo-helper-*
  66. chrpath --delete $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/exo-*/_exo.so
  67. #chrpath --delete $RPM_BUILD_ROOT%{_libdir}/gio/modules/libexo-module-*.so
  68. rm -rf _docs_to_include
  69. mkdir -p _docs_to_include
  70. mv $RPM_BUILD_ROOT%{_docdir}/exo/html _docs_to_include/
  71. rm -rf $RPM_BUILD_ROOT%{_docdir}/exo
  72. %find_lang exo-1
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75. %post
  76. /sbin/ldconfig
  77. touch --no-create %{_datadir}/icons/hicolor
  78. %postun
  79. /sbin/ldconfig
  80. if [ $1 -eq 0 ]; then
  81. touch --no-create %{_datadir}/icons/hicolor
  82. /usr/bin/gtk-update-icon-cache -qf %{_datadir}/icons/hicolor;
  83. fi
  84. %posttrans
  85. gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
  86. %files -f exo-1.lang
  87. %defattr(-,root,root)
  88. %doc AUTHORS COPYING ChangeLog README THANKS TODO
  89. %doc _docs_to_include/*
  90. %config(noreplace) %{_sysconfdir}/xdg/xfce4/helpers.rc
  91. %{_bindir}/*
  92. %{_libdir}/lib*.so.*
  93. %{_libdir}/python?.?/site-packages/*
  94. %{_libdir}/xfce4/*
  95. %{_datadir}/applications/*.desktop
  96. %{_datadir}/icons/hicolor/*/apps/*.png
  97. %{_datadir}/pixmaps/exo-1
  98. %{_datadir}/pygtk/2.0/*
  99. %{_datadir}/xfce4/helpers
  100. %{_mandir}/man1/*
  101. %files -n %{name}-devel
  102. %defattr(-,root,root)
  103. %{_libdir}/lib*.so
  104. %{_libdir}/pkgconfig/*.pc
  105. %{_includedir}/exo-1
  106. %{_datadir}/gtk-doc/html/exo-1
  107. %changelog
  108. * Mon Mar 28 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.0-1
  109. - new upstrem release
  110. * Thu Sep 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.107-2
  111. - rebuilt with rpm-4.8.1 for pkg-config
  112. * Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.107-1
  113. - new upstrem release
  114. - built with new toolchain
  115. * Mon Feb 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.106-1
  116. - new upstrem release
  117. - added BR: perl-URI
  118. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.3.105-2
  119. - rebuilt with python-2.6.4
  120. * Sun Nov 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.105-1
  121. - new upstrem release
  122. * Fri May 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.101-1
  123. - new upstrem release
  124. - removed lib*.a from devel package
  125. * Sun Aug 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.4-1
  126. - applied with new versioning policy
  127. - spec in UTF-8
  128. * Fri Jan 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3.4-0vl3
  129. - add BuildRequires: libnotify >= 0.4.0, xfce-mcs-plugins >= 4.2.2
  130. * Sun Dec 23 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.4-0vl2
  131. - new upstream release.
  132. * Sun Jul 29 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl2
  133. - build for VineSeed
  134. * Sat Jul 28 2007 UECHI Yasumasa <uechi@potaway.net> 0.3.2-0vl1
  135. - new upstream version
  136. - add %{_sysconfdir}/xdg/xfce4/helpers.rc in files section.
  137. - add %{_bindir}/* in files section.
  138. - add %{_libdir}/xfce4 in files section.
  139. - add %{_libexecdir}/* in files section.
  140. - add %{_datadir}/icons/hicolor/*/apps/*.png in files section.
  141. - add %{_mandir}/man1/* in files section.
  142. - add %{_datadir}/xfce4/doc/*/* in files section.
  143. - add %{_datadir}/xfce4/helpers in files section.
  144. - remove %{_datadir}/gtk-doc/html/exo in files section.
  145. - update icon-cache in %post and %postun.
  146. * Fri Aug 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl3
  147. - changed Group to System Environment/Libraires
  148. - changed devel Group to Development/Libraries
  149. - added %post and %postun section
  150. * Fri Apr 22 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl2
  151. - rebuild for VineSeed
  152. * Sun Apr 17 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.3.0-0vl1
  153. - initial build for Vine Linux