ffmpeg-vl.spec 8.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275
  1. #TODO: Build with openjpeg
  2. %define name ffmpeg
  3. %define version 0.6
  4. %define svndate 20100410
  5. %define release 1%{?svndate:.%svndate}%{?_dist_release}
  6. Summary: Digital VCR and streaming server
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. #Source: %{name}-%{version}.tar.bz2
  11. Source: %{name}-%{?svndate:%svndate}.tar.bz2
  12. Source1: %{name}-snapshot.sh
  13. # pre-built man files
  14. Source90: ffmpeg.1.gz
  15. Source91: ffplay.1.gz
  16. Source92: ffserver.1.gz
  17. Source93: ffprobe.1.gz
  18. # get rid of textrels on x86_64 in yasm code (from RPM Fusion)
  19. #Patch0: %{name}-textrel.patch
  20. License: GPLv2+
  21. Group: Applications/Multimedia
  22. URL: http://ffmpeg.org/
  23. BuildRequires: bzip2-devel
  24. BuildRequires: gsm-devel
  25. BuildRequires: imlib2-devel
  26. BuildRequires: libdc1394-devel
  27. BuildRequires: libraw1394-devel
  28. BuildRequires: libtheora-devel
  29. BuildRequires: libvdpau-devel
  30. BuildRequires: libvorbis-devel
  31. ##BuildRequires: openjpeg-devel
  32. BuildRequires: SDL-devel
  33. BuildRequires: speex-devel
  34. ##BuildRequires: texi2html
  35. BuildRequires: zlib-devel
  36. BuildRequires: libogg-devel
  37. %ifarch %{ix86} x86_64
  38. BuildRequires: yasm
  39. %endif
  40. # *-devel packages provided by other self-build-* should only be listed
  41. # in self-build-%{name}.spec as PreReq.
  42. #BuildRequires: xvidcore-devel, faac-devel, lame-devel
  43. #BuildRequires: x264-devel, libdca-devel, a52dec-devel
  44. #BuildRequires: faad2-devel
  45. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  46. %description
  47. FFMpeg is a complete and free Internet live audio and video
  48. broadcasting solution for Linux/Unix. It also includes a digital
  49. VCR. It can encode in real time in many formats including MPEG1 audio
  50. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  51. %package libs
  52. Group: System Environment/Libraries
  53. Summary: Libraries for %{name}
  54. Group: System Environment/Libraries
  55. %description libs
  56. FFMpeg is a complete and free Internet live audio and video
  57. broadcasting solution for Linux/Unix. It also includes a digital
  58. VCR. It can encode in real time in many formats including MPEG1 audio
  59. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  60. This package contains the libraries for %{name}.
  61. %package devel
  62. Summary: Development package for %{name}
  63. Group: Development/Libraries
  64. Requires: %{name}-libs = %{version}-%{release}
  65. Requires: pkgconfig
  66. %description devel
  67. FFMpeg is a complete and free Internet live audio and video
  68. broadcasting solution for Linux/Unix. It also includes a digital
  69. VCR. It can encode in real time in many formats including MPEG1 audio
  70. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  71. This package contains development files for %{name}.
  72. %prep
  73. %setup -q -n %{name}-%{svndate}
  74. #% setup -q
  75. #%patch0 -p1 -b .textrel
  76. %build
  77. %ifarch ppc
  78. # compile with -mlongcall on ppc/ppc64 (rf804)
  79. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
  80. %endif
  81. ./configure \
  82. --prefix=%{_prefix} \
  83. --incdir=%{_includedir}/%{name} \
  84. --shlibdir=%{_libdir} \
  85. --libdir=%{_libdir} \
  86. --mandir=%{_mandir} \
  87. --arch=%{_target_cpu} \
  88. %ifarch %{ix86}
  89. --cpu=%{_target_cpu} \
  90. %endif
  91. %ifarch ppc
  92. --cpu=g3 \
  93. %endif
  94. --enable-runtime-cpudetect \
  95. --extra-cflags="$RPM_OPT_FLAGS" \
  96. %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3} \
  97. --enable-bzlib \
  98. --enable-libdc1394 \
  99. --enable-libfaac --enable-nonfree \
  100. --enable-libfaad \
  101. --enable-libgsm \
  102. --enable-libmp3lame \
  103. %{?_with_openjpeg:--enable-libopenjpeg} \
  104. --enable-libtheora \
  105. --enable-libvorbis \
  106. --enable-libx264 \
  107. --enable-libxvid \
  108. --enable-x11grab \
  109. --enable-avfilter \
  110. --enable-avfilter-lavf \
  111. --enable-postproc \
  112. --enable-swscale \
  113. --enable-pthreads \
  114. --disable-static \
  115. --enable-shared \
  116. --enable-gpl \
  117. --disable-debug \
  118. --disable-stripping
  119. %{__make} %{?_smp_mflags}
  120. #% {__make}
  121. #%{__make} documentation
  122. %install
  123. %__make install DESTDIR=$RPM_BUILD_ROOT
  124. ## install man
  125. %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
  126. %__install %{SOURCE90} %{SOURCE91} %{SOURCE92} %{SOURCE93} \
  127. $RPM_BUILD_ROOT%{_mandir}/man1/
  128. %clean
  129. %{__rm} -rf $RPM_BUILD_ROOT
  130. %post libs -p /sbin/ldconfig
  131. %postun libs -p /sbin/ldconfig
  132. %files
  133. %defattr(-,root,root,-)
  134. %doc COPYING.* CREDITS Changelog README doc/ffserver.conf
  135. %{_bindir}/ff*
  136. %{_mandir}/man1/ff*.1*
  137. %{_datadir}/ffmpeg
  138. %files libs
  139. %defattr(-,root,root,-)
  140. %{_libdir}/lib*.so.*
  141. %files devel
  142. %defattr(-,root,root,-)
  143. %doc MAINTAINERS doc/APIchanges doc/TODO doc/*.txt
  144. %{_includedir}/ffmpeg
  145. %{_libdir}/pkgconfig/lib*.pc
  146. %{_libdir}/lib*.so
  147. %changelog
  148. * Sun Apr 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.6-1.20100410
  149. - bumped version to pre-0.6
  150. * Sun Apr 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-13.20100410
  151. - updated source snapshot 20100410
  152. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-12.20100401
  153. - change release to sync with self-build-ffmpeg-vl.spec
  154. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-11.20100401
  155. - change release to sync with self-build-ffmpeg-vl.spec
  156. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-10.20100401
  157. - updated source snapshot 20100401
  158. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-9.20100216
  159. - updated source snapshot 20100326
  160. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  161. - change release to sync with self-build-ffmpeg
  162. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  163. - updated source snapshot 20100216
  164. - rebuild with recent x264-devel
  165. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  166. - added BuildRequires: libvdpau-devel
  167. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  168. - change release to sync with self-build-ffmpeg
  169. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  170. - change release to sync with self-build-ffmpeg
  171. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  172. - applied ffmpeg-0.5-disable-texi2html.patch
  173. - dropped BuildRequires: texi2html
  174. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  175. - change release to sync with self-build-ffmpeg
  176. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  177. - corrected release number
  178. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  179. - new upstream release
  180. - added BuildRequires:
  181. - speex-devel
  182. - bzip2-devel
  183. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
  184. - 20090227 snapshot
  185. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  186. - added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
  187. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  188. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  189. - dropped Requires: a52dec, faad2 in ffmpeg-libs
  190. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  191. - 20090202 snapshot
  192. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  193. - 20090110 snapshot
  194. - dropped some patches
  195. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  196. - source updated (r15488)
  197. - fixed License: GPLv2+
  198. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  199. - added BuildRequires: yasm (only %%ix86)
  200. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  201. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  202. - spec in utf8
  203. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  204. - change release to sync with self-build-ffmpeg
  205. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  206. - drop "Patch100: ffmpeg-vine.patch".
  207. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  208. - build with new versioning policy
  209. - change to use svn export from svn checkout on post install
  210. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  211. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  212. - [self-build-ffmpeg.spec]
  213. For all pre-required package that is provied by self-build,
  214. changed to its self-build package
  215. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  216. - initial build for Vine Linux 4.2
  217. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  218. ### end of file