aspell-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define ver 0.60.6
  4. %define rel 1
  5. Summary: A spelling checker.
  6. Summary(ja): スペルチェッカ
  7. Name: aspell
  8. Version: %{ver}
  9. Release: %{rel}%{?_dist_release}
  10. License: LGPL
  11. Group: Applications/Text
  12. URL: http://aspell.net/
  13. Source0: ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
  14. Source10: %{name}-install.sh
  15. Source11: %{name}-remove.sh
  16. Source12: %{name}-init.el
  17. Source100: aspell.conf
  18. Patch1003: aspell-0.60.3-install_info.patch
  19. Patch1005: aspell-0.60.5-fileconflict.patch
  20. Patch1007: aspell-0.60.5-pspell_conf.patch
  21. Patch1008: aspell-0.60.6-zero.patch
  22. Buildrequires: gcc-c++
  23. Requires(post,preun): %{_syssbindir}/install-info
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. Provides: pspell
  26. Obsoletes: ispell, pspell
  27. %description
  28. GNU Aspell is a spell checker designed to eventually replace Ispell. It can
  29. either be used as a library or as an independent spell checker. Its main
  30. feature is that it does a much better job of coming up with possible
  31. suggestions than just about any other spell checker out there for the
  32. English language, including Ispell and Microsoft Word. It also has many
  33. other technical enhancements over Ispell such as using shared memory for
  34. dictionaries and intelligently handling personal dictionaries when more
  35. than one Aspell process is open at once.
  36. %package devel
  37. Summary: Static libraries and header files for Aspell development.
  38. Group: Development/Libraries
  39. Requires: aspell = %{version}-%{release}
  40. Obsoletes: pspell-devel
  41. %description devel
  42. Aspell is a spelling checker. The aspell-devel package includes the
  43. static libraries and header files needed for Aspell development.
  44. %package el
  45. Summary: Emacs lisp for aspell
  46. Group: Applications/Editors/Emacs
  47. Requires: aspell = %{version}-%{release}
  48. Requires: emacsen-common
  49. %description el
  50. Aspell is a spelling checker. The aspell-el package includes the
  51. elisp for using aspell within emacsen.
  52. %prep
  53. rm -rf $RPM_BUILD_ROOT
  54. %setup -q
  55. %patch1003 -p1 -b .iinfo
  56. %patch1005 -p1 -b .fc
  57. %patch1007 -p1 -b .mlib
  58. %patch1008 -p1 -b .zero
  59. iconv -f windows-1252 -t utf-8 manual/aspell.info -o manual/aspell.info.aux
  60. mv manual/aspell.info.aux manual/aspell.info
  61. %build
  62. %configure
  63. make %{?_smp_mflags}
  64. %install
  65. %makeinstall
  66. mv ${RPM_BUILD_ROOT}%{_libdir}/aspell-*/ispell ${RPM_BUILD_ROOT}%{_bindir}
  67. mv ${RPM_BUILD_ROOT}%{_libdir}/aspell-*/spell ${RPM_BUILD_ROOT}%{_bindir}
  68. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libaspell.la
  69. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libpspell.la
  70. rm -f ${RPM_BUILD_ROOT}%{_libdir}/aspell-0.60/*-filter.la
  71. # Add by H.Irokawa(2004.02.23)
  72. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
  73. install -m 644 %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/aspell.conf
  74. mkdir -p $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/aspell
  75. mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
  76. mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
  77. install -m 644 %{SOURCE12} $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/%{name}
  78. # install script( bytecompile el and install elc , remove )
  79. %_installemacsenscript %{name} %{SOURCE10}
  80. %_removeemacsenscript %{name} %{SOURCE11}
  81. rm -f $RPM_BUILD_ROOT/usr/share/doc/aspell/manual.aux
  82. %find_lang %{name}
  83. %post
  84. /sbin/ldconfig
  85. # info
  86. if [ "$1" = 0 ] ; then
  87. %{_syssbindir}/install-info %{_infodir}/aspell.info.gz %{_infodir}/dir
  88. fi
  89. %post devel
  90. /sbin/ldconfig
  91. # info
  92. if [ "$1" = 0 ] ; then
  93. %{_syssbindir}/install-info %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
  94. fi
  95. %post el
  96. if [ "$1" = 2 ]; then
  97. %_emacsenPackageRemove %{name}
  98. fi
  99. %_addemacsenlist %{name}
  100. %_emacsenPackageInstall %{name}
  101. %postun
  102. /sbin/ldconfig
  103. %preun
  104. if [ $1 = 0 ]; then
  105. %{_syssbindir}/install-info --delete %{_infodir}/aspell.info.gz %{_infodir}/dir
  106. fi
  107. %preun devel
  108. if [ $1 = 0 ]; then
  109. %{_syssbindir}/install-info --delete %{_infodir}/aspell-dev.info.gz %{_infodir}/dir
  110. fi
  111. %preun el
  112. if [ "$1" = 0 ]; then
  113. %_emacsenPackageRemove %{name}
  114. %_removeemacsenlist %{name}
  115. fi
  116. %clean
  117. rm -rf $RPM_BUILD_ROOT
  118. %files -f %{name}.lang
  119. %defattr(-,root,root)
  120. %config(noreplace) %{_sysconfdir}/aspell.conf
  121. %doc README TODO
  122. %{_bindir}/*
  123. %{_libdir}/lib*.so.*
  124. %{_libdir}/aspell-*
  125. %{_infodir}/aspell.info*
  126. %{_mandir}/man1/*
  127. %files devel
  128. %defattr(-,root,root)
  129. %{_includedir}/aspell.h
  130. %{_includedir}/pspell
  131. %{_infodir}/aspell-dev.info*
  132. %{_libdir}/lib*spell.so
  133. %{_libdir}/pkgconfig/aspell.pc
  134. %files el
  135. %{_datadir}/emacs/site-lisp/%{name}/
  136. %{_prefix}/lib/emacsen-common/packages/install/%{name}
  137. %{_prefix}/lib/emacsen-common/packages/remove/%{name}
  138. %changelog
  139. * Sat Apr 16 2011 IWAI, Masaharu <iwai@alib.jp> 0.60.6-1
  140. - new upstream release
  141. - sync Fedora 0.60.6-14
  142. - split English dictionary package: create aspell-en package
  143. - drop unnecessary patches
  144. - prefix patch (Patch0)
  145. - fix compress patch (Patch1)
  146. - add some patches (Patch1003, 1005, 1007, 1008)
  147. - create aspell.pc file
  148. - update files
  149. - add post, preun scripts for info file
  150. - add Requires(post,preun) for installing info file
  151. - noreplace aspell.conf
  152. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.50.5-1vl5
  153. - applied new versioning policy, spec in utf-8
  154. * Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl3
  155. - rebuilt with new toolchain
  156. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl2
  157. - changed aspell-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  158. * Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.5-0vl1
  159. - upgrade to new upstream
  160. - drop aspell-0.50.3-gcc33.patch
  161. - update prefix.patch
  162. * Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl8
  163. - merged with errata package
  164. * Wed Oct 6 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.50.3-0vl5.1
  165. - added aspell-compress-bug.patch (CAN-2004-0548).
  166. * Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl7
  167. - fixed typo (s/%postun el/%preun el/)
  168. * Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl6
  169. - split elisp-related files into the aspell-el subpackage
  170. * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl5
  171. - add PreReq: emacsen-common
  172. * Mon Feb 23 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.50.3-0vl4
  173. - add /etc/aspell.conf
  174. - modded aspell-init.el(Japanese blended English spell check)
  175. * Wed Feb 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl3
  176. - add %{_bindir}/{ispell,spell} for compatibility script
  177. - enable site-start.d stuff
  178. * Mon Nov 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.3-0vl2
  179. - fixed spec file character code to EUC-JP
  180. * Wed Jun 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl1
  181. - build for Vine Linux
  182. - merge aspell-en
  183. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  184. - rebuilt
  185. * Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-10
  186. - rebuild again to fix libpspell deps
  187. * Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-9
  188. - remove ExcludeArch
  189. * Thu May 22 2003 Jeremy Katz <katzj@redhat.com> 7:0.50.3-8
  190. - fix build with gcc 3.3
  191. * Wed May 22 2003 Adrian Havill <havill@redhat.com> 0.50.3-7
  192. - require aspell-en for upgrades
  193. * Sun May 11 2003 Jeremy Katz <katzj@redhat.com> 6:0.50.3-6
  194. - -devel should obsolete pspell-devel
  195. * Tue May 6 2003 Joe Orton <jorton@redhat.com> 0.50.3-5
  196. - include libpspell.so in devel package
  197. * Wed May 1 2003 Adrian Havill <havill@redhat.com> 0.50.3-4
  198. - removed .la files
  199. * Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-3
  200. - Changed the header for provides, obsoletes, epoch
  201. - fixed config prefix in dirs.h
  202. * Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-1
  203. - upgrade to 0.50.3
  204. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  205. - rebuilt
  206. * Fri Nov 8 2002 Tim Powers <timp@redhat.com>
  207. - fix broken pspell epoch dep
  208. - create $RPM_BUILD_ROOT/usr/bin by hand
  209. - remove /usr/doc
  210. - fix hardcoding of /usr/lib so that we can build on x86_64
  211. * Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.33.7.1-16
  212. - require pspell and pspell-devel using the proper epoch
  213. * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
  214. - rebuilt with gcc-3.2 (we hope)
  215. * Mon Jul 22 2002 Tim Powers <timp@redhat.com> 0.33.7.1-14
  216. - rebuild using gcc-3.2-0.1
  217. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.33.7.1-13
  218. - automated rebuild
  219. * Thu Jun 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-12
  220. - Rebuild to make it work again... #66708
  221. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  222. - automated rebuild
  223. * Mon May 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-10
  224. - Rebuild
  225. * Thu Feb 21 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-9
  226. - Disable evil patch
  227. * Mon Jan 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-8
  228. - Build on more archs (doh)
  229. * Tue Jan 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-7
  230. - Make it compile with new compiler (evil workaround)
  231. * Wed Jan 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-5
  232. - Rebuild
  233. - Unexclude alpha
  234. * Fri Dec 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-3
  235. - Rebuild
  236. - Don't build on alpha
  237. * Mon Oct 29 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.7.1-2
  238. - "make it work with gcc 3.1" ;)
  239. * Tue Sep 18 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7.1-1
  240. - 0.33.7.1, which is a "make it work with gcc 3" release
  241. * Wed Sep 12 2001 Tim Powers <timp@redhat.com>
  242. - rebuild with new gcc and binutils
  243. * Thu Aug 9 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.33.7-1
  244. - 0.33.7 bugfix release. Requested by the author, it fixes
  245. coredumps in sug-mode and when not using typo-analyses.
  246. It also contains code cleanups so it compiles with -ansi
  247. - should fix coredump on IA64 (#49746)
  248. * Wed Jul 11 2001 Trond Eivind Glomsrød <teg@redhat.com>
  249. - Add the .la files in the main package - used for dynamic loading
  250. * Sun Jun 3 2001 Trond Eivind Glomsrød <teg@redhat.com>
  251. - 0.33.6.3, which includes the fix made yesterday
  252. * Sat Jun 2 2001 Trond Eivind Glomsrød <teg@redhat.com>
  253. - Make it search for directories in the correct location
  254. * Wed May 30 2001 Trond Eivind Glomsrød <teg@redhat.com>
  255. - No more workarounds at the specfile level
  256. * Tue May 29 2001 Trond Eivind Glomsrød <teg@redhat.com>
  257. - Use custom ltmain.sh to work around buggy bundled libtool
  258. * Sun May 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
  259. - 0.33.6
  260. - use standard %%configure macro - it works now.
  261. * Fri May 11 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.5-2
  262. - Rebuild with new libltdl
  263. * Mon Apr 23 2001 Trond Eivind Glomsrød <teg@redhat.com>
  264. - 0.33.5
  265. * Thu Nov 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
  266. - use new emacs init scheme for Emacs and XEmacs
  267. * Wed Nov 22 2000 Trond Eivind Glomsrød <teg@redhat.com>
  268. - .32.6
  269. * Sat Aug 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
  270. - .32.5 bugfix release (also contains improved documentation),
  271. obsolete old patch
  272. - the compatibility scripts are now part of the package itself
  273. - clean up build procedure
  274. - remove manual.aux file from docs (#16424)
  275. * Sun Aug 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
  276. - .32.1 bugfix release, obsolete old patch
  277. - rename to 0.32.1
  278. - add patch from author to change his email address
  279. - add spell and ispell compatibility scripts
  280. * Fri Aug 04 2000 Trond Eivind Glomsrød <teg@redhat.com>
  281. - rebuild
  282. * Tue Aug 01 2000 Trond Eivind Glomsrød <teg@redhat.com>
  283. - remember to obsolete ispell
  284. - build the Canadian and British dictionaries here now,
  285. as part of the main package. Same package names and
  286. descriptions.
  287. * Mon Jul 24 2000 Trond Eivind Glomsrød <teg@redhat.com>
  288. - .32
  289. - remove old patches, add a patch since namespace isn't
  290. polluted as much anymore (as opposed to older toolchain)
  291. * Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
  292. - rebuild
  293. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  294. - automatic rebuild
  295. * Tue Jul 4 2000 Jakub Jelinek <jakub@redhat.com>
  296. - Rebuild with new C++
  297. * Fri Jun 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
  298. - use RPM_OPT_FLAGS, not just -O0
  299. - dont include .la-files
  300. * Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
  301. - excludearch ia64
  302. * Fri Jun 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
  303. - patch to work around compiler bug(?) wrt. inline functions
  304. - use CFLAGS and CXXFLAGS
  305. - set them to -O0 to work around YACB
  306. - copy libtool files for IA64 support
  307. * Sun Jun 18 2000 Trond Eivind Glomsrød <teg@redhat.com>
  308. - update to .31.1. My patch was upstreamed and is no longer needed.
  309. - new patch added so DESTDIR works properly
  310. * Fri Jun 16 2000 Trond Eivind Glomsrød <teg@redhat.com>
  311. - (this entry includes some old ones...)
  312. - update to .31
  313. - added patch to make it compile with a pickier compiler
  314. - include /usr/share/pspell
  315. * Mon May 1 2000 Tim Powers <timp@redhat.com>
  316. - updated to .30.1
  317. - used build fixes from Ryan Weaver's 0.30.1-1 package on sourceforge
  318. - updated URL, download/ftp location
  319. - removed redundant define's at top of spec file
  320. * Thu Jul 8 1999 Tim Powers <timp@redhat.com>
  321. - built for Powertools 6.1
  322. - removed %serial definitions from spec file to make versioning
  323. consistant with the other packages we ship.
  324. - changed build root path
  325. - general spec file cleanups
  326. * Tue Mar 2 1999 Ryan Weaver <ryanw@infohwy.com>
  327. [aspell-.27.2-2]
  328. - Changes from .27.1 to .27.2 (Mar 1, 1999)
  329. - Fixed a major bug that caused aspell to dump core when used
  330. without any arguments
  331. - Fixed another major bug that caused aspell to do nothing when used
  332. in interactive mode.
  333. - Added an option to exit in Aspell's interactive mode.
  334. - Removed some old documentation files from the distribution.
  335. - Minor changes on to the section on using Aspell with egcs.
  336. - Minor changes to remove -Wall warnings.