autogen-vl.spec 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143
  1. Version: 5.18.1
  2. Release: 1%{?_dist_release}
  3. Summary: AutoGen - The Automated Program Generator
  4. Name: autogen
  5. URL: http://www.gnu.org/software/autogen/
  6. License: GPL2
  7. Group: Development/Tools
  8. Source: ftp://ftp.gnu.org/gnu/autogen/rel%{version}/autogen-%{version}.tar.xz
  9. BuildRoot: %{_tmppath}/%{name}-root
  10. Requires: install-info
  11. Requires: guile
  12. BuildRequires: guile-devel
  13. BuildRequires: libxml2-devel
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. Packager: yasumichi
  17. %description
  18. AutoGen is a tool designed for generating program files that contain
  19. repetitive text with varied substitutions. Its goal is to simplify the
  20. maintenance of programs that contain large amounts of repetitious text.
  21. This is especially valuable if there are several blocks of such text
  22. that must be kept synchronized in parallel tables.
  23. Some parts are released under different licensing:
  24. libopts LGPL This is a tear-off, redistributable option processing library
  25. autofsm BSD This is a template for producing finite state machine programs
  26. The Copyright itself is privately held by Bruce Korb.
  27. %prep
  28. %setup -q
  29. chmod -R +rw *
  30. %build
  31. %configure
  32. make CFLAGS="$RPM_OPT_FLAGS"
  33. if [ `id -u` -eq 0 ] && egrep -q ^nobody /etc/passwd
  34. then
  35. echo "switching to user nobody to run 'make check'"
  36. chown -R nobody . ; su -c "umask 002; make check || touch FAIL" nobody
  37. else
  38. make check
  39. fi
  40. [ -f FAIL ] && exit 1
  41. %install
  42. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  43. mkdir -p ${RPM_BUILD_ROOT}
  44. make install DESTDIR=${RPM_BUILD_ROOT}
  45. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  46. # IF we have a valid file list OR the build root is _the_ root,
  47. # THEN skip the file list generation.
  48. #
  49. if test \( -f autogen-filelist \
  50. -a -s autogen-filelist \) \
  51. -o ${#RPM_BUILD_ROOT} -le 1
  52. then : ; else
  53. ( cd ${RPM_BUILD_ROOT}
  54. rm -f usr/share/info/dir
  55. find . -type f | grep -v 'usr/share/doc'
  56. ) | sed -e 's@^\./@/@' \
  57. -e'/usr\/share\/info/s,$,.gz,' \
  58. -e'/usr\/share\/man/s,$,.gz,' \
  59. | sort \
  60. > autogen-filelist
  61. fi
  62. %post
  63. /sbin/ldconfig
  64. /sbin/install-info --info-dir=%{_infodir} %{_infodir}/autogen.info.gz
  65. %preun
  66. /sbin/install-info --delete --info-dir=%{_infodir} %{_infodir}/autogen.info.gz
  67. %postun -p /sbin/ldconfig
  68. %clean
  69. rm -rf ${RPM_BUILD_ROOT}
  70. %files -f autogen-filelist
  71. %defattr(-,root,root)
  72. %doc AUTHORS TODO COPYING NEWS THANKS README VERSION
  73. #%%{_libdir}/libguileopts.so
  74. #%%{_libdir}/libguileopts.so.0
  75. %{_libdir}/libopts.so
  76. %{_libdir}/libopts.so.25
  77. %changelog
  78. * Mon Jan 27 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.18.1-1
  79. - new upstream release
  80. - change archive format
  81. - add dependencies
  82. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 5.9.9-2
  83. - rebuilt with rpm-4.8.1 for pkg-config
  84. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.9.9-1
  85. - new upstream release.
  86. - build with guile-1.8.7
  87. - add Vendor, Distribution and Packager.
  88. * Tue Jan 13 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 5.9.7-1
  89. - new upstream release
  90. - build with guile-1.8.6
  91. - correct spec tag (Vendor -> URL)
  92. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.9.4-3vl5
  93. - use macro for Release
  94. * Sat May 10 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.9.4-2vl5
  95. - rebuild with guile-1.6.7-5vl5
  96. * Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.9.4-1vl5
  97. - apply new virsioning policy.
  98. - remove *.la
  99. * Sat Jan 05 2008 Shu KONNO <owa@bg.wakwak.com> 5.9.4-0vl1
  100. - updated to last stable release
  101. * Thu Jan 03 2008 Shu KONNO <owa@bg.wakwak.com> 5.8.7-5vl2
  102. - added %%{_libdir}/lib*.so* in %%files
  103. * Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 5.8.7-5vl1
  104. - build for VineSeed
  105. * Sat Oct 14 2006 Bruce Korb <bkorb@veritas.com> Regenerated
  106. * Fri Dec 31 2004 Bruce Korb <bkorb@gnu.org> Restored the file list
  107. * Wed Oct 27 2004 Ed Swierk <eswierk@users.sf.net> fixed up for Fedora
  108. * Tue Dec 16 2003 Richard Zidlicky <rz@linux-m68k.org> 5.5.7pre5-5
  109. - fix %%doc
  110. - add post/pre scriptlets
  111. - change default prefix
  112. * Sat Mar 15 2003 Bruce Korb <bkorb@gnu.org>
  113. - Rework as a template to automatically produce a properly configured RPM
  114. * Fri Aug 9 2002 Bruce Korb <bkorb@gnu.org>
  115. - Pull stuff from Thomas Steudten's version of this file