gnome-sharp2-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180
  1. %define mono_dir %(/usr/bin/monodir)
  2. %define _name gnome-sharp
  3. Summary: .Net Language Bindings for Gnome
  4. Summary(ja): Mono 用 GNOME バインディング
  5. Name: gnome-sharp2
  6. Version: 2.24.1
  7. Release: 5%{?_dist_release}
  8. License: GNU General ublic License (GPL), GNU Library General Public License v. 2.0 and 2.1 (LGPL)
  9. Group: Development/Libraries
  10. URL: http://gtk-sharp.sf.net
  11. Source: %{_name}-%{version}.tar.bz2
  12. Patch2: gnome-sharp-find_gtkhtml_ver.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: gtk-sharp2 gtk-sharp2-gapi
  15. BuildRequires: librsvg2-devel
  16. BuildRequires: mono-devel monodoc
  17. BuildRequires: vte-devel gtkhtml3-devel
  18. %define env_options export MONO_SHARED_DIR=/tmp
  19. %description
  20. This package contains Mono bindings for Gnome.
  21. %package -n gnome-sharp2-complete
  22. Group: Development/Libraries
  23. Summary: GTK+ and GNOME bindings for Mono (virtual package)
  24. Requires: art-sharp2 = %{version}-%{release}
  25. Requires: gconf-sharp2 = %{version}-%{release}
  26. Requires: gnome-sharp2 = %{version}-%{release}
  27. Requires: gnome-vfs-sharp2 = %{version}-%{release}
  28. #Requires: glib-sharp2 >= 2.10.3
  29. %description -n gnome-sharp2-complete
  30. Gtk# is a library that allows you to build fully native graphical GNOME
  31. applications using Mono. Gtk# is a binding to GTK+, the cross platform
  32. user interface toolkit used in GNOME. It includes bindings for Gtk,
  33. Atk, Pango, Gdk, libgnome, libgnomeui and libgnomecanvas. (Virtual
  34. package which depends on all gtk-sharp2 subpackages)
  35. %package -n gnome-vfs-sharp2
  36. Summary: Mono bindings for gnomevfs
  37. Group: Development/Libraries
  38. Requires: gnome-vfs2
  39. %description -n gnome-vfs-sharp2
  40. This package contains Mono bindings gnomevfs.
  41. %package -n art-sharp2
  42. Summary: Mono bindings for libart
  43. Group: Development/Libraries
  44. Requires: libart_lgpl
  45. %description -n art-sharp2
  46. This package contains Mono bindings for libart.
  47. %package -n gconf-sharp2
  48. Summary: Mono bindings for gconf
  49. Group: Development/Libraries
  50. %description -n gconf-sharp2
  51. This package contains Mono bindings for gconf and gconf peditors.
  52. %prep
  53. %setup -q -n %{_name}-%{version}
  54. #%patch2 -p1
  55. #autoreconf -f -i
  56. %build
  57. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  58. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  59. %configure \
  60. --libexecdir=%{_prefix}/lib \
  61. --enable-debug
  62. make
  63. %install
  64. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  65. %makeinstall
  66. ## remove unuse files
  67. rm -f $RPM_BUILD_ROOT%{_libdir}/*.*a
  68. rm -f $RPM_BUILD_ROOT%{_prefix}/lib/debug/%{_libdir}/libgnomesharpglue-2.so.debug
  69. rm -f $RPM_BUILD_ROOT%{_prefix}/src/debug/gnome-sharp-*/gnome/glue/*.c
  70. %clean
  71. rm -rf $RPM_BUILD_ROOT
  72. %files -n gnome-sharp2-complete
  73. %defattr(-, root, root)
  74. ## This is the 'base' package so we put the common dirs of all in this package
  75. # Otherwise, this package doesn't get created!
  76. %dir %{mono_dir}/gtk-sharp-2.0
  77. %dir %{_prefix}/lib/gtk-sharp-2.0
  78. %files -n gnome-sharp2
  79. %defattr(-,root,root)
  80. %{_libdir}/libgnomesharpglue-2.so
  81. %{_libdir}/pkgconfig/gnome-sharp-2.0.pc
  82. %{mono_dir}/gac/*gnome-sharp
  83. %{mono_dir}/gtk-sharp-2.0/*gnome-sharp.dll
  84. %{_datadir}/gapi-2.0/gnome-api.xml
  85. %files -n gnome-vfs-sharp2
  86. %defattr(-,root,root)
  87. %{_libdir}/pkgconfig/gnome-vfs-sharp-2.0.pc
  88. %{mono_dir}/gac/*gnome-vfs-sharp
  89. %{mono_dir}/gtk-sharp-2.0/*gnome-vfs-sharp.dll
  90. %{_datadir}/gapi-2.0/gnome-vfs-api.xml
  91. %files -n art-sharp2
  92. %defattr(-,root,root)
  93. %{_libdir}/pkgconfig/art-sharp-2.0.pc
  94. %{mono_dir}/gac/*art-sharp
  95. %{mono_dir}/gtk-sharp-2.0/*art-sharp.dll
  96. %{_datadir}/gapi-2.0/art-api.xml
  97. %files -n gconf-sharp2
  98. %defattr(-, root, root)
  99. %{_bindir}/gconfsharp2-schemagen
  100. %{_libdir}/pkgconfig/gconf-sharp-2.0.pc
  101. %{_prefix}/lib/gtk-sharp-2.0/gconfsharp-schemagen.exe
  102. %{mono_dir}/gac/*gconf-sharp
  103. %{mono_dir}/gtk-sharp-2.0/*gconf-sharp.dll
  104. # Other distros place these in gnome-sharp2??
  105. %{_libdir}/pkgconfig/gconf-sharp-peditors-2.0.pc
  106. %{mono_dir}/gac/*gconf-sharp-peditors
  107. %{mono_dir}/gtk-sharp-2.0/*gconf-sharp-peditors.dll
  108. %changelog
  109. * Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.1-5
  110. - build with rpm-4.8.1-1 for pkg-config file
  111. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.24.1-4
  112. - rebuilt with new environment
  113. * Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-3
  114. - rebuilt with latest rpm to update mono-dependencies
  115. - dropt BR: libgnomedb-devel
  116. * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-2
  117. - changed Group to Development/Libraries
  118. * Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.24.1-1
  119. - updated to 2.24.1
  120. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.0-1
  121. - initial build for VineSeed
  122. - updated gnome-sharp2 to 2.20.0
  123. - added japanese summary
  124. - applied vine versioning policy
  125. - spec in utf-8
  126. * Thu Apr 24 2008 wberrier@suse.de
  127. - Update to 2.12.1
  128. * Bugfix in GLib ref management for Gnome.Program crash in
  129. gnome-sharp
  130. * Thu Apr 3 2008 wberrier@novell.com
  131. - Can now build 2.16 and 2.20 from the same spec
  132. - Update to 2.20.0
  133. - Updated bindings to coincide with gtk# 2.12
  134. - Removed bindings: gtkhtml#, rsvg#, and vte#
  135. * Wed Mar 26 2008 wberrier@novell.com
  136. - Update to 2.16.1
  137. - Allow storage of empty lists in gconf
  138. - Bug fixes:
  139. - [GConf] Impossible to set empty list values (bnc#325516)
  140. - Comment #8 of bnc#327058 (incorrect p/invoke bindings)
  141. * Tue Jul 3 2007 wberrier@suse.de
  142. - Initial package of gnome-sharp2 2.16.0
  143. - (Split from gtk-sharp 2.8.3)