calibre-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540
  1. %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. Name: calibre
  3. Version: 0.7.50
  4. Release: 2%{?_dist_release}
  5. Summary: E-book converter and library management
  6. Group: Applications/Multimedia
  7. License: GPLv3
  8. URL: http://calibre-ebook.com/
  9. # SourceURL: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  10. # Upstream packages some unfree fonts which we cannot redistribute.
  11. # While we're at it, also delete the liberation fonts which we already have.
  12. #
  13. # Download the upstream tarball and invoke this script while in the tarball's
  14. # directory:
  15. # ./generate-tarball.sh %{version}
  16. Source0: %{name}-%{version}-nofonts.tar.xz
  17. Source1: generate-tarball.sh
  18. Source2: calibre-mount-helper
  19. Patch0: %{name}-manpages.patch
  20. Patch1: %{name}-no-update.patch
  21. #Patch2: %{name}-0.6.53-mounthelper.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: python >= 2.6
  24. BuildRequires: python-devel >= 2.6
  25. BuildRequires: ImageMagick-devel >= 6.5.9
  26. BuildRequires: python-setuptools
  27. BuildRequires: qt4-devel >= 4.6.0
  28. BuildRequires: PyQt4-devel >= 4.7.0
  29. BuildRequires: poppler-qt4-devel >= 0.12
  30. BuildRequires: podofo-devel
  31. BuildRequires: desktop-file-utils
  32. BuildRequires: python-mechanize >= 0.1.1
  33. BuildRequires: python-lxml >= 2.2.1
  34. BuildRequires: python-cssutils >= 0.9.6
  35. BuildRequires: python-dateutil >= 1.4.1
  36. BuildRequires: python-imaging >= 1.1.6
  37. BuildRequires: xdg-utils >= 1.0.2
  38. BuildRequires: python-BeautifulSoup >= 3.0.5
  39. BuildRequires: xz
  40. BuildRequires: unzip
  41. BuildRequires: libwmf-devel >= 0.2.8
  42. BuildRequires: chmlib-devel >= 0.40
  43. BuildRequires: python-cssutils > 0.9.6
  44. BuildRequires: sqlite3-devel
  45. BuildRequires: libicu-devel
  46. Requires: PyQt4
  47. Requires: pyPdf
  48. Requires: python-cherrypy
  49. Requires: python-cssutils
  50. Requires: ImageMagick
  51. Requires: python-odf
  52. Requires: python-django-tagging
  53. Requires: python-lxml
  54. Requires: python-imaging
  55. Requires: python-mechanize
  56. Requires: python-dateutil
  57. Requires: python-genshi
  58. Requires: python-BeautifulSoup
  59. ## vine
  60. Requires: TrueType-liberation
  61. %description
  62. Calibre is meant to be a complete e-library solution. It includes library
  63. management, format conversion, news feeds to ebook conversion as well as
  64. e-book reader sync features.
  65. Calibre is primarily a ebook cataloging program. It manages your ebook
  66. collection for you. It is designed around the concept of the logical book,
  67. i.e. a single entry in the database that may correspond to ebooks in several
  68. formats. It also supports conversion to and from a dozen different ebook
  69. formats.
  70. Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML, CBR, CBZ,
  71. RTF, TXT, PDF and LRS.
  72. %prep
  73. %setup -q -n %{name}
  74. # don't append calibre1 to the name of the manpages. No need to compress either
  75. # upstream won't fix: http://bugs.calibre-ebook.com/ticket/3770#comment:7
  76. %patch0 -p1 -b .manpages
  77. # don't check for new upstream version (that's what packagers do)
  78. %patch1 -p1 -b .no-update
  79. # dos2unix newline conversion
  80. %{__sed} -i 's/\r//' src/calibre/web/feeds/recipes/*
  81. # remove shebangs
  82. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*/*.py
  83. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*/*/*.py
  84. %{__sed} -i -e '/^#![ ]*\//, 1d' src/calibre/*/*.py
  85. %{__sed} -i -e '/^#!\//, 1d' src/calibre/*.py
  86. %{__sed} -i -e '/^#!\//, 1d' src/templite/*.py
  87. %{__sed} -i -e '/^#!\//, 1d' resources/recipes/*
  88. %{__sed} -i -e '/^#!\//, 1d' resources/default_tweaks.py
  89. %{__chmod} -x src/calibre/*/*/*/*.py
  90. %{__chmod} -x src/calibre/*/*/*.py
  91. %{__chmod} -x src/calibre/*/*.py
  92. %{__chmod} -x src/calibre/*.py
  93. %{__chmod} -x resources/recipes/*
  94. %build
  95. OVERRIDE_CFLAGS="%{optflags}" QMAKE=%{_libdir}/qt4/bin/qmake python setup.py build
  96. %install
  97. %__rm -rf %{buildroot}
  98. %__mkdir -p %{buildroot}%{_datadir}
  99. # create directories for xdg-utils
  100. %__mkdir_p %{buildroot}%{_datadir}/icons
  101. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor
  102. %__mkdir_p %{buildroot}%{_datadir}/packages
  103. %__mkdir_p %{buildroot}%{_datadir}/mime
  104. %__mkdir_p %{buildroot}%{_datadir}/mime/packages
  105. %__mkdir_p %{buildroot}%{_datadir}/applications
  106. %__mkdir_p %{buildroot}%{_datadir}/desktop-directories
  107. # create directory for calibre environment module
  108. # the install script assumes it's there.
  109. %__mkdir_p %{buildroot}%{python_sitelib}
  110. XDG_DATA_DIRS="%{buildroot}%{_datadir}" \
  111. XDG_UTILS_INSTALL_MODE="system" \
  112. LIBPATH="%{_libdir}" \
  113. python setup.py install --root=%{buildroot}%{_prefix} \
  114. --prefix=%{_prefix} \
  115. --libdir=%{_libdir} \
  116. --staging-libdir=%{buildroot}%{_libdir}
  117. # remove shebang from init_calibre.py here because
  118. # it just got spawned by the install script
  119. %{__sed} -i -e '/^#!\//, 1d' %{buildroot}%{python_sitelib}/init_calibre.py
  120. # icons
  121. %__mkdir_p %{buildroot}%{_datadir}/pixmaps/
  122. %__cp -p resources/images/library.png \
  123. %{buildroot}%{_datadir}/pixmaps/%{name}-gui.png
  124. %__cp -p resources/images/viewer.png \
  125. %{buildroot}%{_datadir}/pixmaps/calibre-viewer.png
  126. # every file is empty here
  127. find %{buildroot}%{_datadir}/mime -maxdepth 1 -type f|xargs %__rm -f
  128. # packages aren't allowed to register mimetypes like this
  129. %__rm -f %{buildroot}%{_datadir}/applications/{defaults.list,mimeinfo.cache}
  130. desktop-file-validate \
  131. %{buildroot}%{_datadir}/applications/calibre-ebook-viewer.desktop
  132. desktop-file-validate \
  133. %{buildroot}%{_datadir}/applications/calibre-gui.desktop
  134. desktop-file-validate \
  135. %{buildroot}%{_datadir}/applications/calibre-lrfviewer.desktop
  136. %__mv %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes \
  137. %{buildroot}%{_datadir}/mime/packages/calibre-mimetypes.xml
  138. # mimetype icon for lrf
  139. %__rm -rf %{buildroot}%{_datadir}/icons/hicolor/128x128
  140. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable
  141. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes
  142. %__mkdir_p %{buildroot}%{_datadir}/icons/hicolor/scalable/apps
  143. %__cp -p resources/images/mimetypes/lrf.png \
  144. %{buildroot}%{_datadir}/icons/hicolor/scalable/mimetypes/application-x-sony-bbeb.png
  145. %__cp -p resources/images/viewer.png \
  146. %{buildroot}%{_datadir}/icons/hicolor/scalable/apps/calibre-viewer.png
  147. # don't put bash completions in /usr/etc
  148. %__mv %{buildroot}%{_prefix}%{_sysconfdir} %{buildroot}
  149. # these are provided as separate packages
  150. %__rm -rf %{buildroot}%{_libdir}/%{name}/{odf,cherrypy,pyPdf,encutils,cssutils}
  151. %__rm -rf %{buildroot}%{_libdir}/%{name}/cal/utils/genshi
  152. %__rm -rf %{buildroot}%{_libdir}/%{name}/cal/trac
  153. # link to system fonts after we have deleted (see Source0) the non-free ones
  154. # http://bugs.calibre-ebook.com/ticket/3832
  155. %__mkdir_p %{buildroot}%{_datadir}/%{name}/fonts/prs500/
  156. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSans-Regular.ttf \
  157. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0003m_.ttf
  158. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationSerif-Regular.ttf \
  159. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0011m_.ttf
  160. %__ln_s %{_datadir}/fonts/TrueType-liberation/LiberationMono-Regular.ttf \
  161. %{buildroot}%{_datadir}/%{name}/fonts/prs500/tt0419m_.ttf
  162. # http://bugs.calibre-ebook.com/ticket/3770#comment:7
  163. # man pages
  164. %__mv %{buildroot}%{_datadir}/%{name}/man %{buildroot}%{_mandir}
  165. # move locales
  166. %__mv %{buildroot}%{_datadir}/%{name}/localization/locales \
  167. %{buildroot}%{_datadir}/locale
  168. for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/messages.mo; do
  169. lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
  170. %__mv %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/messages.mo \
  171. %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}.mo
  172. done;
  173. for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/iso639.mo; do
  174. lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
  175. %__mv %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/iso639.mo \
  176. %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}_iso639.mo
  177. done;
  178. for file in %{buildroot}%{_datadir}/locale/*/LC_MESSAGES/qt.qm; do
  179. lang=$(echo $file|%{__sed} 's:.*locale/\(.*\)/LC_MESSAGES.*:\1:')
  180. %__mv $file %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/%{name}_$lang.qm
  181. done;
  182. %find_lang %{name} --with-qt --all-name
  183. # locales should be looked for in the proper place
  184. %{__sed} -i -e "s:P('localization/locales:('/usr/share/locale:" \
  185. -e "s/messages.mo/calibre.mo/" \
  186. -e "s/iso639.mo/calibre_iso639.mo/" \
  187. %{buildroot}%{_libdir}/%{name}/%{name}/utils/localization.py
  188. %{__rm} -f %{buildroot}%{_bindir}/%{name}-uninstall
  189. %__cp -a %{SOURCE2} %{buildroot}%{_bindir}/
  190. %clean
  191. %{__rm} -rf %{buildroot}
  192. %post
  193. update-desktop-database &> /dev/null ||:
  194. update-mime-database %{_datadir}/mime &> /dev/null || :
  195. touch --no-create %{_datadir}/icons/hicolor || :
  196. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  197. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  198. fi
  199. %postun
  200. update-desktop-database &> /dev/null ||:
  201. update-mime-database %{_datadir}/mime &> /dev/null || :
  202. touch --no-create %{_datadir}/icons/hicolor || :
  203. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  204. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  205. fi
  206. %files -f %{name}.lang
  207. %defattr(-,root,root,-)
  208. %doc COPYRIGHT LICENSE Changelog.yaml
  209. %{_bindir}/calibre
  210. %{_bindir}/calibre-complete
  211. %{_bindir}/calibre-customize
  212. %{_bindir}/calibre-debug
  213. %{_bindir}/calibre-parallel
  214. %{_bindir}/calibre-server
  215. %{_bindir}/calibre-smtp
  216. %{_bindir}/calibre-mount-helper
  217. %{_bindir}/calibredb
  218. %{_bindir}/ebook-convert
  219. %{_bindir}/ebook-device
  220. %{_bindir}/ebook-meta
  221. %{_bindir}/ebook-viewer
  222. %{_bindir}/epub-fix
  223. %{_bindir}/fetch-ebook-metadata
  224. %{_bindir}/librarything
  225. %{_bindir}/lrf2lrs
  226. %{_bindir}/lrfviewer
  227. %{_bindir}/lrs2lrf
  228. %{_bindir}/markdown-calibre
  229. %{_bindir}/pdfmanipulate
  230. %{_bindir}/web2disk
  231. %config(noreplace) %{_sysconfdir}/bash_completion.d/
  232. %{_libdir}/%{name}
  233. %{_datadir}/%{name}
  234. %{_datadir}/pixmaps/*
  235. %{_datadir}/applications/*.desktop
  236. %{_datadir}/mime/packages/*
  237. %{_datadir}/icons/hicolor/scalable/mimetypes/*
  238. %{_datadir}/icons/hicolor/scalable/apps/*
  239. %{python_sitelib}/init_calibre.py*
  240. %{_mandir}/man1/*
  241. %changelog
  242. * Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.50-2
  243. - rebuild with ImageMagick-6.7.5.10
  244. * Sun Mar 20 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.50-1
  245. - new upstream release
  246. * Sat Feb 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.46-1
  247. - new upstream release
  248. * Thu Feb 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.44-1
  249. - new upstream release
  250. * Fri Feb 04 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.42-1
  251. - new upstream release
  252. * Fri Jan 21 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.40-1
  253. - new upstream release
  254. * Mon Dec 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.35-1
  255. - new upstream release
  256. * Sun Dec 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.34-1
  257. - new upstream release
  258. * Mon Dec 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.33-1
  259. - new upstream release
  260. - added BuildRequires: libicu-devel
  261. * Sat Dec 11 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.32-1
  262. - new upstream release
  263. * Fri Nov 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.26-1
  264. - new upstream release
  265. * Sun Oct 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.25-1
  266. - new upstream release
  267. * Tue Oct 19 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.24-1
  268. - Update to 0.7.24
  269. * Sat Oct 09 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.23-1
  270. - Update to 0.7.23
  271. - Fix up mount helper with our own local script.
  272. - Change files to list binaries so missing ones can more easily be noted.
  273. * Mon Oct 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.22-1
  274. - Update to 0.7.22
  275. * Fri Oct 01 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.21-1
  276. - Update to 0.7.21
  277. * Wed Sep 29 2010 jkeating - 0.7.20-2
  278. - Rebuilt for gcc bug 634757
  279. * Fri Sep 24 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.20-1
  280. - Update to 0.7.20
  281. * Wed Sep 15 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-3
  282. - Rebuild for new ImageMagick
  283. * Wed Sep 29 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.7.18-1
  284. - new upstream release
  285. - Fix svg/png changes.
  286. * Mon Sep 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-2
  287. - Fix svg/png changes.
  288. * Sun Sep 12 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.18-1
  289. - Update to 0.7.18
  290. - Require > 0.9.6 cssutils
  291. * Fri Sep 03 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.17-1
  292. - Update to 0.7.17
  293. * Fri Aug 27 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.16-1
  294. - Update to 0.7.16
  295. * Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> - 0.7.15-1
  296. - initial build based on Fedora development
  297. * Sat Aug 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.15-1
  298. - Update to 0.7.15
  299. * Thu Aug 19 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.14-2
  300. - rebuild (poppler)
  301. * Fri Aug 13 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.14-1
  302. - Update to 0.7.14
  303. * Fri Aug 06 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.13-1
  304. - Update to 0.7.13
  305. * Mon Aug 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.12-1
  306. - Update to 0.7.12
  307. * Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.11-1
  308. - Update to 0.7.11
  309. * Fri Jul 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-2
  310. - Rebuilt for python2.7
  311. * Fri Jul 23 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.10-1
  312. - Update to 0.7.10
  313. * Sat Jul 17 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.9-1
  314. - Update to 0.7.9
  315. * Sun Jul 11 2010 Michal Nowak <mnowak@redhat.com> - 0.7.8-1
  316. - Update to 0.7.8
  317. - build tar.xz instead of tar.bz2
  318. * Fri Jul 02 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.7-1
  319. - Update to 0.7.7
  320. * Wed Jun 30 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.6-1
  321. - Update to 0.7.6
  322. * Fri Jun 25 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.5-1
  323. - Update to 0.7.5
  324. * Sun Jun 20 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.4-1
  325. - Update to 0.7.4
  326. * Tue Jun 08 2010 Dan Horák <dan@danny.cz> - 0.7.1-2
  327. - rebuilt with podofo 0.8.1
  328. * Mon Jun 07 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.1-1
  329. - Update to 0.7.1
  330. - Added versioned dep on python-cssutils to make sure at least 0.9.6 is installed.
  331. * Fri Jun 04 2010 Kevin Fenzi <kevin@tummy.com> - 0.7.0-1
  332. - Update to 0.7.0
  333. * Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.55-1
  334. - Update to 0.6.55
  335. * Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.54-1
  336. - Update to 0.6.54
  337. * Fri May 21 2010 Kevin Fenzi <kevin@tummy.com> - 0.6.53-1
  338. - Update to 0.6.53
  339. * Wed May 5 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.6.47-2
  340. - Rebuild against new poppler
  341. * Sat Apr 10 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.47-1
  342. - new upstream release 0.6.47
  343. - new chmlib requirement
  344. - create directory for calibre's environment module
  345. - use bzip2 instead of gzip when preparing tarball in generate-tarball.sh
  346. - remove cssutils patches (we now have python-cssutils 0.9.6 in Fedora)
  347. * Fri Feb 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.42-1
  348. - new upstream release 0.6.42
  349. - remove shebang from default_tweaks.py
  350. * Mon Feb 1 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.37-1
  351. - new upstream release 0.6.37
  352. * Fri Jan 29 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.36-1
  353. - new upstream release 0.6.36
  354. - fixed a cssprofiles issue with loading the profiles
  355. * Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-3
  356. - added -cssprofiles patch to cvs
  357. * Tue Jan 26 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-2
  358. - remove python-cssutils 0.9.6 dependency
  359. * Mon Jan 25 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.35-1
  360. - new upstream release
  361. - fedora includes cssutils >= 0.9.6 now; removed the cssprofiles patch
  362. - removed -executables patch, upstream fixed it: http://bugs.calibre-ebook.com/ticket/4437
  363. * Wed Jan 6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-2
  364. - fix for package tagged without adding new patch to cvs
  365. * Wed Jan 6 2010 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.32-1
  366. - new upstream release 0.6.32
  367. - project website has changed
  368. - added python-BeautifulSoup BuildRequire
  369. - new patch to fix full buildpath in binary files
  370. * Sun Dec 6 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.26-1
  371. - New upstream version
  372. - Regenerated no-update patch because of code relocation
  373. * Wed Dec 2 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.25-1
  374. - New upstream release
  375. * Wed Nov 18 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.24-1
  376. - New upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2416Nov2009
  377. * Mon Nov 16 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.23-1
  378. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2313Nov2009
  379. - patch to stop checking for new upstream version
  380. * Sat Nov 7 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.21-1
  381. - new upstream version: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2106Nov2009
  382. - added python-BeautifulSoup requirement
  383. * Wed Nov 4 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.20-1
  384. - new upstream version:
  385. http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.2030Oct2009
  386. - upstream now ships correct .desktop files
  387. - fixed missing dependency: PyQt4
  388. - fixed calibre-gui icon
  389. * Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-3
  390. - removed unfree fonts from source package
  391. * Thu Oct 22 2009 Ionuț C. Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-2
  392. - readability enhancements
  393. - added python-genshi requires
  394. - removed libwmf require since ImageMagick provides libwmf-lite as a
  395. dependency and that's what we actually need
  396. * Wed Oct 21 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.19-1
  397. - new upstream version:
  398. http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1920Oct2009
  399. - delete fonts, calibre can find the system fonts
  400. - specify libdir as an install option, so calibre will link properly
  401. even on 64bit
  402. * Mon Oct 19 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.18-1
  403. - updated requires list
  404. - new upstream release
  405. - can override CFLAGS now
  406. - removed trac and genshi duplicates
  407. - use xdg env variables to do desktop integration in the buildroot
  408. - added xdg-utils buildrequire
  409. - install udev rules in /usr/lib even on 64bit and don't own the whole dir
  410. - removed wrongly used Version field from .desktop files
  411. * Mon Oct 12 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-2
  412. - mimick what calibre's desktop-integration script does (mimetypes, icons etc.)
  413. - removed unneeded INSTALL file
  414. - marked bash completion file as config(noreplace) and take ownership of the dir
  415. * Sat Oct 10 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> - 0.6.17-1
  416. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1709Oct2009
  417. - the install process changed significantly
  418. - locales were added
  419. * Thu Sep 10 2009 Ionuț Arțăriși <mapleoin@lavabit.com> - 0.6.11-1
  420. - new upstream release: http://calibre.kovidgoyal.net/wiki/Changelog#Version0.6.1104Sep2009
  421. - minor path fixes
  422. - rearranged files section
  423. * Fri Aug 28 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.10-1
  424. - handle desktop files
  425. - don't compress manpages and don't list them as duplicates
  426. - added lrfviewer icon
  427. * Tue Aug 25 2009 Ionuț Arțăriși <mapleoin@fedoraproject.org> 0.6.8-1
  428. - Initial RPM release