orc-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: orc
  3. Summary: The Oil Run-time Compiler
  4. Version: 0.4.19
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: BSD
  8. URL: http://code.entropywave.com/projects/orc/
  9. Source0: http://code.entropywave.com/download/orc/orc-%{version}.tar.gz
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: gtk-doc, libtool
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. %description
  15. Orc is a library and set of tools for compiling and executing
  16. very simple programs that operate on arrays of data. The "language"
  17. is a generic assembly language that represents many of the features
  18. available in SIMD architectures, including saturated addition and
  19. subtraction, and many arithmetic operations.
  20. %package doc
  21. Summary: Documentation for Orc
  22. Group: Development/Documentation
  23. Requires: %{name} = %{version}-%{release}
  24. #BuildArch: noarch
  25. %description doc
  26. Documentation for Orc.
  27. %package devel
  28. Summary: Development files and static libraries for Orc
  29. Group: Development/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. Requires: %{name}-compiler
  32. Requires: pkgconfig
  33. %description devel
  34. This package contains the files needed to build packages that depend
  35. on orc.
  36. %package compiler
  37. Summary: Orc compiler
  38. Group: Development/Libraries
  39. Requires: %{name} = %{version}-%{release}
  40. Requires: pkgconfig
  41. %description compiler
  42. The Orc compiler, to produce optimized code.
  43. %package -n compat32-%{name}
  44. Summary: The Oil Run-time Compiler
  45. Group: System Environment/Libraries
  46. Requires: %{name} = %{version}-%{release}
  47. %description -n compat32-%{name}
  48. Orc is a library and set of tools for compiling and executing
  49. very simple programs that operate on arrays of data. The "language"
  50. is a generic assembly language that represents many of the features
  51. available in SIMD architectures, including saturated addition and
  52. subtraction, and many arithmetic operations.
  53. %package -n compat32-%{name}-devel
  54. Summary: Development files and static libraries for Orc
  55. Group: Development/Libraries
  56. Requires: compat32-%{name} = %{version}-%{release}
  57. Requires: pkgconfig
  58. %description -n compat32-%{name}-devel
  59. This package contains the files needed to build packages that depend
  60. on orc.
  61. %prep
  62. %setup -q
  63. autoreconf -vif
  64. %build
  65. export CFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
  66. export CXXFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
  67. %configure --disable-static --enable-gtk-doc
  68. make %{?_smp_mflags}
  69. %install
  70. rm -rf %{buildroot}
  71. make install DESTDIR=%{buildroot} INSTALL="install -p"
  72. # Remove unneeded files.
  73. find %{buildroot}/%{_libdir} -name \*.a -or -name \*.la -delete
  74. rm -rf %{buildroot}/%{_libdir}/orc
  75. touch -r stamp-h1 %{buildroot}%{_includedir}/%{name}-0.4/orc/orc-stdint.h
  76. %clean
  77. rm -rf %{buildroot}
  78. %check
  79. make check || true
  80. %post -p /sbin/ldconfig
  81. %postun -p /sbin/ldconfig
  82. %post -n compat32-%{name} -p /sbin/ldconfig
  83. %postun -n compat32-%{name} -p /sbin/ldconfig
  84. %files
  85. %defattr(-,root,root,-)
  86. %doc COPYING README
  87. %{_bindir}/orc-bugreport
  88. %{_libdir}/liborc-*.so.*
  89. %files doc
  90. %defattr(-,root,root,-)
  91. %doc %{_datadir}/gtk-doc/html/orc/
  92. %files devel
  93. %defattr(-,root,root,-)
  94. %doc examples/*.c
  95. %{_includedir}/%{name}-0.4/
  96. %{_libdir}/liborc-*.so
  97. %{_libdir}/pkgconfig/orc-0.4.pc
  98. %{_datadir}/aclocal/orc.m4
  99. %files compiler
  100. %defattr(-,root,root,-)
  101. %{_bindir}/orcc
  102. %if %{build_compat32}
  103. %defattr(-,root,root,-)
  104. %files -n compat32-%{name}
  105. %{_libdir}/liborc-*.so.*
  106. %files -n compat32-%{name}-devel
  107. %defattr(-,root,root,-)
  108. %{_libdir}/liborc-*.so
  109. %endif
  110. %changelog
  111. * Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.19-1
  112. - new upstream release
  113. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.18-2
  114. - rebuild with VineSeed environment
  115. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.18-1
  116. - new upstream release
  117. * Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.16-1
  118. - new upstream release
  119. - create compat32 sub packages
  120. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.14-1
  121. - new upstream release
  122. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
  123. - new upstream release
  124. * Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.5-5
  125. - rebuilt with rpm-4.8.1 for pkg-config
  126. * Fri Jul 30 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.5-4
  127. - build with -O1 (not -O2) to fix build failure on ppc
  128. (like as the Debian package does)
  129. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.5-3
  130. - Initial build for Vine Linux
  131. * Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-2
  132. - Added removed testing libraries to package.
  133. * Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-1
  134. - Updated to 0.4.5.
  135. - Removed testing libraries from package.
  136. * Mon Apr 05 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-2
  137. - Docs as noarch.
  138. - Sanitize timestamps of header files.
  139. - orcc in -compiler subpackage.
  140. * Tue Mar 30 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-1
  141. - Updated to 0.4.4: Includes bugfixes for x86_64.
  142. * Wed Mar 17 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-2
  143. - Running autoreconf to prevent building problems.
  144. - Added missing files to docs.
  145. - Added examples to devel docs.
  146. * Thu Mar 04 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-1
  147. - Updated to 0.4.3
  148. * Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-4
  149. - Removed unused libdir
  150. * Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-3
  151. - Specfile cleanup
  152. - Removed tools subpackage
  153. - Added docs subpackage
  154. * Sat Oct 03 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-2
  155. - Use orc as pakage name
  156. - spec-file cleanup
  157. - Added devel requirements
  158. - Removed an rpath issue
  159. * Fri Oct 02 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-1
  160. - Initial release