glade3-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217
  1. %define helpdir glade3
  2. Version: 3.18.2
  3. Release: 1%{?_dist_release}
  4. Summary: A user interface builder for the GTK+ toolkit and GNOME
  5. Summary(ja): GTK+ツールキット及びGNOME向けのユーザインターフェースビルダー
  6. Name: glade3
  7. License: GPL
  8. Group: Applications/Development
  9. URL: http://glade.gnome.org/
  10. Source0: http://ftp.gnome.org/pub/GNOME/sources/glade/3.16/glade-%{version}.tar.xz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: gtk3-devel >= 3.0.2
  13. BuildRequires: libxml2-devel >= 2.4.0
  14. BuildRequires: python-devel
  15. BuildRequires: pygobject3-devel
  16. BuildRequires: libSM-devel
  17. BuildRequires: yelp-tools
  18. BuildRequires: docbook-style-xsl
  19. Requires: gtk3 >= 3.0.2
  20. Requires: libxml2 >= 2.4.0
  21. Requires: pygobject3
  22. Requires: devhelp
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. %description
  26. Glade is a RAD tool to enable quick & easy development of user interfaces
  27. for the Gtk+ toolkit and the GNOME desktop environment.
  28. The user interfaces designed in Glade are stored in XML format,
  29. enabling easy integration with external tools.
  30. In particular libglade can load the XML files and create the interfaces
  31. at runtime. The DTD for the XML files is included with libglade, and is
  32. also at http://glade.gnome.org/glade-2.0.dtd.
  33. Other tools are available which can turn the XML files into source code
  34. in languages such as C++, Perl and Python.
  35. %description -l ja
  36. Gladeは、GTK+ツールキットやGNOME向けのユーザインターフェースを素早く簡単に開
  37. 発する事が可能なRADツールです。
  38. Gladeでデザインされたユーザインターフェースは外部ツールに用意に統合可能なXML
  39. フォーマットで保存されます。
  40. 特にlibgladeは、XMLファイルを読み込み、ランタイムにインターフェースを生成す
  41. ることが出来ます。このXMLファイルのDTDは、libgladeに含まれており、
  42. http://glade.gnome.org/glade-2.0.dtdにもあります。
  43. このXMLファイルをC++、PerlやPythonといった言語のソースコードに変換する他のツー
  44. ルも利用可能です。
  45. %package devel
  46. Summary: the Glade UI Builder core library
  47. Group: Development/Libraries
  48. Requires: %{name} = %{version}-%{release}
  49. %description devel
  50. the Glade UI Builder core library to integrate Glade into your application
  51. and integrate your custom (GTK+ based) widget toolkit into the Glade
  52. UI Builder.
  53. %prep
  54. %setup -q -n glade-%{version}
  55. pushd src
  56. ## change gnome help directory
  57. mv glade-window.c glade-window.c.orig
  58. sed "s|GLADE_GNOMEHELPDIR, \"glade\"|GLADE_GNOMEHELPDIR, \"%{helpdir}\"|" \
  59. glade-window.c.orig > glade-window.c
  60. popd
  61. %build
  62. %configure --disable-static
  63. %__make %{_smp_mflags}
  64. %install
  65. rm -rf $RPM_BUILD_ROOT
  66. make install DESTDIR=$RPM_BUILD_ROOT
  67. rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  68. rm -f $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.la
  69. rm -f $RPM_BUILD_ROOT%{_libdir}/libgladeui-2.la
  70. %find_lang glade --all-name --with-gnome
  71. %clean
  72. rm -rf $RPM_BUILD_ROOT
  73. %post
  74. /sbin/ldconfig
  75. touch --no-create %{_datadir}/icons/hicolor
  76. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  77. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  78. fi
  79. %postun
  80. /sbin/ldconfig
  81. touch --no-create %{_datadir}/icons/hicolor
  82. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  83. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  84. fi
  85. %files -f glade.lang
  86. %defattr(-,root,root)
  87. %{_bindir}/glade
  88. %{_bindir}/glade-previewer
  89. %{_libdir}/libgladeui-2.so.*
  90. %{_libdir}/glade/modules/*.so
  91. %{_libdir}/girepository-1.0/Gladeui-2.0.typelib
  92. %{_datadir}/appdata/glade.appdata.xml
  93. %{_datadir}/applications/glade.desktop
  94. %{_datadir}/glade
  95. %{_datadir}/icons/hicolor/*/apps/glade.png
  96. %{_mandir}/man1/glade-previewer.1.gz
  97. %{_mandir}/man1/glade.1.gz
  98. %files devel
  99. %defattr(-,root,root)
  100. %{_includedir}/libgladeui-2.0/gladeui/*
  101. %{_libdir}/pkgconfig/*.pc
  102. %{_libdir}/libgladeui-2.so
  103. %{_datadir}/gir-1.0/Gladeui-2.0.gir
  104. %{_datadir}/gtk-doc/html/gladeui-2
  105. %changelog
  106. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
  107. - new upstream release
  108. * Sun Mar 30 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
  109. - new upstream release
  110. * Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
  111. - new upstream release
  112. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
  113. - new upstream release
  114. - add BuildRequires: docbook-style-xsl
  115. * Fri Jan 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.2-1
  116. - new upstream release
  117. * Mon Oct 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.1-1
  118. - new upstream release
  119. - add BuildRequires: python-devel, pygobject3-devel
  120. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.14.0-1
  121. - new upstream release
  122. - change BuildRequires: yelp-tools instead of gnome-doc-utils
  123. * Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
  124. - new upstream release
  125. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.0-1
  126. - new upstream release
  127. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.2-1
  128. - new upstream release
  129. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.10.0-1
  130. - new upstream release
  131. - change BuildRequires: gtk3-devel instead of gtk2-devel
  132. - delete BuildRequires: libgnomeui-devel, libbonoboui-devel
  133. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.7-4
  134. - rebuild with rpm-4.8.1 for pkg-config file
  135. - add BuildRequires: libSM-devel
  136. * Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-3
  137. - add gnome-doc-utils to BR
  138. - comment out desktop-file-install
  139. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-2
  140. - rebuild with gtk2-2.18.2
  141. * Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-1
  142. - new upstream release
  143. - care ld and icon cache
  144. - define helpdir
  145. * Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.3-1
  146. - new upstream release
  147. - spec in utf-8 (fixed)
  148. * Fri May 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.6.2-2
  149. - spec in utf-8
  150. * Sun Apr 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.2-1
  151. - new upstream release
  152. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.2-1
  153. - new upstream version.
  154. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.5-1
  155. - new upstream version.
  156. - update Requires.
  157. - update description.
  158. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-2vl5
  159. - use macro for release
  160. * Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-1vl5
  161. - apply new virsioning policy.
  162. - remove *.la
  163. * Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 3.4.1-0vl
  164. - new upstream version
  165. - added Requires: devhelp
  166. - added Prereq: scrollkeeper
  167. - added disable-scrollkeeper to configure
  168. - added scrollkeeper-update in %%post and %%postun sections
  169. - changed gnome help directory temporarily
  170. * Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.0.3-0vl
  171. - build for VineSeed