check-vl.spec 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148
  1. Summary: A unit test framework for C
  2. Summary(ja): C 言語用単体テストフレームワーク
  3. Name: check
  4. Version: 0.9.12
  5. Release: 1%{?_dist_release}
  6. License: LGPL
  7. Group: Development/Tools
  8. URL: http://check.sourceforge.net/
  9. Source0: http://prdownloads.sourceforge.net/check/%{name}-%{version}.tar.gz
  10. Patch0: %{name}-examples-bootstrap.patch
  11. Patch1: check-0.9.5-fPIC.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: docbook-utils
  14. Requires(post,preun): /sbin/install-info
  15. Vendor: Project Vine
  16. Distribution: Vine Linux
  17. Packager: USAMI Kosuke <usami-k@yc5.so-net.ne.jp>
  18. %description
  19. Check is a unit test framework for C. It features a simple interface
  20. for defining unit tests, putting little in the way of the developer.
  21. Tests are run in a separate address space, so Check can catch both
  22. assertion failures and code errors that cause segmentation faults or
  23. other signals. The output from unit tests can be used within source
  24. code editors and IDEs.
  25. %package devel
  26. Summary: Libraries and headers for developing programs with check
  27. Summary(ja): Check を使ったプログラム開発用ライブラリとヘッダファイル
  28. Group: Development/Libraries
  29. Requires: pkgconfig
  30. Requires: %{name} = %{version}-%{release}
  31. %description devel
  32. Libraries and headers for developing programs with check
  33. %package tools
  34. Summary: The tools for %{name}
  35. Summary(ja): Check 用のツール
  36. Group: Development/Languages
  37. Requires: %{name} = %{version}-%{release}
  38. %description tools
  39. This package contains check tool "chkckmk".
  40. checkmk, a tool for reducing "boilerplate coding" when writing unit tests with check.
  41. %prep
  42. %setup -q
  43. %patch0 -p1
  44. #patch1 -p1 -b .fPIC
  45. %build
  46. %configure --disable-static
  47. make %{?_smp_mflags}
  48. %install
  49. rm -rf $RPM_BUILD_ROOT
  50. %makeinstall
  51. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  52. rm -rf $RPM_BUILD_ROOT%{_infodir}/dir
  53. rm -rf example
  54. cp -pr $RPM_BUILD_ROOT%{_datadir}/doc/check/example .
  55. rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/check
  56. %clean
  57. rm -rf $RPM_BUILD_ROOT
  58. %post
  59. /sbin/ldconfig
  60. /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
  61. %postun -p /sbin/ldconfig
  62. %preun
  63. if [ $1 = 0 ]; then
  64. /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir || :
  65. fi
  66. %files
  67. %defattr(-,root,root)
  68. %doc AUTHORS COPYING.LESSER ChangeLog ChangeLogOld NEWS README SVNChangeLog
  69. %{_libdir}/libcheck.so.*
  70. %{_infodir}/check.info*
  71. %files devel
  72. %defattr(-,root,root)
  73. %doc example
  74. %{_includedir}/check.h
  75. %{_includedir}/check_stdint.h
  76. %{_libdir}/libcheck.so
  77. %{_libdir}/pkgconfig/check.pc
  78. %{_datadir}/aclocal/check.m4
  79. %files tools
  80. %defattr(-,root,root)
  81. %{_bindir}/checkmk
  82. %{_mandir}/man1/checkmk.1.gz
  83. %changelog
  84. * Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.12-1
  85. - new upstream release
  86. * Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.9-1
  87. - new upstream release
  88. - create %{name}-tools sub package
  89. * Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
  90. - rebuilt with rpm-4.8.1 for pkg-config
  91. * Sat Apr 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.8-1
  92. - new upstream release
  93. - dropt Patch1
  94. * Mon May 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.9.5-2
  95. - spec in UTF-8
  96. - split devel subpackage
  97. * Sat Apr 5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.5-1vl5
  98. - new upstream release
  99. - updated Patch1
  100. * Mon Sep 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl2
  101. - enable -fPIC to build gstreamer on x86_64
  102. * Mon Jan 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.9.3-0vl1
  103. - upstream release
  104. - add BuildRequires: docbook-utils instead of lyx
  105. * Fri Aug 1 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.8.4-0vl2
  106. - Rebuild for new Vine.
  107. * Wed Jun 18 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 0.8.4-0vl1
  108. - Initial build.