wireshark-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326
  1. %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  2. Summary: Network traffic analyzer
  3. Summary(ja): ネットワークトラフィック解析プログラム
  4. Name: wireshark
  5. Version: 1.2.9
  6. Release: 1%{_dist_release}
  7. License: GPLv2
  8. Group: Applications/System
  9. Source0: http://www.wireshark.org/download/src/%{name}-%{version}.tar.bz2
  10. Source1: wireshark.pam
  11. Source2: wireshark.console
  12. Source3: wireshark.desktop
  13. Patch1: wireshark-0.99.7-pie.patch
  14. Patch3: wireshark-nfsv4-opts.patch
  15. Patch4: wireshark-0.99.7-path.patch
  16. URL: http://www.wireshark.org/
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: libcap-devel
  19. BuildRequires: net-snmp-devel >= 5.0
  20. BuildRequires: net-snmp-utils >= 5.0
  21. BuildRequires: zlib-devel, bzip2-devel
  22. BuildRequires: openssl-devel
  23. BuildRequires: glib2-devel, gtk2-devel
  24. BuildRequires: libelf-devel
  25. BuildRequires: python, pcre-devel
  26. BuildRequires: gnutls-devel
  27. BuildRequires: desktop-file-utils, automake, libtool
  28. BuildRequires: bison, flex
  29. %if %{?_dist_release} != "vl4"
  30. BuildRequires: krb5-devel
  31. BuildRequires: libpcap-devel
  32. BuildRequires: lua-devel
  33. %else
  34. BuildRequires: libpcap
  35. %endif
  36. Requires: usermode >= 1.37
  37. Requires(post): desktop-file-utils
  38. Requires(postun): desktop-file-utils
  39. Obsoletes: ethereal
  40. Obsoletes: ethereal-base ethereal-gnome ethereal-gtk+
  41. Obsoletes: ethereal-kde ethereal-usermode
  42. Provides: ethereal ethereal-gnome
  43. Vendor: Project Vine
  44. Distribution: Vine Linux
  45. Packager: inagaki
  46. %description
  47. Wireshark is a network traffic analyzer for Unix-ish operating systems.
  48. This package lays base for libpcap, a packet capture and filtering
  49. library, contains command-line utilities, contains plugins and
  50. documentation for wireshark. A graphical user interface is also
  51. included with this package.
  52. %description -l ja
  53. Wireshark は,UNIX 系 OS 用のネットワークトラフィック解析プログラムです.
  54. このパッケージは,パケットキャプチャ/フィルタリングライブラリである
  55. libpcap を使ったコマンドラインツールと,プラグイン,ドキュメント等が
  56. 収められています.GUI もこのパッケージに収められています.
  57. %prep
  58. %setup -q -n %{name}-%{version}
  59. #patch1 -p1 -b .pie
  60. %patch3 -p1
  61. %patch4 -p1
  62. %build
  63. %ifarch s390 s390x
  64. export PIECFLAGS="-fPIE"
  65. %else
  66. export PIECFLAGS="-fpie"
  67. %endif
  68. # FC5+ automatic -fstack-protector-all switch
  69. export RPM_OPT_FLAGS=${RPM_OPT_FLAGS//-fstack-protector/-fstack-protector-all}
  70. export CFLAGS="$RPM_OPT_FLAGS $CPPFLAGS -I%{_includedir}/pcap -I%{_includedir}/pcre"
  71. export CXXFLAGS="$RPM_OPT_FLAGS $CPPFLAGS"
  72. export LDFLAGS="$LDFLAGS -lm -lcrypto"
  73. export PATH="$PATH:/usr/kerberos/bin"
  74. ./autogen.sh
  75. # --disable-warning-as-erros needs for compiling with glib 2.14.0
  76. %configure \
  77. --bindir=%{_sbindir} \
  78. --enable-ipv6 \
  79. --with-gnu-ld \
  80. --disable-static \
  81. --disable-usr-local \
  82. --enable-wireshark \
  83. --with-pic \
  84. --with-ssl \
  85. --with-pcap \
  86. --with-pcre \
  87. %if %{?_dist_release} != "vl4"
  88. --with-krb5 \
  89. %else
  90. --without-krb5 \
  91. %endif
  92. --with-plugins=%{_libdir}/%{name}/plugins/%{version} \
  93. --disable-warnings-as-errors
  94. time make %{?_smp_mflags}
  95. %install
  96. rm -rf $RPM_BUILD_ROOT
  97. # The evil plugins hack
  98. perl -pi -e 's|-L../../epan|-L../../epan/.libs|' plugins/*/*.la
  99. make DESTDIR=$RPM_BUILD_ROOT install
  100. #symlink tshark to tethereal
  101. ln -s tshark $RPM_BUILD_ROOT%{_sbindir}/tethereal
  102. #empty?!
  103. rm -f $RPM_BUILD_ROOT%{_sbindir}/idl2wrs
  104. # install support files for usermode, gnome and kde
  105. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d
  106. install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/pam.d/wireshark
  107. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps
  108. install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/%{_sysconfdir}/security/console.apps/wireshark
  109. mkdir -p $RPM_BUILD_ROOT/%{_bindir}
  110. ln -s consolehelper $RPM_BUILD_ROOT/%{_bindir}/wireshark
  111. # install man
  112. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/man1
  113. install -m 644 *.1 $RPM_BUILD_ROOT/%{_mandir}/man1
  114. # Install python stuff.
  115. mkdir -p $RPM_BUILD_ROOT%{python_sitelib}
  116. install -m 644 tools/wireshark_be.py tools/wireshark_gen.py $RPM_BUILD_ROOT%{python_sitelib}
  117. desktop-file-install --vendor= \
  118. --dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
  119. %{SOURCE3}
  120. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/pixmaps
  121. install -m 644 image/wsicon48.png $RPM_BUILD_ROOT/%{_datadir}/pixmaps/wireshark.png
  122. # Remove .la files
  123. rm -f $RPM_BUILD_ROOT/%{_libdir}/%{name}/plugins/%{version}/*.la
  124. # Remove .la files in libdir
  125. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
  126. %clean
  127. rm -rf $RPM_BUILD_ROOT
  128. %post
  129. /sbin/ldconfig
  130. update-desktop-database -q
  131. %postun
  132. /sbin/ldconfig
  133. update-desktop-database -q
  134. %files
  135. %defattr(-,root,root)
  136. %doc AUTHORS COPYING ChangeLog INSTALL NEWS README*
  137. %{_sbindir}/editcap
  138. #%{_sbindir}/idl2wrs
  139. %{_sbindir}/tshark
  140. %{_sbindir}/mergecap
  141. %{_sbindir}/text2pcap
  142. %{_sbindir}/dftest
  143. %{_sbindir}/capinfos
  144. %{_sbindir}/randpkt
  145. %{_sbindir}/dumpcap
  146. %{_sbindir}/tethereal
  147. %{_sbindir}/rawshark
  148. %{python_sitelib}/*
  149. %{_libdir}/lib*
  150. %{_mandir}/man1/editcap.*
  151. %{_mandir}/man1/tshark.*
  152. %{_mandir}/man1/idl2wrs.*
  153. %{_mandir}/man1/mergecap.*
  154. %{_mandir}/man1/text2pcap.*
  155. %{_mandir}/man1/capinfos.*
  156. %{_mandir}/man1/dumpcap.*
  157. %{_mandir}/man4/wireshark-filter.*
  158. %{_libdir}/wireshark
  159. %config(noreplace) %{_sysconfdir}/pam.d/wireshark
  160. %config(noreplace) %{_sysconfdir}/security/console.apps/wireshark
  161. %{_datadir}/wireshark
  162. %{_datadir}/applications/*.desktop
  163. %{_datadir}/pixmaps/wireshark.png
  164. %{_bindir}/wireshark
  165. %{_sbindir}/wireshark
  166. %{_mandir}/man1/wireshark.*
  167. %{_mandir}/man1/rawshark.*
  168. %changelog
  169. * Wed Jul 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.9-1
  170. - new upstream release
  171. * Tue May 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.8-2
  172. - rebuilt with libpcap-1.1.1
  173. * Sat May 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.8-1
  174. - new upstream release
  175. (including security fix for CVE-2010-1455)
  176. * Thu Apr 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
  177. - new upstream release
  178. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.2.5-3
  179. - rebuilt with python-2.6.4
  180. * Sun Dec 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-2
  181. - added --enable-wireshark instead of --enable-gtk2
  182. - added BR: bison, flex
  183. * Sat Dec 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.5-1
  184. - new upstream release with security fixes (SNA/SMB/IPMI issues)
  185. * Fri Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
  186. - new upstream release
  187. (includeing security fix for CVE-2009-3549,3550 and 3551)
  188. * Wed Sep 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-2
  189. - add BR: lua-devel (Vine 5.0 and later)
  190. * Sat Sep 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.2-1
  191. - new upstream release
  192. * Tue Jul 21 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
  193. - new upstream release
  194. * Mon Jul 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-1
  195. - new upstream release
  196. * Sat May 23 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.8-1
  197. - new upstream release
  198. * Fri Apr 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.7-1
  199. - new upstream release
  200. * Sun Feb 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.6-1
  201. - new upstream release
  202. - used more macros
  203. * Sat Jan 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-1
  204. - new upstream release
  205. * Sun Nov 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-2vl5
  206. - rebuilt
  207. * Mon Oct 27 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.4-1
  208. - new upstream release with security fix
  209. - add BuildRequires krb5-devel
  210. - SPEC in UTF-8
  211. * Fri Sep 05 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.3-1
  212. - new upstream release with security update
  213. * Wed Apr 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0-1
  214. - new upstream release with security update
  215. - add Vendor/Distribution tag
  216. - add BuildRequires: libcap-devel
  217. - new versioning policy
  218. * Tue Jan 8 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.99.7-0vl2
  219. - modified Source3 because of desktop-file-install error, like this:
  220. /var/tmp/wireshark-0.99.7-root/usr/share/applications/wireshark.desktop:
  221. error: value "wireshark.png" for key "Icon" in group "Desktop Entry" is
  222. an icon name with an extension, but there should be no extension as
  223. described in the Icon Theme Specification if the value is not an
  224. absolute path
  225. this warning/error occurs with desktop-file-utils >= 0.14
  226. * Wed Jan 2 2008 Satoshi MACHINO <machino@vinelinux.org> 0.99.7-0vl1
  227. - new upstream release
  228. - imported patch4 from fc9
  229. * Sun Sep 2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl2
  230. - rebuilt with libpcap-0.9.7
  231. - added --disable-warning-as-errors to %%configure for glib-2.14.0
  232. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.6-0vl1
  233. - new upstream release
  234. - rebuilt with libpcap-0.9.6
  235. - added --with-pcap, --with-pcre
  236. * Fri Jun 1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl2
  237. - rebuilt with new toolchain and environment
  238. * Thu Feb 8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.5-0vl1
  239. - new upstream release
  240. * Mon Nov 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.4-0vl1
  241. - new upstream release
  242. * Wed Oct 4 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.99.3-0vl1
  243. - initial built for Vine Linux based on Fedora
  244. - Obsoletes: ethereal, Provides: ethereal
  245. * Fri Aug 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.3-fc5.1
  246. - upgrade to 0.99.3-1
  247. - CVE-2006-4330 Wireshark security issues (CVE-2006-4333 CVE-2006-4332 CVE-2006-4331)
  248. * Wed Jul 26 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.2
  249. - fix BuildRequires
  250. * Tue Jul 25 2006 Radek Vokal <rvokal@redhat.com> 0.99.2-fc5.1
  251. - build for FC5
  252. * Tue Jul 18 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-1
  253. - upgrade to 0.99.2
  254. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.99.2-0.pre1.1
  255. - rebuild
  256. * Tue Jul 11 2006 Radek Vok叩l <rvokal@redhat.com> 0.99.2-0.pre1
  257. - upgrade to 0.99.2pre1, fixes (#198242)
  258. * Tue Jun 13 2006 Radek Vokal <rvokal@redhat.com> 0.99.1-0.pre1
  259. - spec file changes
  260. * Fri Jun 9 2006 Radek Vokal <rvokal@redhat.com> 0.99.1pre1-1
  261. - initial build for Fedora Core