kdebindings-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651
  1. %define csharp 1
  2. %define falcon 0
  3. %define php 1
  4. %define ruby 1
  5. %define smoke 1
  6. %define java 0
  7. %define pykde4_akonadi 1
  8. %define pyqt4_version 4.7
  9. # Qt4 version auto-detection -- inagaki
  10. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null ||
  11. echo 4.6.1)
  12. %define mono_dir %{_prefix}/lib/mono
  13. #if 0%{?ruby}%{?smoke}
  14. #define devel 1
  15. #endif
  16. %global ruby_lib %(ruby -rrbconfig -e 'puts Config::CONFIG["rubylibdir"]')
  17. %global ruby_arch %(ruby -rrbconfig -e 'puts Config::CONFIG["archdir"]')
  18. %global ruby_sitelib %(ruby -rrbconfig -e 'puts Config::CONFIG["sitelibdir"]')
  19. %global ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')
  20. %global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
  21. %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  22. %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
  23. Name: kdebindings
  24. Version: 4.4.3
  25. Release: 1%{?_dist_release}
  26. Summary: KDE bindings to non-C++ languages.
  27. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.bz2
  28. # http://techbase.kde.org/Policies/Licensing_Policy
  29. License: LGPLv2+
  30. Group: System Environment/Libraries
  31. URL: http://www.kde.org/
  32. # fix build with CMAKE_SKIP_RPATH - also needs sed line below
  33. # WARNING: This is a bunch of quick hacks to get this to build. Please do not
  34. # commit this upstream without further discussion.
  35. Patch1: kdebindings-4.3.75-no-rpath.patch
  36. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  37. BuildRequires: akonadi-devel >= 1.3.0
  38. BuildRequires: kdebase-workspace-devel >= %{version}
  39. # okular bindings
  40. BuildRequires: kdegraphics-devel >= %{version}
  41. BuildRequires: kdelibs4-devel >= %{version}
  42. BuildRequires: kdepimlibs-devel >= %{version}
  43. # kdebindings does not support polkit-qt-1 yet
  44. #BuildRequires: polkit-qt-devel
  45. BuildRequires: python-devel
  46. BuildRequires: PyQt4-devel >= %{pyqt4_version}
  47. BuildRequires: qimageblitz-devel
  48. BuildRequires: qscintilla-devel >= 2.4
  49. BuildRequires: soprano-devel
  50. %if %{csharp}
  51. BuildRequires: mono-core
  52. BuildRequires: mono-devel
  53. %endif
  54. %if %{falcon}
  55. BuildRequires: Falcon-devel >= 0.8.12
  56. %endif
  57. %if %{php}
  58. BuildRequires: php5-devel
  59. %endif
  60. %if %{ruby}
  61. BuildRequires: ruby-devel
  62. BuildRequires: ruby
  63. %endif
  64. %if %{java}
  65. # TODO: kross-java is a mess, not sure what it needs to build
  66. # CMakeLists.txt is also not portable (only gcj and i486 hardcoded)
  67. # -- mathstuf
  68. BuildRequires: java-1.6.0-openjdk-devel
  69. %endif
  70. Requires: kdelibs4 >= %{version}
  71. %description
  72. KDE bindings to non-C++ languages
  73. %package devel
  74. Summary: Development files for kdebindings.
  75. Group: Development/Libraries
  76. Requires: %{name} = %{version}-%{release}
  77. Requires: kdelibs4-devel
  78. %description devel
  79. Development files for the KDE bindings.
  80. Install kdebindings-devel if you want to develop non-KDE applications
  81. that talk to KDE.
  82. %package -n PyKDE4
  83. Summary: Python bindings for KDE4
  84. Summary(ja): KDE4 の Python バインディング
  85. Group: Development/Languages
  86. Requires: kdelibs4 >= %{version}
  87. Requires: PyQt4 >= %{pyqt4_version}
  88. %description -n PyKDE4
  89. %{summary}.
  90. %package -n PyKDE4-akonadi
  91. Summary: Akonadi runtime support for PyKDE4
  92. Group: Development/Languages
  93. Requires: PyKDE4 = %{version}-%{release}
  94. Requires: kdepimlibs-akonadi >= %{version}
  95. %description -n PyKDE4-akonadi
  96. %{summary}.
  97. %package -n PyKDE4-devel
  98. Group: Development/Libraries
  99. Summary: Files needed to build PyKDE4-based applications
  100. Requires: PyQt4-devel
  101. Requires: PyKDE4 = %{version}-%{release}
  102. Requires: PyKDE4-akonadi = %{version}-%{release}
  103. %description -n PyKDE4-devel
  104. %{summary}.
  105. # C# bindings
  106. %if %{csharp}
  107. %package -n kimono
  108. Group: Development/Languages
  109. Summary: C# bindings for KDE4
  110. Summary(ja): KDE4 の C# バインディング
  111. Requires: kdelibs4 >= %{version}
  112. Requires: qyoto = %{version}-%{release}
  113. Provides: kimono4 = %{version}-%{release}
  114. %description -n kimono
  115. %{summary}.
  116. %package -n qyoto
  117. Group: Development/Languages
  118. Summary: C# bindings for Qt4
  119. Summary(ja): Qt4 の C# バインディング
  120. Requires: qt4 >= %{qt4_version}
  121. Provides: qyoto4 = %{version}-%{release}
  122. %description -n qyoto
  123. %{summary}.
  124. %package -n qyoto-devel
  125. Group: Development/Libraries
  126. Summary: Development files for qyoto
  127. Requires: qyoto = %{version}-%{release}
  128. Requires: mono-devel
  129. Provides: qyoto4-devel = %{version}-%{release}
  130. %description -n qyoto-devel
  131. %{summary}.
  132. %endif
  133. # Ruby
  134. %if %{ruby}
  135. %package -n korundum
  136. Group: Development/Languages
  137. Summary: Ruby bindings for KDE4
  138. Summary(ja): KDE4 の Ruby バインディング
  139. Requires: kdelibs4 >= %{version}
  140. Requires: QtRuby = %{version}-%{release}
  141. Provides: korundum4 = %{version}-%{release}
  142. %description -n korundum
  143. %{summary}.
  144. %package -n korundum-devel
  145. Group: Development/Libraries
  146. Summary: Development files for korundum
  147. Requires: QtRuby-devel
  148. Requires: korundum = %{version}-%{release}
  149. Provides: korundum4-devel = %{version}-%{release}
  150. %description -n korundum-devel
  151. %{summary}.
  152. %package -n QtRuby
  153. Group: Development/Languages
  154. Summary: Ruby bindings for Qt4
  155. Summary(ja): Qt4 の Ruby バインディング
  156. Requires: qt4 >= %{qt4_version}
  157. Provides: QtRuby4 = %{version}-%{release}
  158. %description -n QtRuby
  159. %{summary}.
  160. %package -n QtRuby-devel
  161. Group: Development/Libraries
  162. Summary: Development files for QtRuby
  163. Requires: QtRuby = %{version}-%{release}
  164. Provides: QtRuby4-devel = %{version}-%{release}
  165. %description -n QtRuby-devel
  166. %{summary}.
  167. %endif
  168. %if %{php}
  169. %package -n php-qt
  170. Group: Development/Languages
  171. Summary: PHP bindings for Qt4
  172. Summary(ja): Qt4 の PHP バインディング
  173. Requires: qt4 >= %{qt4_version}
  174. Provides: php-qt4 = %{version}-%{release}
  175. %description -n php-qt
  176. %{summary}.
  177. %package -n php-qt-devel
  178. Group: Development/Libraries
  179. Summary: Development files for php-qt
  180. Requires: php-qt = %{version}-%{release}
  181. Provides: php-qt4-devel = %{version}-%{release}
  182. %description -n php-qt-devel
  183. %{summary}.
  184. %endif
  185. %package -n kross-python
  186. Group: Development/Languages
  187. Summary: Kross plugin for python
  188. Requires: kdelibs4 >= %{version}
  189. Provides: kross(python) = %{version}-%{release}
  190. %description -n kross-python
  191. Python plugin for the Kross archtecture in KDE4.
  192. %if %{ruby}
  193. %package -n kross-ruby
  194. Group: Development/Languages
  195. Summary: Kross plugin for ruby
  196. Requires: ruby
  197. Requires: kdelibs4 >= %{version}
  198. Provides: kross(ruby) = %{version}-%{release}
  199. %description -n kross-ruby
  200. Ruby plugin for the Kross archtecture in KDE4.
  201. %endif
  202. %if %{falcon}
  203. %package -n kross-falcon
  204. Group: Development/Languages
  205. Summary: Kross plugin for falcon
  206. Requires: Falcon >= 0.8.12
  207. Requires: kdelibs4 >= %{version}
  208. Provides: kross(falcon) = %{version}-%{release}
  209. %description -n kross-falcon
  210. Falcon plugin for the Kross archtecture in KDE4.
  211. %endif
  212. %prep
  213. %setup -q
  214. # do the no-rpath hack last, after the upstream backports (if any)
  215. #patch1 -p1 -b .no-rpath
  216. #sed -i -e 's!COMMAND generator!COMMAND ${PROJECT_BINARY_DIR}/generator/bin/generator${CMAKE_EXECUTABLE_SUFFIX}.shell!g' -e 's/WORKING_DIRECTORY/DEPENDS generator WORKING_DIRECTORY/g' smoke/*/CMakeLists.txt
  217. %build
  218. mkdir -p %{_target_platform}
  219. pushd %{_target_platform}
  220. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  221. %cmake \
  222. -DCMAKE_BUILD_TYPE=release \
  223. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  224. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  225. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  226. -DPYTHON_LIBRARY=%{_libdir}/libpython%{python_ver}.so.1.0 \
  227. -DPYTHON_LIBRARIES=%{_libdir}/libpython%{python_ver}.so.1.0 \
  228. -DPYTHON_INCLUDE_PATH=%{_includedir}/python%{python_ver} \
  229. %if %{csharp}
  230. -DENABLE_QYOTO=ON \
  231. %else
  232. -DBUILD_csharp=OFF \
  233. %endif
  234. %if %{falcon}
  235. -DENABLE_KROSSFALCON=ON \
  236. %else
  237. -DBUILD_falcon=OFF \
  238. %endif
  239. %if %{php}
  240. -DENABLE_PHP-QT=ON \
  241. %else
  242. -DBUILD_php=OFF \
  243. %endif
  244. %if %{ruby}
  245. -DRUBY_SITE_LIB_DIR:PATH=%{ruby_sitelib} \
  246. -DRUBY_SITE_ARCH_DIR:PATH=%{ruby_sitearch} \
  247. -DCUSTOM_RUBY_SITE_LIB_DIR:PATH=%{ruby_lib} \
  248. -DCUSTOM_RUBY_SITE_ARCH_DIR:PATH=%{ruby_arch} \
  249. %else
  250. -DBUILD_ruby=OFF \
  251. %endif
  252. %if %{smoke}
  253. -DENABLE_SMOKE=ON \
  254. %else
  255. -DBUILD_smoke=OFF \
  256. %endif
  257. %if %{java}
  258. -DENABLE_KROSSJAVA=ON \
  259. %else
  260. -DBUILD_java=OFF \
  261. %endif
  262. -DCMAKE_SKIP_RPATH:BOOL=OFF \
  263. ..
  264. popd
  265. # -DRUBY_INCLUDE_PATH:PATH=%{ruby_arch} \
  266. # smp build not recommended (upstream)
  267. make -C %{_target_platform}
  268. %install
  269. rm -rf $RPM_BUILD_ROOT
  270. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  271. # HACK: fix multilb conflict, similar to PyQt4's http://bugzilla.redhat.com/509415
  272. rm -fv $RPM_BUILD_ROOT%{_bindir}/pykdeuic4
  273. mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pykdeuic4.py \
  274. $RPM_BUILD_ROOT%{_bindir}/pykdeuic4
  275. ln -s %{_bindir}/pykdeuic4 \
  276. $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pykdeuic4.py
  277. # install pykde4 examples under correct dir
  278. #mkdir -p %{buildroot}%{_docdir}
  279. #rm -f %{buildroot}%{_datadir}/kde4/apps/pykde4/examples/*.py?
  280. #mv %{buildroot}%{_datadir}/kde4/apps/pykde4 %{buildroot}%{_docdir}/
  281. # bz#551534 - qyoto doesn't pull mono in
  282. %if %{csharp}
  283. find %{buildroot} -name \*.dll -not -type l | xargs chmod ugo+x
  284. %endif
  285. %clean
  286. rm -rf $RPM_BUILD_ROOT
  287. %post -p /sbin/ldconfig
  288. %postun -p /sbin/ldconfig
  289. %pre -n PyKDE4-devel
  290. if [ -d %{_bindir}/pykdeuic4 ]; then
  291. rm -rf %{_bindir}/pykdeuic4/
  292. fi
  293. %files
  294. %defattr(-,root,root)
  295. %doc AUTHORS ChangeLog COPYING NEWS README
  296. %if %{smoke}
  297. %{_libdir}/libsmoke*.so.*
  298. %endif
  299. %files devel
  300. %defattr(-,root,root)
  301. %if %{smoke}
  302. %{_bindir}/smoke*
  303. %{_includedir}/smoke.h
  304. %{_includedir}/smoke
  305. %{_libdir}/libcppparser.so
  306. %{_libdir}/libsmoke*.so
  307. %dir %{_libdir}/smokegen
  308. %{_libdir}/smokegen/*.so
  309. %{_datadir}/smokegen
  310. %endif
  311. %files -n PyKDE4
  312. %defattr(-,root,root,-)
  313. %doc COPYING
  314. %{python_sitearch}/PyKDE4
  315. %{python_sitearch}/PyQt4/uic/widget-plugins/kde4.py*
  316. %dir %{_datadir}/kde4/apps/pykde4
  317. %{_libdir}/kde4/kpythonpluginfactory.so
  318. %exclude %{python_sitearch}/PyKDE4/akonadi.so
  319. %files -n PyKDE4-akonadi
  320. %defattr(-,root,root,-)
  321. %{python_sitearch}/PyKDE4/akonadi.so
  322. %files -n PyKDE4-devel
  323. %defattr(-,root,root,-)
  324. %{_bindir}/pykdeuic4
  325. %{python_sitearch}/PyQt4/uic/pykdeuic4.py*
  326. %{_datadir}/kde4/apps/pykde4/examples/
  327. %{_datadir}/sip/PyKDE4
  328. %if %{csharp}
  329. %files -n kimono
  330. %defattr(-,root,root,-)
  331. %{_libdir}/kde4/kimonopluginfactory.so
  332. %{_libdir}/libakonadi-sharp.so
  333. %{_libdir}/libkhtml-sharp.so
  334. %{_libdir}/libkimono.so
  335. %{_libdir}/libktexteditor-sharp.so
  336. %{_libdir}/libnepomuk-sharp.so
  337. %{_libdir}/libplasma-sharp.so
  338. %{_libdir}/libsoprano-sharp.so
  339. %{_libdir}/libqimageblitz-sharp.so
  340. %{mono_dir}/qyoto/qimageblitz.dll
  341. %{mono_dir}/qyoto/akonadi.dll
  342. %{mono_dir}/qyoto/kde-dotnet.dll
  343. %{mono_dir}/qyoto/khtml-dll.dll
  344. %{mono_dir}/qyoto/ktexteditor-dotnet.dll
  345. %{mono_dir}/qyoto/nepomuk-dll.dll
  346. %{mono_dir}/qyoto/plasma-dll.dll
  347. %{mono_dir}/qyoto/soprano.dll
  348. %{mono_dir}/gac/akonadi
  349. %{mono_dir}/gac/kde-dotnet
  350. %{mono_dir}/gac/khtml-dll
  351. %{mono_dir}/gac/ktexteditor-dotnet
  352. %{mono_dir}/gac/nepomuk-dll
  353. %{mono_dir}/gac/plasma-dll
  354. %{mono_dir}/gac/soprano
  355. %{mono_dir}/gac/qimageblitz
  356. %{_datadir}/kde4/apps/plasma_scriptengine_kimono
  357. %{_datadir}/kde4/services/plasma-scriptengine-kimono-applet.desktop
  358. %{_datadir}/kde4/services/plasma-scriptengine-kimono-dataengine.desktop
  359. %files -n qyoto
  360. %defattr(-,root,root,-)
  361. %{_libdir}/libqtscript-sharp.so
  362. %{_libdir}/libqttest-sharp.so
  363. %{_libdir}/libqtuitools-sharp.so
  364. %{_libdir}/libqtwebkit-sharp.so
  365. %{_libdir}/libqyoto.so
  366. %{_libdir}/libqyotoshared.so.1
  367. %{_libdir}/libqyotoshared.so.1.0.0
  368. %{mono_dir}/qyoto/qt-dotnet.dll
  369. %{mono_dir}/qyoto/qtscript.dll
  370. %{mono_dir}/qyoto/qttest.dll
  371. %{mono_dir}/qyoto/qtuitools.dll
  372. %{mono_dir}/qyoto/qtwebkit.dll
  373. %{mono_dir}/gac/qt-dotnet
  374. %{mono_dir}/gac/qtscript
  375. %{mono_dir}/gac/qttest
  376. %{mono_dir}/gac/qtuitools
  377. %{mono_dir}/gac/qtwebkit
  378. %files -n qyoto-devel
  379. %defattr(-,root,root,-)
  380. %{_bindir}/csrcc
  381. %{_bindir}/uics
  382. %{_includedir}/qyoto
  383. %{_libdir}/libqyotoshared.so
  384. %{_libdir}/pkgconfig/*
  385. %endif
  386. %if %{ruby}
  387. %files -n korundum
  388. %defattr(-,root,root,-)
  389. %{_bindir}/krubyapplication
  390. %{ruby_lib}/KDE/
  391. %{ruby_lib}/akonadi/
  392. %{ruby_lib}/khtml/
  393. %{ruby_lib}/ktexteditor/
  394. %{ruby_lib}/okular/
  395. %{ruby_lib}/solid/
  396. %{ruby_lib}/soprano/
  397. %{ruby_lib}/nepomuk/
  398. %{ruby_arch}/akonadi.so
  399. %{ruby_arch}/khtml.so
  400. %{ruby_arch}/korundum4.so
  401. %{ruby_arch}/ktexteditor.so
  402. %{ruby_arch}/okular.so
  403. %{ruby_arch}/plasma_applet.so
  404. %{ruby_arch}/solid.so
  405. %{ruby_arch}/soprano.so
  406. %{ruby_arch}/nepomuk.so
  407. %{_libdir}/kde4/krubypluginfactory.so
  408. %{_datadir}/applications/kde4/dbpedia_references.desktop
  409. %{_datadir}/kde4/apps/dbpedia_references
  410. %files -n korundum-devel
  411. %defattr(-,root,root,-)
  412. %{_bindir}/rbkconfig_compiler4
  413. %{_includedir}/qtruby/
  414. %exclude %{_libdir}/libqtruby4shared.so
  415. %files -n QtRuby
  416. %defattr(-,root,root,-)
  417. %{ruby_lib}/Qt/
  418. %{ruby_lib}/Qt*.rb
  419. %{ruby_lib}/qtscript/
  420. %{ruby_lib}/qttest/
  421. %{ruby_lib}/qtuitools/
  422. %{ruby_lib}/qtwebkit/
  423. %{ruby_arch}/qt*.so
  424. %{_libdir}/libqtruby4shared.so.2
  425. %{_libdir}/libqtruby4shared.so.2.0.0
  426. %files -n QtRuby-devel
  427. %defattr(-,root,root,-)
  428. %{_bindir}/rbqtapi
  429. %{_bindir}/rbrcc
  430. %{_bindir}/rbuic4
  431. %{_libdir}/libqtruby4shared.so
  432. %endif
  433. %if %{php}
  434. %files -n php-qt
  435. %defattr(-,root,root,-)
  436. %{_libdir}/php5/php_qt.so
  437. %files -n php-qt-devel
  438. %defattr(-,root,root,-)
  439. %{_bindir}/phpuic
  440. %endif
  441. %files -n kross-python
  442. %defattr(-,root,root,-)
  443. # unversioned library
  444. %{_libdir}/kde4/krosspython.so
  445. %if %{ruby}
  446. %files -n kross-ruby
  447. %defattr(-,root,root,-)
  448. %{_libdir}/kde4/krossruby.so
  449. %endif
  450. %if %{falcon}
  451. %files -n kross-falcon
  452. %defattr(-,root,root,-)
  453. %{_libdir}/kde4/krossfalcon.so
  454. %endif
  455. %changelog
  456. * Fri May 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  457. - new upstream release
  458. * Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  459. - new upstream release
  460. * Tue Mar 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  461. - new upstream release
  462. - added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
  463. (see https://bugs.kde.org/show_bug.cgi?id=214824)
  464. - built with new toolchain
  465. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  466. - new upstream release
  467. * Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
  468. - merged 4.3.1-2 %changelog
  469. - re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
  470. * Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
  471. - use %%{_prefix}/lib for mono-dll (for x86_64)
  472. * Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
  473. - new upstream release
  474. - built with PyQt4-4.6
  475. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
  476. - define %%{mono_dir} to specify mono library install path
  477. * Sun Sep 6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  478. - new upstream release
  479. - fixed ruby modules installation path
  480. * Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  481. - new upstream release
  482. - spilt sub package based on Fedora
  483. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  484. - applied new versioning policy
  485. - added Patch1
  486. (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
  487. * Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
  488. - added --with-qt-libraries option
  489. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  490. - rebuild for VineSeed
  491. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  492. - new upstream release
  493. * Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  494. - rebuild for VineSeed
  495. * Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  496. - new upstream release
  497. - update Patch0
  498. - drop Patch1
  499. * Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  500. - new upstream release
  501. - add Patch1
  502. - add --enable-libsuffix option
  503. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  504. - rebuild for VineSeed
  505. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  506. - new upstream release
  507. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  508. - rebuild for VineSeed
  509. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  510. - new upstream release
  511. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  512. - rebuild for VineSeed
  513. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  514. - new upstream release
  515. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  516. - rebuild for VineSeed
  517. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  518. - new upstream release
  519. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  520. - rebuild for VineSeed
  521. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  522. - new upstream release
  523. - renew BuildPrereq and build section
  524. - renew %%files
  525. - enable python
  526. - change spec to make main and devel package
  527. - add BuildPrereq: ruby ruby-devel
  528. - add Patch0 to install ruby-bindings under /usr/lib/ruby
  529. * Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  530. - build for VineSeed
  531. - disable python and mozilla
  532. - objprelink (i386 only)
  533. * Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
  534. - 2.2.2
  535. - build kmozilla binding only on x86/alpha
  536. * Thu Aug 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
  537. - Make sure %%{name}-kmozilla isn't built on ia64
  538. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
  539. - Move python bindings to separate package
  540. - Add perl bindings
  541. - Shut up rpmlint
  542. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  543. - 2.1
  544. * Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  545. - initial RPM