qt5-qtwebchannel-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222
  1. %global qt_module qtwebchannel
  2. #define docs 1
  3. #define prerelease
  4. %global qt5_minorver 5.15
  5. %global qt5_version 5.15.2
  6. #global qt5_patchlevel 1
  7. Summary: Qt5 - WebChannel component
  8. Name: qt5-%{qt_module}
  9. Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
  10. Release: 1%{?_dist_release}
  11. Group: system
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. # See LICENSE.GPL LICENSE.LGPL LGPL_EXCEPTION.txt, for details
  15. # See also http://doc.qt.io/qt-5/licensing.html
  16. License: LGPLv2 with exceptions or GPLv3 with exceptions
  17. Url: https://qt.io/
  18. Source0: https://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
  19. BuildRequires: cmake
  20. BuildRequires: qt5-rpm-macros
  21. BuildRequires: qt5-srpm-macros
  22. BuildRequires: qt5-qtbase-devel >= %{version}
  23. BuildRequires: qt5-qtbase-private-devel
  24. #libQt5Core.so.5(Qt_5_PRIVATE_API)(64bit)
  25. %{?_qt5:Requires: %{_qt5}%{?_isa} = %{_qt5_version}}
  26. BuildRequires: qt5-qtdeclarative-devel
  27. BuildRequires: qt5-qtwebsockets-devel
  28. %description
  29. The Qt WebChannel module provides a library for seamless integration of C++
  30. and QML applications with HTML/JavaScript clients. Any QObject can be
  31. published to remote clients, where its public API becomes available.
  32. %package devel
  33. Summary: Development files for %{name}
  34. Group: programming
  35. Requires: %{name}%{?_isa} = %{version}-%{release}
  36. Requires: qt5-qtbase-devel%{?_isa}
  37. %description devel
  38. %{summary}.
  39. %if 0%{?docs}
  40. %package doc
  41. Summary: API documentation for %{name}
  42. Group: documentation
  43. License: GFDL
  44. Requires: %{name} = %{version}-%{release}
  45. BuildRequires: qt5-qdoc
  46. BuildRequires: qt5-qhelpgenerator
  47. BuildArch: noarch
  48. %description doc
  49. %{summary}.
  50. %endif
  51. %package examples
  52. Summary: Programming examples for %{name}
  53. Group: programming
  54. Requires: %{name}%{?_isa} = %{version}-%{release}
  55. %description examples
  56. %{summary}.
  57. %debug_package
  58. %prep
  59. %setup -q -n %{qt_module}-everywhere-src-%{qt5_version}
  60. %build
  61. mkdir %{_target_platform}
  62. pushd %{_target_platform}
  63. %{qmake_qt5} ..
  64. make %{?_smp_mflags}
  65. %if 0%{?docs}
  66. # HACK to avoid multilib conflicts in noarch content
  67. # see also https://bugreports.qt.io/browse/QTBUG-42071
  68. QT_HASH_SEED=0; export QT_HASH_SEED
  69. make %{?_smp_mflags} docs
  70. %endif
  71. popd
  72. %install
  73. make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  74. %if 0%{?docs}
  75. make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  76. %endif
  77. ## .prl/.la file love
  78. # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
  79. pushd %{buildroot}%{_qt5_libdir}
  80. for prl_file in libQt5*.prl ; do
  81. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
  82. if [ -f "$(basename ${prl_file} .prl).so" ]; then
  83. rm -fv "$(basename ${prl_file} .prl).la"
  84. sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
  85. fi
  86. done
  87. popd
  88. %files
  89. %license LICENSE.*
  90. %{_qt5_libdir}/libQt5WebChannel.so.5*
  91. %{_qt5_archdatadir}/qml/QtWebChannel/
  92. %files devel
  93. %{_qt5_headerdir}/QtWebChannel/
  94. %{_qt5_libdir}/libQt5WebChannel.so
  95. %{_qt5_libdir}/libQt5WebChannel.prl
  96. %dir %{_qt5_libdir}/cmake/Qt5WebChannel/
  97. %{_qt5_libdir}/cmake/Qt5WebChannel/Qt5WebChannelConfig*.cmake
  98. %{_qt5_libdir}/pkgconfig/Qt5WebChannel.pc
  99. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_webchannel*.pri
  100. %if 0%{?docs}
  101. %files doc
  102. %license LICENSE.FDL
  103. %{_qt5_docdir}/%{qt_module}.qch
  104. %{_qt5_docdir}/%{qt_module}/
  105. %endif
  106. %if 0%{?_qt5_examplesdir:1}
  107. %files examples
  108. %{_qt5_examplesdir}/
  109. %endif
  110. %changelog
  111. * Tue Apr 13 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.15.2-1
  112. - new upstream release.
  113. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-1
  114. - new upstream release.
  115. * Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.7-1
  116. - new upstream release.
  117. * Sun Oct 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.5-1
  118. - new upstream release.
  119. * Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
  120. - new upstream release.
  121. * Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
  122. - initial build for Vine Linux.
  123. - new upstream release.
  124. * Wed Jun 15 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
  125. - drop pkg-config-style deps, BR: qt5-qtbase-private-devel
  126. * Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
  127. - Update to 5.6.1
  128. * Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
  129. - rebuild
  130. * Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
  131. - rebuild
  132. * Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
  133. - 5.6.0 final release
  134. * Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.8.rc
  135. - Update to final RC
  136. * Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.7
  137. - Update RC release
  138. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.6.rc
  139. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  140. * Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.5.rc
  141. - update source URL, use %%license, BR: cmake
  142. * Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.4
  143. - Update to final rc release
  144. * Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.3
  145. - Official rc release
  146. * Sun Dec 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.2
  147. - restore bootstrap macro support
  148. * Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
  149. - Start to implement 5.6.0 rc
  150. * Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
  151. - Update for final qt 5.5.1
  152. * Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
  153. - Update to Qt 5.5.1 RC1
  154. * Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-3
  155. - -docs: BuildRequires: qt5-qhelpgenerator, standardize bootstrapping
  156. * Thu Jul 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-2
  157. - tighten qtbase dep (#1233829)
  158. * Thu Jul 09 2015 Jan Grulich <jgrulich@redhat.com> - 5.5.0-1
  159. - 5.5.0
  160. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.4.2-2
  161. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  162. * Sun Jun 07 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.2-1
  163. - 5.4.2
  164. * Tue Dec 23 2014 Taylor Braun-Jones <taylor.braun-jones@ge.com> - 5.4.0-1
  165. - Initial release.