qt5-qttools-vl.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712
  1. %bcond_with docs
  2. ## set to 1 to enable bootstrap
  3. #global bootstrap 1
  4. # define to build docs, need to undef this for bootstrapping
  5. # where qt5-qttools builds are not yet available
  6. # only primary archs (for now), allow secondary to bootstrap
  7. %if ! 0%{?bootstrap}
  8. %ifarch %{arm} %{ix86} x86_64
  9. %if %{with docs}
  10. #define docs 1
  11. %endif
  12. %endif
  13. %endif
  14. #define prerelease
  15. %global qt_module qttools
  16. %global qt5_minorver 5.15
  17. %global qt5_version 5.15.2
  18. #global qt5_patchlevel 1
  19. Summary: Qt5 - QtTool components
  20. Name: qt5-qttools
  21. Version: %{qt5_version}%{?qt5_patchlevel:.%{qt5_patchlevel}}
  22. Release: 1%{?_dist_release}
  23. Group: system
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. License: LGPLv3 or LGPLv2
  27. Url: https://www.qt.io/
  28. Source0: https://download.qt.io/official_releases/qt/%{qt5_minorver}/%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}/submodules/%{qt_module}-everywhere-src-%{qt5_version}%{?qt5_patchlevel:-%{qt5_patchlevel}}.tar.xz
  29. # help lrelease/lupdate use/prefer qmake-qt5
  30. # https://bugzilla.redhat.com/show_bug.cgi?id=1009893
  31. Patch2: qttools-opensource-src-5.13.2-runqttools-with-qt5-suffix.patch
  32. # 32-bit MIPS needs explicit -latomic
  33. Patch4: qttools-opensource-src-5.7-add-libatomic.patch
  34. # Link against libclang-cpp.so
  35. # https://fedoraproject.org/wiki/Changes/Stop-Shipping-Individual-Component-Libraries-In-clang-lib-Package
  36. Patch5: 0001-Link-against-libclang-cpp.so-instead-of-the-clang-co.patch
  37. ## upstream patches
  38. Source20: assistant.desktop
  39. Source21: designer.desktop
  40. Source22: linguist.desktop
  41. Source23: qdbusviewer.desktop
  42. BuildRequires: cmake
  43. BuildRequires: qt5-rpm-macros
  44. BuildRequires: qt5-srpm-macros
  45. BuildRequires: desktop-file-utils
  46. ## optional (and deprecated), include in bootstrapping only for now
  47. %if ! 0%{?bootstrap}
  48. #BuildRequires: pkgconfig(Qt5WebKit)
  49. #global webkit 1
  50. %endif
  51. BuildRequires: qt5-qtbase-static >= %{version}
  52. BuildRequires: qt5-qtdeclarative-static >= %{version}
  53. %if 0%{?bootstrap}
  54. %global no_examples CONFIG-=compile_examples
  55. Obsoletes: %{name}-examples < %{version}-%{release}
  56. %else
  57. # for qdoc
  58. BuildRequires: clang-devel llvm-devel
  59. %endif
  60. Requires: %{name}-common = %{version}-%{release}
  61. %{?_qt5:Requires: %{_qt5}%{?_isa} >= %{_qt5_version}}
  62. %description
  63. %{summary}.
  64. %package common
  65. Summary: Common files for %{name}
  66. Group: system
  67. BuildArch: noarch
  68. Obsoletes: qt5-qttools-libs-clucene < 5.9.0
  69. %if ! 0%{?webkit}
  70. Obsoletes: qt5-designer-plugin-webkit < 5.9.0
  71. %endif
  72. %description common
  73. %{summary}.
  74. %package devel
  75. Summary: Development files for %{name}
  76. Group: programming
  77. Requires: %{name} = %{version}-%{release}
  78. Requires: %{name}-libs-designer%{?_isa} = %{version}-%{release}
  79. Requires: %{name}-libs-designercomponents%{?_isa} = %{version}-%{release}
  80. Requires: %{name}-libs-help%{?_isa} = %{version}-%{release}
  81. Requires: qt5-doctools = %{version}-%{release}
  82. Requires: qt5-designer = %{version}-%{release}
  83. Requires: qt5-linguist = %{version}-%{release}
  84. Requires: qt5-qtbase-devel%{?_isa}
  85. %description devel
  86. %{summary}.
  87. %package static
  88. Summary: Static library files for %{name}
  89. Group: programming
  90. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  91. %description static
  92. %{summary}.
  93. %package libs-designer
  94. Summary: Qt5 Designer runtime library
  95. Group: system
  96. Requires: %{name}-common = %{version}-%{release}
  97. %description libs-designer
  98. %{summary}.
  99. %package libs-designercomponents
  100. Summary: Qt5 Designer Components runtime library
  101. Group: system
  102. Requires: %{name}-common = %{version}-%{release}
  103. %description libs-designercomponents
  104. %{summary}.
  105. %package libs-help
  106. Summary: Qt5 Help runtime library
  107. Group: programming
  108. Requires: %{name}-common = %{version}-%{release}
  109. %description libs-help
  110. %{summary}.
  111. %package -n qt5-assistant
  112. Summary: Documentation browser for Qt5
  113. Group: programming
  114. Requires: %{name}-common = %{version}-%{release}
  115. %description -n qt5-assistant
  116. %{summary}.
  117. %package -n qt5-designer
  118. Summary: Design GUIs for Qt5 applications
  119. Group: programming
  120. Requires: %{name}-libs-designer%{?_isa} = %{version}-%{release}
  121. Requires: %{name}-libs-designercomponents%{?_isa} = %{version}-%{release}
  122. %description -n qt5-designer
  123. %{summary}.
  124. %if 0%{?webkit}
  125. %package -n qt5-designer-plugin-webkit
  126. Summary: Qt5 designer plugin for WebKit
  127. Group: programming
  128. BuildRequires: pkgconfig(Qt5WebKitWidgets)
  129. Requires: %{name}-libs-designer%{?_isa} = %{version}-%{release}
  130. %description -n qt5-designer-plugin-webkit
  131. %{summary}.
  132. %endif
  133. %package -n qt5-linguist
  134. Summary: Qt5 Linguist Tools
  135. Group: programming
  136. Requires: %{name}-common = %{version}-%{release}
  137. %description -n qt5-linguist
  138. Tools to add translations to Qt5 applications.
  139. %package -n qt5-qdbusviewer
  140. Summary: D-Bus debugger and viewer
  141. Group: programming
  142. Requires: %{name}-common = %{version}-%{release}
  143. %{?_qt5:Requires: %{_qt5}%{?_isa} >= %{_qt5_version}}
  144. %description -n qt5-qdbusviewer
  145. QDbusviewer can be used to inspect D-Bus objects of running programs
  146. and invoke methods on those objects.
  147. %package -n qt5-doctools
  148. Summary: Qt5 doc tools package
  149. Group: programming
  150. Provides: qt5-qdoc = %{version}
  151. Obsoletes: qt5-qdoc < 5.8.0
  152. Provides: qt5-qhelpgenerator = %{version}
  153. Obsoletes: qt5-qhelpgenerator < 5.8.0
  154. Provides: qt5-qtattributionsscanner = %{version}
  155. Obsoletes: qt5-qtattributionsscanner < 5.8.0
  156. Requires: qt5-qtattributionsscanner = %{version}
  157. %description -n qt5-doctools
  158. %{summary}.
  159. %if 0%{?docs}
  160. %package doc
  161. Summary: API documentation for %{name}
  162. Group: documentation
  163. BuildRequires: qt5-qdoc
  164. BuildRequires: qt5-qhelpgenerator
  165. BuildArch: noarch
  166. Conflicts: qt5-qtbase-doc < 5.6.0
  167. %description doc
  168. %{summary}.
  169. %endif
  170. %package examples
  171. Summary: Programming examples for %{name}
  172. Group: programming
  173. Requires: %{name}-common = %{version}-%{release}
  174. %description examples
  175. %{summary}.
  176. %debug_package
  177. %prep
  178. %setup -q -n %{qt_module}-everywhere-src-%{version}
  179. %patch2 -p1 -b .runqttools-with-qt5-suffix.patch
  180. #patch4 -p1 -b .libatomic
  181. %patch5 -p1 -b .libclang-cpp
  182. %build
  183. mkdir %{_target_platform}
  184. pushd %{_target_platform}
  185. %{qmake_qt5} %{?no_examples} ..
  186. make %{?_smp_mflags}
  187. %if 0%{?docs}
  188. make %{?_smp_mflags} docs
  189. %endif
  190. popd
  191. %install
  192. rm -rf %{buildroot}
  193. make install INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  194. %if 0%{?docs}
  195. make install_docs INSTALL_ROOT=%{buildroot} -C %{_target_platform}
  196. %endif
  197. # Add desktop files, --vendor=qt4 helps avoid possible conflicts with qt3/qt4
  198. desktop-file-install \
  199. --dir=%{buildroot}%{_datadir}/applications \
  200. --vendor="qt5" \
  201. %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23}
  202. # icons
  203. install -m644 -p -D src/assistant/assistant/images/assistant.png %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/assistant-qt5.png
  204. install -m644 -p -D src/assistant/assistant/images/assistant-128.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/assistant-qt5.png
  205. install -m644 -p -D src/designer/src/designer/images/designer.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/designer-qt5.png
  206. install -m644 -p -D src/qdbus/qdbusviewer/images/qdbusviewer.png %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/qdbusviewer-qt5.png
  207. install -m644 -p -D src/qdbus/qdbusviewer/images/qdbusviewer-128.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/qdbusviewer-qt5.png
  208. # linguist icons
  209. for icon in src/linguist/linguist/images/icons/linguist-*-32.png ; do
  210. size=$(echo $(basename ${icon}) | cut -d- -f2)
  211. install -p -m644 -D ${icon} %{buildroot}%{_datadir}/icons/hicolor/${size}x${size}/apps/linguist-qt5.png
  212. done
  213. # hardlink files to %{_bindir}, add -qt5 postfix to not conflict
  214. mkdir %{buildroot}%{_bindir}
  215. pushd %{buildroot}%{_qt5_bindir}
  216. for i in * ; do
  217. case "${i}" in
  218. assistant|designer|lconvert|linguist|lrelease|lupdate|pixeltool|qcollectiongenerator|qdbus|qdbusviewer|qhelpconverter|qhelpgenerator|qtplugininfo|qtattributionsscanner)
  219. ln -v ${i} %{buildroot}%{_bindir}/${i}-qt5
  220. ln -sv ${i} ${i}-qt5
  221. ;;
  222. *)
  223. ln -v ${i} %{buildroot}%{_bindir}/${i}
  224. ;;
  225. esac
  226. done
  227. popd
  228. ## .prl/.la file love
  229. # nuke .prl reference(s) to %%buildroot, excessive (.la-like) libs
  230. pushd %{buildroot}%{_qt5_libdir}
  231. for prl_file in libQt5*.prl ; do
  232. sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" ${prl_file}
  233. if [ -f "$(basename ${prl_file} .prl).so" ]; then
  234. rm -fv "$(basename ${prl_file} .prl).la"
  235. sed -i -e "/^QMAKE_PRL_LIBS/d" ${prl_file}
  236. fi
  237. done
  238. popd
  239. ## Qt5Designer.pc references non-existent Qt5UiPlugin.pc, remove the reference for now
  240. sed -i -e 's| Qt5UiPlugin||g' %{buildroot}%{_qt5_libdir}/pkgconfig/Qt5Designer.pc
  241. ## work-in-progress... -- rex
  242. %check
  243. # verify validity of Qt5Designer.pc
  244. export PKG_CONFIG_PATH=%{buildroot}%{_libdir}/pkgconfig
  245. pkg-config --print-requires --print-requires-private Qt5Designer
  246. export CMAKE_PREFIX_PATH=%{buildroot}%{_qt5_prefix}:%{buildroot}%{_prefix}
  247. export PATH=%{buildroot}%{_qt5_bindir}:%{_qt5_bindir}:$PATH
  248. export LD_LIBRARY_PATH=%{buildroot}%{_qt5_libdir}
  249. mkdir -p tests/auto/cmake/%{_target_platform}
  250. pushd tests/auto/cmake/%{_target_platform}
  251. cmake ..
  252. ctest --output-on-failure ||:
  253. popd
  254. # check icon resolutions
  255. pushd %{buildroot}%{_datadir}/icons
  256. for RES in $(ls hicolor); do
  257. for APP in designer assistant linguist qdbusviewer; do
  258. if [ -e hicolor/$RES/apps/${APP}*.* ]; then
  259. file hicolor/$RES/apps/${APP}*.* | grep "$(echo $RES | sed 's/x/ x /')"
  260. fi
  261. done
  262. done
  263. popd
  264. %files
  265. %{_bindir}/qdbus-qt5
  266. %{_bindir}/qtpaths
  267. %{_qt5_bindir}/qdbus
  268. %{_qt5_bindir}/qdbus-qt5
  269. %{_qt5_bindir}/qtpaths
  270. %files common
  271. %license LICENSE.LGPL*
  272. %files libs-designer
  273. %{_qt5_libdir}/libQt5Designer.so.5*
  274. %dir %{_qt5_libdir}/cmake/Qt5Designer/
  275. %files libs-designercomponents
  276. %{_qt5_libdir}/libQt5DesignerComponents.so.5*
  277. %files libs-help
  278. %{_qt5_libdir}/libQt5Help.so.5*
  279. %files -n qt5-assistant
  280. %{_bindir}/assistant-qt5
  281. %{_qt5_bindir}/assistant*
  282. %{_datadir}/applications/*assistant.desktop
  283. %{_datadir}/icons/hicolor/*/apps/assistant*.*
  284. %files -n qt5-doctools
  285. %{_bindir}/qdoc*
  286. %{_qt5_bindir}/qdoc*
  287. %{_bindir}/qdistancefieldgenerator*
  288. %{_bindir}/qhelpgenerator*
  289. %{_qt5_bindir}/qdistancefieldgenerator*
  290. %{_qt5_bindir}/qhelpgenerator*
  291. %{_bindir}/qtattributionsscanner-qt5
  292. %{_qt5_bindir}/qtattributionsscanner*
  293. %files -n qt5-designer
  294. %{_bindir}/designer*
  295. %{_qt5_bindir}/designer*
  296. %{_datadir}/applications/*designer.desktop
  297. %{_datadir}/icons/hicolor/*/apps/designer*.*
  298. %{_qt5_libdir}/cmake/Qt5DesignerComponents/Qt5DesignerComponentsConfig*.cmake
  299. %if 0%{?webkit}
  300. %files -n qt5-designer-plugin-webkit
  301. %{_qt5_plugindir}/designer/libqwebview.so
  302. %{_qt5_libdir}/cmake/Qt5Designer/Qt5Designer_QWebViewPlugin.cmake
  303. %endif
  304. %files -n qt5-linguist
  305. %{_bindir}/linguist*
  306. %{_qt5_bindir}/linguist*
  307. # phrasebooks used by linguist
  308. %{_qt5_datadir}/phrasebooks/
  309. %{_datadir}/applications/*linguist.desktop
  310. %{_datadir}/icons/hicolor/*/apps/linguist*.*
  311. # linguist friends
  312. %{_bindir}/lconvert*
  313. %{_bindir}/lrelease*
  314. %{_bindir}/lupdate*
  315. %{_bindir}/lprodump*
  316. %{_qt5_bindir}/lconvert*
  317. %{_qt5_bindir}/lrelease*
  318. %{_qt5_bindir}/lupdate*
  319. %{_qt5_bindir}/lprodump*
  320. # cmake config
  321. %dir %{_qt5_libdir}/cmake/Qt5LinguistTools/
  322. %{_qt5_libdir}/cmake/Qt5LinguistTools/Qt5LinguistToolsConfig*.cmake
  323. %{_qt5_libdir}/cmake/Qt5LinguistTools/Qt5LinguistToolsMacros.cmake
  324. %files -n qt5-qdbusviewer
  325. %{_bindir}/qdbusviewer*
  326. %{_qt5_bindir}/qdbusviewer*
  327. %{_datadir}/applications/*qdbusviewer.desktop
  328. %{_datadir}/icons/hicolor/*/apps/qdbusviewer*.*
  329. %files devel
  330. %{_bindir}/pixeltool*
  331. %{_bindir}/qcollectiongenerator*
  332. #{_bindir}/qhelpconverter*
  333. %{_bindir}/qtdiag*
  334. %{_bindir}/qtplugininfo*
  335. %{_qt5_bindir}/pixeltool*
  336. %{_qt5_bindir}/qtdiag*
  337. %{_qt5_bindir}/qcollectiongenerator*
  338. #{_qt5_bindir}/qhelpconverter*
  339. %{_qt5_bindir}/qtplugininfo*
  340. %{_qt5_headerdir}/QtDesigner/
  341. %{_qt5_headerdir}/QtDesignerComponents/
  342. %{_qt5_headerdir}/QtHelp/
  343. %{_qt5_headerdir}/QtUiPlugin
  344. %{_qt5_libdir}/libQt5Designer*.prl
  345. %{_qt5_libdir}/libQt5Designer*.so
  346. %{_qt5_libdir}/libQt5Help.prl
  347. %{_qt5_libdir}/libQt5Help.so
  348. %{_qt5_libdir}/Qt5UiPlugin.la
  349. %{_qt5_libdir}/libQt5UiPlugin.prl
  350. %{_qt5_libdir}/cmake/Qt5Designer/Qt5DesignerConfig*.cmake
  351. %dir %{_qt5_libdir}/cmake/Qt5Help/
  352. %{_qt5_libdir}/cmake/Qt5Help/Qt5HelpConfig*.cmake
  353. %{_qt5_libdir}/cmake/Qt5UiPlugin/
  354. %{_qt5_libdir}/pkgconfig/Qt5Designer.pc
  355. %{_qt5_libdir}/pkgconfig/Qt5Help.pc
  356. %{_qt5_libdir}/pkgconfig/Qt5UiPlugin.pc
  357. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_designer.pri
  358. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_designer_private.pri
  359. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_designercomponents_private.pri
  360. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_help.pri
  361. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_help_private.pri
  362. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_uiplugin.pri
  363. %{_qt5_libdir}/cmake/Qt5AttributionsScannerTools/
  364. %{_qt5_libdir}/cmake/Qt5DocTools/
  365. %files static
  366. %{_qt5_headerdir}/QtUiTools/
  367. %{_qt5_libdir}/libQt5UiTools.*a
  368. %{_qt5_libdir}/libQt5UiTools.prl
  369. %{_qt5_libdir}/cmake/Qt5UiTools/
  370. %{_qt5_libdir}/pkgconfig/Qt5UiTools.pc
  371. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_uitools.pri
  372. %{_qt5_archdatadir}/mkspecs/modules/qt_lib_uitools_private.pri
  373. %if 0%{?docs}
  374. %files doc
  375. %license LICENSE.FDL
  376. %{_qt5_docdir}/qtassistant.qch
  377. %{_qt5_docdir}/qtassistant/
  378. %{_qt5_docdir}/qtdesigner.qch
  379. %{_qt5_docdir}/qtdesigner/
  380. %{_qt5_docdir}/qdoc.qch
  381. %{_qt5_docdir}/qdoc/
  382. %{_qt5_docdir}/qthelp.qch
  383. %{_qt5_docdir}/qthelp/
  384. %{_qt5_docdir}/qtlinguist.qch
  385. %{_qt5_docdir}/qtlinguist/
  386. %{_qt5_docdir}/qtuitools.qch
  387. %{_qt5_docdir}/qtuitools/
  388. %endif
  389. %if ! 0%{?bootstrap}
  390. %files examples
  391. %{_qt5_examplesdir}/
  392. %{_qt5_plugindir}/designer/*
  393. %dir %{_qt5_libdir}/cmake/Qt5Designer
  394. %{_qt5_libdir}/cmake/Qt5Designer/Qt5Designer_*
  395. %endif
  396. %changelog
  397. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.8-1
  398. - new upstream release.
  399. - dropped scriptlets.
  400. - dropped Patch2.
  401. - imported Patch2-5 from rawhide.
  402. * Mon Mar 23 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.7-1
  403. - new upstream release.
  404. * Sun Oct 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.12.5-1
  405. - new upstream release.
  406. - dropped Patch1.
  407. * Tue Jan 09 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.3-1
  408. - new upstream release.
  409. * Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 5.6.1.1-1
  410. - new upstream release.
  411. - initial build for Vine Linux.
  412. * Fri Jun 10 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.1-2
  413. - drop BR: double-conversion (fix qtdeclarative instead)
  414. * Thu Jun 09 2016 Jan Grulich <jgrulich@redhat.com> - 5.6.1-1
  415. - Update to 5.6.1
  416. * Sun Mar 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-3
  417. - rebuild
  418. * Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-2
  419. - rebuild
  420. * Wed Mar 16 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-2
  421. - 5.6.0 final release
  422. * Mon Mar 14 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-1
  423. - 5.6.0 final release
  424. * Tue Feb 23 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.12.rc
  425. - Update to final RC
  426. * Fri Feb 19 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.11.rc
  427. - workaround Qt5Designer.pc reference to non-existent Qt5UiPlugin.pc
  428. * Mon Feb 15 2016 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.10
  429. - Update RC release
  430. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.6.0-0.9.rc
  431. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  432. * Sun Jan 17 2016 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.8.rc
  433. - port QTBUG-43057 workaround
  434. * Mon Dec 28 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.7.rc
  435. - update source URL, use %%license
  436. * Mon Dec 21 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.6
  437. - Update to final rc release
  438. * Fri Dec 11 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.6.0-0.5
  439. - (re)fix bootstrap macro
  440. - include qt5-qdoc/qt5-qhelpgenerator build dep deps in -doc subpkg only
  441. - fix whitespace
  442. * Thu Dec 10 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.4
  443. - Official rc release
  444. * Tue Dec 08 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-3
  445. - Reenable examples. Some interfaces marked as examples are needed from phonon
  446. - Update to second rc snapshot
  447. * Sun Dec 06 2015 Rex Dieter <rdieter@fedoraproject.org> 5.6.0-0.2
  448. - de-bootstrap
  449. * Tue Nov 03 2015 Helio Chissini de Castro <helio@kde.org> - 5.6.0-0.1
  450. - Start to implement 5.6.0 rc, bootstrapped
  451. * Thu Oct 15 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-2
  452. - Update to final release 5.5.1
  453. * Tue Sep 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.1-1
  454. - Update to Qt 5.5.1 RC1
  455. * Sat Aug 08 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-4
  456. - qt5-linguist: move lconvert,lrelease,lupdate, cmake Qt5LinguistTools here
  457. * Wed Jul 29 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-3
  458. - de-bootstrap
  459. * Thu Jul 16 2015 Rex Dieter <rdieter@fedoraproject.org> 5.5.0-2
  460. - qt5-designer, qt5-linguist, qt5-qhelpgenerator subpkgs
  461. * Wed Jul 1 2015 Helio Chissini de Castro <helio@kde.org> 5.5.0-1
  462. - New final upstream release Qt 5.5.0
  463. * Mon Jun 29 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.4.rc
  464. - Second round of builds now with bootstrap enabled due new qttools
  465. * Sat Jun 27 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.3.rc
  466. - Disable bootstrap
  467. * Thu Jun 25 2015 Helio Chissini de Castro <helio@kde.org> - 5.5.0-0.2.rc
  468. - Update for official RC1 released packages
  469. * Mon Jun 15 2015 Daniel Vrátil <dvratil@redhat.com> - 5.5.0-0.1.rc
  470. - Qt 5.5.0 RC1
  471. * Wed Jun 03 2015 Jan Grulich <jgrulich@redhat.com> - 5.4.2-1
  472. - 5.4.2
  473. * Sat May 02 2015 Rex Dieter <rdieter@fedoraproject.org> 5.4.1-3
  474. - rebuild (gcc5)
  475. * Fri Feb 27 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.1-2
  476. - rebuild (gcc5)
  477. * Tue Feb 24 2015 Jan Grulich <jgrulich@redhat.com> 5.4.1-1
  478. - 5.4.1
  479. * Thu Feb 19 2015 Rex Dieter <rdieter@fedoraproject.org> - 5.4.0-2
  480. - rebuild (gcc5)
  481. * Wed Dec 10 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-1
  482. - 5.4.0 (final)
  483. * Tue Dec 09 2014 Daniel Vrátil <dvratil@redhat.com> 5.4.0-0.10.rc
  484. - fix icon name in qdbusviewer-qt5.desktop
  485. * Sun Nov 30 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.4.0-0.9.rc
  486. - install Linguist icon as linguist-qt5.png, fixes file conflict (#1169127)
  487. * Fri Nov 28 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.8.rc
  488. - 5.4.0-rc
  489. * Mon Nov 03 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.7.rc
  490. - out-of-tree build, use %%qmake_qt5
  491. * Fri Oct 31 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.6.rc
  492. - respin system-clucene.patch
  493. * Sun Oct 26 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.4.0-0.5.rc
  494. - system-clucene patch: create path recursively in QtCLucene, CLucene can't
  495. * Sun Oct 26 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.4.0-0.4.rc
  496. - disable bootstrap (reenable -doc)
  497. - system-clucene patch: drop -fpermissive flag
  498. - system-clucene patch: use toLocal8Bit instead of toStdString
  499. - system_clucene: BR clucene09-core-devel >= 0.9.21b-12 (-11 was broken)
  500. * Sat Oct 25 2014 Rex Dieter <rdieter@fedoraproject.org> - 5.4.0-0.3.rc
  501. - libQt5Designer should be in a subpackage (#1156685)
  502. - -doc: disable(boostrap for new clucene), drop dep on main pkg
  503. * Sat Oct 25 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.4.0-0.2.rc
  504. - BR and rebuild against reference-counting-enabled clucene09 (#1128293)
  505. * Sat Oct 18 2014 Rex Dieter <rdieter@fedoraproject.org> 5.4.0-0.1.rc
  506. - 5.4.0-rc
  507. * Fri Oct 17 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-2
  508. - -devel: Requires: qt5-designer-plugin-webkit
  509. * Tue Sep 16 2014 Rex Dieter <rdieter@fedoraproject.org> 5.3.2-1
  510. - 5.3.2
  511. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.1-2
  512. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  513. * Tue Jun 17 2014 Jan Grulich <jgrulich@redhat.com> - 5.3.1-1
  514. - 5.3.1
  515. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.0-3
  516. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  517. * Thu May 29 2014 Kevin Kofler <Kevin@tigcc.ticalc.org> 5.3.0-2
  518. - restore system-clucene patch, rm the bundled copy
  519. * Wed May 21 2014 Jan Grulich <jgrulich@redhat.com> 5.3.0-1
  520. - 5.3.0
  521. * Wed Feb 05 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.1-1
  522. - 5.2.1
  523. * Mon Jan 27 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-3
  524. - -examples subpkg
  525. * Tue Jan 14 2014 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-2
  526. - epel7 bootstrapped
  527. * Thu Dec 12 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-1
  528. - 5.2.0
  529. * Mon Dec 02 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.10.rc1
  530. - 5.2.0-rc1
  531. * Mon Nov 25 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.5.rc1
  532. - enable -doc only on primary archs (allow secondary bootstrap)
  533. * Sat Nov 09 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.4.rc1
  534. - rebuild (arm/qreal)
  535. * Thu Oct 24 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.3.rc1
  536. - 5.2.0-rc1
  537. * Wed Oct 16 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.2.alpha
  538. - bootstrap ppc
  539. * Tue Oct 01 2013 Rex Dieter <rdieter@fedoraproject.org> 5.2.0-0.1.alpha
  540. - 5.2.0-alpha
  541. - -doc subpkg
  542. * Sat Sep 21 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-6
  543. - lupdate can't find qmake configuration file default (#1009893)
  544. * Sat Sep 21 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-4
  545. - use upstream cmake fix(es) (QTBUG-32570, #1006254)
  546. * Wed Sep 11 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-3
  547. - wrong path to lrelease (#1006254)
  548. - %%check: first try
  549. * Tue Sep 10 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-2
  550. - ExclusiveArch: %{ix86} x86_64 %{arm}
  551. - epel-6 love
  552. * Wed Aug 28 2013 Rex Dieter <rdieter@fedoraproject.org> 5.1.1-1
  553. - qttools-5.1.1
  554. - qt5-assistant, qt5-qdbusviewer, qt5-designer-plugin-webkit subpkgs (to match qt4)
  555. * Mon Aug 19 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-4
  556. - use system clucene09-core
  557. * Mon Apr 29 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-3
  558. - drop deprecated Encoding= key from .desktop files
  559. - add justification for desktop vendor usage
  560. * Fri Apr 19 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-2
  561. - add .desktop/icons for assistant, designer, linguist, qdbusviewer
  562. * Thu Apr 11 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.2-1
  563. - 5.0.2
  564. * Mon Feb 25 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.1-2
  565. - BR: pkgconfig(zlib)
  566. - -static subpkg
  567. * Sat Feb 23 2013 Rex Dieter <rdieter@fedoraproject.org> 5.0.1-1
  568. - first try