nginx-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. # build http_geoip_module
  4. %if "%{_dist_release}" >= "vl7"
  5. %bcond_without geoip
  6. %else
  7. %bcond_with geoip
  8. %endif
  9. %if "%{_dist_release}" > "vl6"
  10. %define nginx_user www-data
  11. %else
  12. %define nginx_user nginx
  13. %endif
  14. %define nginx_group %{nginx_user}
  15. %define nginx_home %{_localstatedir}/lib/nginx
  16. %define nginx_home_tmp %{nginx_home}/tmp
  17. %define nginx_home_cache %{nginx_home}/cache
  18. %define nginx_logdir %{_localstatedir}/log/nginx
  19. %define nginx_confdir %{_sysconfdir}/nginx
  20. %define nginx_datadir %{_datadir}/nginx
  21. %define nginx_webroot %{nginx_datadir}/html
  22. Summary: Robust, small and high performance http and reverse proxy server
  23. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  24. Name: nginx
  25. Version: 1.5.10
  26. Release: 2%{?_dist_release}
  27. Group: System Environment/Daemons
  28. # BSD License (two clause)
  29. # http://www.freebsd.org/copyright/freebsd-license.html
  30. License: BSD
  31. URL: http://nginx.net/
  32. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  33. Source1: %{name}.init
  34. Source2: %{name}.logrotate
  35. Source3: nginx-virtual.conf.template
  36. Source4: nginx-ssl.conf
  37. Source5: %{name}.sysconfig
  38. Source10: nginx-vine.conf
  39. Source11: nginx-default-vine
  40. Source20: proxy_cache.conf
  41. Source100: nginx-index.html
  42. Source101: poweredby-vine.png
  43. Source102: nginx-logo.png
  44. Source103: nginx-50x.html
  45. Source104: nginx-404.html
  46. %define ngx_fancyindex_version 0.3.3
  47. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.xz
  48. %define nginx_accept_language_module_version 02262ce
  49. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  50. %define passenger_version 4.0.37
  51. Source1020: passenger-%{passenger_version}.tar.gz
  52. %define upstream_fair_version 2131c73
  53. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  54. %define mod_wsgi_version 6975f0ec7eeb
  55. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  56. # removes -Werror in upstream build scripts. -Werror conflicts with
  57. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  58. Patch0: nginx-auto-cc-gcc.patch
  59. # to fix https://svn.boost.org/trac/boost/ticket/8731
  60. Patch100: boost-changeset_84950.diff
  61. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  62. BuildRequires: pcre-devel
  63. BuildRequires: zlib-devel
  64. BuildRequires: openssl-devel
  65. BuildRequires: gd-devel
  66. BuildRequires: perl
  67. BuildRequires: perl(ExtUtils::Embed)
  68. BuildRequires: libxml2-devel
  69. BuildRequires: libxslt-devel
  70. BuildRequires: curl-devel
  71. %if %{with geoip}
  72. BuildRequires: GeoIP-devel
  73. %endif
  74. %if "%{?_dist_release}" == "vl4"
  75. Requires: perl >= 5.8.6
  76. %else
  77. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  78. %endif
  79. # for /usr/sbin/useradd
  80. Requires(pre): shadow-utils
  81. Requires(post): chkconfig
  82. # for /sbin/service
  83. Requires(preun): chkconfig, initscripts
  84. Requires(postun): initscripts
  85. %if "%{_dist_release}" > "vl6"
  86. Requires(pre): www-common
  87. %endif
  88. Provides: webserver
  89. Vendor: Project Vine
  90. Distribution: Vine Linux
  91. Packager: daisuke
  92. %description
  93. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  94. proxy server written by Igor Sysoev.
  95. %description -l ja
  96. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  97. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  98. - HTTP(S) サーバ
  99. - HTTP(S) リバースプロキシサーバ
  100. - IMAP/POP3 プロキシサーバ
  101. %package passenger
  102. Summary: Nginx with mod_passenger support
  103. Summary(ja): Passenger サポート入りの Nginx
  104. Group: System Environment/Daemons
  105. BuildRequires: ruby, rubygem-rake
  106. Requires: ruby, rubygem-rake
  107. %if "%{_dist_release}" >= "vl7"
  108. BuildRequires: ruby-devel, ruby-rubygems
  109. Requires: ruby-rubygems
  110. %else
  111. BuildRequires: rubygems
  112. Requires: rubygems
  113. %endif
  114. Requires: nginx
  115. %description passenger
  116. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  117. This package contains nginx server with passenger support.
  118. %description -l ja passenger
  119. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  120. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  121. - HTTP(S) サーバ
  122. - HTTP(S) リバースプロキシサーバ
  123. - IMAP/POP3 プロキシサーバ
  124. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  125. %prep
  126. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000}
  127. %patch0 -p0
  128. pushd passenger-%{passenger_version}/ext/
  129. %patch100 -p2
  130. popd
  131. %build
  132. # nginx does not utilize a standard configure script. It has its own
  133. # and the standard configure options cause the nginx configure script
  134. # to error out. This is is also the reason for the DESTDIR environment
  135. # variable. The configure script(s) have been patched (Patch1 and
  136. # Patch2) in order to support installing into a build environment.
  137. export DESTDIR=%{buildroot}
  138. CONFIGOPTS="\
  139. --user=%{nginx_user} \
  140. --group=%{nginx_group} \
  141. --prefix=%{nginx_datadir} \
  142. --sbin-path=%{_sbindir}/%{name} \
  143. --conf-path=%{nginx_confdir}/%{name}.conf \
  144. --error-log-path=%{nginx_logdir}/error.log \
  145. --http-log-path=%{nginx_logdir}/access.log \
  146. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  147. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  148. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  149. --pid-path=%{_localstatedir}/run/%{name}.pid \
  150. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  151. --with-file-aio \
  152. --with-ipv6 \
  153. --with-http_ssl_module \
  154. --with-http_spdy_module \
  155. --with-http_realip_module \
  156. --with-http_addition_module \
  157. --with-http_xslt_module \
  158. --with-http_image_filter_module \
  159. %if %{with geoip}
  160. --with-http_geoip_module \
  161. %endif
  162. --with-http_sub_module \
  163. --with-http_dav_module \
  164. --with-http_flv_module \
  165. --with-http_mp4_module \
  166. --with-http_gunzip_module \
  167. --with-http_gzip_static_module \
  168. --with-http_auth_request_module \
  169. --with-http_random_index_module \
  170. --with-http_secure_link_module \
  171. --with-http_degradation_module \
  172. --with-http_stub_status_module \
  173. --with-http_perl_module \
  174. --with-mail \
  175. --with-mail_ssl_module \
  176. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  177. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  178. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  179. %if %{with wsgi}
  180. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  181. %endif
  182. %ifarch i686
  183. --with-cpu-opt=pentiumpro \
  184. --with-zlib-asm=pentiumpro \
  185. --with-md5-asm \
  186. --with-sha1-asm \
  187. %endif
  188. "
  189. ## build with passenger
  190. ./configure \
  191. $CONFIGOPTS \
  192. --with-cc-opt="%{optflags}" \
  193. --add-module=passenger-%{passenger_version}/ext/nginx
  194. make %{?_smp_mflags}
  195. mv objs/nginx objs/nginx.passenger
  196. ## build without passenger
  197. ./configure \
  198. $CONFIGOPTS \
  199. --with-cc-opt="%{optflags}"
  200. make %{?_smp_mflags}
  201. %install
  202. rm -rf %{buildroot}
  203. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  204. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  205. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  206. find %{buildroot} -type f -empty -exec rm -f {} \;
  207. find %{buildroot} -type f -exec chmod 0644 {} \;
  208. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  209. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  210. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  211. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  212. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  213. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  214. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  215. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  216. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  217. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  218. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  219. %{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
  220. %{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
  221. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  222. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  223. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  224. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  225. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  226. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  227. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  228. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  229. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  230. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  231. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  232. %if %{with wsgi}
  233. %{__install} -p -m 0644 \
  234. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  235. %{buildroot}%{nginx_confdir}
  236. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  237. %endif
  238. # upstream fair module document
  239. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  240. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  241. # convert to UTF-8 all files that give warnings.
  242. for textfile in CHANGES
  243. do
  244. mv $textfile $textfile.old
  245. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  246. rm -f $textfile.old
  247. done
  248. %clean
  249. rm -rf %{buildroot}
  250. %post
  251. if [ $1 == 1 ]; then
  252. /sbin/chkconfig --add %{name}
  253. fi
  254. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  255. %post passenger
  256. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  257. %preun
  258. if [ $1 = 0 ]; then
  259. /sbin/service %{name} stop >/dev/null 2>&1
  260. /sbin/chkconfig --del %{name}
  261. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  262. fi
  263. %preun passenger
  264. if [ $1 = 0 ]; then
  265. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  266. fi
  267. %postun
  268. if [ $1 == 2 ]; then
  269. /sbin/service %{name} upgrade || :
  270. fi
  271. %files
  272. %defattr(-,root,root,-)
  273. %doc LICENSE CHANGES README
  274. %doc README.upstream_fair
  275. %doc %{?with_wsgi:README.mod_wsgi}
  276. %{nginx_datadir}/
  277. %{_sbindir}/%{name}.normal
  278. %{_mandir}/man3/%{name}.3pm.gz
  279. %{_initrddir}/%{name}
  280. %dir %{nginx_confdir}
  281. %dir %{nginx_confdir}/conf.d
  282. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  283. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  284. %config(noreplace) %{nginx_confdir}/sites.d/*
  285. %config(noreplace) %{nginx_confdir}/win-utf
  286. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  287. %config(noreplace) %{nginx_confdir}/mime.types.default
  288. %config(noreplace) %{nginx_confdir}/fastcgi_params
  289. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  290. %config(noreplace) %{nginx_confdir}/koi-win
  291. %config(noreplace) %{nginx_confdir}/koi-utf
  292. %config(noreplace) %{nginx_confdir}/%{name}.conf
  293. %config(noreplace) %{nginx_confdir}/mime.types
  294. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  295. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  296. %config(noreplace) %{nginx_confdir}/scgi_params
  297. %config(noreplace) %{nginx_confdir}/scgi_params.default
  298. %config(noreplace) %{nginx_confdir}/uwsgi_params
  299. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  300. %if %{with wsgi}
  301. %config(noreplace) %{nginx_confdir}/wsgi_vars
  302. %endif
  303. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  304. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  305. %dir %{perl_vendorarch}/auto/%{name}
  306. %{perl_vendorarch}/%{name}.pm
  307. %{perl_vendorarch}/auto/%{name}/%{name}.so
  308. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  309. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  310. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  311. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  312. %files passenger
  313. %defattr(-,root,root,-)
  314. %doc passenger-%{passenger_version}/doc/*.txt
  315. %doc passenger-%{passenger_version}/doc/*.html
  316. %doc passenger-%{passenger_version}/doc/template
  317. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  318. %doc passenger-%{passenger_version}/doc/images
  319. %{_sbindir}/%{name}.passenger
  320. %changelog
  321. * Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
  322. - update fancyindex to 0.3.3
  323. * Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
  324. - update to 1.5.10
  325. - update passenger to 4.0.37
  326. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
  327. - rebuilt with GeoIP-1.6.0.
  328. - added Patch100.
  329. * Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
  330. - update to 1.5.6
  331. - update passenger to 4.0.21
  332. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
  333. - rebuilt with gd-2.1.0.
  334. * Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
  335. - update to 1.4.1
  336. * Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
  337. - update to 1.4.0
  338. - enable SPDY module
  339. * Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
  340. - new upstream release
  341. - update passenger to 3.0.19
  342. - update ngx-fancyindex to upstream git master
  343. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
  344. - new upstream release
  345. - update passenger to 3.0.17
  346. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
  347. - rebuild with pcre-8.31
  348. * Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
  349. - added http_geoip_module.
  350. * Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
  351. - update to 1.2.4
  352. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
  353. - update to 1.2.2
  354. * Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  355. - update to 1.2.1
  356. - change nginx user from nginx to www-data
  357. - R(pre): www-common
  358. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  359. - update to 1.2.0
  360. - update passenger to 3.0.12
  361. - drop http_upstream_keepalive
  362. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  363. - new upstream release
  364. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  365. - update to 1.0.12
  366. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  367. - update to 1.0.11
  368. - update passenger to 3.0.11
  369. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  370. - update to 1.0.10
  371. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  372. - update passenger to 3.0.9
  373. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  374. - update to 1.0.6
  375. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  376. - update to 1.0.4
  377. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  378. - add gnosek-nginx-upstream-fair module
  379. - add ngx_http_upstream_keepalive module
  380. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  381. - add nginx-passenger sub pakckage
  382. - use alternatives to choose nginx with or without passenger
  383. - add BR: ruby, rubygems, rubygem-rake
  384. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  385. - update to 1.0.2
  386. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  387. - update to 1.0.1
  388. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  389. - add bcond_with wsgi for mod_wsgi
  390. - add bcond_with passenger
  391. - you need to install rake.gem to build with this option.
  392. - add Provides: webserver
  393. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  394. - new upstream release 1.0.0!
  395. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  396. - rebuild with perl-5.12.3
  397. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  398. - update to 0.8.54
  399. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  400. - update to 0.8.53
  401. - add nginx_accept_language_module
  402. * Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  403. - update to 0.8.50
  404. - update ngx-fancyindex to 0.3
  405. - add BR: libxml2-devel, libxslt-devel
  406. - add scgi_params* and uwsgi_params* to %%files
  407. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  408. - update to 0.8.35 (development version)
  409. - add sites.d/ to store vitualhost settings
  410. - split out default server settings to sites.d/default
  411. - add fancyindex module
  412. * Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  413. - new upstream release
  414. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  415. - update to 0.7.62 (included security fix: VU#180065)
  416. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  417. - fix typo
  418. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  419. - add translated descriptions
  420. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  421. - update 404.html/50x.html to use powered by vine logo.
  422. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  423. - initial build for Vine Linux
  424. - update to 0.7.61
  425. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  426. - init script updates from Gena Makhomed
  427. - remove nginx-upstream-fair
  428. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  429. - update to 0.6.36
  430. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  431. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  432. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  433. - rebuild
  434. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  435. - update to 0.6.35
  436. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  437. - rebuild with new openssl
  438. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  439. - update to 0.6.34
  440. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  441. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  442. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  443. - update to 0.6.33
  444. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  445. - update to 0.6.32
  446. - nginx now supports DESTDIR so removed the patches that enabled it
  447. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  448. - init script fixes
  449. - resolve 'listen 80 default' [#447873]
  450. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  451. - update to 0.6.31
  452. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  453. - upate to new upstream stable branch 0.6
  454. - added 3rd party module nginx-upstream-fair
  455. - added default webpages
  456. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  457. - update init script to match recommended guidelines
  458. - add /etc/nginx/conf.d support [#443280]
  459. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  460. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  461. - add Requires for versioned perl (libperl.so)
  462. - drop silly file Requires
  463. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  464. - Autorebuild for GCC 4.3
  465. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  466. - update to 0.5.35
  467. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  468. - update to 0.5.34
  469. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  470. - Rebuild for deps
  471. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  472. - update to 0.5.33
  473. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  474. - updated to 0.5.32
  475. - fixed rpmlint UTF-8 complaints.
  476. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  477. - added --with-http_stub_status_module build option.
  478. - added --with-http_sub_module build option.
  479. - added use of pcre-config --cflags
  480. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  481. - Update to 0.5.31
  482. - specify license is BSD
  483. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  484. - Add BuildRequires: perl-devel - fixing rawhide build
  485. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  486. - Update to 0.5.30
  487. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  488. - Update to 0.5.29
  489. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  490. - Update to 0.5.28
  491. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  492. - Update to 0.5.27
  493. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  494. - Update to 0.5.26
  495. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  496. - Update to 0.5.19
  497. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  498. - Update to 0.5.17
  499. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  500. - Update to 0.5.16
  501. - add ownership of /usr/share/nginx/html (#233950)
  502. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  503. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  504. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  505. - fixed package review bugs (#233522) given by kevin@tummy.com
  506. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  507. - create patches to assist with building for Fedora
  508. - initial packaging for Fedora