module-init-tools-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552
  1. Summary: Kernel module management utilities.
  2. Summary(ja): カーネルモジュール管理ユーティリティ
  3. Name: module-init-tools
  4. Version: 3.12
  5. Release: 2%{?_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Kernel
  8. Source: http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-%{version}.tar.bz2
  9. Source1: http://www.kernel.org/pub/linux/utils/kernel/module-init-tools/module-init-tools-%{version}.tar.bz2.sign
  10. Source2: modprobe-dist.conf
  11. Source3: weak-modules
  12. Source4: depmod-dist.conf
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: zlib-devel, docbook-utils
  15. BuildRequires: zlib-static
  16. BuildRequires: glibc-static
  17. Exclusiveos: Linux
  18. Requires(post): chkconfig, coreutils
  19. Obsoletes: modutils-devel, modutils
  20. Provides: modutils = %{version}
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. Packager: daisuke
  24. %description
  25. The module-init-tools package includes various programs needed for automatic
  26. loading and unloading of modules under 2.6 and later kernels, as well
  27. as other module management programs. Device drivers and filesystems
  28. are two examples of loaded and unloaded modules.
  29. %description -l ja
  30. module-init-tools パッケージには,バージョン 2.6 以上の kernel モジュールを
  31. 自動的にロード/アンロードする為の様々なプログラムや,モジュール管理の
  32. 為のプログラムなどが収められています.モジュールとしては,デバイスドライバ,
  33. ファイルシステム,その他が挙げられます.
  34. %prep
  35. %setup -q
  36. %build
  37. export CC=gcc
  38. export CFLAGS="$RPM_OPT_FLAGS -DCONFIG_NO_BACKWARDS_COMPAT=1"
  39. %configure --enable-zlib
  40. make
  41. %install
  42. rm -rf $RPM_BUILD_ROOT
  43. %makeinstall sbindir=$RPM_BUILD_ROOT/sbin
  44. install -m 755 generate-modprobe.conf \
  45. $RPM_BUILD_ROOT/sbin
  46. install -m 644 modprobe.conf.5 \
  47. $RPM_BUILD_ROOT/%{_mandir}/man5/modprobe.d.5
  48. install -m 644 depmod.conf.5 \
  49. $RPM_BUILD_ROOT/%{_mandir}/man5/depmod.d.5
  50. mkdir -p $RPM_BUILD_ROOT/etc
  51. mkdir -p $RPM_BUILD_ROOT/etc/modprobe.d
  52. install -m 644 %{SOURCE2} $RPM_BUILD_ROOT/etc/modprobe.d/modprobe-dist.conf
  53. install -m 755 %{SOURCE3} $RPM_BUILD_ROOT/sbin/weak-modules
  54. mkdir -p $RPM_BUILD_ROOT/etc/depmod.d
  55. install -m 644 %{SOURCE4} $RPM_BUILD_ROOT/etc/depmod.d/depmod-dist.conf
  56. mv $RPM_BUILD_ROOT/%{_bindir}/lsmod $RPM_BUILD_ROOT/sbin
  57. touch $RPM_BUILD_ROOT/etc/modprobe.d/modprobe.conf
  58. %clean
  59. rm -rf $RPM_BUILD_ROOT
  60. %post
  61. if [ -f /etc/modprobe.conf -a ! -f /etc/modprobe.d/modprobe.conf ] ; then
  62. mv -f /etc/modprobe.conf /etc/modprobe.d/modprobe.conf
  63. fi
  64. %files
  65. %defattr(-,root,root)
  66. /etc/modprobe.d
  67. /etc/depmod.d
  68. /sbin/*
  69. %{_mandir}/*/*
  70. %ghost %config(noreplace) %verify(not md5 size mtime) /etc/modprobe.d/modprobe.conf
  71. %changelog
  72. * Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12-2
  73. - add BR: glibc-static
  74. - add V/D/P tags
  75. * Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.12-1
  76. - new upstream release
  77. * Tue May 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-4
  78. - remove kernel 2.4 compatibility from %%post
  79. * Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-3
  80. - move /etc/modprobe.conf to /etc/modprobe.d/modprobe.conf
  81. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-2
  82. - rename /etc/modprobe.d/{depmod,modprobe}.conf.dist to
  83. {depmod,modprobe}-dist.conf
  84. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8-1
  85. - new upstream release
  86. - add BR: zlib-static
  87. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6-1
  88. - new upstream release
  89. - rename to module-init-tools
  90. - Provides: modutils, Obsoletes: modules, modutils-devel
  91. - drop modutils compatibility support
  92. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 3.2.2-1vl5
  93. - applied new versioning policy, spec in utf-8
  94. * Mon Oct 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl4
  95. - add Patch102 to build with gcc4
  96. - enable combined-rmmod for insmod.static (initramfs needs rmmod)
  97. * Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl3
  98. - update modprobe.conf.dist
  99. - load mmc_block when sdhci is loaded
  100. * Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl2
  101. - enable %%build_small
  102. - add modutils-devel subpackage for internal use.
  103. * Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2-0vl1
  104. - update module-init-tools-3.2.2
  105. - use module-init-tools version for package version
  106. - update modprobe.conf.dist, move to /etc/modprobe.d
  107. - remove "include" statement from /etc/modprobe.conf if found.
  108. * Thu May 6 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.27-0vl1
  109. - new upstream release
  110. - modutils-2.4.27
  111. - module-init-tools-3.0
  112. - import fedora fixes
  113. * Wed May 5 2004 Bill Nottingham <notting@redhat.com> 2.4.26-16
  114. - fix sound restoring on module load when done via OSS compat
  115. * Thu Apr 15 2004 Bill Nottingham <notting@redhat.com> 2.4.26-15
  116. - don't buildreq autoconf-2.13 (#116770)
  117. - sound-slot-0/snd-card-0 hacking-around
  118. * Mon Mar 29 2004 Bill Nottingham <notting@redhat.com> 2.4.26-14
  119. - modinfo: use new modinfo if passed <foo>.ko
  120. * Tue Mar 23 2004 Steve Dickson <SteveD@RedHat.com>
  121. - Added the mounting of /proc/fs/nfsd to modprobe.conf.dist
  122. so it gets mounted when nfsd is loaded.
  123. * Tue Mar 16 2004 Steve Dickson <SteveD@RedHat.com>
  124. - /var/lib/nfs/rpc_pipefs not /var/lib/rpc_pipes should be
  125. mounted when sunrpc is loaded.
  126. * Fri Mar 12 2004 Steve Dickson <SteveD@RedHat.com>
  127. - umount rpc_pipefs when sunrpc is unloaded
  128. * Thu Mar 11 2004 Bill Nottingham <notting@redhat.com> 2.4.26-9
  129. - add nfsv4 aliases to modprobe.conf.dist
  130. - clean out upstreamed aliases in modprobe.conf.dist
  131. - mount rpc_pipefs when sunrpc is loaded
  132. * Fri Mar 5 2004 Bill Nottingham <notting@redhat.com> 2.4.26-7
  133. - blacklist eth1394 (#117383)
  134. * Mon Feb 23 2004 Bill Nottingham <notting@redhat.com> 2.4.26-6
  135. - update module-init-tools to 3.0pre10
  136. - fix modinfo (#116305)
  137. - always include /etc/modprobe.conf.dist (don't require the line in modprobe.conf)
  138. - ship a static modprobe.conf.dist, don't generate it at build time
  139. - clean up modprobe.conf.dist a little (#113772, #113768)
  140. * Wed Feb 11 2004 Bill Nottingham <notting@redhat.com>
  141. - don't use trampolines in insmod, working around #106005
  142. * Thu Jan 29 2004 Bill Nottingham <notting@redhat.com> 2.4.26-3
  143. - fix irda (#114268), bluetooth (#114019) and alsa aliases
  144. * Wed Jan 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.4.26-2vl1
  145. - syncd with fedora
  146. * Fri Nov 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.26-0vl1
  147. - new upstream release
  148. * Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.25-0vl1
  149. - new upstream release
  150. * Tue Dec 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.22-0vl3
  151. - enable build with dietlibc also on ppc and alpha
  152. * Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.22-0vl2
  153. - enable zlib
  154. - remove pre-defined "above"s. it's not needed for Vine Linux.
  155. * Sun Dec 8 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.22-0vl1
  156. - new upstream release
  157. * Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.20-0vl1
  158. - new upstream release
  159. * Thu Jul 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.16-1vl2
  160. - BuildPreReq: dietlibc for ix86 only
  161. * Tue Jul 09 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.16-1vl1
  162. - new upstream release
  163. * Sun May 05 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.14-1vl2
  164. - rebuild with diet.
  165. - merged with Skipjack.
  166. * Mon Apr 1 2002 Bill Nottingham <notting@redhat.com> 2.4.14-2
  167. - fix support for symbols that contain _R (<streeter@redhat.com>)
  168. * Thu Mar 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.4.14-1vl1
  169. - source update
  170. * Sat Mar 2 2002 Bill Nottingham <notting@redhat.com> 2.4.14-1
  171. - update to 2.4.14
  172. - take out genksyms.old, no more buildprereq for gperf
  173. * Thu Feb 28 2002 Bill Nottingham <notting@redhat.com> 2.4.13-7/8
  174. - rebuild against diet
  175. - reenable rmmod in the library version, shrink it too
  176. * Wed Feb 27 2002 Bill Nottingham <notting@redhat.com> 2.4.13-5
  177. - rebuild in earlier environments
  178. * Fri Feb 22 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.4.13-4vl1
  179. - modified for Vine
  180. - merged devel-package with parent package
  181. * Sun Feb 10 2002 Bill Nottingham <notting@redhat.com> 2.4.13-4
  182. - various space shavings in -devel
  183. * Fri Feb 8 2002 Bill Nottingham <notting@redhat.com> 2.4.13-3
  184. - bump rev
  185. - buildprereq gperf
  186. * Mon Feb 4 2002 Bill Nottingham <notting@redhat.com> 2.4.13-1
  187. - update to 2.4.13
  188. - fix GPL symbol export
  189. * Wed Jan 30 2002 Bill Nottingham <notting@redhat.com> 2.4.12-9
  190. - shrink insmod.static
  191. * Thu Jan 24 2002 Bill Nottingham <notting@redhat.com> 2.4.12-8
  192. - fix installation of extra libraries (#58427)
  193. * Thu Jan 17 2002 Bill Nottingham <notting@redhat.com> 2.4.12-7
  194. - hack to allow depmod of 64bit kernels on 32bit PPC
  195. * Tue Jan 15 2002 Bill Nottingham <notting@redhat.com> 2.4.12-6
  196. - more ppc64 fixes
  197. * Thu Jan 10 2002 Bill Nottingham <notting@redhat.com> 2.4.12-5
  198. - fix build on combined 32/64 targets (ppc/sparc)
  199. * Tue Dec 11 2001 Matt Wilson <msw@redhat.com>
  200. - added a -devel subpackage that contains libraries that apps can use
  201. to implement insmod and rmmod
  202. * Tue Dec 4 2001 Bill Nottingham <notting@redhat.com>
  203. - get rid of some obsolete patches, other tweaks
  204. * Thu Nov 29 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  205. - update to 2.4.12
  206. * Sat Nov 17 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  207. - update to 2.4.11
  208. * Tue Oct 2 2001 Bill Nottingham <notting@redhat.com>
  209. - update to 2.4.10
  210. - deprecate -i, -m arguments to depmod
  211. * Tue Sep 25 2001 Bill Nottingham <notting@redhat.com>
  212. - update to 2.4.9
  213. * Wed Aug 29 2001 Bill Nottingham <notting@redhat.com>
  214. - replace modutils-2.4.6-error patch with version that was integrated
  215. upstream
  216. * Sat Aug 18 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  217. - disable char-major-4 for s390/s390x
  218. * Mon Jul 8 2001 Bill Nottingham <notting@redhat.com>
  219. - remove /etc/cron.d/kmod
  220. * Fri Jul 6 2001 Bill Nottingham <notting@redhat.com>
  221. - update to 2.4.6
  222. - alias binfmt-0000 off (#9709)
  223. - turn off 'modules.conf is more recent than modules.dep' message (#14276,
  224. others)
  225. - return nonzero from depmod if there are errors (#40935)
  226. - fix manpage typo (#33123)
  227. * Thu Jul 05 2001 Karsten Hopp <karsten@redhat.de>
  228. - new S390 patch from IBM
  229. * Tue Jun 26 2001 Elliot Lee <sopwith@redhat.com> 2.4.5-3
  230. - Add modutils-2.4.5-stblocal.patch from Jakub. See the e-mail message
  231. inside the patch file for details.
  232. - Use smp_mflags macro
  233. * Thu Jun 21 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  234. - add s390/s390x support
  235. * Tue Apr 24 2001 Bill Nottingham <notting@redhat.com>
  236. - update to 2.4.5
  237. * Tue Mar 6 2001 Bill Nottingham <notting@redhat.com>
  238. - add default post/preun for binfmt_misc
  239. * Mon Feb 19 2001 Bill Nottingham <notting@redhat.com>
  240. - change ipv6 alias to 'alias net-pf-10 off'
  241. * Tue Feb 13 2001 Bill Nottingham <notting@redhat.com>
  242. - add 'net-pf-10 ipv6' alias (#25405)
  243. * Sun Jan 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  244. - change "#ifdef s390" -> "#if defined(__s390__) || defined(__s390x__)"
  245. * Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
  246. - update to 2.4.2
  247. - ship a genksyms.old
  248. * Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
  249. - fix ppp aliases
  250. * Tue Jan 9 2001 Bill Nottingham <notting@redhat.com>
  251. - oops, I blew away other people's changes. Fix that.
  252. - only have tty-ldisc-11 in the aliases once
  253. * Mon Jan 8 2001 Bill Nottingham <notting@redhat.com>
  254. - update to 2.4.0
  255. - tweak irda aliases
  256. - remove vixie-cron dependency (it's not *required*)
  257. - add missing %build (where did that go?)
  258. * Sun Jan 7 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  259. - 2.4.0
  260. - Get rid of obsolete char-major-60==ircom-tty patch
  261. (moved to 161)
  262. * Sat Jan 06 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  263. - add "ctc{0,1,2} -> ctc" alias for s390
  264. * Sat Dec 23 2000 Bill Nottingham <notting@redhat.com>
  265. - add missing comma in alias list
  266. - add irda aliases
  267. * Tue Dec 12 2000 Bill Nottingham <notting@redhat.com>
  268. - add char-major-108 ppp_async alias
  269. * Mon Dec 11 2000 Bill Nottingham <notting@redhat.com>
  270. - fix ide-probe aliases (now ide-probe-mod)
  271. * Wed Nov 22 2000 Matt Wilson <msw@redhat.com>
  272. - 2.3.21, fixes more security problems.
  273. * Thu Nov 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  274. - 2.3.20, fixes security holes
  275. * Tue Oct 31 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  276. - 2.3.19
  277. - add IrDA devices to alias patch
  278. - update source URL
  279. * Thu Oct 26 2000 Bill Nottingham <notting@redhat.com>
  280. - fix ia64 module loading
  281. * Mon Oct 2 2000 Bill Nottingham <notting@redhat.com>
  282. - stupid ia64 tricks
  283. * Fri Sep 29 2000 Jeff Johnson <jbj@redhat.com>
  284. - upgrade to 2.3.17.
  285. - sparc64 ELF hacks.
  286. * Mon Aug 21 2000 Michael K. Johnson <johnsonm@redhat.com>
  287. - Use %{_mandir} for removing kerneld-related man pages.
  288. * Wed Aug 9 2000 Jakub Jelinek <jakub@redhat.com>
  289. - fix build on SPARC
  290. * Tue Aug 8 2000 Jakub Jelinek <jakub@redhat.com>
  291. - update to 2.3.14
  292. * Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
  293. - update to 2.3.13
  294. - turn psaux off again
  295. - remove sound patch; it's obsolete
  296. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  297. - rebuild to cope with glibc locale binary incompatibility
  298. * Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  299. - 2.3.12
  300. - fix up ia64
  301. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  302. - automatic rebuild
  303. * Sat Jul 1 2000 Florian La Roche <laroche@redhat.com>
  304. - add aliases for cipcb[0-3]
  305. * Wed Jun 14 2000 Matt Wilson <msw@redhat.com>
  306. - fix build on combined 32/64 bit sparc
  307. * Thu Jun 1 2000 Bill Nottingham <notting@redhat.com>
  308. - modules.confiscation
  309. * Wed May 17 2000 Bill Nottingham <notting@redhat.com>
  310. - add ia64 patch from Intel
  311. * Wed May 17 2000 Jakub Jelinek <jakub@redhat.com>
  312. - fix build with glibc 2.2
  313. * Tue May 09 2000 Doug Ledford <dledford@redhat.com>
  314. - Correct %description to reflect that we don't build kerneld by default
  315. * Fri Apr 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  316. - 2.3.11
  317. * Mon Apr 3 2000 Bill Nottingham <notting@redhat.com>
  318. - fix net-pf-* aliases for ipx, appletalk
  319. * Fri Mar 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  320. - 2.3.10
  321. * Thu Feb 17 2000 Matt Wilson <msw@redhat.com>
  322. - added alias for agpgart
  323. * Mon Feb 14 2000 Bill Nottingham <notting@redhat.com>
  324. - hardcode psaux alias to off everywhere
  325. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  326. - add a symlink from conf.modules.5 to modules.conf.5
  327. * Fri Jan 29 2000 Bill Nottingham <notting@redhat.com>
  328. - fix breakage *correctly*
  329. * Sat Jan 22 2000 Bill Nottingham <notting@redhat.com>
  330. - fix breakage of our own cause w.r.t sound modules
  331. * Thu Jan 06 2000 Jakub Jelinek <jakub@redhat.com>
  332. - update to 2.3.9.
  333. - port RH patches from 2.1.121 to 2.3.9 where needed.
  334. - disable warning about conf.modules for now, in 7.0
  335. we should move to modules.conf.
  336. * Wed Oct 13 1999 Jakub Jelinek <jakub@redhat.com>
  337. - hardcode psaux alias on sparc to off.
  338. * Tue Oct 05 1999 Bill Nottingham <notting@redhat.com>
  339. - hardcode parport aliases....
  340. * Mon Oct 04 1999 Cristian Gafton <gafton@redhat.com>
  341. - rebuild against new glibc in the sparc tree
  342. * Wed Sep 15 1999 Jakub Jelinek <jakub@redhat.com>
  343. - rewrite sparckludge so that separate *64 binaries
  344. are not needed anymore.
  345. * Sat Sep 11 1999 Cristian Gafton <gafton@redhat.com>
  346. - apply the last patch in the %prep section (doh!)
  347. * Mon Apr 19 1999 Cristian Gafton <gafton@redhat.com>
  348. - add support for the ppp compression modules by default
  349. * Tue Apr 13 1999 Michael K. Johnson <johnsonm@redhat.com>
  350. - add cron.d file to run rmmod -as
  351. * Fri Apr 09 1999 Cristian Gafton <gafton@redhat.com>
  352. - take out kerneld
  353. * Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
  354. - add patch to make all raid personalities recognized
  355. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  356. - auto rebuild in the new build environment (release 7)
  357. * Thu Mar 18 1999 Cristian Gafton <gafton@redhat.com>
  358. - obsoletes modules
  359. - get rid of the /lib/modules/preferred hack
  360. * Mon Mar 15 1999 Bill Nottingham <notting@redhat.com>
  361. - added support for /lib/modules/foo/pcmcia
  362. - make kerneld initscript not start by default
  363. * Tue Feb 23 1999 Matt Wilson <msw@redhat.com>
  364. - added sparc64 support from UltraPenguin
  365. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  366. - call libtoolize to allow it to compile on the arm
  367. * Wed Dec 23 1998 Jeff Johnson <jbj@redhat.com>
  368. - search /lib/modules/preferred before defaults but after specified paths.
  369. * Tue Nov 17 1998 Cristian Gafton <gafton@redhat.com>
  370. - upgraded to version 2.1.121
  371. * Thu Nov 05 1998 Erik Troan <ewt@redhat.com>
  372. - added -m, -i options
  373. * Thu Oct 01 1998 Michael K. Johnson <johnsonm@redhat.com>
  374. - fix syntax error I introduced when enhancing initscript
  375. * Wed Sep 30 1998 Michael K. Johnson <johnsonm@redhat.com>
  376. - enhance initscript
  377. * Fri Aug 28 1998 Jeff Johnson <jbj@redhat.com>
  378. - recompile statically linked binary for 5.2/sparc
  379. * Tue Jul 28 1998 Jeff Johnson <jbj@redhat.com>
  380. - pick up ultrapenguin patches (not applied for now).
  381. - pre-generate keyword.c so gperf doesn't have to be present (not applied).
  382. - util/sys_cm.c: fix create_module syscall (signed return on sparc too)
  383. * Wed Jul 15 1998 Jeff Johnson <jbj@redhat.com>
  384. - correct %postun typos
  385. * Fri May 01 1998 Erik Troan <ewt@redhat.com>
  386. - added /lib/modules/preferred to search path
  387. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  388. - translations modified for de, fr, tr
  389. * Tue Apr 07 1998 Cristian Gafton <gafton@redhat.com>
  390. - updated to 2.1.85
  391. - actually make use of the BuildRoot
  392. * Fri Apr 3 1998 Jakub Jelinek <jj@ultra.linux.cz>
  393. - Fix sparc64, add modinfo64 on sparc.
  394. * Wed Mar 23 1998 Jakub Jelinek <jj@ultra.linux.cz>
  395. - Handle EM_SPARCV9, kludge to support both 32bit and 64bit kernels
  396. from the same package on sparc/sparc64.
  397. * Fri Nov 7 1997 Michael Fulbright
  398. - removed warning message when conf.modules exists and is a empty
  399. * Tue Oct 28 1997 Erik Troan <ewt@redhat.com>
  400. - patched to honor -k in options
  401. - added modprobe.1
  402. - added init script
  403. * Thu Oct 23 1997 Erik Troan <ewt@redhat.com>
  404. - removed bogus strip of lsmod (which is a script)
  405. * Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
  406. - updated to 2.1.55
  407. - builds in a buildroot
  408. * Mon Aug 25 1997 Erik Troan <ewt@redhat.com>
  409. - added insmod.static
  410. * Sun Aug 24 1997 Erik Troan <ewt@redhat.com>
  411. - built on Intel
  412. - combined rmmod and insmod