rust-vl.spec 30 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896897898899900901902903904905906907908909910911912913914915916917918919920921922923924925926927928929930931932933934935936937938939940941942943944945946947948949950951952953954955956957958959960961962963964965966967968969970971972973974975976977978979980981982983984985986987988989990991992993
  1. %bcond_with bootstrap
  2. %bcond_with test
  3. %bcond_with newrpm
  4. %bcond_with miri
  5. %bcond_without clang
  6. %bcond_without bundled_libgit2
  7. %bcond_without bundled_libssh2
  8. # Some sub-packages are versioned independently of the rust compiler and runtime itself.
  9. # Also beware that if any of these are not changed in a version bump, then the release
  10. # number should still increase, not be reset to 1!
  11. %global rustc_version 1.65.0
  12. %global cargo_version %{rustc_version}
  13. %global rustfmt_version %{rustc_version}
  14. %global rls_version %{rustc_version}
  15. %global clippy_version %{rustc_version}
  16. # The channel can be stable, beta, or nightly
  17. %{!?channel: %global channel stable}
  18. # Only x86_64 and i686 are Tier 1 platforms at this time.
  19. # https://forge.rust-lang.org/platform-support.html
  20. %global rust_arches x86_64 i686
  21. # To bootstrap from scratch, set the channel and date from src/stage0.txt
  22. # e.g. 1.10.0 wants rustc: 1.9.0-2016-05-24
  23. # or nightly wants some beta-YYYY-MM-DD
  24. %global bootstrap_rust 1.64.0
  25. %global bootstrap_cargo 1.64.0
  26. %global bootstrap_channel %{bootstrap_rust}
  27. # Only the specified arches will use bootstrap binaries.
  28. %if %{with bootstrap}
  29. %global bootstrap_arches %%{rust_arches}
  30. %endif
  31. # We generally don't want llvm-static present at all, since llvm-config will
  32. # make us link statically. But we can opt in, e.g. to aid LLVM rebases.
  33. # FIXME: LLVM 3.9 prefers shared linking now! Which is good, but next time we
  34. # *want* static we'll have to force it with "llvm-config --link-static".
  35. # See also https://github.com/rust-lang/rust/issues/36854
  36. # The new rustbuild accepts `--enable-llvm-link-shared`, else links static.
  37. %bcond_with llvm_static
  38. # We can also choose to just use Rust's bundled LLVM, in case the system LLVM
  39. # is insufficient. Rust currently requires LLVM 3.7+.
  40. %bcond_with bundled_llvm
  41. # LLDB only works on some architectures
  42. %ifarch %{arm} aarch64 %{ix86} x86_64
  43. # LLDB isn't available everywhere...
  44. %bcond_without lldb
  45. %else
  46. %bcond_with lldb
  47. %endif
  48. Summary: The Rust Programming Language
  49. Name: rust
  50. Version: %{rustc_version}
  51. Release: 1%{?_dist_release}
  52. Group: programming
  53. Vendor: Project Vine
  54. Distribution: Vine Linux
  55. License: (ASL 2.0 or MIT) and (BSD and ISC and MIT)
  56. # ^ written as: (rust itself) and (bundled libraries)
  57. URL: https://www.rust-lang.org
  58. ExclusiveArch: %{rust_arches}
  59. %if "%{channel}" == "stable"
  60. %global rustc_package rustc-%{version}-src
  61. %else
  62. %global rustc_package rustc-%{channel}-src
  63. %endif
  64. Source0: https://static.rust-lang.org/dist/%{rustc_package}.tar.gz
  65. # Get the Rust triple for any arch.
  66. %{lua: function rust_triple(arch)
  67. local abi = "gnu"
  68. if arch == "armv7hl" then
  69. arch = "armv7"
  70. abi = "gnueabihf"
  71. elseif arch == "ppc64" then
  72. arch = "powerpc64"
  73. elseif arch == "ppc64le" then
  74. arch = "powerpc64le"
  75. end
  76. return arch.."-unknown-linux-"..abi
  77. end}
  78. %global rust_triple %{lua: print(rust_triple(rpm.expand("%{_target_cpu}")))}
  79. %if %defined bootstrap_arches
  80. # For each bootstrap arch, add an additional binary Source.
  81. # Also define bootstrap_source just for the current target.
  82. %{lua: do
  83. local bootstrap_arches = {}
  84. for arch in string.gmatch(rpm.expand("%{bootstrap_arches}"), "%S+") do
  85. table.insert(bootstrap_arches, arch)
  86. end
  87. local base = rpm.expand("https://static.rust-lang.org/dist"
  88. .."/rust-%{bootstrap_channel}")
  89. local target_arch = rpm.expand("%{_target_cpu}")
  90. for i, arch in ipairs(bootstrap_arches) do
  91. print(string.format("Source%d: %s-%s.tar.gz\n",
  92. i, base, rust_triple(arch)))
  93. if arch == target_arch then
  94. rpm.define("bootstrap_source "..i)
  95. end
  96. end
  97. end}
  98. %endif
  99. %ifarch %{bootstrap_arches}
  100. %global bootstrap_root rust-%{bootstrap_channel}-%{rust_triple}
  101. %global local_rust_root %{_builddir}/%{bootstrap_root}/usr
  102. Provides: bundled(%{name}-bootstrap) = %{bootstrap_rust}
  103. %else
  104. BuildRequires: cargo >= %{bootstrap_cargo}
  105. BuildRequires: %{name} >= %{bootstrap_rust}
  106. BuildConflicts: %{name} > %{version}
  107. %global local_rust_root %{_prefix}
  108. %endif
  109. BuildRequires: cmake
  110. BuildRequires: make
  111. %if %{with clang}
  112. BuildRequires: clang
  113. BuildRequires: lld
  114. %else
  115. BuildRequires: gcc
  116. BuildRequires: gcc-c++
  117. %endif
  118. %if %{without bundled_libgit2}
  119. BuildRequires: libgit2-devel
  120. %endif
  121. %if %{without bundled_libssh2}
  122. BuildRequires: libssh2-devel
  123. %endif
  124. BuildRequires: ncurses-devel
  125. BuildRequires: openssl-devel
  126. BuildRequires: zlib-devel
  127. BuildRequires: python3
  128. BuildRequires: python3-rpm-macros
  129. BuildRequires: curl
  130. BuildRequires: curl-devel
  131. BuildRequires: xz-devel
  132. %if %{with bundled_llvm}
  133. BuildRequires: cmake
  134. BuildRequires: git
  135. Provides: bundled(llvm) = 6.0
  136. %else
  137. BuildRequires: cmake
  138. %if %defined llvm
  139. %global llvm_root %{_libdir}/%{llvm}
  140. %else
  141. %global llvm llvm
  142. %global llvm_root %{_prefix}
  143. %global llvm_has_filecheck 1
  144. %endif
  145. BuildRequires: %{llvm}-devel >= 11.0.0
  146. %if %{with llvm_static}
  147. BuildRequires: %{llvm}-static
  148. BuildRequires: libffi-devel
  149. %else
  150. BuildConflicts: %{llvm}-static
  151. %endif
  152. %endif
  153. # make check needs "ps" for src/test/run-pass/wait-forked-but-failed-child.rs
  154. BuildRequires: procps
  155. # debuginfo-gdb tests need gdb
  156. BuildRequires: gdb
  157. # TODO: work on unbundling these!
  158. Provides: bundled(jquery) = 2.1.4
  159. Provides: bundled(miniz) = 1.14
  160. # Virtual provides for folks who attempt "dnf install rustc"
  161. Provides: rustc = %{version}-%{release}
  162. Provides: rustc%{?_isa} = %{version}-%{release}
  163. Obsoletes: rust-rls < %{version}-%{release}
  164. %if ! %{with miri}
  165. Obsoletes: rust-miri < %{version}-%{release}
  166. %endif
  167. # Always require our exact standard library
  168. Requires: %{name}-std-static%{?_isa} = %{version}-%{release}
  169. # The C compiler is needed at runtime just for linking. Someday rustc might
  170. # invoke the linker directly, and then we'll only need binutils.
  171. # https://github.com/rust-lang/rust/issues/11937
  172. Requires: /usr/bin/cc
  173. # ALL Rust libraries are private, because they don't keep an ABI.
  174. %global _privatelibs lib(.*-[[:xdigit:]]{16}*|rustc.*)[.]so.*
  175. %global __provides_exclude ^(%{_privatelibs})$
  176. %global __requires_exclude ^(%{_privatelibs})$
  177. %global __provides_exclude_from ^(%{_docdir}|%{rustlibdir}/src)/.*$
  178. %global __requires_exclude_from ^(%{_docdir}|%{rustlibdir}/src)/.*$
  179. %if !%{with newrpm}
  180. # eu-strip is very eager by default, so we have to limit it to -g, only debugging symbols.
  181. %global _find_debuginfo_opts -g
  182. %undefine _include_minidebuginfo
  183. %else
  184. # Newer find-debuginfo.sh supports --keep-section, which is preferable. rhbz1465997
  185. %global _find_debuginfo_opts --keep-section .rustc
  186. %endif
  187. %if !%{with newrpm}
  188. Obsoletes: rust-debuginfo < %{version}-%{release}
  189. %else
  190. %ifnarch x86_64
  191. Obsoletes: rust-debuginfo < %{version}-%{release}
  192. %endif
  193. %endif
  194. # Use hardening ldflags.
  195. %global rustflags -Clink-arg=-Wl,-z,relro,-z,now
  196. %if %{without bundled_llvm} && "%{llvm_root}" != "%{_prefix}"
  197. # https://github.com/rust-lang/rust/issues/40717
  198. %global library_path $(%{llvm_root}/bin/llvm-config --libdir)
  199. %endif
  200. %description
  201. Rust is a systems programming language that runs blazingly fast, prevents
  202. segfaults, and guarantees thread safety.
  203. This package includes the Rust compiler and documentation generator.
  204. %package std-static
  205. Summary: Standard library for Rust
  206. Group: programming
  207. %description std-static
  208. This package includes the standard libraries for building applications
  209. written in Rust.
  210. %package debugger-common
  211. Summary: Common debugger pretty printers for Rust
  212. Group: programming
  213. BuildArch: noarch
  214. %description debugger-common
  215. This package includes the common functionality for %{name}-gdb and %{name}-lldb.
  216. %package gdb
  217. Summary: GDB pretty printers for Rust
  218. Group: programming
  219. BuildArch: noarch
  220. Requires: gdb
  221. Requires: %{name}-debugger-common = %{version}-%{release}
  222. %description gdb
  223. This package includes the rust-gdb script, which allows easier debugging of Rust
  224. programs.
  225. %if %{with lldb}
  226. %package lldb
  227. Summary: LLDB pretty printers for Rust
  228. Group: programming
  229. # It could be noarch, but lldb has limited availability
  230. #BuildArch: noarch
  231. Requires: lldb
  232. Requires: python3-lldb
  233. Requires: %{name}-debugger-common = %{version}-%{release}
  234. %description lldb
  235. This package includes the rust-lldb script, which allows easier debugging of Rust
  236. programs.
  237. %endif
  238. %package doc
  239. Summary: Documentation for Rust
  240. Group: documentation
  241. # NOT BuildArch: noarch
  242. # Note, while docs are mostly noarch, some things do vary by target_arch.
  243. # Koji will fail the build in rpmdiff if two architectures build a noarch
  244. # subpackage differently, so instead we have to keep its arch.
  245. %description doc
  246. This package includes HTML documentation for the Rust programming language and
  247. its standard library.
  248. %package -n cargo
  249. Summary: Rust's package manager and build tool
  250. Version: %{cargo_version}
  251. Group: programming
  252. # For tests:
  253. BuildRequires: git
  254. # Cargo is not much use without Rust
  255. Requires: rust
  256. %description -n cargo
  257. Cargo is a tool that allows Rust projects to declare their various dependencies
  258. and ensure that you'll always get a repeatable build.
  259. %package -n cargo-doc
  260. Summary: Documentation for Cargo
  261. Version: %{cargo_version}
  262. Group: programming
  263. BuildArch: noarch
  264. # Cargo no longer builds its own documentation
  265. # https://github.com/rust-lang/cargo/pull/4904
  266. Requires: rust-doc = %{rustc_version}-%{release}
  267. %description -n cargo-doc
  268. This package includes HTML documentation for Cargo.
  269. %package -n rustfmt
  270. Summary: Tool to find and fix Rust formatting issues
  271. Version: %{rustfmt_version}
  272. Group: programming
  273. Requires: cargo
  274. Obsoletes: rustfmt-preview < 1.0.0
  275. %description -n rustfmt
  276. A tool for formatting Rust code according to style guidelines.
  277. %package -n clippy
  278. Summary: Lints to catch common mistakes and improve your Rust code
  279. Version: %{clippy_version}
  280. Group: programming
  281. License: MPLv2.0
  282. Requires: cargo
  283. # /usr/bin/clippy-driver is dynamically linked against internal rustc libs
  284. Requires: %{name} = %{rustc_version}-%{release}
  285. Obsoletes: clippy-preview < 1.0.0
  286. %description -n clippy
  287. A collection of lints to catch common mistakes and improve your Rust code.
  288. %package src
  289. Summary: Sources for the Rust standard library
  290. Group: programming
  291. BuildArch: noarch
  292. %description src
  293. This package includes source files for the Rust standard library. It may be
  294. useful as a reference for code completion tools in various editors.
  295. %package analysis
  296. Summary: Compiler analysis data for the Rust standard library
  297. Group: programming
  298. Requires: rust-std-static = %{rustc_version}-%{release}
  299. %description analysis
  300. This package contains analysis data files produced with rustc's -Zsave-analysis
  301. feature for the Rust standard library.
  302. %if %{with miri}
  303. %package miri
  304. Summary: An interpreter for Rust's mid-level intermediate representation
  305. Group: programming
  306. Requires: rust = %{rustc_version}-%{release}
  307. %description miri
  308. An experimental interpreter for Rust's mid-level intermediate representation
  309. (MIR). It can run binaries and test suites of cargo projects and detect certain
  310. classes of undefined behavior.
  311. %endif
  312. %package analyzer
  313. Summary: A modular compiler frontend for the Rust language
  314. Group: programming
  315. Requires: rust = %{rustc_version}-%{release}
  316. %description analyzer
  317. rust-analyzer is a modular compiler frontend for the Rust language.
  318. %if %{with newrpm}
  319. # debuginfo is available on x86_64 only
  320. %ifarch x86_64
  321. %debug_package
  322. %else
  323. %global _build_id_links none
  324. %global __debug_install_post %{nil}
  325. %global debug_package %{nil}
  326. %endif
  327. %else
  328. %global _build_id_links none
  329. %global __debug_install_post %{nil}
  330. %global debug_package %{nil}
  331. %endif
  332. %prep
  333. %ifarch %{bootstrap_arches}
  334. %setup -q -n %{bootstrap_root} -T -b %{bootstrap_source}
  335. ./install.sh --components=cargo,rustc,rust-std-%{rust_triple} \
  336. --prefix=%{local_rust_root} --disable-ldconfig
  337. test -f '%{local_rust_root}/bin/cargo'
  338. test -f '%{local_rust_root}/bin/rustc'
  339. %endif
  340. %setup -q -n %{rustc_package}
  341. %autopatch -p1
  342. sed -i.try-py3 -e '/try python2.7/i try python3 "$@"' ./configure
  343. %if %without bundled_llvm
  344. rm -rf src/llvm-project/
  345. mkdir -p src/llvm-project/libunwind/
  346. %endif
  347. # We never enable emscripten.
  348. rm -rf src/llvm-emscripten/
  349. # Remove other unused vendored libraries
  350. rm -rf vendor/curl-sys/curl/
  351. rm -rf vendor/*jemalloc-sys*/jemalloc/
  352. rm -rf vendor/libmimalloc-sys/c_src/mimalloc/
  353. rm -rf vendor/libz-sys/src/zlib/
  354. rm -rf vendor/libz-sys/src/zlib-ng/
  355. rm -rf vendor/lzma-sys/xz-*/
  356. rm -rf vendor/openssl-src/openssl/
  357. %if %{without bundled_libgit2}
  358. rm -rf vendor/libgit2-sys/libgit2/
  359. %endif
  360. %if %{without bundled_libssh2}
  361. rm -rf vendor/libssh2-sys/libssh2/
  362. %endif
  363. # This only affects the transient rust-installer, but let it use our dynamic xz-libs
  364. sed -i.lzma -e '/LZMA_API_STATIC/d' src/bootstrap/tool.rs
  365. # rename bundled license for packaging
  366. if [ -e vendor/backtrace-sys/src/libbacktrace/LICENSE ]; then
  367. cp -a vendor/backtrace-sys/src/libbacktrace/LICENSE{,-libbacktrace}
  368. fi
  369. %if %{with bundled_llvm} && 0%{?epel}
  370. mkdir -p cmake-bin
  371. ln -s /usr/bin/cmake cmake-bin/cmake
  372. %global cmake_path $PWD/cmake-bin
  373. %endif
  374. %if %{without bundled_llvm} && %{with llvm_static}
  375. # Static linking to distro LLVM needs to add -lffi
  376. # https://github.com/rust-lang/rust/issues/34486
  377. sed -i.ffi -e '$a #[link(name = "ffi")] extern {}' \
  378. src/librustc_llvm/lib.rs
  379. %endif
  380. # The configure macro will modify some autoconf-related files, which upsets
  381. # cargo when it tries to verify checksums in those files. If we just truncate
  382. # that file list, cargo won't have anything to complain about.
  383. find vendor -name .cargo-checksum.json \
  384. -exec sed -i.uncheck -e 's/"files":{[^}]*}/"files":{ }/' '{}' '+'
  385. %build
  386. %if %{without bundled_libgit2}
  387. export LIBGIT2_SYS_USE_PKG_CONFIG=1
  388. %endif
  389. %if %{without bundled_libssh2}
  390. export LIBSSH2_SYS_USE_PKG_CONFIG=1
  391. %endif
  392. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  393. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  394. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  395. # We're going to override --libdir when configuring to get rustlib into a
  396. # common path, but we'll fix the shared libraries during install.
  397. %global common_libdir %{_prefix}/lib
  398. %global rustlibdir %{common_libdir}/rustlib
  399. %ifarch x86_64
  400. %if %{with newrpm}
  401. %define enable_debuginfo --debuginfo-level=0 --debuginfo-level-std=2
  402. %else
  403. %define enable_debuginfo --debuginfo-level=0
  404. %global debug_package %{nil}
  405. %endif
  406. %else
  407. %define enable_debuginfo --debuginfo-level=0
  408. %global debug_package %{nil}
  409. %endif
  410. # Some builders have relatively little memory for their CPU count.
  411. # At least 2GB per CPU is a good rule of thumb for building rustc.
  412. ncpus=$(/usr/bin/getconf _NPROCESSORS_ONLN)
  413. max_cpus=$(( ($(LANG=C free -g | awk '/^Mem:/{print $2}') + 1) / 2 ))
  414. if [ "$max_cpus" -ge 1 -a "$max_cpus" -lt "$ncpus" ]; then
  415. ncpus="$max_cpus"
  416. fi
  417. %if %{with clang}
  418. export CC=clang
  419. export CXX=clang++
  420. export LDFLAGS="$LDFLAGS -fuse-ld=lld"
  421. export RUSTFLAGS="$RUSTFLAGS -C linker=clang -C link-arg=-fuse-ld=lld"
  422. %endif
  423. # workaround for https://github.com/rust-lang/rust/issues/69953
  424. # --set rust.deny-warnings=false
  425. %configure \
  426. --disable-option-checking \
  427. --libdir=%{common_libdir} \
  428. --build=%{rust_triple} --host=%{rust_triple} --target=%{rust_triple} \
  429. --enable-local-rust --local-rust-root=%{local_rust_root} \
  430. --set build.rustfmt=/bin/true \
  431. %{!?with_bundled_llvm: --llvm-root=%{llvm_root} \
  432. %{!?llvm_has_filecheck: --disable-codegen-tests} \
  433. %{!?with_llvm_static: --enable-llvm-link-shared } } \
  434. --disable-llvm-static-stdcpp \
  435. --disable-rpath \
  436. %{enable_debuginfo} \
  437. --set rust.codegen-units-std=1 \
  438. --enable-extended \
  439. --tools=analysis,cargo,clippy,rustfmt,rust-analyzer,src \
  440. --enable-vendor \
  441. --enable-verbose-tests \
  442. --release-channel=%{channel} \
  443. --dist-compression-formats=gz \
  444. --release-description="Vine Linux %{version}-%{release}" \
  445. %{nil}
  446. RUST_BACKTRACE=1 %{__python3} ./x.py build -j "$ncpus" --stage 2
  447. %{__python3} ./x.py doc --stage 2
  448. %install
  449. rm -rf %{buildroot}
  450. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  451. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  452. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  453. %if %{with clang}
  454. export CC=clang
  455. export CXX=clang++
  456. export RUSTFLAGS="$RUSTFLAGS -C linker=clang -C link-arg=-fuse-ld=lld"
  457. %endif
  458. DESTDIR=%{buildroot} ./x.py install
  459. #DESTDIR=%{buildroot} ./x.py install src
  460. # Make sure the shared libraries are in the proper libdir
  461. %if "%{_libdir}" != "%{common_libdir}"
  462. mkdir -p %{buildroot}%{_libdir}
  463. find %{buildroot}%{common_libdir} -maxdepth 1 -type f -name '*.so' \
  464. -exec mv -v -t %{buildroot}%{_libdir} '{}' '+'
  465. %endif
  466. # The shared libraries should be executable for debuginfo extraction.
  467. find %{buildroot}%{_libdir} -maxdepth 1 -type f -name '*.so' \
  468. -exec chmod -v +x '{}' '+'
  469. # The libdir libraries are identical to those under rustlib/. It's easier on
  470. # library loading if we keep them in libdir, but we do need them in rustlib/
  471. # to support dynamic linking for compiler plugins, so we'll symlink.
  472. (cd "%{buildroot}%{rustlibdir}/%{rust_triple}/lib" &&
  473. find ../../../../%{_lib} -maxdepth 1 -name '*.so' |
  474. while read lib; do
  475. if [ -f "${lib##*/}" ]; then
  476. # make sure they're actually identical!
  477. cmp "$lib" "${lib##*/}"
  478. ln -v -f -s -t . "$lib"
  479. fi
  480. done)
  481. # Remove installer artifacts (manifests, uninstall scripts, etc.)
  482. find %{buildroot}%{rustlibdir} -maxdepth 1 -type f -exec rm -v '{}' '+'
  483. # Remove backup files from %%configure munging
  484. find %{buildroot}%{rustlibdir} -type f -name '*.orig' -exec rm -v '{}' '+'
  485. # https://fedoraproject.org/wiki/Changes/Make_ambiguous_python_shebangs_error
  486. # We don't actually need to ship any of those python scripts in rust-src anyway.
  487. find %{buildroot}%{rustlibdir}/src -type f -name '*.py' -exec rm -v '{}' '+'
  488. # FIXME: __os_install_post will strip the rlibs
  489. # -- should we find a way to preserve debuginfo?
  490. # Remove unwanted documentation files (we already package them)
  491. # Remove unwanted documentation files (we already package them)
  492. rm -f %{buildroot}%{_docdir}/%{name}/README.md
  493. rm -f %{buildroot}%{_docdir}/%{name}/COPYRIGHT
  494. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE
  495. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-APACHE
  496. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-MIT
  497. rm -f %{buildroot}%{_docdir}/%{name}/LICENSE-THIRD-PARTY
  498. rm -f %{buildroot}%{_docdir}/%{name}/*.old
  499. # Sanitize the HTML documentation
  500. find %{buildroot}%{_docdir}/%{name}/html -empty -delete
  501. find %{buildroot}%{_docdir}/%{name}/html -type f -exec chmod -x '{}' '+'
  502. # Create the path for crate-devel packages
  503. mkdir -p %{buildroot}%{_datadir}/cargo/registry
  504. # Cargo no longer builds its own documentation
  505. # https://github.com/rust-lang/cargo/pull/4904
  506. mkdir -p %{buildroot}%{_docdir}/cargo
  507. ln -sT ../rust/html/cargo/ %{buildroot}%{_docdir}/cargo/html
  508. %if %{without lldb}
  509. rm -f %{buildroot}%{_bindir}/rust-lldb
  510. rm -f %{buildroot}%{rustlibdir}/etc/lldb_*.py*
  511. rm -f %{buildroot}%{rustlibdir}/etc/lldb_commands
  512. %endif
  513. %if %{with bundled_llvm}
  514. rm -rf %{buildroot}/home
  515. %endif
  516. # We don't want Rust copies of LLVM tools (rust-lld, rust-llvm-dwp)
  517. rm -f %{buildroot}%{rustlibdir}/%{rust_triple}/bin/rust-ll*
  518. %check
  519. %if %{with test}
  520. %{?cmake_path:export PATH=%{cmake_path}:$PATH}
  521. %{?library_path:export LIBRARY_PATH="%{library_path}"}
  522. %{?rustflags:export RUSTFLAGS="%{rustflags}"}
  523. %if %{with clang}
  524. export CC=clang
  525. export CXX=clang++
  526. export LD=ld.lld
  527. export RUSTFLAGS="$RUSTFLAGS -C linker=ld.lld -C link-arg=-fuse-ld=lld"
  528. %endif
  529. # The results are not stable on koji, so mask errors and just log it.
  530. %{__python3} ./x.py test --no-fail-fast || :
  531. %{__python3} ./x.py test --no-fail-fast cargo || :
  532. %{__python3} ./x.py test --no-fail-fast clippy || :
  533. %{__python3} ./x.py test --no-fail-fast rustfmt || :
  534. %endif
  535. %files
  536. %license COPYRIGHT LICENSE-APACHE LICENSE-MIT
  537. #license src/libbacktrace/LICENSE-libbacktrace
  538. %doc README.md
  539. %{_bindir}/rustc
  540. %{_bindir}/rustdoc
  541. %{_libdir}/*.so
  542. %{_mandir}/man1/rustc.1*
  543. %{_mandir}/man1/rustdoc.1*
  544. %dir %{rustlibdir}
  545. %dir %{rustlibdir}/%{rust_triple}
  546. %dir %{rustlibdir}/%{rust_triple}/lib
  547. %{rustlibdir}/%{rust_triple}/lib/*.so
  548. %files std-static
  549. %dir %{rustlibdir}
  550. %dir %{rustlibdir}/%{rust_triple}
  551. %dir %{rustlibdir}/%{rust_triple}/lib
  552. %{rustlibdir}/%{rust_triple}/lib/*.rlib
  553. %files debugger-common
  554. %dir %{rustlibdir}
  555. %dir %{rustlibdir}/etc
  556. %{rustlibdir}/etc/rust_types.py*
  557. %files gdb
  558. %{_bindir}/rust-gdb
  559. %{rustlibdir}/etc/gdb_*.py*
  560. %exclude %{_bindir}/rust-gdbgui
  561. %if %with lldb
  562. %files lldb
  563. %{_bindir}/rust-lldb
  564. %{rustlibdir}/etc/lldb_*.py*
  565. %{rustlibdir}/etc/lldb_commands
  566. %endif
  567. %files doc
  568. %docdir %{_docdir}/%{name}
  569. %dir %{_docdir}/%{name}
  570. %dir %{_docdir}/%{name}/html
  571. %{_docdir}/%{name}/html/*/
  572. %{_docdir}/%{name}/html/*.html
  573. %{_docdir}/%{name}/html/*.css
  574. %{_docdir}/%{name}/html/*.js
  575. %{_docdir}/%{name}/html/*.png
  576. %{_docdir}/%{name}/html/*.svg
  577. %{_docdir}/%{name}/html/*.woff2
  578. %license %{_docdir}/%{name}/html/*.txt
  579. %license %{_docdir}/%{name}/html/*.md
  580. %files -n cargo
  581. %license src/tools/cargo/LICENSE-APACHE src/tools/cargo/LICENSE-MIT src/tools/cargo/LICENSE-THIRD-PARTY
  582. %doc src/tools/cargo/README.md
  583. %{_bindir}/cargo
  584. %{_libexecdir}/cargo*
  585. %{_mandir}/man1/cargo*.1*
  586. %dir %{_sysconfdir}/bash_completion.d
  587. %{_sysconfdir}/bash_completion.d/cargo
  588. %dir %{_datadir}/zsh
  589. %dir %{_datadir}/zsh/site-functions
  590. %{_datadir}/zsh/site-functions/_cargo
  591. %dir %{_datadir}/cargo
  592. %dir %{_datadir}/cargo/registry
  593. %files -n cargo-doc
  594. %docdir %{_docdir}/cargo
  595. %dir %{_docdir}/cargo
  596. %{_docdir}/cargo/html
  597. %files -n rustfmt
  598. %{_bindir}/rustfmt
  599. %{_bindir}/cargo-fmt
  600. %doc src/tools/rustfmt/{README,CHANGELOG,Configurations}.md
  601. %license src/tools/rustfmt/LICENSE-{APACHE,MIT}
  602. %files -n clippy
  603. %{_bindir}/cargo-clippy
  604. %{_bindir}/clippy-driver
  605. %doc src/tools/clippy/{README.md,CHANGELOG.md}
  606. %license src/tools/clippy/LICENSE*
  607. %files src
  608. %dir %{rustlibdir}
  609. %{rustlibdir}/src
  610. %files analysis
  611. %{rustlibdir}/%{rust_triple}/analysis/
  612. %files analyzer
  613. %{_bindir}/rust-analyzer
  614. %{_libexecdir}/rust-analyzer-proc-macro-srv
  615. %if %{with miri}
  616. %files miri
  617. %{_bindir}/miri
  618. %{_bindir}/cargo-miri
  619. %endif
  620. %changelog
  621. * Fri Nov 04 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.65.0-1
  622. - new upstream release.
  623. * Fri Sep 23 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.64.0-1
  624. - new upstream release.
  625. * Fri Aug 12 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.63.0-1
  626. - new upstream release.
  627. * Wed Jul 20 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.62.1-1
  628. - new upstream release.
  629. * Fri Jul 01 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.62.0-1
  630. - new upstream release.
  631. * Sat May 21 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.61.0-1
  632. - new upstream release.
  633. * Fri Apr 22 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.60.0-1
  634. - new upstream release.
  635. * Fri Feb 25 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.59.0-1
  636. - new upstream release.
  637. * Fri Jan 21 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.58.1-1
  638. - new upstream release.
  639. * Fri Jan 14 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.58.0-1
  640. - new upstream release.
  641. * Fri Dec 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.57.0-1
  642. - new upstream release.
  643. * Tue Nov 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.56.1-1
  644. - new upstream release.
  645. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.56.0-1
  646. - new upstream release.
  647. * Wed Sep 15 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.55.0-1
  648. - new upstream release.
  649. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.54.0-2
  650. - rebuilt with current toolchain.
  651. * Fri Jul 30 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.54.0-1
  652. - new upstream release.
  653. * Mon Jun 21 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.53.0-1
  654. - new upstream release.
  655. - dropped a package: rust-miri.
  656. * Sun Jun 13 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.52.1-1
  657. - new upstream release.
  658. * Mon May 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.52.0-1
  659. - new upstream release.
  660. - dropped Patch0 and 1: merged to upstream.
  661. * Sun Apr 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.51.0-2
  662. - rebuilt with llvm-12.
  663. * Tue Mar 30 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.51.0-1
  664. - new upstream release.
  665. * Sun Feb 21 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.50.0-1
  666. - new upstream release.
  667. * Wed Jan 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.49.0-1
  668. - new upstream release.
  669. * Sat Dec 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.48.0-1
  670. - new upstream release.
  671. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.47.0-1
  672. - new upstream release.
  673. * Thu Sep 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.46.0-1
  674. - new upstream release.
  675. * Thu Mar 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.42.0-1
  676. - new upstream release.
  677. - separated debuginfo.
  678. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.40.0-1
  679. - new upstream release.
  680. * Sat Sep 28 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.38.0-1
  681. - new upstream release.
  682. - erased "-preview" from the name of subpackages.
  683. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.30.1-1
  684. - new upstream release.
  685. - dropped Patch1.
  686. - added subpackages cargo, cargo-doc, rustformat-preview, rls-preview, clippy-preview and rust-analysis.
  687. * Fri Jan 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-1
  688. - Update to 1.23.0 (stable).
  689. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.23.0-0.beta1
  690. - initial build for Vine Linux.
  691. - Update to 1.23.0-beta.
  692. - built a bootstrap rpm.
  693. * Thu Nov 23 2017 Josh Stone <jistone@redhat.com> - 1.22.1-1
  694. - Update to 1.22.1.
  695. * Thu Oct 12 2017 Josh Stone <jistone@redhat.com> - 1.21.0-1
  696. - Update to 1.21.0.
  697. * Mon Sep 11 2017 Josh Stone <jistone@redhat.com> - 1.20.0-2
  698. - ABI fixes for ppc64 and s390x.
  699. * Thu Aug 31 2017 Josh Stone <jistone@redhat.com> - 1.20.0-1
  700. - Update to 1.20.0.
  701. - Add a rust-src subpackage.
  702. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-4
  703. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  704. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.19.0-3
  705. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  706. * Mon Jul 24 2017 Josh Stone <jistone@redhat.com> - 1.19.0-2
  707. - Use find-debuginfo.sh --keep-section .rustc
  708. * Thu Jul 20 2017 Josh Stone <jistone@redhat.com> - 1.19.0-1
  709. - Update to 1.19.0.
  710. * Thu Jun 08 2017 Josh Stone <jistone@redhat.com> - 1.18.0-1
  711. - Update to 1.18.0.
  712. * Mon May 08 2017 Josh Stone <jistone@redhat.com> - 1.17.0-2
  713. - Move shared libraries back to libdir and symlink in rustlib
  714. * Thu Apr 27 2017 Josh Stone <jistone@redhat.com> - 1.17.0-1
  715. - Update to 1.17.0.
  716. * Mon Mar 20 2017 Josh Stone <jistone@redhat.com> - 1.16.0-3
  717. - Make rust-lldb arch-specific to deal with lldb deps
  718. * Fri Mar 17 2017 Josh Stone <jistone@redhat.com> - 1.16.0-2
  719. - Limit rust-lldb arches
  720. * Thu Mar 16 2017 Josh Stone <jistone@redhat.com> - 1.16.0-1
  721. - Update to 1.16.0.
  722. - Use rustbuild instead of the old makefiles.
  723. - Update bootstrapping to include rust-std and cargo.
  724. - Add a rust-lldb subpackage.
  725. * Thu Feb 09 2017 Josh Stone <jistone@redhat.com> - 1.15.1-1
  726. - Update to 1.15.1.
  727. - Require rust-rpm-macros for new crate packaging.
  728. - Keep shared libraries under rustlib/, only debug-stripped.
  729. - Merge and clean up conditionals for epel7.
  730. * Fri Dec 23 2016 Josh Stone <jistone@redhat.com> - 1.14.0-2
  731. - Rebuild without bootstrap binaries.
  732. * Thu Dec 22 2016 Josh Stone <jistone@redhat.com> - 1.14.0-1
  733. - Update to 1.14.0.
  734. - Rewrite bootstrap logic to target specific arches.
  735. - Bootstrap ppc64, ppc64le, s390x. (thanks to Sinny Kumari for testing!)
  736. * Thu Nov 10 2016 Josh Stone <jistone@redhat.com> - 1.13.0-1
  737. - Update to 1.13.0.
  738. - Use hardening flags for linking.
  739. - Split the standard library into its own package
  740. - Centralize rustlib/ under /usr/lib/ for multilib integration.
  741. * Thu Oct 20 2016 Josh Stone <jistone@redhat.com> - 1.12.1-1
  742. - Update to 1.12.1.
  743. * Fri Oct 14 2016 Josh Stone <jistone@redhat.com> - 1.12.0-7
  744. - Rebuild with LLVM 3.9.
  745. - Add ncurses-devel for llvm-config's -ltinfo.
  746. * Thu Oct 13 2016 Josh Stone <jistone@redhat.com> - 1.12.0-6
  747. - Rebuild with llvm-static, preparing for 3.9
  748. * Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-5
  749. - Rebuild with fixed eu-strip (rhbz1380961)
  750. * Fri Oct 07 2016 Josh Stone <jistone@redhat.com> - 1.12.0-4
  751. - Rebuild without bootstrap binaries.
  752. * Thu Oct 06 2016 Josh Stone <jistone@redhat.com> - 1.12.0-3
  753. - Bootstrap aarch64.
  754. - Use jemalloc's MALLOC_CONF to work around #36944.
  755. - Apply pr36933 to really disable armv7hl NEON.
  756. * Sat Oct 01 2016 Josh Stone <jistone@redhat.com> - 1.12.0-2
  757. - Protect .rustc from rpm stripping.
  758. * Fri Sep 30 2016 Josh Stone <jistone@redhat.com> - 1.12.0-1
  759. - Update to 1.12.0.
  760. - Always use --local-rust-root, even for bootstrap binaries.
  761. - Remove the rebuild conditional - the build system now figures it out.
  762. - Let minidebuginfo do its thing, since metadata is no longer a note.
  763. - Let rust build its own compiler-rt builtins again.
  764. * Sat Sep 03 2016 Josh Stone <jistone@redhat.com> - 1.11.0-3
  765. - Rebuild without bootstrap binaries.
  766. * Fri Sep 02 2016 Josh Stone <jistone@redhat.com> - 1.11.0-2
  767. - Bootstrap armv7hl, with backported no-neon patch.
  768. * Wed Aug 24 2016 Josh Stone <jistone@redhat.com> - 1.11.0-1
  769. - Update to 1.11.0.
  770. - Drop the backported patches.
  771. - Patch get-stage0.py to trust existing bootstrap binaries.
  772. - Use libclang_rt.builtins from compiler-rt, dodging llvm-static issues.
  773. - Use --local-rust-root to make sure the right bootstrap is used.
  774. * Sat Aug 13 2016 Josh Stone <jistone@redhat.com> 1.10.0-4
  775. - Rebuild without bootstrap binaries.
  776. * Fri Aug 12 2016 Josh Stone <jistone@redhat.com> - 1.10.0-3
  777. - Initial import into Fedora (#1356907), bootstrapped
  778. - Format license text as suggested in review.
  779. - Note how the tests already run in parallel.
  780. - Undefine _include_minidebuginfo, because it duplicates ".note.rustc".
  781. - Don't let checks fail the whole build.
  782. - Note that -doc can't be noarch, as rpmdiff doesn't allow variations.
  783. * Tue Jul 26 2016 Josh Stone <jistone@redhat.com> - 1.10.0-2
  784. - Update -doc directory ownership, and mark its licenses.
  785. - Package and declare licenses for libbacktrace and hoedown.
  786. - Set bootstrap_base as a global.
  787. - Explicitly require python2.
  788. * Thu Jul 14 2016 Josh Stone <jistone@fedoraproject.org> - 1.10.0-1
  789. - Initial package, bootstrapped