fcgi-vl.spec 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165
  1. %define snap -SNAP-0910052249
  2. Summary: FastCGI development kit
  3. Summary(ja): FastCGI 開発キット
  4. Name: fcgi
  5. Version: 2.4.1
  6. Release: 3%{?_dist_release}
  7. Group: Development/Languages
  8. License: BSD
  9. URL: http://www.fastcgi.com/#TheDevKit
  10. Source0: http://fastcgi.com/dist/fcgi-%{version}%{?snap}.tar.gz
  11. Source1: fcgi-autogen.sh
  12. Patch0: fcgi-2.4.0-autotools.patch
  13. # Patch0 created with Source1 after patching Patch1 and Patch2
  14. #Patch1: fcgi-2.4.0-configure.in.patch
  15. #Patch2: fcgi-2.4.0-Makefile.am-CPPFLAGS.patch
  16. Patch3: fcgi-2.4.0-gcc44_fixes.patch
  17. Patch4: fcgi-2.4.1-poll.patch
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  19. # for -perl
  20. BuildRequires: perl(ExtUtils::MakeMaker)
  21. # don't "provide" private Perl libs
  22. %global __provides_exclude_from %{perl_vendorarch}.*\\.so$
  23. %description
  24. FastCGI is a language independent, scalable, open extension to CGI that
  25. provides high performance without the limitations of server specific APIs.
  26. %package devel
  27. Summary: Development files for %{name}
  28. Summary(ja): Development files for %{name}
  29. Group: Development/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. %description devel
  32. The %{name}-devel package contains libraries and header files for
  33. developing applications that use %{name}.
  34. %package perl
  35. Summary: Perl bindings for %{name}
  36. Summary(ja): Perl bindings for %{name}
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  40. %description perl
  41. The %{name}-perl package contains the perl bindings for fcgi.
  42. %prep
  43. %setup -q -n "%{name}-%{version}%{snap}"
  44. #%patch0 -p1
  45. %patch3 -p1
  46. %patch4 -p1
  47. # remove DOS End Of Line Encoding
  48. sed -i 's/\r//' doc/fastcgi-prog-guide/ch2c.htm
  49. # fix file permissions
  50. chmod a-x include/fcgios.h libfcgi/os_unix.c
  51. %build
  52. %configure
  53. # does not build with parallel make flags
  54. make
  55. %install
  56. %{__rm} -rf %{buildroot}
  57. %{__mkdir_p} %{buildroot}
  58. make install DESTDIR=%{buildroot}
  59. %{__rm} -fv %{buildroot}/%{_libdir}/libfcgi{++,}.{l,}a
  60. install -p -m 0644 -D doc/cgi-fcgi.1 %{buildroot}/%{_mandir}/man1/cgi-fcgi.1
  61. for manpage in doc/*.3
  62. do
  63. install -p -m 0644 -D $manpage %{buildroot}%{_mandir}/man3/$(basename $manpage)
  64. done
  65. %{__rm} -f -- doc/*.1
  66. %{__rm} -f -- doc/*.3
  67. %post
  68. /sbin/ldconfig
  69. %postun
  70. /sbin/ldconfig
  71. %clean
  72. rm -rf $RPM_BUILD_ROOT
  73. %files
  74. %defattr(-,root,root,-)
  75. %{_bindir}/cgi-fcgi
  76. %{_libdir}/libfcgi.so.*
  77. %{_libdir}/libfcgi++.so.*
  78. %{_mandir}/man1/*
  79. %defattr(0644,root,root,0755)
  80. %doc LICENSE.TERMS README
  81. %files devel
  82. %defattr(-,root,root,-)
  83. %{_includedir}/*
  84. %{_libdir}/libfcgi.so
  85. %{_libdir}/libfcgi++.so
  86. %{_mandir}/man3/*
  87. %defattr(0644,root,root,0755)
  88. %doc doc/
  89. %changelog
  90. * Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> 2.4.1-3
  91. - rebuild with gcc-5.4.0
  92. * Mon Dec 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-2
  93. - made to use internal dependency generator.
  94. * Tue Jul 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-1
  95. - new upstream release.
  96. - removed perl binding (not used).
  97. * Sun Apr 3 2011 IWAI, Masaharu <iwai@alib.jp> 2.4.0-2vl6
  98. - build with perl 5.12.3
  99. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  100. - initial build for Vine Linux
  101. * Sun Mar 01 2009 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-9
  102. - Stripping bad provides of private Perl extension libs
  103. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-8
  104. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  105. * Sun Feb 15 2009 Till Maas <opensource@till.name> - 2.4.0-7
  106. - Add missing #include <cstdio> to make it compile with gcc 4.4
  107. * Tue Oct 14 2008 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-6
  108. - package up the perl bindings in their own subpackage
  109. * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.4.0-5
  110. - Autorebuild for GCC 4.3
  111. * Thu Aug 23 2007 Till Maas <opensource till name> - 2.4.0-4
  112. - bump release for rebuild
  113. * Wed Jul 11 2007 Till Maas <opensource till name> - 2.4.0-3
  114. - remove parallel make flags
  115. * Tue Apr 17 2007 Till Maas <opensource till name> - 2.4.0-2
  116. - add some documentation
  117. - add mkdir ${RPM_BUILD_ROOT} to %%install
  118. - install man-pages
  119. * Mon Mar 5 2007 Till Maas <opensource till name> - 2.4.0-1
  120. - Initial spec for fedora