R-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328
  1. %define pkg_version 2.11.0
  2. %define pkg_release 3%{?_dist_release}
  3. Summary: A language for data analysis and graphics
  4. Summary(ja): データ解析・グラフィック化の言語
  5. Name: R
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. Source0: ftp://cran.r-project.org/pub/R/src/base/R-2/%{name}-%{version}.tar.gz
  9. #Patch0: R-release.diff.gz
  10. License: GPL2
  11. Group: Applications/Engineering
  12. URL: http://www.r-project.org
  13. Requires: libgfortran
  14. BuildRequires: gcc-c++
  15. BuildRequires: gcc-gfortran libgfortran
  16. #BuildRequires: tetex texinfo tcl tk
  17. BuildRequires: texlive texinfo tcl tk
  18. BuildRequires: libpng-devel libjpeg-devel
  19. BuildRequires: readline-devel libtermcap-devel
  20. BuildRequires: zlib-devel bzip2-devel XOrg-devel
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: Toshiaki Ara <ara_t@384.jp>
  25. %description
  26. 'GNU S' - A language and environment for statistical computing and
  27. graphics. R is similar to the award-winning S system, which was
  28. developed at Bell Laboratories by John Chambers et al. It provides
  29. a wide variety of statistical and graphical techniques (linear and
  30. nonlinear modelling, statistical tests, time series analysis,
  31. classification, clustering, ...).
  32. R is designed as a true computer language with control-flow
  33. constructions for iteration and alternation, and it allows users to
  34. add additional functionality by defining new functions.
  35. For computationally intensive tasks, C, C++ and Fortran code
  36. can be linked and called at run time.
  37. %description -l ja
  38. 'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
  39. Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
  40. 線形・非線型モデル、統計検定、時系列分析、クラスター分析など
  41. 幅広い統計解析・視覚化手法を提供する。
  42. Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
  43. として設計されており、ユーザが新たに関数を組み込むことが可能である。
  44. また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
  45. 使用することができる。
  46. %package devel
  47. Summary: files for development of R packages.
  48. Summary(ja): Rパッケージ開発用ファイル
  49. Group: Development/Libraries
  50. Requires: R = %{version}-%{release}
  51. %description devel
  52. Install R-devel if you are going to develop or compile R packages.
  53. This is just a stub package containing the documentation on "Writing R
  54. Extensions". However, installing it will ensure that the build
  55. environment for R packages is correct.
  56. %description -l ja devel
  57. Rパッケージを開発したりコンパイルする場合には、このR-develを
  58. インストールします。R-exts.pdf ("Writing R Extensions": 英文)
  59. が含まれているだけのサブパッケージですが、正しくRパッケージを
  60. 開発するための助けになるでしょう。
  61. %package -n libRmath
  62. Summary: standalone math library from the R project
  63. Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
  64. Group: System Environment/Libraries
  65. %description -n libRmath
  66. A standalone library of mathematical and statistical functions derived
  67. from the R project. This packages provides the shared libRmath library.
  68. %description -l ja -n libRmath
  69. 単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
  70. 共有ライブラリを提供する。
  71. %package -n libRmath-devel
  72. Summary: standalone math library from the R project
  73. Summary(ja): libRmathの開発ライブラリ
  74. Group: Development/Libraries
  75. Requires: libRmath = %{version}-%{release}
  76. %description -n libRmath-devel
  77. A standalone library of mathematical and statistical functions derived
  78. from the R project. This packages provides the header files.
  79. %description -l ja -n libRmath-devel
  80. libRmathのヘッダファイル(Rmath.h)
  81. %prep
  82. %{__rm} -rf ${RPM_BUILD_ROOT}
  83. %setup -q
  84. #%patch0 -p1
  85. %build
  86. export R_BROWSER="%{_bindir}/firefox"
  87. %configure
  88. %{__make} %{?_smp_mflags}
  89. (cd src/nmath/standalone; %{__make} %{?_smp_mflags})
  90. LANG=C make check-all
  91. %{__make} pdf
  92. #We can only "make info" if we have an up to date version of texinfo
  93. %{?INFO: %{__make} info}
  94. %install
  95. %{__make} install DESTDIR=${RPM_BUILD_ROOT} install-pdf %{?INFO:install-info}
  96. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  97. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
  98. #Install libRmath files
  99. (cd src/nmath/standalone; %{__make} install DESTDIR=${RPM_BUILD_ROOT})
  100. mkdir -p ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
  101. echo "%{_libdir}/R/lib" > ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
  102. #Fix lication of R_HOME_DIR in shell wrapper
  103. sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  104. > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  105. chmod 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  106. sed -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  107. > ${RPM_BUILD_ROOT}%{_bindir}/R
  108. chmod 755 ${RPM_BUILD_ROOT}%{_bindir}/R
  109. %files
  110. %defattr(-, root, root)
  111. %{_bindir}/R
  112. %{_bindir}/Rscript
  113. %{_libdir}/R
  114. %{?INFO:%{_infodir}/R-*.info*}
  115. %{_mandir}/man1/*
  116. /etc/ld.so.conf.d/*
  117. %files devel
  118. %defattr(-, root, root)
  119. %doc doc/manual/R-exts.pdf
  120. %files -n libRmath
  121. %defattr(-, root, root)
  122. %{_libdir}/libRmath.so
  123. %files -n libRmath-devel
  124. %defattr(-, root, root)
  125. %{_libdir}/pkgconfig/*.pc
  126. %{_includedir}/Rmath.h
  127. %clean
  128. %{__rm} -rf ${RPM_BUILD_ROOT}
  129. %post
  130. %if 0%{?INFO}
  131. # Create directory entries for info files
  132. # (optional doc files, so we must check that they are installed)
  133. for doc in admin data exts FAQ intro lang; do
  134. file=%{_infodir}/R-${doc}.info.gz
  135. if [ -e $file ]; then
  136. /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
  137. fi
  138. done
  139. %endif
  140. %{_syssbindir}/ldconfig
  141. %preun
  142. %if 0%{?INFO}
  143. if [ $1 = 0 ]; then
  144. # Delete directory entries for info files (if they were installed)
  145. for doc in admin data exts FAQ intro lang; do
  146. file=%{_infodir}/R-${doc}.info.gz
  147. if [ -e ${file} ]; then
  148. /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
  149. fi
  150. done
  151. fi
  152. %endif
  153. %postun -p %{_syssbindir}/ldconfig
  154. %post -n libRmath -p %{_syssbindir}/ldconfig
  155. %postun -n libRmath -p %{_syssbindir}/ldconfig
  156. %changelog
  157. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
  158. - rebuilt with rpm-4.8.1 for pkg-config
  159. * Thu Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
  160. - recompiled because tcl/tk were not linked
  161. * Thu Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
  162. - Updated to 2.11.0
  163. - added Requires: libgfortran
  164. * Thu Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
  165. - Updated to 2.10.1
  166. * Thu Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
  167. - patched to 2.10.0
  168. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
  169. - spec in UTF-8
  170. * Thu Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
  171. - Updated to 2.10.0
  172. * Thu Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
  173. - Updated to 2.9.2
  174. - deleted BuildRequires: lapack-devel blas-devel
  175. - rewrote SPEC file
  176. * Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
  177. - Updated to 2.5.1
  178. - added BuildRequires: gcc-gfortran for VineSeed
  179. - added BuildRequires: lapack-devel blas-devel
  180. - fixed %preun script
  181. * Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
  182. - Updated to 2.4.1
  183. - Added INFO option
  184. - Exclude Japanese Rprofile.site
  185. * Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  186. - Updated to 2.4.0
  187. * Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
  188. - Added optimization flags
  189. * Tue Jun 6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
  190. - Packaged for VineLinux3.2
  191. * Tue May 9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
  192. - Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
  193. * Mon May 8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
  194. - Packaged for VineLinux3.2
  195. - Slipped texinfo
  196. - Fixed preun error
  197. - Preset Japanese fonts
  198. * Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  199. - Packaged for VineLinux3.2
  200. * Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
  201. - Restored CAPABILITIES file lost in 2.2.1beta
  202. * Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
  203. - Configure uses --without-blas by default.
  204. - Install pdf manuals.
  205. - All toplevel documentation files are installed into _libdir/R
  206. as they may be required by R (qv note on AUTHORS and THANKS below).
  207. - Legacy scripts for rebuilding package indices removed.
  208. * Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
  209. - R now compiles with gcc 4.0.1 and default rpm optimization flags.
  210. * Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
  211. - The files AUTHORS and THANKS need to be installed into _libdir/R
  212. as they are required by the function contributors(). Previously
  213. they were installed only as documentation files.
  214. * Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
  215. - Corrected date error in SPEC file.
  216. * Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
  217. - Dropped support for Red Hat boxed set.
  218. - Synchronized with Fedora Extras 4 RPM by Tom Calloway
  219. including support for shared R library.
  220. - Added gfortran support. However, gcc 4.0.0 will not compile R correctly
  221. with the default optimization flags, so there is a temporary work-around.
  222. * Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
  223. - Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
  224. * Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
  225. - Install R-data.info file as well.
  226. - Make info processing conditional on texinfo version, not platform release,
  227. so that if a new enough version is installed, we will build and install info.
  228. * Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
  229. - Built R 2.1.0. R now supports internationalization, so the patch
  230. to set the locale to "C" is now dropped.
  231. - install.packages() exits gracefully with a helpful message if
  232. the file INSTALL is not present, so this is now included in the
  233. R-devel package.
  234. * Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
  235. - Added support for Scientific Linux (http://www.scientificlinux.org)
  236. A distribution based on RHEL. Thanks to Jon Peatfield.
  237. * Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
  238. - Fixed file ownership in R-devel and libRmath packages
  239. * Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
  240. - R-devel package is now a stub package with no files, except a documentation
  241. file (RPM won't accept sub-packages with no files). R now conflicts
  242. with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
  243. - Created libRmath subpackage with shared library.
  244. * Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
  245. - Created R-devel and libRmath-devel subpackages
  246. * Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
  247. - Built R 2.0.1
  248. * Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
  249. - Set R_PRINTCMD at configure times so that by default getOption(printcmd)
  250. gives "lpr".
  251. - Define macro fcx for all Fedora distributions. This replaces Rinfo
  252. * Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
  253. - Info support is now conditional on the macro Rinfo, which is only
  254. defined for Fedora 1 and 2.
  255. * Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
  256. - Built R 2.0.0
  257. - There is no longer a BUGS file, so this is not installed as a
  258. documentation file.