librsvg2-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385
  1. %define __libtoolize :
  2. %define libxml2_version 2.7.8
  3. %define gdk_pixbuf2 2.26.1
  4. %define gtk3_version 3.4.1
  5. %define freetype_version 2.4.2
  6. %define popt_version 1.14
  7. %define libart_version 2.3.21
  8. %define cairo_version 1.12.0
  9. %define dbus_version 1.4.0
  10. %define dbus_glib_version 0.88
  11. %define avahi_glib_version 0.6.23
  12. %define libcroco_version 0.6.2
  13. %define libgsf_version 1.14.19
  14. Name: librsvg2
  15. Summary: An SVG library based on libart.
  16. Summary(ja): libart ベースの SVG ライブラリ
  17. Version: 2.40.1
  18. Release: 2%{?_dist_release}
  19. License: LGPL
  20. Group: System Environment/Libraries
  21. Source: librsvg-%{version}.tar.xz
  22. Requires(post,postun): gtk3 >= %{gtk3_version}
  23. Requires(post): dbus-glib >= %{dbus_glib_version}
  24. Requires(post): avahi-glib >= %{avahi_glib_version}
  25. Requires(post): libgsf, libcroco
  26. Requires: gtk3 >= %{gtk3_version}
  27. Requires: libxml2 >= %{libxml2_version}
  28. Requires: popt >= %{popt_version}
  29. Requires: freetype2 >= %{freetype_version}
  30. Requires: libpng
  31. BuildRequires: libpng-devel
  32. BuildRequires: gtk3-devel >= %{gtk3_version}
  33. BuildRequires: gobject-introspection-devel
  34. BuildRequires: libxml2-devel >= %{libxml2_version}
  35. BuildRequires: freetype2-devel >= %{freetype_version}
  36. BuildRequires: cairo-devel >= %{cairo_version}
  37. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  38. BuildRequires: avahi-glib-devel >= %{avahi_glib_version}
  39. BuildRequires: libcroco-devel >= %{libcroco_version}
  40. BuildRequires: libgsf-devel >= %{libgsf_version}
  41. BuildRequires: autoconf
  42. BuildRequires: gtk-doc
  43. BuildRequires: vala-devel
  44. BuildRequires: vala-tools
  45. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  46. Vendor: Project Vine
  47. Distribution: Vine Linux
  48. %description
  49. An SVG library based on libart.
  50. %description -l ja
  51. libart ベースの SVG ライブラリです
  52. %package devel
  53. Summary: Libraries and include files for developing with librsvg.
  54. Summary(ja): librsvg の開発用ライブラリおよびヘッダファイル
  55. Group: Development/Libraries
  56. Requires: %{name} = %{version}
  57. Requires: gdk-pixbuf2-devel >= %{gdk_pixbug2_version}
  58. Requires: cairo-devel >= %{cairo_version}
  59. %description devel
  60. This package provides the necessary development libraries and include
  61. files to allow you to develop with librsvg.
  62. %package docs
  63. Summary: Documentation for %{name}
  64. Summary(ja): %{name} 用のドキュメント
  65. Group: Documentation
  66. Requires: %{name} = %{version}-%{release}
  67. BuildArch: noarch
  68. %description docs
  69. This package contains documentation for %{name}.
  70. %package vala
  71. Summary: Vala bindings for %{name}
  72. Summary(ja): %{name} の Vala バインディング
  73. Group: Development/Libraries
  74. Requires: %{name} = %{version}-%{release}
  75. Requires: vala
  76. %description vala
  77. Vala bindings for %{name}.
  78. %prep
  79. %setup -q -n librsvg-%{version}
  80. %build
  81. sed -i "s|0.17.1.26|0.20|" configure.in
  82. autoreconf -if
  83. %configure --enable-gtk-doc \
  84. --enable-introspection=yes \
  85. --enable-vala=yes \
  86. --with-svgz \
  87. --enable-gtk-theme \
  88. --with-croco \
  89. --disable-static
  90. %__make %{?_smp_mflags}
  91. %install
  92. rm -rf $RPM_BUILD_ROOT
  93. make install DESTDIR=$RPM_BUILD_ROOT
  94. rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
  95. rm -f $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/*/loaders/libpixbuf*.*a
  96. rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gtk-2.0/gdk-pixbuf.loaders
  97. %clean
  98. rm -rf $RPM_BUILD_ROOT
  99. %post
  100. /sbin/ldconfig
  101. if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
  102. /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
  103. fi ||:
  104. %postun
  105. /sbin/ldconfig
  106. if [ -x /usr/bin/gdk-pixbuf-query-loaders ]; then
  107. /usr/bin/gdk-pixbuf-query-loaders --update-cache || :
  108. fi ||:
  109. %files
  110. %defattr(-,root,root,-)
  111. %doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
  112. %{_bindir}/rsvg-convert
  113. %{_bindir}/rsvg-view-3
  114. %{_libdir}/librsvg-2.so.*
  115. %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so
  116. %{_libdir}/girepository-1.0/Rsvg-2.0.typelib
  117. %{_mandir}/man1/rsvg-convert.1.gz
  118. %files devel
  119. %defattr(-,root,root,-)
  120. %{_libdir}/librsvg-2.so
  121. %{_includedir}/librsvg-2.0/librsvg
  122. %{_libdir}/pkgconfig/librsvg-2.0.pc
  123. %{_datadir}/gir-1.0/Rsvg-2.0.gir
  124. %files docs
  125. %defattr(-,root,root,-)
  126. %{_datadir}/gtk-doc/html/rsvg-2.0
  127. %files vala
  128. %defattr(-,root,root,-)
  129. %{_datadir}/vala/vapi/librsvg-2.0.vapi
  130. %changelog
  131. * Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-2
  132. - fix typo
  133. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.1-1
  134. - new upstream release
  135. - remove BuildRequires: gtk2-devel
  136. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-2
  137. - add BuildRequires: autoconf, gtk-doc, vala-devel, vala-tools
  138. - create %%{name}-docs and %%{name}-vala subpackages
  139. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
  140. - new upstream release
  141. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
  142. - new upstream release
  143. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
  144. - new upstream release
  145. * Sun Nov 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
  146. - new upstream release
  147. - add BuildRequires: gobject-introspection-devel
  148. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
  149. - new upstream release
  150. - remove Patch0
  151. * Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
  152. - new upstream release
  153. - add Patch0 (librsvg2-2.34.0-git20110728.patch)
  154. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  155. - new upstream release
  156. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  157. - new upstream release
  158. - remove BuildRequires: popt, libart_lgpl, libgnomeui-devel, gnome-vfs2-devel
  159. - remove Requires: libart_lgpl
  160. - add configure option (--disable-static)
  161. - remove unrecognized configure option (--enable-gnome-vfs, --disable-mozilla-plugins)
  162. - fix %install, %files, %post and %postun
  163. * Wed Sep 22 2010 IWAI, Masaharu <iwai@alib.jp> 2.26.3-1
  164. - build with rpm-4.8.1-1 for pkg-config file
  165. * Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.3-1
  166. - new upstream release
  167. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  168. - new upstream release
  169. - remove static libs
  170. * Sun Oct 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.3-1vl5
  171. - new upstream release
  172. - spec in UTF-8
  173. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.2-1vl5
  174. - new upstream release
  175. * Sat Mar 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl2
  176. - rebuilt with libgsf-1.14.8
  177. * Sat Sep 8 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  178. - new upstream release
  179. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.1-0vl1
  180. - new upstream release
  181. - add BuildRequires: dbus-glib-devel, avahi-glib-devel
  182. - add BuildRequires: libgsf-devel, libcroco-devel
  183. - add Requires(post): dbus-glib, avahi-glib, libgsf, libcroco
  184. - add Requires(post,postun): glib2
  185. * Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl5
  186. - rebuild with gtk+-2.10
  187. * Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl4
  188. - rebuilt without libgsf-devel
  189. * Tue Jun 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.4-0vl3
  190. - update %%post scripts to use %%{_sysconfdir}/gtk-2.0/%%{_arch}/gd-pixbuf.loaders
  191. for biarch support. (TODO: add compat32)
  192. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.4-0vl2
  193. - rebuild
  194. * Mon May 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.4-0vl1
  195. - new upstream release
  196. * Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
  197. - new upstream release
  198. * Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
  199. - new upstream release
  200. * Wed Oct 12 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.7-0vl1
  201. - new upstream release
  202. - added --disable-gtk-doc option
  203. * Sat Oct 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
  204. - new upstream release
  205. - added gtk-doc to devel package
  206. * Sun Oct 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.3-0vl1
  207. - new upstream release
  208. - added Japanese description
  209. - added --without-svgz option (because it requires libgsf)
  210. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
  211. - new upstream release
  212. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  213. - new upstream release
  214. * Fri Jun 18 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.0-0vl4
  215. - rebuilt to avoid unwanted dependency (libgsf)
  216. * Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl3
  217. - add gdk-pixbuf-query-loaders to post/postun script.
  218. * Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl2
  219. - rebuild with gtk+-2.4.0
  220. * Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  221. - new upstream release
  222. * Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl2
  223. - fix kanji code of spec file
  224. - fix file entry, add missing files
  225. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
  226. - new upstream release
  227. * Sat Jul 12 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl2
  228. - added --without-svgz and --without-gimp to %configure
  229. * Thu Jul 10 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.5-0vl1
  230. - new upstream release
  231. - added %{_bindir}/rsvg and %{_mandir}/man1/* to main package
  232. - added %{_libdir}/gtk-2.0/* to devel package
  233. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  234. - new upstream release
  235. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
  236. - new upstream release
  237. * Fri Jan 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
  238. - new upstream release
  239. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.2-0vl1
  240. - build for Vine Linux
  241. - new upstream release from gnome-2.1.4
  242. * Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
  243. - 2.0.1
  244. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  245. - automated rebuild
  246. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  247. - automated rebuild
  248. * Tue May 21 2002 Havoc Pennington <hp@redhat.com>
  249. - rebuild in different environment
  250. * Thu May 02 2002 Havoc Pennington <hp@redhat.com>
  251. - rebuild in different environment
  252. * Thu Apr 18 2002 Havoc Pennington <hp@redhat.com>
  253. - 1.1.6
  254. * Mon Feb 11 2002 Alex Larsson <alexl@redhat.com> 1.1.3-1
  255. - Update to 1.1.3
  256. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  257. - automated rebuild
  258. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  259. - new CVS snap 1.1.0.91
  260. - remove automake/autoconf calls
  261. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  262. - convert to librsvg2 RPM
  263. * Tue Oct 23 2001 Havoc Pennington <hp@redhat.com>
  264. - 1.0.2
  265. * Fri Jul 27 2001 Alexander Larsson <alexl@redhat.com>
  266. - Add a patch that moves the includes to librsvg-1/librsvg
  267. - in preparation for a later librsvg 2 library.
  268. * Tue Jul 24 2001 Havoc Pennington <hp@redhat.com>
  269. - build requires gnome-libs-devel, #49509
  270. * Thu Jul 19 2001 Havoc Pennington <hp@redhat.com>
  271. - own /usr/include/librsvg
  272. * Wed Jul 18 2001 Akira TAGOH <tagoh@redhat.com> 1.0.0-4
  273. - fixed the linefeed problem in multibyte environment. (Bug#49310)
  274. * Mon Jul 09 2001 Havoc Pennington <hp@redhat.com>
  275. - put .la file back in package
  276. * Fri Jul 6 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  277. - Put changelog at the end
  278. - Move .so files to devel subpackage
  279. - Don't mess with ld.so.conf
  280. - Don't use %%{prefix}, this isn't a relocatable package
  281. - Don't define a bad docdir
  282. - Add BuildRequires
  283. - Use %%{_tmppath}
  284. - Don't define name, version etc. on top of the file (why do so many do that?)
  285. - s/Copyright/License/
  286. * Wed May 9 2001 Jonathan Blandford <jrb@redhat.com>
  287. - Put into Red Hat Build system
  288. * Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
  289. - removed obsoletes from sub packages and added mozilla and trilobite
  290. subpackages
  291. * Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
  292. - created this thing