proftpd-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599
  1. %bcond_with systemd
  2. %if %{with systemd}
  3. %define rundir /run
  4. %else
  5. %define rundir /var/run
  6. %endif
  7. %define _prefix /usr
  8. %define _localstatedir %{rundir}
  9. %define _sysconfdir /etc
  10. %define _rundir %{rundir}/proftpd
  11. %define tarballversion 1.3.8a
  12. %define origversion 1.3.8a
  13. Summary: ProFTPd -- Professional FTP Server.
  14. Summary(ja): ProFTPd -- プロフェッショナル FTP サーバ
  15. Name: proftpd
  16. Epoch: 1
  17. Version: %{origversion}
  18. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  19. Group: servers,internet
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. License: GPL
  23. URL: http://www.proftpd.org/
  24. Source0: https://github.com/proftpd/proftpd/archive/v%{origversion}.tar.gz#/%{name}-%{origversion}.tar.gz
  25. Source1: proftpd.vine.conf
  26. Source2: ftpusers.vine
  27. Source3: proftpd.init
  28. Source5: welcome.msg
  29. # upstream bug fixes & security fixes
  30. # fedora patches
  31. Patch1: proftpd-1.3.7b-shellbang.patch
  32. # auth
  33. Patch201: proftpd-1.3.1-use-system-auth-instead-of-pam_pwdb.patch
  34. # fix build on recent kernel headers
  35. # Patch400: proftpd-1.3.1-umode.patch
  36. # security fix
  37. # nothing..
  38. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  39. BuildRequires: pam-devel, openldap-devel, openssl-devel
  40. BuildRequires: ncurses-devel, libcap-devel, libacl-devel
  41. BuildRequires: e2fsprogs-devel
  42. Requires: pam > 0.59
  43. Obsoletes: wu-ftpd, anonftp
  44. Provides: ftpserver
  45. %description
  46. ProFTPd is an enhanced FTP server with a focus toward simplicity,
  47. security, and ease of configuration. It features a very Apache-like
  48. configuration syntax, and a highly customizable server infrastructure,
  49. including support for multiple 'virtual' FTP servers, anonymous FTP,
  50. and permission-based directory visibility.
  51. %description -l ja
  52. ProFTPd は シンプルさ, セキュリティ, 設定の容易さに焦点をあてた 優れた
  53. FTP サーバです。Apache に似た構文による設定や、複数の仮想 FTP サーバ、
  54. anonymous FTP, パーミッションベースのディレクトリ可視性のサポートを含む、
  55. 高度にカスタマイズ可能なサーバ・インターフェイスを特徴としています。
  56. %package utils
  57. Summary: ProFTPD - Additional utilities
  58. Group: admin-tools
  59. Requires: %{name} = %{epoch}:%{version}-%{release}
  60. %description utils
  61. This package contains additional utilities for monitoring and configuring the
  62. ProFTPD server:
  63. * ftpasswd: generate passwd(5) files for use with AuthUserFile
  64. * ftpcount: show the current number of connections per server/virtualhost
  65. * ftpmail: monitor transfer log and send email when files uploaded
  66. * ftpquota: manipulate quota tables
  67. * ftptop: show the current status of FTP sessions
  68. * ftpwho: show the current process information for each FTP session
  69. %debug_package
  70. %prep
  71. %setup -q -n %{name}-%{tarballversion}
  72. find . -type d -name CVS | xargs -r rm -frv
  73. # Avoid documentation name conflicts
  74. mv contrib/README contrib/README.contrib
  75. # Change shellbangs /usr/bin/env perl ⇒ /usr/bin/perl
  76. %patch1
  77. # upstream fixes
  78. %if %{with systemd}
  79. # Tweak logrotate script for systemd compatibility (#802178)
  80. sed -i -e '/killall/s/test.*/systemctl reload proftpd.service/' \
  81. contrib/dist/rpm/proftpd.logrotate
  82. %endif
  83. # Avoid docfile dependencies
  84. chmod -c -x contrib/xferstats.holger-preiss
  85. # Remove bogus exec permissions from source files
  86. chmod -c -x include/hanson-tpl.h lib/hanson-tpl.c
  87. # Remove any patch backup files from documentation
  88. find doc/ contrib/ -name '*.orig' -delete
  89. ## patches from mdk
  90. # use system-auth instead of pam_pwdb
  91. %patch201 -p1
  92. %build
  93. # Disable stripping in order to get useful debuginfo packages
  94. %{__perl} -pi -e 's|"-s"|""|g' configure
  95. %configure \
  96. --libexecdir="%{_libexecdir}/proftpd" \
  97. --localstatedir="%{rundir}/proftpd" \
  98. --disable-strip \
  99. --enable-ctrls \
  100. --enable-facl \
  101. --enable-dso \
  102. --enable-nls \
  103. --enable-ipv6 \
  104. --enable-openssl \
  105. --disable-pcre \
  106. --disable-redis \
  107. --enable-shadow \
  108. --with-modules=mod_readme:mod_auth_pam:mod_tls:\
  109. mod_ban:mod_dynmasq:mod_load:mod_ratio:mod_rewrite \
  110. --with-shared=mod_ldap:mod_quotatab:mod_quotatab_file:mod_quotatab_ldap
  111. # It seems that with _smp_mflags -lsupp tries to get linked before being built
  112. # (as of 1.3.0a-4 F7/devel with koji, happened on F8 x86_64 and F7 ppc64)
  113. %{__make}
  114. %install
  115. %{__rm} -rf %{buildroot}
  116. %{__make} install DESTDIR=%{buildroot} \
  117. rundir="%{rundir}/proftpd" \
  118. INSTALL_USER=`id -un` \
  119. INSTALL_GROUP=`id -gn`
  120. # auth
  121. mkdir -p %{buildroot}%{_sysconfdir}/pam.d
  122. %{__install} -m 644 contrib/dist/rpm/ftp.pamd %{buildroot}%{_sysconfdir}/pam.d/ftp
  123. # logrotate
  124. mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
  125. %{__install} -m 644 contrib/dist/rpm/proftpd.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/proftpd
  126. %{__install} -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/proftpd.conf
  127. %{__install} -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/ftpusers
  128. %{__install} -D -p -m 0644 %{SOURCE5} %{buildroot}/%{_var}/ftp/welcome.msg
  129. touch %{buildroot}%{_sysconfdir}/ftpusers
  130. %if %{with systemd}
  131. install -D -p -m 644 contrib/dist/rpm/proftpd.service \
  132. %{buildroot}%{_unitdir}/proftpd.service
  133. install -D -p -m 644 contrib/dist/systemd/proftpd.socket \
  134. %{buildroot}%{_unitdir}/proftpd.socket
  135. install -D -p -m 644 contrib/dist/systemd/proftpd@.service \
  136. %{buildroot}%{_unitdir}/proftpd@.service
  137. install -d -m 755 %{buildroot}%{_tmpfilesdir}
  138. install -p -m 644 contrib/dist/rpm/proftpd-tmpfs.conf \
  139. %{buildroot}%{_tmpfilesdir}/proftpd.conf
  140. %else
  141. # init.d
  142. %{__install} -D -p -m 0755 %{SOURCE3} \
  143. %{buildroot}%{_sysconfdir}/rc.d/init.d/proftpd
  144. %endif
  145. rm contrib/README.* || :
  146. # eliminate executable bit in %doc
  147. find doc/ sample-configurations/ -type f -perm +111 | xargs -r chmod -x
  148. # remove .{la,a}
  149. rm -f %{buildroot}%{_libexecdir}/proftpd/*.{la,a}
  150. # remove development files (headers and pkgconfig file)
  151. # who need these files?
  152. rm -rf %{buildroot}%{_includedir}/proftpd
  153. rm -rf %{buildroot}%{_libdir}/pkgconfig
  154. # Find translations
  155. %find_lang proftpd
  156. %clean
  157. rm -rf %{buildroot}
  158. %preun
  159. %if %{with systemd}
  160. if [ $1 -eq 0 ]; then
  161. systemctl --no-reload disable proftpd.service &>/dev/null || :
  162. systemctl stop proftpd.service &>/dev/null || :
  163. fi
  164. %else
  165. if [ $1 = 0 -o -x /bin/systemctl ] ; then
  166. /sbin/service proftpd stop &>/dev/null || :
  167. /sbin/chkconfig --del proftpd || :
  168. fi
  169. %endif
  170. if [ -d %{_rundir} ] ; then
  171. rm -rf %{_rundir}/*
  172. fi
  173. %postun
  174. %if %{with systemd}
  175. systemctl daemon-reload &>/dev/null || :
  176. if [ $1 -ge 1 ]; then
  177. systemctl try-restart proftpd.service &>/dev/null || :
  178. fi
  179. %else
  180. if [ $1 -ge 1 ]; then
  181. /sbin/service proftpd condrestart
  182. fi
  183. %endif
  184. %post
  185. %if %{with systemd}
  186. systemctl daemon-reload &>/dev/null || :
  187. systemctl preset proftpd.service &>/dev/null || :
  188. %else
  189. /sbin/chkconfig --add proftpd
  190. %endif
  191. %files -f proftpd.lang
  192. %defattr(-,root,root)
  193. %license COPYING
  194. %doc CREDITS ChangeLog NEWS README.md
  195. %doc README.{md,LDAP,modules}
  196. %doc doc/*
  197. %doc contrib/README.contrib contrib/README.ratio
  198. %doc sample-configurations/
  199. %{_sbindir}/*
  200. %{_bindir}/ftpdctl
  201. %{_bindir}/prxs
  202. %{_mandir}/man5/proftpd.conf.5*
  203. %{_mandir}/man5/xferlog.5*
  204. %{_mandir}/man8/ftpdctl.8*
  205. %{_mandir}/man8/ftpscrub.8*
  206. %{_mandir}/man8/ftpshut.8*
  207. %{_mandir}/man8/proftpd.8*
  208. %{_var}/ftp/welcome.msg
  209. %dir %{_libexecdir}/proftpd/
  210. %{_libexecdir}/proftpd/mod_*
  211. %dir %{_var}/ftp
  212. %if %{with systemd}
  213. %{_unitdir}/proftpd.service
  214. %{_unitdir}/proftpd.socket
  215. %{_unitdir}/proftpd@.service
  216. %{_tmpfilesdir}/proftpd.conf
  217. %else
  218. %config %{_sysconfdir}/rc.d/init.d/proftpd
  219. %dir %{_rundir}
  220. %endif
  221. %config(noreplace) %{_sysconfdir}/pam.d/ftp
  222. %config(noreplace) %{_sysconfdir}/proftpd.conf
  223. %config(noreplace) %{_sysconfdir}/ftpusers
  224. %config(noreplace) %{_sysconfdir}/logrotate.d/proftpd
  225. %files utils
  226. %doc contrib/xferstats.holger-preiss
  227. %{_bindir}/ftpasswd
  228. %{_bindir}/ftpcount
  229. %{_bindir}/ftpmail
  230. %{_bindir}/ftpquota
  231. %{_bindir}/ftptop
  232. %{_bindir}/ftpwho
  233. %{_mandir}/man1/ftpasswd.1*
  234. %{_mandir}/man1/ftpcount.1*
  235. %{_mandir}/man1/ftpmail.1*
  236. %{_mandir}/man1/ftpquota.1*
  237. %{_mandir}/man1/ftptop.1*
  238. %{_mandir}/man1/ftpwho.1*
  239. %changelog
  240. * Mon Oct 09 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.8a-1
  241. - new upstream release.
  242. * Mon Dec 05 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.8-1
  243. - new upstream release.
  244. * Sun Nov 13 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.7e-2
  245. - rebuilt with openldap-2.6.3.
  246. * Sun Jul 24 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.7e-1
  247. - new upstream release.
  248. * Thu Apr 28 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.7d-1
  249. - new upstream release.
  250. * Wed Oct 06 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.7c-2
  251. - rebuilt with openssl-3.0.0.
  252. - imported Patch1 from rawhide.
  253. * Sat Sep 04 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.7c-1
  254. - new upstream release.
  255. * Thu Dec 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.7a-1
  256. - new upstream release.
  257. - added systemd support (disabled as default).
  258. - dropped Patch300.
  259. * Sat Feb 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.6c-1
  260. - new upstream release.
  261. * Thu Oct 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.6b-1
  262. - new upstream release.
  263. * Fri Mar 16 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.5e-1
  264. - new upstream release.
  265. - remake patch24 for 1.3.5e
  266. * Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.5b-1
  267. - new upstream release.
  268. - removed Patch14, Patch23 and Patch25 (no longer needed).
  269. - updated Patch300.
  270. * Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4b-2
  271. - fix util package dependency
  272. * Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4b-1
  273. - new upstream release
  274. - util tools in util subpackage
  275. - update patch300 to fit new version
  276. - add patch14, 23, 24, 25 from fc18 (thanks to fc team)
  277. - add enable-nls in configure
  278. * Sun Apr 24 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.3e-1
  279. - new upstream release
  280. - update patch300 to fit new version
  281. - drop patch1000 (is included in new release)
  282. - add BR: e2fsprogs-devel
  283. * Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2e-2
  284. - rebuild with openssl-1.0.0c
  285. * Fri Nov 5 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2e-1
  286. - new upstream release
  287. - add patch1000 for CVE-2010-4221 (TELNET_IAC)
  288. - add BRs: ncurses-devel, libcap-devel, libacl-devel
  289. * Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2c-1
  290. - new upstream release with security fix (CVE-2009-3555)
  291. * Wed Oct 21 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2b-1
  292. - new upstream release with security fix (NULL char in X.509 certificate)
  293. - add chkconfig --add in post script
  294. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2a-3
  295. - remove .{la,a}
  296. - remove headers and pkgconfig file
  297. * Mon Jul 6 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-2
  298. - update Source1 (sample config file for vine)
  299. set default char set to UTF-8
  300. * Fri Jul 3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-1
  301. - new upstream release
  302. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
  303. - rebuild with openldap-2.4.11
  304. * Tue Mar 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-2
  305. - built with openssl-0.9.8k
  306. * Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-1
  307. - new upstream release
  308. - add configure option to activate new modules
  309. - drop patch400
  310. * Wed Jan 14 2009 Shu KONNO <owa@bg.wakwak.com> 1.3.1-6
  311. - built with openssl-0.9.8j
  312. * Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5
  313. - built with openssl-0.9.8i
  314. * Sun Aug 10 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.1-4
  315. - add Patch400 to fix build failure at least on i386
  316. - spec in UTF-8
  317. * Tue Jul 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-3
  318. - built with openssl-0.9.8h
  319. * Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-2
  320. - update proftpd.vine.conf (use DisplayChdir instead of DisplayFirstChdir)
  321. * Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-1
  322. - new upstream release
  323. - drop old patches which are included in new release
  324. - update patch201, 300
  325. - build under new versioning policy
  326. * Mon Sep 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.0a-0vl1
  327. - new upstream release
  328. - built with openssl098
  329. - drop old (for 1.2.10) patches
  330. - Patch100-150 from FC8 package
  331. - Patch160-170 from upstream CVS (maybe will be fixed in 1.3.1)
  332. - update patch300 for 1.3.0
  333. - change configure option refer to FC8
  334. - add process reboot with message output when package is upgraded
  335. - docfiles list update
  336. - fix changelog ver number typo
  337. * Sun Sep 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-0vl6
  338. - add patch202 for fix timestamp (backport from 1.3.0rc1 #2798)
  339. (<WISHES:15>)
  340. - add Vendor/Distribution tag
  341. - add patch104 for fix pr_ctrls_recv_request issue
  342. - add patch103 for fix CVE-2006-6170
  343. - add patch102 for fix CVE-2006-5815
  344. - add patch101 for fix CVE-2006-6171
  345. * Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl5
  346. - rebuilt with openldap-2.3.27-0vl
  347. * Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 1.2.10-0vl4
  348. - rebuilt with openldap-2.3.24-0vl1
  349. * Sun May 14 2006 Shoji Matsumoto <shom@vinelinux.org> 1.2.10-0vl3
  350. - add patch300 for iconv patch
  351. * Thu Mar 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl2
  352. - enable mod_ldap
  353. - add BuildRequires: openldap-devel, openssl-devel
  354. - add Patch200 from MDK to support ldap
  355. - add Patch201 from MDK to use system-auth instead of pam_pwdb
  356. (pam_pwdb is now obsolete, and will be removed in the future pam version)
  357. * Fri Sep 09 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
  358. - 1.2.10-0vl1.1
  359. - add patch100 for fix CAN-2005-2390
  360. * Sun Sep 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl1
  361. - new upstream release
  362. * Tue Aug 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl0.3
  363. - new upstream release (1.2.10rc3)
  364. - build for Vine Linux 3.0
  365. * Fri May 21 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.10-0vl0.1
  366. - new upstream release
  367. - fix security issue: http://secunia.com/advisories/11527/
  368. * Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
  369. - new upstream release
  370. * Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8p-0vl1
  371. - new upstream release
  372. - fix security issue: http://xforce.iss.net/xforce/alerts/id/154
  373. * Sun Mar 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
  374. - new upstream release
  375. * Fri Dec 6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
  376. - new upstream release 1.2.7
  377. - add logrotate config file.
  378. - move ftp home directory from /home/ftp to /var/ftp
  379. * Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl1
  380. - new upstream release 1.2.6
  381. * Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl4
  382. - new upstream release 1.2.5 (stable release version)
  383. * Mon Jun 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
  384. - new upstream release 1.2.5-rc3
  385. * Mon Jan 28 2002 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl2
  386. - eliminate executable bit in %doc (requierment for /usr/bin/perl)
  387. - put files in sample-configurations/ to the according directory
  388. - remove unnecessary README.* files
  389. * Thu Dec 20 2001 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl1
  390. - updated to 1.2.5rc1 for problems in file globbing
  391. * Sun Oct 21 2001 Toru Sagami <sagami@vinelinux.org>
  392. - 1.2.4-0vl1
  393. * Fri Oct 19 2001 Toru Sagami <sagami@vinelinux.org>
  394. - 1.2.3-0vl1
  395. * Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
  396. - 1.2.2-0vl1: update to 1.2.2 release
  397. - added more documents
  398. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl0.rc3
  399. - update to 1.2.2rc3
  400. - use macros
  401. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  402. - 1.2.1-0vl3
  403. - rebuilt for VineSeed
  404. * Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.1-0vl2]
  405. - update to 1.2.1
  406. * Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl2]
  407. - build for VineSeed
  408. * Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl1]
  409. - update to 1.2.0
  410. - set Epoch 1 to update from pre* and rc* version
  411. * Tue Feb 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  412. - 1.2.0rc3-0vl3
  413. - removed PreReq and postun about /etc/ftpusers stuff
  414. * Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl3]
  415. - remove setup of /etc/ftpusers in %%pre script
  416. - add ftpusers.vine insted of the %%pre script
  417. - remove contrib/README.* frpm %%files
  418. - add BuildRequires: pam-devel
  419. * Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl2]
  420. - rebuild for VineSeed
  421. * Wed Feb 07 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl1]
  422. - update to 1.2.0rc3
  423. - add 'TimesGMT FALSE' in default configuration file
  424. - build on Vine 2.1
  425. * Mon Feb 05 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  426. - modified pre script to make it run by bash2 and added PreReq
  427. - remove /etc/ftpusers after uninstall
  428. * Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  429. - 1.2.0rc2-0vl8
  430. - rebuilt on VineSeed
  431. * Thu Feb 01 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl7]
  432. - remove patch from CVS to avoid 'after 5min data brake'
  433. - add passive patch insted of abobe CVS patch
  434. - revival contribute's proftpd.init.d
  435. * Tue Jan 23 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl6]
  436. - fixed %pre script and remove /etc/ftpusers from files
  437. - modify Japanese summary and descriptions
  438. * Sun Dec 03 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  439. - actually fixed to make the package relocatable.
  440. - non-root build failure by broken %prein, which should be %pre.
  441. - dont include CVS directory in doc
  442. - add %config /etc/rc.d/init.d/proftpd
  443. * Tue Nov 14 2000 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl4]
  444. - correct config directive of the init.d script
  445. * Wed Oct 18 2000 Yoshihiro Kajiki <kajiki@ylug.org> [1.2.0rc2-0vl3]
  446. - adopt current patch from CVS to avoid the 'put on passive mode' probrem
  447. * Sun Jul 30 2000 Jun Nishii <jun@vinelinux.org>
  448. - 1.2.0rc2-0vl1
  449. - obsoletes anonftp
  450. - do not chkconfig --add in %post
  451. - requires: pam
  452. - added proftpd.vine.conf
  453. * Fri Jul 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  454. - libtoolize for alpha
  455. * Sat Jul 15 2000 Kazuhisa TAKEI<takei@vinelinux.org>
  456. - [1.2.0rc2]
  457. * Wed Jun 28 2000 Kazuhisa TAKEI<takei@vinelinux.org>
  458. - repackaging for VineLinux
  459. * Sun Oct 3 1999 O.Elliyasa <osman@Cable.EU.org>
  460. - Multi package creation.
  461. Created core, standalone, inetd (&doc) package creations.
  462. Added startup script for init.d
  463. Need to make the "standalone & inetd" packages being created as "noarch"
  464. - Added URL.
  465. - Added prefix to make the package relocatable.
  466. * Wed Sep 8 1999 O.Elliyasa <osman@Cable.EU.org>
  467. - Corrected inetd.conf line addition/change logic.
  468. * Sat Jul 24 1999 MacGyver <macgyver@tos.net>
  469. - Initial import of spec.