opencv-vl.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717
  1. %bcond_with test
  2. %bcond_without gstreamer
  3. #global indice a
  4. Name: opencv
  5. Version: 4.3.0
  6. Release: 1%{?_dist_release}
  7. Summary: Collection of algorithms for computer vision
  8. Summary(ja): コンピュータビジョン用のアルゴリズム集
  9. Group: System Environment/Libraries
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. # This is normal three clause BSD.
  13. License: BSD
  14. URL: https://opencv.org
  15. # Need to remove SIFT/SURF from source tarball, due to legal concerns
  16. # rm -f opencv-%%{version}/modules/nonfree/src/sift.cpp
  17. # rm -f opencv-%%{version}/modules/nonfree/src/surf.cpp
  18. # Removed because we don't use pre-built contribs
  19. # rm -rf 3rdparty
  20. #Source0: http://downloads.sourceforge.net/opencvlibrary/opencv-unix/%{version}/%{name}-%{version}%{?indice}.zip
  21. Source0: %{name}-clean-%{version}.tar.gz
  22. Source1: %{name}_contrib-clean-%{version}.tar.gz
  23. Source2: %{name}_extra-clean-%{version}.tar.gz
  24. Source3: face_landmark_model.dat.xz
  25. # from https://github.com/opencv/ade/archive/v0.1.1f.zip
  26. Source4: b624b995ec9c439cbc2e9e6ee940d3a2-v0.1.1f.zip
  27. Source5: xorg.conf
  28. Patch0: opencv-4.1.0-install_3rdparty_licenses.patch
  29. Patch1: https://patch-diff.githubusercontent.com/raw/opencv/opencv/pull/17431.patch
  30. Patch2: https://patch-diff.githubusercontent.com/raw/opencv/opencv_contrib/pull/2549.patch
  31. # Comment out removed vulkan symbols
  32. Patch3: opencv_vulkan.patch
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  34. BuildRequires: libtool
  35. BuildRequires: cmake >= 2.6.3
  36. BuildRequires: chrpath
  37. BuildRequires: eigen3-devel
  38. BuildRequires: libtheora-devel
  39. BuildRequires: libvorbis-devel
  40. #BuildRequires: libraw1394-devel
  41. #BuildRequires: libdc1394-devel
  42. BuildRequires: jasper-devel
  43. BuildRequires: libpng-devel
  44. BuildRequires: libjpeg-devel
  45. BuildRequires: libtiff-devel
  46. BuildRequires: libv4l-devel
  47. BuildRequires: libwebp-devel
  48. BuildRequires: mesa-libGL-devel
  49. BuildRequires: OpenEXR-devel
  50. #ifarch %{ix86} x86_64
  51. #BuildRequires: openni-devel
  52. #BuildRequires: openni-primesense
  53. #endif
  54. BuildRequires: tbb-devel
  55. BuildRequires: qt5-qtbase-devel
  56. BuildRequires: freetype2-devel
  57. BuildRequires: harfbuzz-devel
  58. BuildRequires: zlib-devel pkgconfig
  59. BuildRequires: python3-devel
  60. BuildRequires: python3-setuptools
  61. BuildRequires: python3-rpm-macros
  62. BuildRequires: python3-numpy
  63. BuildRequires: swig >= 1.3.24
  64. #BuildRequires: python-sphinx
  65. #BuildRequires: ffmpeg-devel >= 0.4.9
  66. BuildRequires: gstreamer1-devel
  67. BuildRequires: gstreamer1-plugins-base-devel
  68. #BuildRequires: xine-lib-devel
  69. #BuildRequires: opencl-headers
  70. Requires: opencv-core = %{version}-%{release}
  71. %description
  72. OpenCV means Intel® Open Source Computer Vision Library. It is a collection of
  73. C functions and a few C++ classes that implement some popular Image Processing
  74. and Computer Vision algorithms.
  75. %package core
  76. Summary: OpenCV core libraries
  77. Summary(ja): OpenCV コアライブラリ
  78. Group: System Environment/Libraries
  79. Obsoletes: %{name}-python < %{version}-%{release}
  80. %description core
  81. This package contains the OpenCV C/C++ core libraries.
  82. %package devel
  83. Summary: Development files for using the OpenCV library
  84. Summary(ja): OpenCV ライブラリを使用するための開発用ファイル
  85. Group: Development/Libraries
  86. Requires: opencv = %{version}-%{release}
  87. %description devel
  88. This package contains the OpenCV C/C++ library and header files, as well as
  89. documentation. It should be installed if you want to develop programs that
  90. will use the OpenCV library. You should consider installing opencv-devel-docs
  91. package.
  92. %package -n python3-opencv
  93. Summary: Python bindings for apps which use OpenCV
  94. Summary(ja): OpenCV を使用するアプリケーション用の Python バインディング
  95. Group: Development/Libraries
  96. Requires: opencv = %{version}-%{release}
  97. Requires: python3-numpy
  98. %description -n python3-opencv
  99. This package contains Python bindings for the OpenCV library.
  100. %package contrib
  101. Summary: OpenCV contributed functionality
  102. Summary(ja): 寄付された OpenCV の追加機能
  103. %description contrib
  104. This package is intended for development of so-called "extra" modules, contribut
  105. ed
  106. functionality. New modules quite often do not have stable API, and they are not
  107. well-tested. Thus, they shouldn't be released as a part of official OpenCV
  108. distribution, since the library maintains binary compatibility, and tries
  109. to provide decent performance and stability.
  110. %prep
  111. %setup -q -a1 -a2
  112. # we don't use pre-built contribs except quirc
  113. pushd 3rdparty
  114. shopt -s extglob
  115. rm -r !(openexr|openvx|quirc)
  116. shopt -u extglob
  117. popd &>/dev/null
  118. %patch0 -p1 -b .install_3rdparty_licenses
  119. %patch1 -p1
  120. %patch3 -p1
  121. pushd %{name}_contrib-%{version}
  122. %patch2 -p1
  123. popd
  124. # Install ADE, needed for opencv_gapi
  125. mkdir -p .cache/ade
  126. install -pm 0644 %{SOURCE4} .cache/ade/
  127. %build
  128. # enabled by default if libraries are presents at build time:
  129. # GTK, GSTREAMER, 1394, V4L
  130. # non available on Fedora: FFMPEG, XINE
  131. mkdir -p build
  132. pushd build
  133. rm -rf share/opencv4/testdata/cv/face
  134. mkdir -p share/opencv4/testdata/cv/face
  135. install -pm 0644 %{SOURCE3} share/opencv4/testdata/cv/face
  136. pushd share/opencv4/testdata/cv/face
  137. xz -d face_landmark_model.dat.xz
  138. popd
  139. # disabling IPP because it is closed source library from intel
  140. %cmake CMAKE_VERBOSE=1 \
  141. -DWITH_IPP=OFF \
  142. -DWITH_ITT=OFF \
  143. -DWITH_QT=ON \
  144. -DWITH_OPENGL=ON \
  145. -DOpenGL_GL_PREFERENCE=GLVND \
  146. -DWITH_GDAL=ON \
  147. -DWITH_OPENEXR=ON \
  148. -DWITH_UNICAP=ON \
  149. -DCMAKE_SKIP_RPATH=ON \
  150. -DWITH_CAROTENE=OFF \
  151. %ifnarch x86_64 ia64
  152. -DENABLE_SSE=0 \
  153. -DENABLE_SSE2=0 \
  154. %else
  155. -DCPU_BASELINE=SSE2 \
  156. %endif
  157. -DENABLE_PRECOMPILED_HEADERS=OFF \
  158. -DCMAKE_BUILD_TYPE=ReleaseWithDebInfo \
  159. -DBUILD_opencv_java=OFF \
  160. %{?with_tbb: -DWITH_TBB=ON } \
  161. %{!?with_gstreamer: -DWITH_GSTREAMER=OFF } \
  162. -DWITH_FFMPEG=OFF \
  163. %{?with_openni: -DWITH_OPENNI=ON } \
  164. -DWITH_XINE=OFF \
  165. -DBUILD_DOCS=OFF \
  166. -DBUILD_EXAMPLES=OFF \
  167. -DBUILD_opencv_python2=OFF \
  168. -DINSTALL_C_EXAMPLES=OFF \
  169. -DINSTALL_PYTHON_EXAMPLES=OFF \
  170. -DPYTHON3_EXECUTABLE=%{__python3} \
  171. -DPYTHON3_PACKAGES_PATH=%{python3_sitearch} \
  172. -DENABLE_PYLINT=ON \
  173. -DBUILD_PROTOBUF=OFF \
  174. -DPROTOBUF_UPDATE_FILES=ON \
  175. -DWITH_OPENCL=OFF \
  176. -DOPENCV_SKIP_PYTHON_LOADER=ON \
  177. -DOPENCV_EXTRA_MODULES_PATH=../opencv_contrib-%{version}/modules \
  178. -DWITH_LIBV4L=ON \
  179. -DWITH_OPENMP=ON \
  180. -DOPENCV_CONFIG_INSTALL_PATH=%{_lib}/cmake/OpenCV \
  181. -DOPENCV_GENERATE_PKGCONFIG=ON \
  182. -DOPENCV_TEST_DATA_PATH=opencv_extra-%{version}/testdata \
  183. %{?with_gdcm: -DWITH_GDCM=ON } \
  184. %{?with_libmfx: -DWITH_MFX=ON } \
  185. %{?with_clp: -DWITH_CLP=ON } \
  186. %{?with_va: -DWITH_VA=ON } \
  187. -DWITH_VTK=OFF \
  188. -DWITH_TBB=1 -DTBB_LIB_DIR=%{_libdir} \
  189. ..
  190. make VERBOSE=1 %{?_smp_mflags}
  191. popd
  192. %install
  193. rm -rf %{buildroot}
  194. %make_install -C build
  195. find %{buildroot} -name '*.la' -delete
  196. rm -rf %{buildroot}%{_datadir}/OpenCV/licenses/
  197. %if %{with test}
  198. %check
  199. # Check fails since we don't support most video
  200. # read/write capability and we don't provide a display
  201. # ARGS=-V increases output verbosity
  202. pushd build
  203. cp %SOURCE5 .
  204. if [ -x /usr/libexec/Xorg ]; then
  205. Xorg=/usr/libexec/Xorg
  206. else
  207. Xorg=/usr/libexec/Xorg.bin
  208. fi
  209. $Xorg -noreset +extension GLX +extension RANDR +extension RENDER -logfile ./xorg.log -config ./xorg.conf -configdir . :99 &
  210. export DISPLAY=:99
  211. LD_LIBRARY_PATH=%{_builddir}/%{name}-%{version}/build/lib:$LD_LIBARY_PATH make test ARGS=-V || :
  212. popd
  213. %endif
  214. %clean
  215. rm -rf %{buildroot}
  216. %post core -p /sbin/ldconfig
  217. %postun core -p /sbin/ldconfig
  218. %post -p /sbin/ldconfig
  219. %postun -p /sbin/ldconfig
  220. %post contrib -p /sbin/ldconfig
  221. %postun contrib -p /sbin/ldconfig
  222. %files
  223. %doc README.md
  224. %{_bindir}/opencv_*
  225. %dir %{_datadir}/opencv4
  226. %{_datadir}/opencv4/haarcascades
  227. %{_datadir}/opencv4/lbpcascades
  228. %{_datadir}/opencv4/valgrind*
  229. %{_datadir}/opencv4/quality
  230. %files core
  231. %license LICENSE
  232. %{_datadir}/licenses/opencv4/
  233. %{_libdir}/libopencv_alphamat.so.*
  234. %{_libdir}/libopencv_core.so.*
  235. %{_libdir}/libopencv_cvv.so.*
  236. %{_libdir}/libopencv_features2d.so.*
  237. %{_libdir}/libopencv_flann.so.*
  238. %{_libdir}/libopencv_gapi.so.*
  239. %{_libdir}/libopencv_hfs.so.*
  240. %{_libdir}/libopencv_highgui.so.*
  241. %{_libdir}/libopencv_imgcodecs.so.*
  242. %{_libdir}/libopencv_imgproc.so.*
  243. %{_libdir}/libopencv_intensity_transform.so.*
  244. %{_libdir}/libopencv_ml.so.*
  245. %{_libdir}/libopencv_objdetect.so.*
  246. %{_libdir}/libopencv_photo.so.*
  247. %{_libdir}/libopencv_rapid.so.*
  248. %{_libdir}/libopencv_shape.so.*
  249. %{_libdir}/libopencv_stitching.so.*
  250. %{_libdir}/libopencv_superres.so.*
  251. %{_libdir}/libopencv_video.so.*
  252. %{_libdir}/libopencv_videoio.so.*
  253. %{_libdir}/libopencv_videostab.so.*
  254. %files devel
  255. %dir %{_includedir}/opencv4
  256. %{_includedir}/opencv4/opencv2
  257. %{_libdir}/lib*.so
  258. %{_libdir}/pkgconfig/opencv*.pc
  259. %{_libdir}/cmake/OpenCV/*.cmake
  260. %files -n python3-opencv
  261. %exclude %{_bindir}/setup_vars_opencv4.sh
  262. %{python3_sitearch}/cv2.cpython-3*.so
  263. %files contrib
  264. %{_libdir}/libopencv_aruco.so.*
  265. %{_libdir}/libopencv_bgsegm.so.*
  266. %{_libdir}/libopencv_bioinspired.so.*
  267. %{_libdir}/libopencv_calib3d.so.*
  268. %{_libdir}/libopencv_ccalib.so.*
  269. %{_libdir}/libopencv_datasets.so.*
  270. # needs protobuf
  271. #{_libdir}/libopencv_dnn.so.*
  272. #{_libdir}/libopencv_dnn_objdetect.so.*
  273. #{_libdir}/libopencv_dnn_superres.so.*
  274. %{_libdir}/libopencv_dpm.so.*
  275. %{_libdir}/libopencv_face.so.*
  276. %{_libdir}/libopencv_freetype.so.*
  277. %{_libdir}/libopencv_fuzzy.so.*
  278. # needs hdf5
  279. #{_libdir}/libopencv_hdf.so.*
  280. %{_libdir}/libopencv_img_hash.so.*
  281. %{_libdir}/libopencv_line_descriptor.so.*
  282. %{_libdir}/libopencv_optflow.so.*
  283. %{_libdir}/libopencv_phase_unwrapping.so.*
  284. %{_libdir}/libopencv_plot.so.*
  285. %{_libdir}/libopencv_reg.so.*
  286. %{_libdir}/libopencv_rgbd.so.*
  287. %{_libdir}/libopencv_quality.so.*
  288. %{_libdir}/libopencv_saliency.so.*
  289. %{_libdir}/libopencv_stereo.so.*
  290. %{_libdir}/libopencv_structured_light.so.*
  291. %{_libdir}/libopencv_surface_matching.so.*
  292. # needs tesseract
  293. #{_libdir}/libopencv_text.so.*
  294. %{_libdir}/libopencv_tracking.so.*
  295. %{_libdir}/libopencv_ximgproc.so.*
  296. %{_libdir}/libopencv_xobjdetect.so.*
  297. %{_libdir}/libopencv_xphoto.so.*
  298. %changelog
  299. * Tue Jun 30 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3.0-1
  300. - new upstream release.
  301. * Mon Mar 27 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-8
  302. - use eigen2 on Vine Linux 6.x
  303. - disable tbb/v4l on Vine Linux 6.x
  304. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 2.4.9-7
  305. - rebuild with gcc-5.4.0
  306. * Wed Mar 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-6
  307. - built with tbb
  308. - moved main package to System Environment/Libraries Group
  309. * Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-5
  310. - Initial build for Vine Linux
  311. * Tue Nov 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-4
  312. - rebuild (openexr)
  313. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.9-3
  314. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  315. * Fri Jul 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-2
  316. - backport support for GStreamer 1 (#1123078)
  317. * Thu Jul 03 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.9-1
  318. - Update to 2.4.9
  319. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.7-7
  320. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  321. * Sat Apr 26 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-6
  322. - revert pkgcmake2 patch (#1070428)
  323. * Fri Jan 17 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-5
  324. - Fix opencv_ocl isn't part of -core
  325. * Thu Jan 16 2014 Christopher Meng <rpm@cicku.me> - 2.4.7-4
  326. - Enable OpenCL support.
  327. - SPEC small cleanup.
  328. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-3
  329. - rebuild (openexr)
  330. * Mon Nov 18 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-2
  331. - OpenCV cmake configuration broken (#1031312)
  332. * Wed Nov 13 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-1
  333. - Update to 2.4.7
  334. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.6.1-2
  335. - rebuild (openexr)
  336. * Wed Jul 24 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.6.1-1
  337. - Update to 2.4.6.1
  338. * Thu May 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.5-1
  339. - Update to 2.4.5-clean
  340. - Spec file clean-up
  341. - Split core libraries into a sub-package
  342. * Sat May 11 2013 François Cami <fcami@fedoraproject.org> - 2.4.4-3
  343. - change project URL.
  344. * Tue Apr 02 2013 Tom Callaway <spot@fedoraproject.org> - 2.4.4-2
  345. - make clean source without SIFT/SURF
  346. * Sat Mar 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-1
  347. - Update to 2.4.4a
  348. - Fix ttb-devel architecture conditionals
  349. * Sun Mar 10 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.4-0.2.beta
  350. - rebuild (OpenEXR)
  351. * Mon Feb 18 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-0.1.beta
  352. - Update to 2.4.4 beta
  353. - Drop python-imaging also from requires
  354. - Drop merged patch for additionals codecs
  355. - Disable the java binding for now (untested)
  356. * Fri Jan 25 2013 Honza Horak <hhorak@redhat.com> - 2.4.3-7
  357. - Do not build with 1394 libs in rhel
  358. * Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 2.4.3-6
  359. - rebuild due to "jpeg8-ABI" feature drop
  360. * Sun Jan 20 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-5
  361. - Add more FourCC for gstreamer - rhbz#812628
  362. - Allow to use python-pillow - rhbz#895767
  363. * Mon Nov 12 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-3
  364. - Switch Build Type to ReleaseWithDebInfo to avoid -03
  365. * Sun Nov 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-2
  366. - Disable SSE3 and allow --with sse3 build conditional.
  367. - Disable gpu module as we don't build cuda
  368. - Update to 2.4.3
  369. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-2
  370. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  371. * Mon Jul 09 2012 Honza Horak <hhorak@redhat.com> - 2.4.2-1
  372. - Update to 2.4.2
  373. * Fri Jun 29 2012 Honza Horak <hhorak@redhat.com> - 2.4.1-2
  374. - Fixed cmake script for generating opencv.pc file
  375. - Fixed OpenCVConfig script file
  376. * Mon Jun 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.1-1
  377. - Update to 2.4.1
  378. - Rework dependencies - rhbz#828087
  379. Re-enable using --with tbb,opennpi,eigen2,eigen3
  380. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-8
  381. - Rebuilt for c++ ABI breakage
  382. * Mon Jan 16 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-7
  383. - Update gcc46 patch for ARM FTBFS
  384. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-6
  385. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  386. * Mon Dec 05 2011 Adam Jackson <ajax@redhat.com> 2.3.1-5
  387. - Rebuild for new libpng
  388. * Thu Oct 20 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-4
  389. - Rebuilt for tbb silent ABI change
  390. * Mon Oct 10 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-3
  391. - Update to 2.3.1a
  392. * Mon Sep 26 2011 Dan Horák <dan[at]danny.cz> - 2.3.1-2
  393. - openni is exclusive for x86/x86_64
  394. * Fri Aug 19 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-1
  395. - Update to 2.3.1
  396. - Add BR openni-devel python-sphinx
  397. - Remove deprecated cmake options
  398. - Add --with cuda conditional (wip)
  399. - Disable make test (unavailable)
  400. * Thu May 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-6
  401. - Backport fixes from branch 2.2 to date
  402. * Tue May 17 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-5
  403. - Re-enable v4l on f15
  404. - Remove unused cmake options
  405. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-3
  406. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  407. * Wed Feb 02 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-2
  408. - Fix with gcc46
  409. - Disable V4L as V4L1 is disabled for Fedora 15
  410. * Thu Jan 06 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-1
  411. - Update to 2.2.0
  412. - Disable -msse and -msse2 on x86_32
  413. * Wed Aug 25 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.1.0-5
  414. - -devel: include OpenCVConfig.cmake (#627359)
  415. * Thu Jul 22 2010 Dan Horák <dan[at]danny.cz> - 2.1.0-4
  416. - TBB is available only on x86/x86_64 and ia64
  417. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.0-3
  418. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  419. * Fri Jun 25 2010 Nicolas Chauvet <kwizart@gmail.com> - 2.1.0-2
  420. - Move samples from main to -devel
  421. - Fix spurious permission
  422. - Add BR tbb-devel
  423. - Fix CFLAGS
  424. * Fri Apr 23 2010 Nicolas Chauvet <kwizart@fedoraproject.org> - 2.1.0-1
  425. - Update to 2.1.0
  426. - Update libdir patch
  427. * Tue Apr 13 2010 Karel Klic <kklic@redhat.com> - 2.0.0-10
  428. - Fix nonstandard executable permissions
  429. * Tue Mar 09 2010 Karel Klic <kklic@redhat.com> - 2.0.0-9
  430. - apply the previously added patch
  431. * Mon Mar 08 2010 Karel Klic <kklic@redhat.com> - 2.0.0-8
  432. - re-enable testing on CMake build system
  433. - fix memory corruption in the gaussian random number generator
  434. * Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-7
  435. - replaced BR unicap-devel by libucil-devel (unicap split)
  436. * Thu Feb 25 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-6
  437. - use cmake build system
  438. - applications renamed to opencv_xxx instead of opencv-xxx
  439. - add devel-docs subpackage #546605
  440. - add OpenCVConfig.cmake
  441. - enable openmp build
  442. - enable old SWIG based python wrappers
  443. - opencv package is a good boy and use global instead of define
  444. * Tue Feb 16 2010 Karel Klic <kklic@redhat.com> - 2.0.0-5
  445. - Set CXXFLAXS without -match=i386 for i386 architecture #565074
  446. * Sat Jan 09 2010 Rakesh Pandit <rakesh@fedoraproject.org> - 2.0.0-4
  447. - Updated opencv-samples-Makefile (Thanks Scott Tsai) #553697
  448. * Wed Jan 06 2010 Karel Klic <kklic@redhat.com> - 2.0.0-3
  449. - Fixed spec file issues detected by rpmlint
  450. * Sun Dec 06 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-2
  451. - Fix autotools scripts (missing LBP features) - #544167
  452. * Fri Nov 27 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-1
  453. - Updated to 2.0.0
  454. - Removed upstream-ed patches
  455. - Ugly hack (added cvconfig.h)
  456. - Disable %%check on ppc64
  457. * Thu Sep 10 2009 Karsten Hopp <karsten@redhat.com> - 1.1.0-0.7.pre1
  458. - fix build on s390x where we don't have libraw1394 and devel
  459. * Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.6.pre1
  460. - Fix typo I introduced that prevented build on i386/i586
  461. * Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.5.pre1
  462. - Added 1394 libs and unicap support
  463. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-0.4.pre1
  464. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  465. * Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.3.pre1
  466. - Build with gstreamer support - #491223
  467. - Backport gcc43 fix from trunk
  468. * Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.2.pre1
  469. - Fix FTBFS #511705
  470. * Fri Apr 24 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.1.pre1
  471. - Update to 1.1pre1
  472. - Disable CXXFLAGS hardcoded optimization
  473. - Add BR: python-imaging, numpy
  474. - Disable make check failure for now
  475. * Wed Apr 22 2009 kwizart < kwizart at gmail.com > - 1.0.0-14
  476. - Fix for gcc44
  477. - Enable BR jasper-devel
  478. - Disable ldconfig run on python modules (uneeded)
  479. - Prevent timestamp change on install
  480. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-13
  481. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  482. * Mon Dec 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 1.0.0-12
  483. - fix URL field
  484. * Fri Dec 19 2008 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.0.0-11
  485. - Adopt latest python spec rules.
  486. - Rebuild for Python 2.6 once again.
  487. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.0-10
  488. - Rebuild for Python 2.6
  489. * Thu May 22 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.0.0-9
  490. - fix license tag
  491. * Sun May 11 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-8
  492. - Adjust library order in opencv.pc.in (BZ 445937).
  493. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-7
  494. - Autorebuild for GCC 4.3
  495. * Sun Feb 10 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-6
  496. - Rebuild for gcc43.
  497. * Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.0.0-5
  498. - Rebuild for selinux ppc32 issue.
  499. * Wed Aug 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-4
  500. - Mass rebuild.
  501. * Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-3
  502. - Fix %%{_datadir}/opencv/samples ownership.
  503. - Adjust timestamp of cvconfig.h.in to avoid re-running autoheader.
  504. * Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-2
  505. - Move all of the python module to pyexecdir (BZ 233128).
  506. - Activate the testsuite.
  507. * Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-1
  508. - Upstream update.
  509. * Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-4
  510. - Remove python-abi.
  511. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.9.9-3
  512. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  513. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-2
  514. - Stop configure.in from hacking CXXFLAGS.
  515. - Activate testsuite.
  516. - Let *-devel require pkgconfig.
  517. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-1
  518. - Upstream update.
  519. - Don't BR: autotools.
  520. - Install samples' Makefile as GNUmakefile.
  521. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-18
  522. - Un'%%ghost *.pyo.
  523. - Separate %%{pythondir} from %%{pyexecdir}.
  524. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-17
  525. - Rebuild for FC6.
  526. - BR: libtool.
  527. * Fri Mar 17 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-16
  528. - Rebuild.
  529. * Wed Mar 8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-15
  530. - Force a re-run of Autotools by calling autoreconf.
  531. * Wed Mar 8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-14
  532. - Added build dependency on Autotools.
  533. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-13
  534. - Changed intrinsics patch so that it matches upstream.
  535. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-12
  536. - More intrinsics patch fixing.
  537. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-11
  538. - Don't do "make check" because it doesn't run any tests anyway.
  539. - Back to main intrinsics patch.
  540. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-10
  541. - Using simple intrinsincs patch.
  542. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-9
  543. - Still more fixing of intrinsics patch for Python bindings on x86_64.
  544. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-8
  545. - Again fixed intrinsics patch so that Python modules build on x86_64.
  546. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-7
  547. - Fixed intrinsics patch so that it works.
  548. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-6
  549. - Fixed Python bindings location on x86_64.
  550. * Mon Mar 6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-5
  551. - SSE2 support on x86_64.
  552. * Mon Mar 6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-4
  553. - Rebuild
  554. * Sun Oct 16 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-3
  555. - Removed useless sample compilation makefiles/project files and replaced them
  556. with one that works on Fedora Core.
  557. - Removed shellbang from Python modules.
  558. * Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-2
  559. - Made FFMPEG dependency optional (needs to be disabled for inclusion in FE).
  560. * Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-1
  561. - Initial package.