eigen3-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201
  1. %bcond_with test
  2. # The (empty) main package is arch, to have the package built and tests run
  3. # on all arches, but the actual result package is the noarch -devel subpackge.
  4. # Debuginfo packages are disabled to prevent rpmbuild from generating an empty
  5. # debuginfo package for the empty main package.
  6. %global debug_package %{nil}
  7. %global commit 323c052e1731
  8. Name: eigen3
  9. Version: 3.3.7
  10. Release: 1%{?_dist_release}
  11. Summary: A lightweight C++ template library for vector and matrix math
  12. Summary(ja): ベクトル及び行列演算のための軽量 C++ テンプレートライブラリ
  13. Group: Development/Libraries
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. License: MPLv2.0 and LGPLv2+ and BSD
  17. URL: http://eigen.tuxfamily.org/index.php?title=Main_Page
  18. Source0: http://bitbucket.org/eigen/eigen/get/%{version}.tar.bz2#/eigen-%{version}.tar.bz2
  19. # Install FindEigen3.cmake
  20. # Adapted from Debian eigen3 package
  21. Patch0: 01_install_FindEigen3.patch
  22. # Fix pkg-config file
  23. Patch1: eigen_pkgconfig.patch
  24. # Fix the include paths in the new Eigen3Config.cmake file
  25. Patch2: eigen3-3.3.1-fixcmake.patch
  26. #BuildRequires: atlas-devel
  27. BuildRequires: fftw3-devel
  28. BuildRequires: glew-devel
  29. BuildRequires: gmp-devel
  30. BuildRequires: gsl-devel
  31. BuildRequires: mpfr-devel
  32. #BuildRequires: sparsehash-devel
  33. BuildRequires: suitesparse-devel
  34. BuildRequires: gcc-gfortran
  35. #BuildRequires: SuperLU-devel
  36. BuildRequires: qt4-devel
  37. BuildRequires: cmake
  38. BuildRequires: doxygen
  39. BuildRequires: graphviz
  40. %description
  41. %{summary}.
  42. %package devel
  43. Summary: A lightweight C++ template library for vector and matrix math
  44. Summary(ja): ベクトル及び行列演算のための軽量 C++ テンプレートライブラリ
  45. Group: Development/Libraries
  46. BuildArch: noarch
  47. # -devel subpkg only atm, compat with other distros
  48. Provides: %{name} = %{version}-%{release}
  49. # not *strictly* a -static pkg, but the results are the same
  50. Provides: %{name}-static = %{version}-%{release}
  51. %description devel
  52. %{summary}.
  53. %prep
  54. %autosetup -p1 -n eigen-eigen-%{commit}
  55. %build
  56. mkdir %{_target_platform}
  57. pushd %{_target_platform}
  58. #cmake .. -DBLAS_LIBRARIES="cblas" -DSUPERLU_INCLUDES=%{_includedir}/SuperLU
  59. %cmake -DINCLUDE_INSTALL_DIR=%{_includedir}/eigen3 \
  60. -DBLAS_LIBRARIES="cblas" \
  61. ..
  62. popd
  63. make -C %{_target_platform} %{?_smp_mflags}
  64. rm -f %{_target_platform}/doc/html/installdox
  65. rm -f %{_target_platform}/doc/html/unsupported/installdox
  66. %install
  67. rm -rf %{buildroot}
  68. %make_install -C %{_target_platform}
  69. %if %{with test}
  70. %check
  71. # Run tests but make failures non-fatal. Note that upstream doesn't expect the
  72. # tests to pass consistently since they're seeded randomly.
  73. make -C %{_target_platform} %{?_smp_mflags} buildtests
  74. make -C %{_target_platform} %{?_smp_mflags} test ARGS="-V" || exit 0
  75. %endif
  76. %clean
  77. rm -rf %{buildroot}
  78. %files devel
  79. %license COPYING.README COPYING.BSD COPYING.MPL2 COPYING.LGPL
  80. %{_includedir}/eigen3
  81. %{_datadir}/%{name}
  82. %{_datadir}/pkgconfig/*
  83. %{_datadir}/cmake/Modules/*.cmake
  84. %changelog
  85. * Tue Jun 30 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.3.7-1
  86. - new upstream release.
  87. * Tue Feb 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 3.2.4-2
  88. - Initial build for Vine Linux
  89. * Thu Jan 22 2015 Sandro Mani <manisandro@gmail.com> - 3.2.4-1
  90. - Update to release 3.2.4
  91. * Mon Jan 05 2015 Rich Mattes <richmattes@gmail.com> - 3.2.3-2
  92. - Backport upstream Rotation2D fix
  93. * Thu Dec 18 2014 Sandro Mani <manisandro@gmail.com> - 3.2.3-1
  94. - Update to release 3.2.3
  95. - Drop upstreamed eigen3-ppc64.patch
  96. * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.2-2
  97. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  98. * Mon Aug 04 2014 Sandro Mani <manisandro@gmail.com> - 3.2.2-1
  99. - Update to release 3.2.2
  100. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-5
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  102. * Tue Mar 11 2014 Orion Poplawski <orion@cora.nwra.com> - 3.2.1-4
  103. - Add ppc64 support
  104. * Thu Feb 27 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-3
  105. - Make doc package noarch
  106. * Thu Feb 27 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-2
  107. - Split off doc to a separate package
  108. * Wed Feb 26 2014 Sandro Mani <manisandro@gmail.com> - 3.2.1-1
  109. - Udpate to release 3.2.1
  110. * Sun Aug 11 2013 Sandro Mani <manisandro@gmail.com> - 3.2-3
  111. - Build and run tests
  112. - Drop -DBLAS_LIBRARIES_DIR, not used
  113. - Add some BR to enable tests of corresponding backends
  114. - spec cleanup
  115. * Wed Jul 24 2013 Sandro Mani <manisandro@gmail.com> - 3.2-1
  116. - Update to release 3.2
  117. * Sat Jun 29 2013 Rich Mattes <richmattes@gmail.com> - 3.1.3-2
  118. - Add upstream patch to fix malloc/free bugs (rhbz#978971)
  119. * Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 3.1.3-1
  120. - Update to release 3.1.3
  121. - Add patch for unused typedefs warning with gcc4.8
  122. * Tue Mar 05 2013 Rich Mattes <richmattes@gmail.com> - 3.1.2-1
  123. - Update to release 3.1.2
  124. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.6-2
  125. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  126. * Sat Jul 28 2012 Tim Niemueller <tim@niemueller.de> - 3.0.6-1
  127. - Update to release 3.0.6 (fixes GCC 4.7 warnings)
  128. * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.5-2
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  130. * Sun Mar 11 2012 Rich Mattes <richmattes@gmail.com> - 3.0.5-1
  131. - Update to release 3.0.5
  132. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.4-2
  133. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  134. * Sun Dec 18 2011 Rich Mattes <richmattes@gmail.com> - 3.0.4-1
  135. - Update to release 3.0.4
  136. * Tue Nov 15 2011 Rich Mattes <richmattes@gmail.com> - 3.0.3-1
  137. - Update to release 3.0.3
  138. * Sun Apr 17 2011 Rich Mattes <richmattes@gmail.com> - 3.0.0-2
  139. - Patched sources to fix build failure
  140. - Removed fixes made upstream
  141. - Added project name to source tarball filename
  142. * Sat Mar 26 2011 Rich Mattes <richmattes@gmail.com> - 3.0.0-1
  143. - Update to release 3.0.0
  144. * Tue Jan 25 2011 Rich Mattes <richmattes@gmail.com> - 3.0-0.2.beta2
  145. - Change blas-devel buildrequirement to atlas-devel
  146. - Don't make the built-in experimental blas library
  147. * Mon Jan 24 2011 Rich Mattes <richmattes@gmail.com> - 3.0-0.1.beta2
  148. - Initial package