octave-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382
  1. %define pkg_name octave
  2. %define pkg_version 4.4.1
  3. %define pkg_release 2%{?_dist_release}
  4. %define gui 1
  5. %define sound 1
  6. Summary: GNU Octave -- a high-level language for numerical computations
  7. Summary(ja): 数値計算のための高級言語
  8. Name: %{pkg_name}
  9. Version: %{pkg_version}
  10. Release: %{pkg_release}
  11. License: GPLv3
  12. Group: Applications/Edutainment
  13. URL: http://www.gnu.org/software/octave/
  14. Source0: ftp://ftp.octave.org/gnu/octave/%{name}-%{version}.tar.lz
  15. Buildroot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: gcc-gfortran
  17. BuildRequires: bison flex gperf texinfo less
  18. BuildRequires: gnuplot
  19. BuildRequires: ghostscript-devel
  20. BuildRequires: mesa-libOSMesa-devel
  21. BuildRequires: blas-devel lapack-devel
  22. BuildRequires: pcre-devel
  23. BuildRequires: readline-devel
  24. %if %{?_dist_release} == "vl6"
  25. BuildRequires: arpack
  26. %endif
  27. %if %{?_dist_release} >= "vl7"
  28. BuildRequires: arpack-devel
  29. %endif
  30. BuildRequires: curl-devel
  31. BuildRequires: fftw3-devel
  32. BuildRequires: fontconfig-devel
  33. BuildRequires: freetype-devel
  34. BuildRequires: glpk-devel
  35. BuildRequires: GraphicsMagick-c++-devel
  36. BuildRequires: hdf5-devel
  37. BuildRequires: java-devel
  38. BuildRequires: qhull-devel
  39. BuildRequires: qrupdate
  40. BuildRequires: suitesparse-devel
  41. BuildRequires: zlib-devel
  42. BuildRequires: xz-devel
  43. BuildRequires: libtool-ltdl-devel
  44. BuildRequires: libXext-devel
  45. BuildRequires: openssl-devel
  46. %if %{gui}
  47. BuildRequires: desktop-file-utils
  48. BuildRequires: freeglut-devel
  49. BuildRequires: fltk-devel
  50. BuildRequires: gl2ps-devel
  51. %if %{?_dist_release} == "vl6"
  52. BuildRequires: qt4-devel
  53. BuildRequires: qscintilla-devel
  54. %endif
  55. %if %{?_dist_release} >= "vl7"
  56. BuildRequires: qt5-qtbase-devel
  57. BuildRequires: qt5-qttools-devel
  58. %endif
  59. %endif
  60. %if %{sound}
  61. BuildRequires: portaudio-devel
  62. BuildRequires: libsndfile-devel
  63. %endif
  64. BuildRequires: lzip
  65. Requires: ghostscript
  66. Requires: blas lapack
  67. Requires: pcre
  68. Requires: readline
  69. Requires: mesa-libOSMesa
  70. Requires: gnuplot
  71. Requires: arpack
  72. Requires: curl
  73. Requires: fftw3
  74. Requires: fontconfig
  75. Requires: freetype
  76. Requires: glpk
  77. Requires: GraphicsMagick-c++
  78. Requires: hdf5
  79. Requires: libqhull
  80. Requires: qrupdate
  81. Requires: suitesparse
  82. Requires: zlib
  83. Requires: openssl
  84. Requires: pstoedit epstool transfig
  85. %if %{gui}
  86. Requires: freeglut
  87. Requires: fltk
  88. Requires: gl2ps
  89. %if %{?_dist_release} == "vl6"
  90. Requires: qt4
  91. Requires: qscintilla
  92. %endif
  93. %if %{?_dist_release} >= "vl7"
  94. Requires: qt5-qtbase
  95. Requires: qt5-qttools-libs-help
  96. %endif
  97. %endif
  98. %if %{sound}
  99. Requires: portaudio
  100. Requires: libsndfile
  101. %endif
  102. Requires(post): /sbin/install-info
  103. Requires(postun): /sbin/ldconfig
  104. Requires(post): /sbin/ldconfig
  105. Requires(preun): /sbin/install-info
  106. Vendor: Project Vine
  107. Distribution: Vine Linux
  108. Packager: ara_t
  109. %description
  110. GNU Octave is a high-level language, primarily intended for numerical
  111. computations. It provides a convenient command line interface for
  112. solving linear and nonlinear problems numerically, and for performing
  113. other numerical experiments using a language that is mostly compatible
  114. with Matlab. It may also be used as a batch-oriented language.
  115. Octave has extensive tools for solving common numerical linear algebra
  116. problems, finding the roots of nonlinear equations, integrating
  117. ordinary functions, manipulating polynomials, and integrating ordinary
  118. differential and differential-algebraic equations. It is easily
  119. extensible and customizable via user-defined functions written in
  120. Octave's own language, or using dynamically loaded modules written in
  121. C++, C, Fortran, or other languages.
  122. # '
  123. %description -l ja
  124. GNU Octave は数値計算用に開発の始められた高級言語です。線形問題や非線形
  125. 問題を数値的に解いたり、その他のMatlab と互換性の高い言語を用いた数値計算
  126. を行うための使いやすいコマンドライン・インタフェースを備えています。
  127. バッチ指向言語としても使うこともできます。Octave は多機能なツールで、
  128. 一般的な線形幾何の問題の数値解や、通常の関数の積分・微分、多項式の操作等を
  129. 行うことができます。
  130. Octave の言語でユーザが関数を定義したり、C++, C, Fortran その他の言語で
  131. 書いた動的ライブラリを用いて容易に拡張やカスタマイズを行うことができます。
  132. %if %{gui}
  133. (注意)
  134. デフォルトではグラフの描画にOpenGL/fltkを使用してます。
  135. もし不安定な場合には、
  136. gnuplotをデフォルトとするために ~/.octaverc に
  137. graphics_toolkit("gnuplot");
  138. を追加してから起動して下さい。
  139. %endif
  140. %prep
  141. %{__rm} -rf ${RPM_BUILD_ROOT}
  142. %setup -q
  143. %build
  144. %{configure} \
  145. CPPFLAGS="-I%{_includedir}/pcre" \
  146. --with-x \
  147. --with-magick=GraphicsMagick \
  148. --with-curl-includedir=%{_includedir}/curl \
  149. --with-glpk-includedir=%{_includedir}/glpk \
  150. --with-qhull-includedir=%{_includedir}/libqhull \
  151. --with-amd-includedir=%{_includedir}/suitesparse \
  152. --with-camd-includedir=%{_includedir}/suitesparse \
  153. --with-colamd-includedir=%{_includedir}/suitesparse \
  154. --with-ccolamd-includedir=%{_includedir}/suitesparse \
  155. --with-cholmod-includedir=%{_includedir}/suitesparse \
  156. --with-cxsparse-includedir=%{_includedir}/suitesparse \
  157. --with-umfpack-includedir=%{_includedir}/suitesparse \
  158. --enable-java \
  159. %if %{gui}
  160. --with-qt=5 \
  161. %endif
  162. %if !%{gui}
  163. --without-opengl \
  164. --without-fltk \
  165. %endif
  166. %if !%{sound}
  167. --without-sndfile --without-portaudio \
  168. %endif
  169. %{__make} %{?_smp_mflags}
  170. %install
  171. %{make_install}
  172. find %{buildroot} -name "*.oct" | xargs strip
  173. # Make library links
  174. %{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
  175. echo "%{_libdir}/octave-%{version}" > \
  176. ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/octave-%{_arch}.conf
  177. %if %{gui}
  178. # desktop file
  179. %{__perl} -pi -e s/"Education;Science;Math;"/"Education;Science;"/g \
  180. ${RPM_BUILD_ROOT}%{_datadir}/applications/org.octave.Octave.desktop
  181. %endif
  182. %check
  183. %{__make} %{?_smp_mflags} check
  184. %clean
  185. %{__rm} -rf ${RPM_BUILD_ROOT}
  186. %post -p %{_syssbindir}/ldconfig
  187. %postun -p %{_syssbindir}/ldconfig
  188. %files
  189. %defattr(-,root,root)
  190. %doc AUTHORS BUGS CITATION COPYING ChangeLog NEWS README
  191. %doc examples doc/interpreter/octave.pdf doc/refcard
  192. %config(noreplace) /etc/ld.so.conf.d/
  193. %{_bindir}/
  194. %{_libdir}/octave
  195. %{_includedir}/octave-%{version}
  196. %if %{gui}
  197. %{_datadir}/applications/
  198. %endif
  199. %{_datadir}/icons/
  200. %{_datadir}/metainfo/
  201. %{_datadir}/octave
  202. %{_libexecdir}/octave
  203. %changelog
  204. * Tue Sep 04 2018 Toshiaki Ara <ara_t@384.jp> 4.4.1-2
  205. - rebuild with qhull-2015.2
  206. * Thu Aug 30 2018 Toshiaki Ara <ara_t@384.jp> 4.4.1-1
  207. - update to 4.4.1
  208. * Sun Jul 01 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-4
  209. - using qt5 for VineSeed
  210. - add configure option: --with-qt=5
  211. - add BuildRequires: qt5-qtbase-devel and qt5-qttools-devel
  212. - add Requires: qt5-qtbase and qt5-qttools-libs-help
  213. * Sun Jul 01 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-3
  214. - rebuild with hdf5-1.8.20 for VineSeed
  215. * Wed Jun 06 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-2
  216. - add BuildRequires: arpack-devel for VineSeed
  217. * Sun May 20 2018 Toshiaki Ara <ara_t@384.jp> 4.4.0-1
  218. - update to 4.4.0
  219. - correct License
  220. * Sun Apr 01 2018 Toshiaki Ara <ara_t@384.jp> 4.2.2-1
  221. - update to 4.2.2
  222. * Sun Oct 29 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-2
  223. - rebuild under glpk-4.63
  224. * Mon Feb 27 2017 Toshiaki Ara <ara_t@384.jp> 4.2.1-1
  225. - update to 4.2.1
  226. * Sat Nov 19 2016 Toshiaki Ara <ara_t@384.jp> 4.2.0-1
  227. - update to 4.2.0
  228. - add make check
  229. - add BuildRequires: lzip
  230. - change BuildRequires: java-devel
  231. * Mon Jul 18 2016 Toshiaki Ara <ara_t@384.jp> 4.0.3-1
  232. - update to 4.0.3
  233. - change BuildRequires: java-1.8.0-openjdk-devel for VineSeed
  234. * Wed May 11 2016 Toshiaki Ara <ara_t@384.jp> 4.0.2-1
  235. - update to 4.0.2
  236. - add BuildRequires: openssl-devel
  237. - add Requires: openssl
  238. * Wed Apr 13 2016 Toshiaki Ara <ara_t@384.jp> 4.0.1-1
  239. - update to 4.0.1
  240. - change dependencies
  241. * Sun Oct 05 2014 Toshiaki Ara <ara_t@384.jp> 3.6.4-2
  242. - [BTS:0002801] add configure option --with-magick=Magick
  243. - delete BuildRequires: texlive-collection-texinfo
  244. - add BuildRequires: texlive-collection-plainextra
  245. - add BuildRequires: texlive-collection-latexextra
  246. - add BuildRequires: texlive-collection-fontsrecommended
  247. - for VineSeed
  248. * Wed Mar 06 2013 Toshiaki Ara <ara_t@384.jp> 3.6.4-1
  249. - update to 3.6.4
  250. - add BuildRequires: freeglut-devel and Requires: freeglut for VineSeed
  251. * Tue Sep 11 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-2
  252. - delete octave from menu (programming)
  253. * Tue Aug 28 2012 Toshiaki Ara <ara_t@384.jp> 3.6.2-1
  254. - update to 3.6.2
  255. - correct spec file for version 3.6.2
  256. - add BuildRequires: pcre-devel fltk-devel
  257. - add BuildRequires: ImageMagick-devel ImageMagick-c++-devel
  258. - add BuildRequires: gcc-gfortran
  259. - add BuildRequires: texlive texlive-common texlive-collection-basic
  260. - add BuildRequires: texlive-collection-texinfo texlive-collection-genericrecommended
  261. - chanfe Group to Applications/Edutainment
  262. * Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
  263. - update to 3.0.2
  264. - applied new versioning policy, spec in utf-8
  265. * Sun Feb 03 2008 NAKAMURA Kenta <kenta@vinelinux.org> 3.0.0-0vl1
  266. - update to 3.0.0
  267. * Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl2
  268. - rebuilt for VineSeed
  269. * Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9.13-0vl1
  270. - update to 2.9.13
  271. - rebuilt with new toolchain and environment
  272. * Sun Apr 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
  273. - update to 2.0.17
  274. - rebuild with new toolchains
  275. - add BuildRequires: gcc295, gcc295-c++
  276. * Sun Mar 3 2002 Jun Nishii <jun@vinelinux.org> 2.1.35-0vl1
  277. - ver.up
  278. * Tue Sep 26 2000 Jun Nishii <jun@vinelinux.org> 2.0.16-0vl1
  279. - build for Vine Linux 2.1
  280. * Mon Aug 07 2000 Frederic Lepied <flepied@mandrakesoft.com> 2.0.16-5mdk
  281. - automatically added BuildRequires
  282. * Wed Jul 26 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-4mdk
  283. - Macros, BM, add multiple icons sizes
  284. * Wed Apr 12 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-3mdk
  285. - strip oct file
  286. - add menu entry
  287. * Tue Mar 21 2000 Vincent Saugey <vince@mandrakesoft.com> 2.0.16-2mdk
  288. - corrected for new groups
  289. * Thu Mar 09 2000 Lenny Cartier <lenny@mandrakesoft.com>
  290. - mandrake build
  291. - v2.0.16
  292. * Fri Oct 23 1998 Jeff Johnson <jbj@redhat.com>
  293. - update to 2.0.13.90
  294. * Thu Jul 9 1998 Jeff Johnson <jbj@redhat.com>
  295. - repackage in powertools.
  296. * Thu Jun 11 1998 Andrew Veliath <andrewtv@usa.net>
  297. - Add %attr, build as user.
  298. * Mon Jun 1 1998 Andrew Veliath <andrewtv@usa.net>
  299. - Add BuildRoot, installinfo, require gnuplot, description from
  300. Octave's web page, update to Octave 2.0.13.
  301. - Adapt from existing spec file.
  302. * Tue Dec 2 1997 Otto Hammersmith <otto@redhat.com>
  303. - removed libreadline stuff from the file list
  304. * Mon Nov 24 1997 Otto Hammersmith <otto@redhat.com>
  305. - changed configure command to put things in $RPM_ARCH-rehat-linux,
  306. rather than genereated one... was causing problems between building
  307. on i686 build machine.
  308. * Mon Nov 17 1997 Otto Hammersmith <otto@redhat.com>
  309. - moved buildroot from /tmp to /var/tmp
  310. * Mon Sep 22 1997 Mike Wangsmo <wanger@redhat.com>
  311. - Upgraded to version 2.0.9 and built for glibc system
  312. * Thu May 01 1997 Michael Fulbright <msf@redhat.com>
  313. - Updated to version 2.0.5 and changed to build using a BuildRoot