texlive-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697
  1. # -*- coding: utf-8-unix -*-
  2. %bcond_with firstbuild
  3. %global _use_internal_dependency_generator 0
  4. %global __find_provides %{SOURCE99}
  5. %global __find_requires %{SOURCE98}
  6. %global texlivesrcver 20140524
  7. %global tlptexlivesrcver 20140507
  8. Summary: The TeX text formatting system
  9. Summary(ja): TeX 文書整形システム
  10. Name: texlive
  11. Version: 2014
  12. Release: 1%{?_dist_release}
  13. License: distributable
  14. Group: Applications/Publishing
  15. URL: http://www.tug.org/texlive/
  16. ## original TeX Live source
  17. Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
  18. ## snapshot
  19. # $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
  20. # $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
  21. # Source: %{name}-source-%{texlivesrcver}.tar.xz
  22. ## tlptexlive: pmetapost
  23. Source1: http://www.preining.info/software/build-tlptexlive-%{tlptexlivesrcver}.zip
  24. Source2: http://www.tug.org/texlive/updmap-kanji.html
  25. ## our updmap{,-hdr}.cfg from collection-basic 20130823
  26. # NOTE:
  27. # * texmf.cnf: we use the conf file texmf.cnf generated from Source0
  28. Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
  29. Source7: updmap.cfg.texlive-%{texlivesrcver}
  30. ## desktop files
  31. Source11: texdoctk.desktop
  32. Source98: find-requires-texlive.sh
  33. ## find library sonames for libkpathsea and libptexenc
  34. Source99: find-provides-texlive.sh
  35. ######
  36. # TeX patches
  37. ######
  38. ## vine
  39. Patch0: reautoconf-parallel.diff
  40. Patch1: texlive-%{texlivesrcver}-vine.patch
  41. Patch2: texlive-%{texlivesrcver}-texmfcnf-vine.patch
  42. Patch3: texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
  43. #Patch10: texlive-%{texlivesrcver}-pxdvik-vine.patch
  44. ## security
  45. Requires: perl-Tk perl-Tk-TableMatrix
  46. Requires: ghostscript >= 8.71
  47. Requires: nkf
  48. Requires(post,postun): fontconfig
  49. Requires(post): ed mktemp
  50. Requires(post): vutils >= 7.1
  51. %{!?with_firstbuild:Requires: texlive-common = %{version}}
  52. BuildRequires: bison flex
  53. BuildRequires: bzip2-devel
  54. BuildRequires: zlib-devel
  55. BuildRequires: libpng-devel
  56. BuildRequires: gd-devel
  57. BuildRequires: ncurses-devel
  58. BuildRequires: libjpeg-devel
  59. BuildRequires: XOrg-devel
  60. BuildRequires: freetype2-devel >= 2.1.10
  61. BuildRequires: autoconf >= 2.68
  62. BuildRequires: openMotif-devel
  63. BuildRequires: poppler-devel >= 0.20
  64. BuildRequires: openssl-devel
  65. BuildRequires: fontconfig-devel
  66. # BuildRequires: libpaper-devel >= 1.1.24-2
  67. BuildRequires: nkf
  68. ## needs to build pxdvi
  69. #BuildRequires: t1lib-devel
  70. BuildRequires: texlive-vtlpkg = %{version}
  71. Buildroot: %{_tmppath}/%{name}-%{version}-root
  72. Vendor: Project Vine
  73. Distribution: Vine Linux
  74. Packager: munepi
  75. %description
  76. The TeX Live software distribution offers a complete TeX system for a
  77. variety of Unix, Macintosh, Windows and other platforms. It
  78. encompasses programs for editing, typesetting, previewing and printing
  79. of TeX documents in many different languages, and a large collection
  80. of TeX macros and font libraries.
  81. The distribution includes extensive general documentation about TeX,
  82. as well as the documentation for the included software packages.
  83. %description -l ja
  84. TeX Live ソフトウェアディストリビューションは、
  85. さまざまな Unix, Macintosh, Windows、および
  86. 他のプラットホームに対して完全な TeX システムを提供します。
  87. 多くの異なった言語を含む TeX ドキュメントの
  88. 編集、組版、閲覧、印刷するためのプログラム、
  89. そして、TeX マクロやフォントライブラリの大きなコレクションを
  90. 同梱しています。
  91. このディストリビューションは
  92. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  93. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  94. %package doc
  95. Summary: TeX Live: Documentation files of %{name}
  96. Group: Applications/Publishing
  97. Requires: %{name} = %{version}-%{release}
  98. BuildArch: noarch
  99. %description doc
  100. This package contains documentation files of %{name}.
  101. %package -n libkpathsea
  102. Summary: path search library for the TeX Live
  103. Summary(ja): TeX Live 用パス検索ライブラリ
  104. Group: System Environment/Libraries
  105. %description -n libkpathsea
  106. This package includes runtime part of the Kpathsea library.
  107. %package -n libkpathsea-devel
  108. Summary: path search libary and header files for the TeX Live
  109. Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
  110. Group: Development/Libraries
  111. Requires: libkpathsea = %{version}-%{release}
  112. %description -n libkpathsea-devel
  113. This package includes static library and header files of the Kpathsea library.
  114. %package -n libptexenc
  115. Summary: Kanji code convert library for Japanese pTeX
  116. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
  117. Group: System Environment/Libraries
  118. Requires: libkpathsea = %{version}-%{release}
  119. %description -n libptexenc
  120. This package includes runtime part of the ptexenc library.
  121. %package -n libptexenc-devel
  122. Summary: Kanji code convert library and header files for Japanese pTeX
  123. Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
  124. Group: Development/Libraries
  125. Requires: libptexenc = %{version}-%{release}
  126. %description -n libptexenc-devel
  127. This package includes header files of the ptexenc library.
  128. %prep
  129. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  130. %setup -q -n %{name}-%{texlivesrcver}-source -a 1
  131. # %setup -q -n %{name}-source-%{texlivesrcver} -a 1
  132. %patch0 -p0 -b .parallel
  133. %patch1 -p1 -b .vine
  134. %patch2 -p1 -b .vine
  135. %patch3 -p1 -b .vine
  136. ## Applying tlptexlive that provides pxdvi(k) and pmpost
  137. echo "applying patches"
  138. cat "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/series" | while read p r ; do
  139. echo $p | grep '^#' >/dev/null || \
  140. patch -p1 $r < "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/$p" || exit 1
  141. done
  142. ## Avoid pollution from internal libraries.
  143. %__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,paper,pixman,poppler,t1lib,unzip,xpdf,zlib} || exit 1
  144. # ./reautoconf || exit 1
  145. %build
  146. set -x
  147. unset TEXINPUTS || :
  148. unset HOME || :
  149. export CFLAGS="$RPM_OPT_FLAGS" \
  150. CXXFLAGS="$RPM_OPT_FLAGS" \
  151. LANG=C
  152. PREFIX=$(pwd)/work
  153. TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
  154. TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
  155. TL_CONFIGURE_ARGS=" \
  156. --disable-multiplatform \
  157. --disable-native-texlive-build \
  158. --with-banner-add=\"/Vine Linux\" \
  159. --enable-shared --disable-static \
  160. --enable-compiler-warnings=max \
  161. --without-cxx-runtime-hack \
  162. \
  163. --with-system-xpdf \
  164. --with-system-gd \
  165. --with-system-t1lib \
  166. --with-system-libpng \
  167. --with-system-zlib \
  168. --with-system-freetype2 \
  169. --with-system-pixman \
  170. --with-system-poppler \
  171. --with-system-cairo \
  172. --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
  173. --with-pic \
  174. \
  175. --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
  176. --disable-dvi2tty \
  177. --disable-t1utils --disable-psutils --disable-detex \
  178. --disable-dvipng --disable-lcdf-typetools \
  179. "
  180. export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
  181. TL_MAKE=%__make ./Build || exit 1
  182. %install
  183. ## prepare %%install session
  184. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  185. ## copy inst directory to /usr
  186. %__mkdir_p %{buildroot}
  187. %__cp -a inst %{buildroot}%{_prefix} || exit 1
  188. %ifarch x86_64
  189. %__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
  190. %endif
  191. ## make some fundamental texmf trees
  192. %__mkdir_p %{buildroot}%{_tl_texmfvine}
  193. %__mkdir_p %{buildroot}%{_tl_texmfdist}
  194. %__mkdir_p %{buildroot}%{_tl_texmflocal}
  195. %__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
  196. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}
  197. %__mkdir_p %{buildroot}%{_tl_vartexfonts}
  198. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
  199. %__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
  200. cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
  201. The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
  202. distribution wide.
  203. You must not do any changes in this directory.
  204. EOF
  205. cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
  206. The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
  207. You should not use this directory to manage any other packages because
  208. we Project Vine use this directory to manage non-CTAN packages, some
  209. enhancement packages and so on.
  210. EOF
  211. cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
  212. The directory %{_tl_texmflocal} is the texmf tree of the system wide.
  213. If you are a privileged user of this system,
  214. you can use this directory to manage your local packages.
  215. EOF
  216. ## our texmf-dist/web2c/updmap{,-hdr}.cfg
  217. %__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
  218. %__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
  219. %__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
  220. ## our map files for dvipdfmx
  221. %__mkdir_p %{buildroot}%{_tl_aliasttfdir}
  222. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
  223. for x in ptex uptex otf otf-up; do
  224. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
  225. done
  226. for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
  227. touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
  228. done
  229. ## desktop things
  230. %__mkdir_p %{buildroot}%{_datadir}/applications
  231. # %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
  232. %__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
  233. # for created fonts
  234. %__mkdir_p %{buildroot}%{_tl_vartexfonts}
  235. # %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
  236. # %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
  237. ## set executable bit for the library
  238. %__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
  239. %__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
  240. # configure ConTeXt
  241. for x in context luatools texexec texmfstart; do
  242. %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
  243. done
  244. # touch ghosts
  245. touch %{buildroot}%{_tl_texmfvine}/ls-R
  246. touch %{buildroot}%{_tl_texmfdist}/ls-R
  247. touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
  248. touch %{buildroot}%{_tl_texmfsysvar}/ls-R
  249. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
  250. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
  251. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
  252. %__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
  253. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
  254. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
  255. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
  256. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
  257. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
  258. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
  259. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
  260. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
  261. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
  262. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
  263. touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
  264. ## remove unpackaging files
  265. find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
  266. find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
  267. %__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
  268. find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
  269. find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
  270. %__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
  271. %__rm -f %{buildroot}%{_infodir}/*
  272. ## use external packages
  273. %__rm %{buildroot}/usr/bin/latexmk || exit 1
  274. ### Files list
  275. find %{buildroot} -type f -or -type l | \
  276. %__sed -e "s|%{buildroot}||g" | \
  277. %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
  278. %__grep -v "%{_includedir}" | \
  279. %__grep -v "%{_libdir}" | \
  280. %__grep -v "%{_infodir}" | \
  281. %__sed -e "s|.*ls-R$|%ghost &|" \
  282. -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
  283. -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
  284. -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
  285. -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
  286. -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
  287. -e "s|.*\.cnf$|%config(noreplace) &|" \
  288. -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
  289. -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
  290. -e "s|^.*/updmap/$|%config &|" \
  291. -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
  292. -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
  293. -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
  294. -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
  295. -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
  296. -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
  297. -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
  298. -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
  299. -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
  300. -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
  301. -e "s|%{_mandir}/.*|&*|" \
  302. > %{_builddir}/filelist.full
  303. find %{buildroot}%{_tl_texmfvine}* -type d | \
  304. %__sed -e "s|^%{buildroot}|%dir |" \
  305. -e "s|$|/|" >> %{_builddir}/filelist.full
  306. ## subpackages
  307. %__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
  308. cat %{_builddir}/filelist.doc \
  309. %{_builddir}/filelist.full | \
  310. sort | uniq -u > %{_builddir}/filelist.tmp
  311. %__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
  312. %clean
  313. %__rm -rf %{buildroot}
  314. %pretrans
  315. rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012 -e 2013
  316. [ $? -eq 1 ] && exit 0
  317. _trans_time=$(date +%Y%m%d)
  318. echo "Running some transitional processes on your TeX system ... "
  319. x=(
  320. /usr/share/texmf-local
  321. /usr/share/texmf-var
  322. /usr/share/texmf-config
  323. )
  324. for dir in ${x[@]}; do
  325. _trans_dir=${dir}.${_trans_time}.rpmorig
  326. [ -d ${_trans_dir}.old ] && \
  327. echo -n " " && \
  328. echo "Found ${_trans_dir}.old: " && \
  329. echo -n " " && \
  330. %__rm -rvf ${_trans_dir}.old
  331. [ -d ${_trans_dir} ] && \
  332. echo -n " " && \
  333. echo "Found ${_trans_dir}: " && \
  334. echo -n " " && \
  335. %__mv -v ${_trans_dir} ${_trans_dir}.old
  336. [ -d ${dir} ] && \
  337. echo -n " " && \
  338. echo "Found ${dir}: " && \
  339. echo -n " " && \
  340. %__mv -v ${dir} ${_trans_dir}
  341. done
  342. echo "done."
  343. %postun
  344. if [ "$1" = 0 ]; then
  345. %__rm -rf %{_tl_vartexfonts}
  346. fi
  347. exit 0
  348. %post
  349. %_tl_touch_run texhash
  350. %_tl_touch_run updmap
  351. %_tl_touch_run mtxrun
  352. %_tl_touch_run fmtutil
  353. exit 0
  354. %posttrans
  355. %__mkdir_p %{_tl_vartexfonts}
  356. %__chmod 1777 %{_tl_vartexfonts}
  357. ## create our map files {ptex,uptex,otf,otf-up}-vine.map
  358. ( %{_tl_exec_upddeffont} ) ||:
  359. %{_tl_exec_texhash}
  360. %{_tl_exec_mtxrun}
  361. %{_tl_exec_updmap}
  362. %{_tl_exec_fmtutil}
  363. exit 0
  364. %post -n libkpathsea
  365. /sbin/ldconfig
  366. # for x in kpathsea tds web2c; do
  367. # /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
  368. # done
  369. # %preun -n libkpathsea
  370. # if [ "$1" = 0 ]; then
  371. # for x in kpathsea tds web2c; do
  372. # /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
  373. # done
  374. # fi
  375. %postun -n libkpathsea
  376. /sbin/ldconfig
  377. %post -n libptexenc
  378. /sbin/ldconfig
  379. %postun -n libptexenc
  380. /sbin/ldconfig
  381. %triggerin -- ghostscript
  382. %__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
  383. if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
  384. %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
  385. elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
  386. %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
  387. fi
  388. %_tl_touch_run texhash
  389. exit 0
  390. %files -f %{_builddir}/filelist.full
  391. %defattr(-,root,root)
  392. %dir %{_tl_aliasttfdir}
  393. %attr(1777,root,root) %dir %{_tl_vartexfonts}
  394. # %config %{_sysconfdir}/cron.daily/texlive.cron
  395. %files doc -f %{_builddir}/filelist.doc
  396. %defattr(-,root,root)
  397. %files -n libkpathsea
  398. %defattr(-,root,root)
  399. %{_libdir}/libkpathsea.so.*
  400. # %{_infodir}/kpathsea.info*
  401. %files -n libkpathsea-devel
  402. %defattr(-,root,root)
  403. %{_libdir}/libkpathsea.so
  404. %dir %{_includedir}/kpathsea
  405. %{_includedir}/kpathsea/*
  406. %files -n libptexenc
  407. %defattr(-,root,root)
  408. %{_libdir}/libptexenc.so.*
  409. %files -n libptexenc-devel
  410. %defattr(-,root,root)
  411. %{_libdir}/libptexenc.so
  412. %dir %{_includedir}/ptexenc
  413. %{_includedir}/ptexenc/*
  414. %changelog
  415. * Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
  416. - upgrade to TeX Live 2014
  417. - texlive-source-20140524 + tlptexlive 20140507
  418. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2013-7
  419. - rebuild with poppler-0.24.5
  420. * Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
  421. - rebuilt
  422. * Fri Nov 1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
  423. - texlive-source-20131101 2014/dev + tlptexlive 20130815
  424. - added BuildRequires: libpaper-devel >= 1.1.24-2 :-(
  425. * Mon Oct 7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
  426. - updated texlive-20131002-texmfcnf-vine.patch:
  427. texmf.cnf (shell_escape_commands): added some programs
  428. * Wed Oct 2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
  429. - texlive-source-20131002 2014/dev + tlptexlive 20130815
  430. - defined %%global __find_requires find-requires-texlive.sh
  431. - dropped unused dependencies of Requires
  432. * Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
  433. - texlive-source-20130919 2014/dev + tlptexlive 20130815
  434. - correct some scripts of README.vine for each texmf trees
  435. * Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
  436. - upgrade to TeX Live 2013
  437. - texlive-source-20130823 2014/dev + tlptexlive 20130815
  438. - dropped Requires: jvf
  439. * Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
  440. - update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
  441. - fixed duplicated lw35 for updmap.pl
  442. - updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
  443. * Sat Mar 9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
  444. - touch the map files generated by updmap-sys
  445. * Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
  446. - fixed Source7: updmap.cfg.texlive-20120701
  447. (upto /etc/texmf/web2c/updmap.cfg)
  448. - fixex %%triggerin -- ghostscript
  449. - replaced %%exec_texhash with %%touch_run texhash
  450. * Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
  451. - TeX Live 2012 + tlptexlive 20121107
  452. * Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
  453. - drop BR: poppler-devel temporaly
  454. - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
  455. * Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
  456. - build with poppler-0.18.4
  457. - remove tlmgr
  458. * Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
  459. - updated to tl11supp-120120
  460. - run %%{exec_fmtutil} at %%post when upgrading
  461. * Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
  462. - updated to tl11supp-111214
  463. * Sat Dec 3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
  464. - added BuildRequires: texlive-common
  465. - Babel needs docstrip.tex, which is contained in texlive-collection-latex
  466. - check japanese.ldf
  467. - updated tl11supp-111120-vine.patch
  468. - added the following options to $$TL_CONFIGURE_ARGS:
  469. --disable-detex
  470. --disable-dvipng
  471. --disable-lcdf-typetools
  472. - remove some files of asymptote
  473. - remove a man file of latexmk
  474. - remove man files of lcdf-typetools
  475. - remove man files of dvipng
  476. - remove a man file of detex
  477. * Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
  478. - added find-provides-texlive.sh and set it to %%__find_provides
  479. - use to find library sonames for libkpathsea and libptexenc
  480. - added cmex.enc (%%{SOURCE110})
  481. - do not install cmex.enc in our TDS, yet
  482. - removed some unused directories in texmf/fonts/map
  483. - removed man files of lcdf-typetools
  484. - moved texdoc{,tk} and its related files to texlive-doc
  485. * Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
  486. - TeX Live 2011 + tl11supp-111120
  487. * Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
  488. - make the directory VARTEXFONTS (%%posttrans)
  489. - dropped %%triggerpostun -- texlive < 2009-17vl6
  490. * Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
  491. - fixed ptexlive-20100711-dvipdfmx-vine.patch
  492. - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
  493. * Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
  494. - added %%pre to avoid conflictions of texmf-{config,var}
  495. * Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
  496. - dropped Requires: texlive-common
  497. - added perl-Tk-TableMatrix
  498. - supported texdoctk
  499. - removed broken symbolic links in /usr/bin
  500. - for each these symbolic links, the package of its real file/path
  501. should be its owner.
  502. * Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
  503. - added %%triggerpostun -- texlive < 2009-17vl6
  504. - make the directory VARTEXFONTS
  505. * Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
  506. - fixed %%dir VARTEXFONTS around in %%files
  507. - dropped BuildRequires: t1utils
  508. * Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
  509. - updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
  510. - changed VARTEXFONTS to /var/lib/texmf/fonts
  511. * Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
  512. - fixed updmap.cfg
  513. * Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
  514. - dropped Requires: texlive-macros
  515. * Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
  516. - updated ptexlive-20100711-pxdvik-vine.patch
  517. and added texlive-20091107-xdvik-vine.patch
  518. - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
  519. * Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
  520. - supported Vine Linux 5
  521. - for vl5, changed a requirement of Japanese VF package
  522. - added Requires: texlive-jvf = 2009 (vl5)
  523. - dropped dependencies of Provides:/Obsoletes: tags
  524. - merged these dependencies in texlive-common-vl.spec
  525. * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
  526. - rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
  527. * Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
  528. - applied some security patches from Debian
  529. - texlive-2009-CVE-2010-0827.patch
  530. - texlive-2009-CVE-2010-1440.patch
  531. - applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
  532. - applied texlive-2009-luatexdir-libpoppler-0.12.patch
  533. based on texlive-2009-pdftexdir-libpoppler-0.12.patch
  534. - fixed some dependencies
  535. * Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
  536. - added BuildArch: noarch in %%package doc
  537. - removed some comment-out sentences
  538. * Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
  539. - separeted texmf-dist to texlive-common package
  540. * Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
  541. - unpacked texlive-20091107-source.tar.xz
  542. - babel is available now
  543. - applied eptex-100420 and some patches:
  544. - eptex-100420-vine.patch
  545. - eptex-100420-patch1.diff
  546. * Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
  547. - updated ptexlive-20100711
  548. * Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
  549. - customized updmap.cfg to correspond installed fonts
  550. * Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
  551. - fixed insttexfont()
  552. * Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
  553. - added jvf of MORISAWA basic 5 fonts
  554. - added cm-super, mathdesign in fntlst
  555. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
  556. - define insttexfont() in %%install
  557. - copy almost compatible tetex-3.0
  558. * Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  559. - ptexlive-20090322 + TeXLive 2009
  560. - added BuildRequires: openssl-devel
  561. * Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
  562. - ptexlive-20091009 + TeXLive 2008