upstart-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372
  1. %global prepare_systemd 1
  2. Name: upstart
  3. Version: 1.12.1
  4. Release: 7%{?_dist_release}
  5. Summary: An event-driven init system
  6. Summary(ja): イベントドリブン型 init システム
  7. Group: System Environment/Base
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2 and LGPLv2+
  11. URL: http://launchpad.net/upstart
  12. Source0: http://launchpad.net/upstart/1.x/%{version}/+download/upstart-%{version}.tar.gz
  13. Source1: init-system-dbus.conf
  14. #Patch1: upstart-telinit.patch
  15. Patch0: upstart-glibc-2.31.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. Obsoletes: SysVinit < 2.88
  18. Provides: SysVinit = 2.88
  19. BuildRequires: gettext, audit-libs-devel, expat-devel
  20. BuildRequires: dbus-devel >= 1.2.16
  21. BuildRequires: libnih-devel >= 1.0.3-2
  22. BuildRequires: json-c-devel >= 0.14
  23. BuildRequires: eudev-libudev-devel
  24. BuildRequires: dconf-devel
  25. Requires: initscripts >= 8.90.4
  26. Requires(post,postun): bash
  27. Provides: /sbin/halt
  28. Provides: /sbin/init
  29. Provides: /sbin/poweroff
  30. Provides: /sbin/reboot
  31. Provides: /sbin/runlevel
  32. Provides: /sbin/shutdown
  33. Provides: /sbin/telinit
  34. %description
  35. Upstart is an event-based replacement for the /sbin/init daemon which
  36. handles starting of tasks and services during boot, stopping them
  37. during shutdown and supervising them while the system is running.
  38. %description -l ja
  39. Upstart はイベントドリブン型の /sbin/init デーモンです。OSブート時の
  40. タスクやサービスの開始やシャットダウン時の終了およびそれらの管理を担
  41. 当します。
  42. %package devel
  43. Summary: Development files for upstart
  44. Group: Development/Libraries
  45. Requires: %{name} = %{version}-%{release}
  46. %description devel
  47. Development files for upstart
  48. %package tools
  49. Summary: Misc tools for upstart
  50. Group: System Environment/Base
  51. Requires: %{name} = %{version}-%{release}
  52. Requires: python3
  53. Requires: dbus-python3
  54. %description tools
  55. Misc tools for upstart
  56. %prep
  57. %setup -q
  58. %patch0 -p1
  59. %build
  60. %configure --sbindir=/sbin --libdir=/%{_lib}
  61. make %{?_smp_mflags}
  62. %install
  63. rm -rf %{buildroot}
  64. make install DESTDIR=%{buildroot}
  65. # don't ship default jobs
  66. rm -f %{buildroot}/%{_sysconfdir}/init/*
  67. install -m 644 %{SOURCE1} %{buildroot}/%{_sysconfdir}/init/
  68. # install upstart-{socket,udev}-bridge.conf
  69. install -m 644 extra/conf/*.conf %{buildroot}/%{_sysconfdir}/init/
  70. # remove unneeded files
  71. rm %{buildroot}/%{_lib}/*.{a,la}
  72. %find_lang %{name}
  73. # for alternatives
  74. %if 0%{?prepare_systemd}
  75. mkdir -p %{buildroot}/%{_lib}/upstart
  76. for f in init halt poweroff reboot runlevel shutdown telinit; do
  77. mv -f %{buildroot}/sbin/$f %{buildroot}/%{_lib}/upstart/
  78. done
  79. for f in halt poweroff reboot runlevel shutdown telinit; do
  80. mv -f %{buildroot}/%{_mandir}/man8/$f.8 \
  81. %{buildroot}/%{_mandir}/man8/upstart-$f.8
  82. done
  83. %endif
  84. %check
  85. #some tests fail in koji while pass in mock and local build
  86. #to run make check use "--with check"
  87. %if %{?_with_check:1}%{!?_with_check:0}
  88. make check
  89. %endif
  90. %if 0%{?prepare_systemd}
  91. %post
  92. /sbin/alternatives \
  93. --install /sbin/init init /%{_lib}/upstart/init 200 \
  94. --slave /sbin/halt halt /%{_lib}/upstart/halt \
  95. --slave /sbin/poweroff poweroff /%{_lib}/upstart/poweroff \
  96. --slave /sbin/reboot reboot /%{_lib}/upstart/reboot \
  97. --slave /sbin/runlevel runlevel /%{_lib}/upstart/runlevel \
  98. --slave /sbin/shutdown shutdown /%{_lib}/upstart/shutdown \
  99. --slave /sbin/telinit telinit /%{_lib}/upstart/telinit \
  100. --slave %{_mandir}/man8/halt.8.gz halt.8 %{_mandir}/man8/upstart-halt.8.gz \
  101. --slave %{_mandir}/man8/poweroff.8.gz poweroff.8 %{_mandir}/man8/upstart-poweroff.8.gz \
  102. --slave %{_mandir}/man8/reboot.8.gz reboot.8 %{_mandir}/man8/upstart-reboot.8.gz \
  103. --slave %{_mandir}/man8/runlevel.8.gz runlevel.8 %{_mandir}/man8/upstart-runlevel.8.gz \
  104. --slave %{_mandir}/man8/shutdown.8.gz shutdown.8 %{_mandir}/man8/upstart-shutdown.8.gz \
  105. --slave %{_mandir}/man8/telinit.8.gz telinit.8 %{_mandir}/man8/upstart-telinit.8.gz
  106. %postun
  107. if [ "$1" = "0" ]; then
  108. /sbin/alternatives --remove init /%{_lib}/upstart/init
  109. fi
  110. %triggerpostun -- upstart <= 1.12.1-5vl7
  111. /sbin/alternatives \
  112. --install /sbin/init init /%{_lib}/upstart/init 200 \
  113. --slave /sbin/halt halt /%{_lib}/upstart/halt \
  114. --slave /sbin/poweroff poweroff /%{_lib}/upstart/poweroff \
  115. --slave /sbin/reboot reboot /%{_lib}/upstart/reboot \
  116. --slave /sbin/runlevel runlevel /%{_lib}/upstart/runlevel \
  117. --slave /sbin/shutdown shutdown /%{_lib}/upstart/shutdown \
  118. --slave /sbin/telinit telinit /%{_lib}/upstart/telinit \
  119. --slave %{_mandir}/man8/halt.8.gz halt.8 %{_mandir}/man8/upstart-halt.8.gz \
  120. --slave %{_mandir}/man8/poweroff.8.gz poweroff.8 %{_mandir}/man8/upstart-poweroff.8.gz \
  121. --slave %{_mandir}/man8/reboot.8.gz reboot.8 %{_mandir}/man8/upstart-reboot.8.gz \
  122. --slave %{_mandir}/man8/runlevel.8.gz runlevel.8 %{_mandir}/man8/upstart-runlevel.8.gz \
  123. --slave %{_mandir}/man8/shutdown.8.gz shutdown.8 %{_mandir}/man8/upstart-shutdown.8.gz \
  124. --slave %{_mandir}/man8/telinit.8.gz telinit.8 %{_mandir}/man8/upstart-telinit.8.gz
  125. %endif
  126. %clean
  127. rm -rf %{buildroot}
  128. %files -f %{name}.lang
  129. %defattr(-,root,root,-)
  130. %license COPYING
  131. %doc AUTHORS
  132. %doc NEWS
  133. %doc README
  134. %doc TODO
  135. %doc HACKING
  136. %{_sysconfdir}/init/
  137. %config(noreplace) %{_sysconfdir}/dbus-1/system.d/Upstart.conf
  138. /%{_lib}/libupstart.so.*
  139. %if 0%{?prepare_systemd}
  140. /%{_lib}/upstart
  141. %else
  142. /sbin/halt
  143. /sbin/init
  144. /sbin/poweroff
  145. /sbin/reboot
  146. /sbin/runlevel
  147. /sbin/shutdown
  148. /sbin/telinit
  149. %endif
  150. /sbin/initctl
  151. /sbin/start
  152. /sbin/status
  153. /sbin/stop
  154. /sbin/restart
  155. /sbin/reload
  156. /sbin/upstart-socket-bridge
  157. /sbin/upstart-udev-bridge
  158. /sbin/upstart-dbus-bridge
  159. /sbin/upstart-dconf-bridge
  160. /sbin/upstart-event-bridge
  161. /sbin/upstart-file-bridge
  162. /sbin/upstart-local-bridge
  163. %{_bindir}/init-checkconf
  164. %dir %{_datadir}/upstart
  165. %dir %{_datadir}/upstart/sessions
  166. %{_datadir}/upstart/sessions/*
  167. %{_mandir}/man5/init.5.gz
  168. %{_mandir}/man5/inittab.5.gz
  169. %{_mandir}/man7/*.7*
  170. %{_mandir}/man8/*.8*
  171. %exclude %{_mandir}/man8/initctl2dot.8*
  172. %exclude %{_mandir}/man8/upstart-monitor.8*
  173. %files devel
  174. %defattr(-,root,root,-)
  175. /%{_lib}/libupstart.so
  176. %{_includedir}/upstart*
  177. %{_prefix}/lib/pkgconfig/*.pc
  178. %files tools
  179. %defattr(-,root,root,-)
  180. %{_bindir}/upstart-monitor
  181. %{_bindir}/initctl2dot
  182. %{_datadir}/applications/*.desktop
  183. %{_datadir}/icons/hicolor/scalable/apps/*.svg
  184. %{_datadir}/upstart/icons/*.svg
  185. %{_mandir}/man8/initctl2dot.8*
  186. %{_mandir}/man8/upstart-monitor.8*
  187. %changelog
  188. * Sat May 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.1-7
  189. - rebuilt with json-c-0.14.
  190. * Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.1-6
  191. - manuals for {halt,poweroff,reboot,runlevel,shutdown,telinit} are alternatives ready.
  192. * Tue Jan 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.1-5
  193. - rebuilt with json-c-0.13.
  194. - /sbin/{init,halt,poweroff,reboot,runlevel,shutdown,telinit} are alternatives ready.
  195. * Tue Jun 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-4
  196. - change BuildRequires: eudev-libudev-devel instead of libudev-devel
  197. * Sun Jun 22 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-3
  198. - rebuild with libnih-1.0.3-2
  199. * Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-2
  200. - add -tools subpackage
  201. - split initctl2dot and upstart-monitor to -tools subpackage
  202. - add R: dbus-python3 to upstart-tools
  203. * Sun Jun 15 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.12.1-1
  204. - update to 1.12.1
  205. - add BR: dconf-devel
  206. - add -devel subpackage
  207. * Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-2
  208. - install upstart-{socket,udev}-bridge.conf
  209. * Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-1
  210. - update to 1.6
  211. - add BR: libudev-devel
  212. - add BR: json-c-devel >= 0.10
  213. * Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-1
  214. - new upstream release
  215. * Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.7-1
  216. - new upstream release
  217. * Wed May 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-2
  218. - add R: initscripts >= 8.90.4
  219. * Sun Apr 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.5-1
  220. - initial build for Vine Linux
  221. * Wed Feb 24 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.5-3
  222. - run "make check" only with --with check
  223. * Fri Feb 19 2010 Casey Dahlin <cdahlin@redhat.com> 0.6.5-2
  224. - be more specific about which libnih we need.
  225. * Wed Feb 17 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.5-1
  226. - upgrade to 0.6.5
  227. * Fri Jan 29 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.3-7
  228. - add SIGUSR1 handler and init-system-dbus.conf (#559660)
  229. * Sun Jan 17 2010 Dennis Gilmore <dennis@ausil.us> - 0.6.3-6
  230. - add patch from upstream fixing sparc alignment issues
  231. * Mon Jan 11 2010 Petr Lautrbach <plautrba@redhat.com> 0.6.3-5
  232. - License changed to GPLv2 and LGPLv2+
  233. * Wed Dec 16 2009 Petr Lautrbach <plautrba@redhat.com> 0.6.3-4
  234. - audit events patch rebased for 0.6 (#470661)
  235. * Thu Dec 3 2009 Bill Nottingham <notting@redhat.com> 0.6.3-3
  236. - make 'telinit u' a no-op, temporarily
  237. * Fri Nov 27 2009 Petr Lautrbach <plautrba@redhat.com> 0.6.3-2
  238. - Removed tests which fail in koji
  239. * Fri Nov 20 2009 Casey Dahlin <cdahlin@redhat.com> - 0.6.3-1
  240. - Upgrade to 0.6.3
  241. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.3.11-3
  242. - rebuilt with new audit
  243. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.11-2
  244. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  245. * Mon Jun 22 2009 Petr Lautrbach <plautrba@redhat.com> - 0.3.11-1
  246. - Update to 0.3.11
  247. * Mon Apr 27 2009 Bill Nottingham <notting@redhat.com> - 0.3.9-24
  248. - Apply the audit patch correctly (#470661)
  249. * Fri Apr 3 2009 Casey Dahlin <cdahlin@redhat.com> - 0.3.9-23
  250. - Add audit events patch from Steve Grubb <sgrubb@redhat.com> (Bug #470661)
  251. * Fri Jan 23 2009 Casey Dahlin <cdahlin@redhat.com> - 0.3.9-22
  252. - Re-add 'telinit u' support along with patch to fix it (#450488). Patch due to
  253. <pspencer@fields.utoronto.ca>
  254. * Mon Jan 12 2009 Bill Nottingham <notting@redhat.com> - 0.3.9-21
  255. - Remove 'telinit u' support as it is broken (#450488, <cjdahlin@ncsu.edu>)
  256. * Fri Apr 25 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-19
  257. - with the merge of event-compat-sysv, move the sysvinit obsoletes/provides here
  258. * Thu Apr 24 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-18
  259. - fix some man page typos (#444008, <archimerged@gmail.com>)
  260. * Wed Apr 09 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-17
  261. - Added list of stock events to events(5)
  262. * Tue Apr 08 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-16
  263. - Add telinit u support
  264. * Fri Apr 04 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-15
  265. - Add a events(5) manpage that describes event syntax
  266. * Thu Apr 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-14
  267. - Change bug report email address to fedora-devel-list@redhat.com
  268. * Fri Mar 14 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-13
  269. - Ignore rpm temporary files of the foo;<somehex> format
  270. - Make ignores of .rpm{new,orig,save} match only at the end of the name
  271. * Thu Mar 13 2008 Bill Nottingham <notting@redhat.com> - 0.3.9-12
  272. - forgot about rpmorig too (ugh)
  273. * Thu Mar 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-11
  274. - Make logd a noreplace
  275. * Thu Mar 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-10
  276. - Add patch to ignore .rpm{new,save} files
  277. * Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-9
  278. - Remove automake dependency, build Makefile.in changes into patch
  279. * Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-8
  280. - Run automake after patching
  281. * Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-7
  282. - Added BuildRequires: automake
  283. * Mon Mar 03 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-6
  284. - Added patch to allow runtime tty changes
  285. * Fri Feb 15 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-5
  286. - Added patch to imply --force on runlevels 0 and 6
  287. * Wed Feb 06 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-4
  288. - Patched for GCC 4.3
  289. * Thu Jan 31 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-3
  290. - Added AUTHORS, COPYING, etc.
  291. - Made config --libdir option relative
  292. * Mon Jan 21 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-2
  293. - Remove libnih and libupstart
  294. * Sun Jan 13 2008 Casey Dahlin <cjdahlin@ncsu.edu> - 0.3.9-1
  295. - Initial packaging