slang-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: The shared library for the S-Lang extension language
  3. Summary(ja): S-Lang 拡張言語ライブラリ
  4. Name: slang
  5. Version: 2.3.2
  6. Release: 1%{?_dist_release}
  7. License: GPLv2+
  8. Group: System Environment/Libraries
  9. URL: https://www.jedsoft.org/slang/
  10. Source: ftp://space.mit.edu/pub/davis/slang/v2.1/%{name}-%{version}.tar.bz2
  11. # don't use memcpy() on overlapping buffers
  12. Patch1: slang-getkey-memmove.patch
  13. # disable test that fails with SIGHUP ignored (e.g. in koji)
  14. Patch2: slang-sighuptest.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: libpng-devel
  17. BuildRequires: oniguruma-devel
  18. BuildRequires: pcre-devel
  19. BuildRequires: zlib-devel
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  23. %description
  24. S-lang (pronounced `sssslang'') is a powerful stack based interpreter
  25. that supports a C-like syntax. It has been designed from the beginning
  26. to be easily embedded into a program to make it extensible. Slang also
  27. provides a way to quickly develop and debug the application embedding it
  28. in a safe and efficient manner. Since slang resembles C, it is easy to
  29. recode slang procedures in C if the need arises.
  30. %description -l ja
  31. S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
  32. ・インタプリタです。開発初期から、プログラムに容易に組み込めるように
  33. デザインされてきました。また、S-lang を用いると、アプリケーションを安
  34. 全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
  35. 必要になれば、S-lang の手続きをCに簡単に変換することもできます。
  36. %package slsh
  37. Summary: Interpreter for S-Lang scripts
  38. Summary(ja): S-Lang スクリプトインタプリタ
  39. Group: Development/Languages
  40. Requires: %{name} = %{version}-%{release}
  41. %description slsh
  42. slsh (slang-shell) is a program for interpreting S-Lang scripts.
  43. It supports dynamic loading of S-Lang modules and includes a readline
  44. interface for interactive use.
  45. This package also includes S-Lang modules that are distributed with
  46. the S-Lang distribution.
  47. %package devel
  48. Summary: Development package for %{name}
  49. Summary(ja): %{name} の開発パッケージ
  50. Group: Development/Libraries
  51. Requires: %{name} = %{version}-%{release}
  52. %description devel
  53. This package contains files which you'll need if you want to
  54. develop S-Lang based applications. Documentation which may help
  55. you write S-Lang based applications is also included.
  56. Install the slang-devel package if you want to develop applications
  57. based on the S-Lang extension language.
  58. #'
  59. %description devel -l ja
  60. このパッケージには S-lang を用いたアプリケーションの開発に必要な静的
  61. ライブラリとヘッダファイルが含まれています。S-lang を記述する助けに
  62. なるようなドキュメントも含まれています。
  63. もし S-lang を使ったアプリケーションを開発するなら、このパッケージを
  64. インストールしてください。
  65. ## to build compat32 for x86_64 architecture support
  66. %package -n compat32-%{name}
  67. Summary: The shared library for the S-Lang extension language
  68. Summary(ja): S-Lang 拡張言語ライブラリ
  69. Group: System Environment/Libraries
  70. Requires: %{name} = %{version}-%{release}
  71. %description -n compat32-%{name}
  72. S-lang (pronounced `sssslang'') is a powerful stack based interpreter
  73. that supports a C-like syntax. It has been designed from the beginning
  74. to be easily embedded into a program to make it extensible. Slang also
  75. provides a way to quickly develop and debug the application embedding it
  76. in a safe and efficient manner. Since slang resembles C, it is easy to
  77. recode slang procedures in C if the need arises.
  78. %description -n compat32-%{name} -l ja
  79. S-lang (`sssslang'' と発音します)は、Cとよく似た文法のスタックベース
  80. ・インタプリタです。開発初期から、プログラムに容易に組み込めるように
  81. デザインされてきました。また、S-lang を用いると、アプリケーションを安
  82. 全にかつ効率良くデバッグ・開発できます。S-lang は C と似ていますから、
  83. 必要になれば、S-lang の手続きをCに簡単に変換することもできます。
  84. %package -n compat32-%{name}-devel
  85. Summary: Development package for %{name}
  86. Summary(ja): %{name} の開発パッケージ
  87. Group: Development/Libraries
  88. Requires: compat32-%{name} = %{version}-%{release}
  89. Requires: %{name}-devel = %{version}-%{release}
  90. %description -n compat32-%{name}-devel
  91. This package contains files which you'll need if you want to
  92. develop S-Lang based applications. Documentation which may help
  93. you write S-Lang based applications is also included.
  94. Install the slang-devel package if you want to develop applications
  95. based on the S-Lang extension language.
  96. #'
  97. %prep
  98. %setup -q
  99. %patch1 -p1 -b .getkey-memmove
  100. %patch2 -p1 -b .sighuptest
  101. # fix permissions of installed modules
  102. sed -i '/^INSTALL_MODULE=/s/_DATA//' configure
  103. # disable test failing on 32-bit archs
  104. sed -i '/TEST_SCRIPTS_SLC = /s/array //' src/test/Makefile
  105. %build
  106. %configure \
  107. --includedir=%{_includedir}/slang \
  108. --with-{pcre,png,z,onig}lib=%{_libdir} \
  109. --with-{pcre,png,z,onig}inc=%{_includedir} \
  110. ;
  111. make RPATH="" install_doc_dir=%{_docdir}/%{name}-%{version} all
  112. %install
  113. rm -rf ${RPM_BUILD_ROOT}
  114. make install-all INSTALL="install -p" RPATH="" DESTDIR=$RPM_BUILD_ROOT
  115. rm -rf $RPM_BUILD_ROOT%{_docdir}/{slang,slsh}
  116. %clean
  117. rm -rf ${RPM_BUILD_ROOT}
  118. %post -p /sbin/ldconfig
  119. %postun -p /sbin/ldconfig
  120. %post -n compat32-%{name} -p /sbin/ldconfig
  121. %postun -n compat32-%{name} -p /sbin/ldconfig
  122. %files
  123. %defattr(-,root,root)
  124. %doc COPYING doc/README changes.txt doc/*/slang*.txt doc/*.txt
  125. %{_libdir}/libslang*.so.*
  126. %files slsh
  127. %defattr(-,root,root)
  128. %doc slsh/doc/html/slsh*.html
  129. %config(noreplace) %{_sysconfdir}/slsh.rc
  130. %{_bindir}/slsh
  131. %{_libdir}/slang
  132. %{_mandir}/man1/slsh.1*
  133. %{_datadir}/slsh
  134. %files devel
  135. %defattr(-,root,root)
  136. %doc doc/*/cslang*.txt doc/*/cref.txt
  137. %{_libdir}/libslang*.so
  138. %{_libdir}/pkgconfig/slang.pc
  139. %{_libdir}/libslang*.a
  140. %{_includedir}/slang
  141. %if %{build_compat32}
  142. %files -n compat32-%{name}
  143. %defattr(- , root, root)
  144. %{_libdir}/libslang.so.*
  145. %files -n compat32-%{name}-devel
  146. %defattr(- , root, root)
  147. %{_libdir}/libslang.a
  148. %{_libdir}/libslang.so
  149. %endif
  150. %changelog
  151. * Sun Sep 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
  152. - new upstream release.
  153. - dropped Patch1 and 2.
  154. - imported Patch1 and 2 from rawhide.
  155. * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.4-5
  156. - rebuild with VineSeed environment
  157. * Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.4-4
  158. - rebuilt with new toolchains
  159. * Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.4-3
  160. - removed unneccesary %if !%{build_compat32} case condition
  161. * Thu Mar 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.4-2
  162. - rebuilt with oniguruma-5.9.1
  163. * Wed Mar 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-1
  164. - new upstream release
  165. * Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-1
  166. - new upstream release
  167. - drop slang_jp patch
  168. * Sun Aug 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-0vl1
  169. - update to slang-1.4.9
  170. - rediffed slang_jp patch
  171. * Thu Feb 16 2006 Shu KONNO <owa@bg.wakwak.com> 1.4.4-0vl5
  172. - change ./configure to %%configure
  173. - uncommented a script to make symbolic link of %%{_libdir}/libslang.so.1
  174. - added compat32-* packages for x86_64 architecture support
  175. * Fri Jul 18 2003 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 1.4.4-0vl4
  176. - rebuild with new toolchains
  177. - s/Copyright/License/
  178. * Sat Feb 9 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl3
  179. - bug fixed canna input for jed
  180. - change patch: bug fixed slsng-console.patch
  181. * Mon Jan 21 2002 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl2
  182. - rebuild with glibc-2.2.4
  183. * Wed Jun 27 2001 MATUBARA Kazuyuki <matubara@mb.asmnet.ne.jp> 1.4.4-0vl1
  184. - update to 1.4.4
  185. - use jp0 patch
  186. - use better macros
  187. - use Release No for Vine Linux
  188. * Fri Jan 7 2000 Jun Nishii <jun@vinelinux.org>
  189. [1.2.2_jp-7]
  190. - Japanese summary and description
  191. - change group
  192. * Sun Sep 12 1999 Norihito Ohmori <ohmori@flatout.org>
  193. - rebuild for new environment.
  194. * Fri Jul 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  195. [1.2.2_jp-5]
  196. - Updated to 1.2.2j056
  197. * Sun Feb 21 1999 MATSUMOTO Shoji <vine@flatout.org>
  198. [1.2.2_jp-4]
  199. - fix box bug with KANJI
  200. * Tue Feb 16 1999 Daisuke SUZUKI <daisuke@linux.or.jp>
  201. [1.2.2_jp-2]
  202. - Updated to 1.2.2j054
  203. * Mon Dec 21 1998 MATSUMOTO Shoji <shom@flatout.org>
  204. [1.2.2j052-2]
  205. - patch for linux console and kon
  206. - bug fix for no-kanji version
  207. - separate devel
  208. * Sat Jul 4 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
  209. [1.2.1j-1]
  210. - Updated to 1.2.2 (j052)
  211. * Fri Jun 5 1998 Daisuke SUZUKI <daisuke@linux.or.jp>
  212. [1.2.1j-1]
  213. - japanize patch added
  214. * Mon Apr 13 1998 Manoj Kasichainula <manojk@io.com>
  215. [1.2.1-1]
  216. - Updated to 1.2.1
  217. * Sun Apr 12 1998 Manoj Kasichainula <manojk@io.com>
  218. [1.2.0-1]
  219. - Updated to 1.2.0, the first 1.x non-beta version
  220. * Wed Feb 11 1998 Manoj Kasichainula <manojk@io.com>
  221. [1.0.3-1]
  222. - Updated to 1.0.3
  223. - Minor fixes
  224. * Tue Feb 3 1998 Manoj Kasichainula <manojk@io.com>
  225. - Earlier changes were lost, because of misplacement of RPM:
  226. - BuildRoot
  227. - RPM_OPT_FLAGS
  228. - %clean section
  229. - other minor spec file changes
  230. - Should be buildable by non-root now
  231. - Included untic, a very cool terminfo interpreter (this probably out to be
  232. split out eventually)
  233. - Added bug fix from JED
  234. * Thu Jan 29 1998 Bill Nottingham <wen1@cec.wustl.edu>
  235. - upgraded to 1.0.2
  236. * Wed Jan 28 1998 Bill Nottingham <wen1@cec.wustl.edu>
  237. - Apparently so, Donnie. :)
  238. - upgraded to 1.0.0beta
  239. * Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
  240. - spec file cleanups
  241. * Mon Sep 1 1997 Donnie Barnes <djb@redhat.com>
  242. - upgraded to 0.99.38 (will it EVER go 1.0???)
  243. - all patches removed (all appear to be in this version)
  244. * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
  245. - built against glibc