openssl102-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797
  1. %bcond_with devel
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define soversion 10
  4. %define version 1.0.2p
  5. %define release 1%{_dist_release}
  6. Summary: Secure Sockets Layer Toolkit
  7. Name: openssl102
  8. Version: %{version}
  9. Release: %{release}
  10. Source: ftp://ftp.openssl.org/source/openssl-%{version}.tar.gz
  11. Source2: Makefile.certificate
  12. Source6: make-dummy-cert
  13. Source7: renew-dummy-cert
  14. # Patch0: openssl-1.0.2-soversion.patch
  15. # Patch2: openssl-1.0.1-rpm_opt.patch
  16. Patch0: openssl-1.0.2g-rpmbuild.patch
  17. Patch4: openssl-1.0.2g-enginesdir.patch
  18. Patch5: openssl-1.0.2a-version-add-engines.patch
  19. Patch8: openssl-1.0.1c-perlfind.patch
  20. # security fix
  21. # nothing ;-)
  22. License: BSDish
  23. Group: System Environment/Libraries
  24. URL: http://www.openssl.org/
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. BuildRequires: perl, sed
  27. BuildRequires: zlib-devel, krb5-devel
  28. Requires: mktemp
  29. Requires: ca-certificates
  30. %if %{with devel}
  31. Requires: openssl >= 1.1.1
  32. %endif
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. Packager: daisuke, iwamoto
  36. %define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
  37. %description
  38. The OpenSSL certificate management tool and the shared libraries that
  39. provide various cryptographic algorithms and protocols.
  40. %if %{with devel}
  41. %package devel
  42. Summary: OpenSSL libraries and development headers.
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. Requires: krb5-devel
  46. %description devel
  47. The static libraries and include files needed to compile apps
  48. with support for various the cryptographic algorithms and protocols
  49. supported by OpenSSL.
  50. Patches for many networking apps can be found at:
  51. ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
  52. %package static
  53. Summary: Libraries for static linking of applications which will use OpenSSL
  54. Group: Development/Libraries
  55. Requires: %{name}-devel = %{version}-%{release}
  56. %description static
  57. OpenSSL is a toolkit for supporting cryptography. The openssl-static
  58. package contains static libraries needed for static linking of
  59. applications which support various cryptographic algorithms and
  60. protocols.
  61. %package perl
  62. Summary: OpenSSL scripts which require Perl.
  63. Group: Applications/Internet
  64. Requires: perl
  65. Requires: %{name} = %{version}-%{release}
  66. %description perl
  67. Perl scripts provided with OpenSSL for converting certificates and keys
  68. from other formats to those used by OpenSSL.
  69. %endif
  70. ## to build compat32 for x86_64 architecture support
  71. %package -n compat32-%{name}
  72. Summary: Secure Sockets Layer Toolkit
  73. Group: System Environment/Libraries
  74. Requires: %{name} = %{version}-%{release}
  75. %description -n compat32-%{name}
  76. The OpenSSL certificate management tool and the shared libraries that
  77. provide various cryptographic algorithms and protocols.
  78. %if %{with devel}
  79. %package -n compat32-%{name}-devel
  80. Summary: OpenSSL libraries and development headers.
  81. Group: Development/Libraries
  82. Requires: compat32-%{name} = %{version}-%{release}
  83. Requires: compat32-krb5-devel
  84. %description -n compat32-%{name}-devel
  85. The static libraries and include files needed to compile apps
  86. with support for various the cryptographic algorithms and protocols
  87. supported by OpenSSL.
  88. %endif
  89. %prep
  90. %setup -q -n openssl-%{version}
  91. %patch0 -p1 -b .soversion
  92. %patch4 -p1 -b .enginesdir
  93. %patch5 -p1 -b .version-add-engines
  94. %patch8 -p1 -b .perlfind
  95. # security fix
  96. # nothing ;-)
  97. chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
  98. chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
  99. # chmod 644 doc/openssl_button.html doc/openssl_button.gif
  100. chmod 644 doc/ssleay.txt
  101. %build
  102. PATH=${PATH}:${PWD}/bin
  103. TOPDIR=${PWD}
  104. LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
  105. # Modify the various perl scripts to reference perl in the right location.
  106. perl util/perlpath.pl `dirname %{__perl}`
  107. # Generate a table with the compile settings for my perusal.
  108. touch Makefile
  109. make TABLE PERL=%{__perl}
  110. # Figure out which flags we want to use.
  111. # default
  112. sslarch=%{_os}-%{_target_cpu}
  113. #
  114. %ifarch %ix86
  115. sslarch=linux-elf
  116. if ! echo %{_target} | grep -q i686 ; then
  117. sslflags="no-asm 386"
  118. fi
  119. %endif
  120. %ifarch sparcv9
  121. sslarch=linux-sparcv9
  122. sslflags=no-asm
  123. %endif
  124. %ifarch sparc64
  125. sslarch=linux64-sparcv9
  126. sslflags=no-asm
  127. %endif
  128. %ifarch alpha alphaev56 alphaev6 alphaev67
  129. sslarch=linux-alpha-gcc
  130. %endif
  131. %ifarch s390 sh3eb sh4eb
  132. sslarch="linux-generic32 -DB_ENDIAN"
  133. %endif
  134. %ifarch s390x
  135. sslarch="linux64-s390x"
  136. %endif
  137. %ifarch %{arm} sh3 sh4
  138. sslarch=linux-generic32
  139. %endif
  140. # ia64/x86_64/ppc\ppc64 are OK by default.
  141. # Configure the build tree. Override OpenSSL defaults with known-good defaults
  142. # usable on all platforms. The Configure script already knows to use -fPIC and
  143. # RPM_OPT_FLAGS, so we can skip specifiying them here.
  144. ./Configure \
  145. --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
  146. zlib-dynamic enable-camellia enable-seed enable-tlsext \
  147. enable-rfc3779 enable-cms enable-md2 \
  148. --enginesdir=%{_libdir}/%{name}/engines \
  149. --with-krb5-flavor=MIT --with-krb5-dir=/usr \
  150. shared ${sslarch}
  151. # Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
  152. # marked as not requiring an executable stack.
  153. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
  154. make depend
  155. make all build-shared
  156. # Generate hashes for the included certs.
  157. LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  158. export LD_LIBRARY_PATH
  159. make rehash build-shared
  160. # Verify that what was compiled actually works.
  161. make -C test apps tests
  162. # Relink the main binary to get it dynamically linked.
  163. rm apps/openssl
  164. make all build-shared
  165. %install
  166. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  167. # Install OpenSSL.
  168. install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/%{name}}
  169. make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
  170. install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
  171. # added for lib64
  172. # mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
  173. mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/%{name}
  174. # mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
  175. mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
  176. mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
  177. rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
  178. rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
  179. for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
  180. chmod 755 ${lib}
  181. ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
  182. ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
  183. done
  184. # install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
  185. # Install a makefile for generating keys and self-signed certs, and a script
  186. # for generating them on the fly.
  187. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
  188. install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
  189. install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
  190. install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
  191. # Make sure we actually include the headers we built against.
  192. for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
  193. if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
  194. install -m644 include/openssl/`basename ${header}` ${header}
  195. fi
  196. done
  197. # Rename man pages so that they don't conflict with system man pages. We used
  198. # to change the file extensions, but that only prevents file conflicts. The
  199. # man viewer still can't select either of the two unless we physically change
  200. # the directory.
  201. for section in 1 2 3 4 5 6 7 8 ; do
  202. if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
  203. mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
  204. $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
  205. fi
  206. done
  207. # Pick a CA script.
  208. pushd $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
  209. mv CA.sh CA
  210. popd
  211. mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
  212. mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
  213. mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
  214. mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
  215. mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
  216. # Ensure the openssl.cnf timestamp is identical across builds to avoid
  217. # mulitlib conflicts and unnecessary renames on upgrade
  218. touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
  219. %clean
  220. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  221. %files
  222. %defattr(-,root,root)
  223. %doc FAQ LICENSE CHANGES NEWS INSTALL README
  224. %doc doc/README doc/c-indentation.el doc/openssl.txt
  225. %doc doc/openssl_button.html doc/openssl_button.gif
  226. %doc doc/ssleay.txt
  227. %if %{with devel}
  228. %{_sysconfdir}/pki/tls/certs/make-dummy-cert
  229. %{_sysconfdir}/pki/tls/certs/renew-dummy-cert
  230. %{_sysconfdir}/pki/tls/certs/Makefile
  231. %{_sysconfdir}/pki/tls/misc/CA
  232. %dir %{_sysconfdir}/pki/CA
  233. %dir %{_sysconfdir}/pki/CA/private
  234. %dir %{_sysconfdir}/pki/CA/certs
  235. %dir %{_sysconfdir}/pki/CA/crl
  236. %dir %{_sysconfdir}/pki/CA/newcerts
  237. %{_sysconfdir}/pki/tls/misc/c_*
  238. %dir %{_sysconfdir}/pki/tls
  239. %dir %{_sysconfdir}/pki/tls/certs
  240. %dir %{_sysconfdir}/pki/tls/misc
  241. %dir %{_sysconfdir}/pki/tls/private
  242. %config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
  243. %attr(0755,root,root) %{_bindir}/openssl
  244. %endif
  245. %attr(0755,root,root) /%{_lib}/*.so.*
  246. %attr(0755,root,root) %{_libdir}/%{name}/engines/*.so
  247. %if %{with devel}
  248. %attr(0755,root,root) %dir %{_mandir}/man1*
  249. %attr(0644,root,root) %{_mandir}/man1*/*
  250. %attr(0755,root,root) %dir %{_mandir}/man5*
  251. %attr(0644,root,root) %{_mandir}/man5*/*
  252. %attr(0755,root,root) %dir %{_mandir}/man7*
  253. %attr(0644,root,root) %{_mandir}/man7*/*
  254. %endif
  255. %if %{with devel}
  256. %files devel
  257. %defattr(-,root,root)
  258. %{_prefix}/include/openssl
  259. %exclude %{_libdir}/lib*.a
  260. %attr(0755,root,root) %{_libdir}/*.so
  261. %attr(0755,root,root) %dir %{_mandir}/man3*
  262. %attr(0644,root,root) %{_mandir}/man3*/*
  263. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  264. %files static
  265. %defattr(-,root,root)
  266. %attr(0644,root,root) %{_libdir}/*.a
  267. %files perl
  268. %defattr(-,root,root)
  269. %attr(0755,root,root) %{_bindir}/c_rehash
  270. %attr(0755,root,root) %dir %{_mandir}/man1*
  271. %attr(0644,root,root) %{_mandir}/man1*/*.pl*
  272. %{_sysconfdir}/pki/tls/misc/*.pl
  273. #%{_sysconfdir}/pki/tls/misc/tsget
  274. %doc apps/tsget
  275. %endif
  276. ## to build compat32 for x86_64 architecture support
  277. %if %{build_compat32}
  278. %files -n compat32-%{name}
  279. %defattr(-,root,root)
  280. %attr(0755,root,root) /%{_lib}/*.so.*
  281. %if %{with devel}
  282. %files -n compat32-%{name}-devel
  283. %defattr(-,root,root)
  284. %exclude %{_libdir}/lib*.a
  285. %attr(0755,root,root) %{_libdir}/*.so
  286. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  287. %endif
  288. %endif
  289. %post -p /sbin/ldconfig
  290. %postun -p /sbin/ldconfig
  291. %post -n compat32-%{name} -p /sbin/ldconfig
  292. %postun -n compat32-%{name} -p /sbin/ldconfig
  293. %changelog
  294. * Wed Oct 31 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.2p-1
  295. - new upstream release.
  296. - renamed for compatibility.
  297. * Sun Apr 1 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2o-1
  298. - new upstream release with security fixes
  299. * Sun Jan 21 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2n-1
  300. - new upstream release with security fixes
  301. * Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2m-1
  302. - new upstream release with security fixes
  303. * Sun Jan 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2k-1
  304. - new upstream release with security fixes
  305. * Thu May 5 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2h-1
  306. - new upstream release with security fixes
  307. * Wed Mar 9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2g-1
  308. - new upstream release 1.0.2 with security fixes
  309. - Patch2 is merged into Patch0
  310. * Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
  311. - new upstream release with security fixes
  312. * Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
  313. - new upstream release with security fixes
  314. * Wed Jul 1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
  315. - new upstream release
  316. * Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
  317. - merged into Vine6
  318. * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
  319. - new upstream release with security fixes
  320. - update Patch2,5
  321. * Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
  322. - new upstream release with security fixes
  323. * Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
  324. - new upstream release with security fixes
  325. - add patch8 from fc21 (fix perl find.pl)
  326. * Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
  327. - new upstream release with security fixes.
  328. * Tue Apr 8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
  329. - new upstream release with security fixes
  330. * Thu Jan 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
  331. - new upstream release with security fixes
  332. * Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
  333. - move root CA bundle to ca-certificates package
  334. * Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
  335. - update to 1.0.1e
  336. - 1.0.1d has major regressions from 1.0.1c
  337. * Sat Feb 9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
  338. - remove tsget script to delete dependency perl(WWW::Curl::Easy)
  339. - openssl-perl package contains it in docdir
  340. * Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
  341. - new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
  342. - fixed %%files
  343. * Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
  344. - update to 1.0.1c
  345. - enable configure options:
  346. enable-camellia enable-seed enable-tlsext enable-rfc3779
  347. enable-cms enable-md2
  348. - remove no-asm option from ai64/x86_64/ppc/ppc64/i686
  349. - generate a table with the compile settings before configure
  350. * Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
  351. - new upstream release with security fix (CVE-2012-0050)
  352. * Fri Jan 6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
  353. - new upstream release with security fix
  354. (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
  355. * Wed Sep 7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
  356. - new upstream release with security fix (CVE-2011-3207, 3210)
  357. * Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
  358. - rebuild with krb5-libs 1.8
  359. * Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
  360. - new upstream release with security fix
  361. * Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
  362. - use upstream openssl.pc instead of vine original one (SOURCE6)
  363. * Sun Jan 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
  364. - move tsget to docs to delete dependency perl(WWW::Curl::Easy)
  365. * Sat Jan 1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
  366. - add R: krb5-devel into devel pkg
  367. - add R: compat32-krb5-devel into compat32-devel pkg
  368. * Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
  369. - new upstream release 1.0.0x
  370. - separate static libs into static package
  371. - change configure options
  372. - change so version 10
  373. - add tsget into perl package
  374. - update all patches
  375. * Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
  376. - fix changelog typo...
  377. * Tue Dec 7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
  378. - new upstream release with security fix (CVE-2010-4180)
  379. * Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
  380. - new upstream release with security fix (CVE-2010-3864)
  381. - drop patches included in new release
  382. - update patch4
  383. * Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
  384. - add patch12 for fix CVE-2009-3555 (renegotiation)
  385. * Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
  386. - add patch11 for fix CVE-2009-4355 (memory leak)
  387. * Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
  388. - add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
  389. * Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
  390. - removed unnecessary %%if %{build_compat32} statements
  391. - removed lib*.a from devel package
  392. * Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
  393. - new upstream release with security fix (CVE-2000-0590,0591,0789)
  394. * Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
  395. - new upstream release with security fix (CVE-2008-5077)
  396. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
  397. - new upstream release
  398. * Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
  399. - new upstream release
  400. - new versioning policy
  401. * Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
  402. - new upstream release
  403. - drop patch10,20 which is merged in upstream
  404. * Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
  405. - add security patch in advance for CVE-2007-5135
  406. http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
  407. http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
  408. * Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
  409. - add security patch for CVE-2007-3108
  410. (http://openssl.org/news/patch-CVE-2007-3108.txt)
  411. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
  412. - new upstream release
  413. * Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
  414. - update (fix) openssl.pc <BTS:437>
  415. * Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
  416. - new upstream release (with security fix)
  417. * Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
  418. - new upstream release
  419. - add patch2 to use RPM_OPT macro
  420. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
  421. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  422. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
  423. - added compat32-* packages for x86_64 architecture support
  424. - added openssl-0.9.7i.Configure-compat32.patch
  425. - changed '/lib' to '/%{_lib}'
  426. * Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
  427. - new upstream release
  428. * Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
  429. - rebuild on VineSeed
  430. * Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
  431. - added a security patch from Gentoo.
  432. - Patch1: openssl-0.9.7c-tempfile.patch
  433. * Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
  434. - sslarch for ppc was missing... added.
  435. * Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
  436. - use sslarch=linux-alpha-gcc instead of alpha-gcc
  437. * Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
  438. - new upstream version
  439. - clean up of spec file
  440. -- removed old patches
  441. * Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
  442. - new upstream release
  443. - SECURITY fix.
  444. - http://www.openssl.org/news/secadv_20040317.txt
  445. * Wed Oct 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
  446. - new upstream release
  447. - [Security fix]
  448. - Vulnerabilities in ASN.1 parsing
  449. http://www.openssl.org/news/secadv_20030930.txt
  450. - see %{_docdir}/%{name}-%{version}/CHANGES for other changes
  451. * Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
  452. - add openssl.pc for pkgconfig
  453. * Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
  454. - New upstream version
  455. - dropped patch10, 11
  456. -- merged upstream version
  457. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
  458. - rebuild for VineSeed
  459. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
  460. - [Security Fix]
  461. - Timing-based attacks on RSA keys
  462. http://www.openssl.org/news/secadv_20030317.txt
  463. - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
  464. http://www.openssl.org/news/secadv_20030317.txt
  465. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
  466. - new upstream release 0.9.6i
  467. - [Security Fix]
  468. - build for Vine Linux 2.6 errata
  469. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
  470. - new upstream release 0.9.6h
  471. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
  472. - new upstream release 0.9.6g
  473. * Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
  474. - SECURITY: CAN-2002-0659 fixed
  475. - added Patch101 from RedHat 7.2 updates 0.9.6b-28
  476. * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
  477. - update asn patch to fix accidental reversal of a logic check
  478. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
  479. - update asn patch to reduce chance that compiler optimization will remove
  480. one of the added tests
  481. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
  482. - rebuild
  483. * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
  484. - add patch to fix ASN.1 vulnerabilities
  485. * Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
  486. - rename spec file name
  487. - SECURITY: CA-2002-23 fixed
  488. - added Patch100 from RedHat 7.2 updates 0.9.6b-24
  489. * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
  490. - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
  491. * Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
  492. - added ${PATH} in LD_LIBRARY_PATH
  493. - added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
  494. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
  495. - remove --no-<cipher>
  496. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
  497. - add Patch10 for mipsel shared ( Configure )
  498. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
  499. - build for Vine Linux
  500. - use openssl-engine-0.9.6b.tar.gz
  501. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  502. - update to 0.9.6b
  503. * Thu Jul 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  504. - move .so symlinks back to %%{_libdir}
  505. * Tue Jul 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  506. - move shared libraries to /lib (#38410)
  507. * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  508. - switch to engine code base
  509. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  510. - add a script for creating dummy certificates
  511. - move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
  512. * Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  513. - add s390x support
  514. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  515. - change two memcpy() calls to memmove()
  516. - don't define L_ENDIAN on alpha
  517. * Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  518. - make subpackages depend on the main package
  519. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  520. - adjust the hobble script to not disturb symlinks in include/ (fix from
  521. Joe Orton)
  522. * Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  523. - drop the m2crypo patch we weren't using
  524. * Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
  525. - configure using "shared" as well
  526. * Sun Apr 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  527. - update to 0.9.6a
  528. - use the build-shared target to build shared libraries
  529. - bump the soversion to 2 because we're no longer compatible with
  530. our 0.9.5a packages or our 0.9.6 packages
  531. - drop the patch for making rsatest a no-op when rsa null support is used
  532. - put all man pages into <section>ssl instead of <section>
  533. - break the m2crypto modules into a separate package
  534. * Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  535. - use BN_LLONG on s390
  536. * Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
  537. - fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
  538. * Sat Mar 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  539. - move c_rehash to the perl subpackage, because it's a perl script now
  540. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  541. - update to 0.9.6
  542. - enable MD2
  543. - use the libcrypto.so and libssl.so targets to build shared libs with
  544. - bump the soversion to 1 because we're no longer compatible with any of
  545. the various 0.9.5a packages circulating around, which provide lib*.so.0
  546. * Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  547. - change hobble-openssl for disabling MD2 again
  548. * Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  549. - re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
  550. bytes or so, causing EVP_DigestInit() to zero out stack variables in
  551. apps built against a version of the library without it
  552. * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  553. - disable some inline assembly, which on x86 is Pentium-specific
  554. - re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
  555. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  556. - fix s390 patch
  557. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  558. - added support s390
  559. * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  560. - remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
  561. - add the CA.pl man page to the perl subpackage
  562. * Thu Nov 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  563. - always build with -mcpu=ev5 on alpha
  564. * Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  565. - add a symlink from cert.pem to ca-bundle.crt
  566. * Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
  567. - add a ca-bundle file for packages like Samba to reference for CA certificates
  568. * Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  569. - remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
  570. * Mon Oct 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  571. - add unzip as a buildprereq (#17662)
  572. - update m2crypto to 0.05-snap4
  573. * Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
  574. - fix some issues in building when it's not installed
  575. * Wed Sep 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  576. - make sure the headers we include are the ones we built with (aaaaarrgh!)
  577. * Fri Sep 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  578. - add Richard Henderson's patch for BN on ia64
  579. - clean up the changelog
  580. * Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  581. - fix the building of python modules without openssl-devel already installed
  582. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  583. - byte-compile python extensions without the build-root
  584. - adjust the makefile to not remove temporary files (like .key files when
  585. building .csr files) by marking them as .PRECIOUS
  586. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  587. - break out python extensions into a subpackage
  588. * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  589. - tweak the makefile some more
  590. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  591. - disable MD2 support
  592. * Thu Jul 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  593. - disable MDC2 support
  594. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  595. - tweak the disabling of RC5, IDEA support
  596. - tweak the makefile
  597. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  598. - strip binaries and libraries
  599. - rework certificate makefile to have the right parts for Apache
  600. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  601. - use %%{_perl} instead of /usr/bin/perl
  602. - disable alpha until it passes its own test suite
  603. * Fri Jun 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  604. - move the passwd.1 man page out of the passwd package's way
  605. * Fri Jun 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  606. - update to 0.9.5a, modified for U.S.
  607. - add perl as a build-time requirement
  608. - move certificate makefile to another package
  609. - disable RC5, IDEA, RSA support
  610. - remove optimizations for now
  611. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  612. - Bero told me to move the Makefile into this package
  613. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  614. - add lib*.so symlinks to link dynamically against shared libs
  615. * Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  616. - update to 0.9.5
  617. - run ldconfig directly in post/postun
  618. - add FAQ
  619. * Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  620. - Fix build on non-x86 platforms
  621. * Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  622. - move /usr/share/ssl/* from -devel to main package
  623. * Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  624. - inital packaging
  625. - changes from base:
  626. - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
  627. - handle RPM_OPT_FLAGS