openhpi-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344
  1. Summary: Hardware Platform Interface library and tools
  2. Summary(ja): ハードウエアプラットフォームインタフェースライブラリおよびツール
  3. Name: openhpi
  4. Version: 3.0.0
  5. Release: 2%{?_dist_release}
  6. License: BSD
  7. Group: System Environment/Base
  8. URL: http://www.openhpi.org
  9. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  10. Source1: %{name}.initd
  11. Source2: %{name}.sysconfig
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. BuildRequires: sysfsutils-devel, net-snmp-devel, OpenIPMI-devel, glib2-devel
  14. BuildRequires: libtool-ltdl-devel, openssl-devel, ncurses-devel
  15. BuildRequires: libxml2-devel, docbook-utils, libuuid-devel
  16. Requires(post): chkconfig
  17. Requires(preun): chkconfig
  18. Requires(preun): initscripts
  19. %description
  20. OpenHPI is an open source project created with the intent of providing an
  21. implementation of the SA Forum's Hardware Platform Interface (HPI). HPI
  22. provides an abstracted interface to managing computer hardware, typically for
  23. chassis and rack based servers. HPI includes resource modeling; access to and
  24. control over sensor, control, watchdog, and inventory data associated with
  25. resources; abstracted System Event Log interfaces; hardware events and alerts;
  26. and a managed hot swap interface.
  27. OpenHPI provides a modular mechanism for adding new hardware and device support
  28. easily. Many plug-ins exist in the OpenHPI source tree to provide access to
  29. various types of hardware. This includes, but is not limited to, IPMI based
  30. servers, Blade Center, and machines which export data via sysfs.
  31. #'
  32. %package libs
  33. Group: System Environment/Libraries
  34. Summary: The system libraries for the OpenHPI project
  35. Summary(ja): OpenHPI のシステムライブラリ
  36. Obsoletes: %{name} < 2.10.2-1
  37. %description libs
  38. The system libraries for the OpenHPI project.
  39. %package devel
  40. Group: Development/Libraries
  41. Summary: The development environment for the OpenHPI project
  42. Summary(ja): OpenHPIの開発環境
  43. Requires: %{name}-libs = %{version}-%{release}
  44. Requires: glib2-devel, pkgconfig
  45. %description devel
  46. The development libraries and header files for the OpenHPI project.
  47. %prep
  48. %setup -q
  49. # fix permissions
  50. chmod a-x plugins/simulator/*.[ch]
  51. chmod a-x clients/*.[ch]
  52. %build
  53. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  54. %configure --disable-static
  55. # Don't use rpath!
  56. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  57. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  58. make %{?_smp_mflags}
  59. %install
  60. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
  61. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  62. mkdir -p $RPM_BUILD_ROOT%{_initddir}
  63. mkdir -p -m1777 $RPM_BUILD_ROOT%{_var}/lib/%{name}
  64. make install DESTDIR=$RPM_BUILD_ROOT
  65. rm -f $RPM_BUILD_ROOT%{_sysconfdir}/init.d/openhpid
  66. install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initddir}/openhpid
  67. install -p -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/openhpid
  68. rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la
  69. rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/*.la
  70. %clean
  71. rm -rf $RPM_BUILD_ROOT
  72. %post
  73. /sbin/chkconfig --add openhpid
  74. %preun
  75. if [ $1 = 0 ] ; then
  76. /sbin/service openhpid stop >/dev/null 2>&1
  77. /sbin/chkconfig --del openhpid
  78. fi
  79. %postun
  80. if [ "$1" -ge "1" ] ; then
  81. /sbin/service openhpid condrestart >/dev/null 2>&1
  82. fi
  83. %post libs -p /sbin/ldconfig
  84. %postun libs -p /sbin/ldconfig
  85. %files
  86. %defattr(-,root,root,-)
  87. %doc COPYING README README.daemon openhpi.conf.example
  88. %dir %{_sysconfdir}/%{name}
  89. %config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
  90. %config(noreplace) %{_sysconfdir}/%{name}/%{name}client.conf
  91. %config(noreplace) %{_sysconfdir}/openhpi/simulation.data
  92. %{_initddir}/openhpid
  93. %config(noreplace) %{_sysconfdir}/sysconfig/openhpid
  94. %attr(1777,root,root) %{_var}/lib/%{name}
  95. %{_bindir}/*
  96. %{_sbindir}/*
  97. %{_libdir}/%{name}
  98. %{_mandir}/man1/*
  99. %{_mandir}/man7/*
  100. %{_mandir}/man8/*
  101. %files libs
  102. %defattr(-,root,root,-)
  103. %{_libdir}/*.so.*
  104. %files devel
  105. %defattr(-,root,root,-)
  106. %doc COPYING
  107. %{_libdir}/*.so
  108. %{_includedir}/%{name}
  109. %{_libdir}/pkgconfig/*.pc
  110. %changelog
  111. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 3.0.0-2
  112. - rebuild with gcc-5.4.0
  113. * Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
  114. - new upstream release
  115. - remove Patch0
  116. * Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.14.1-2
  117. - rebuild with openssl-1.0.0d
  118. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
  119. - initial build for Vine Linux
  120. * Wed Feb 24 2010 Dan Horák <dan[at]danny.cz> - 2.14.1-3
  121. - update initscript (#521648, #521830)
  122. * Fri Jan 15 2010 Dan Horák <dan[at]danny.cz> - 2.14.1-2
  123. - added fix for inconsistent SaHpi.h
  124. * Wed Nov 25 2009 Dan Horák <dan[at]danny.cz> - 2.14.1-1
  125. - updated to bug fix release 2.14.1
  126. * Fri Oct 9 2009 Dan Horák <dan[at]danny.cz> - 2.14.0-6
  127. - rebuilt with net-snmp 5.5
  128. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.14.0-5
  129. - rebuilt with new openssl
  130. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14.0-4
  131. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  132. * Wed Jul 14 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-3
  133. - add BR: libuuid-devel
  134. * Fri Apr 17 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-2
  135. - use upstream default config
  136. - libtoolize/autoreconf is not needed
  137. * Fri Apr 17 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-1
  138. - update to 2.14.0
  139. * Wed Feb 25 2009 Dan Horak <dan[at]danny.cz> - 2.13.3-2
  140. - fix ppc/ppc64 builds
  141. * Wed Feb 25 2009 Dan Horak <dan[at]danny.cz> - 2.13.3-1
  142. - update to 2.13.3
  143. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.13.1-3
  144. - rebuild with new openssl
  145. * Tue Nov 25 2008 Dan Horak <dan[at]danny.cz> - 2.13.1-2
  146. - shorten Summary
  147. * Thu Nov 20 2008 Dan Horak <dan[at]danny.cz> - 2.13.1-1
  148. - update to 2.13.1
  149. * Mon Nov 17 2008 Dan Horak <dan[at]danny.cz> - 2.12.0-2
  150. - rebuild for new libtool
  151. * Sat Jul 26 2008 Dan Horak <dan[at]danny.cz> - 2.12.0-1
  152. - update to 2.12.0
  153. * Thu Jun 27 2008 Dan Horak <dan[at]danny.cz> - 2.11.3-1
  154. - update to 2.11.3
  155. * Thu Apr 18 2008 Dan Horak <dan[at]danny.cz> - 2.10.2-2
  156. - enable the sysfs plugin
  157. - add missing R: for -devel subpackage
  158. * Thu Mar 13 2008 Dan Horak <dan[at]danny.cz> - 2.10.2-1
  159. - update to 2.10.2
  160. - spec file and patch cleanup
  161. * Thu Feb 28 2008 Phil Knirsch <pknirsch@redhat.com> - 2.10.1-3
  162. - Removed incorrect patch for IBM BC snmp_bc plugin
  163. - Fixed GCC 4.3 rebuild problems
  164. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.10.1-2
  165. - Autorebuild for GCC 4.3
  166. * Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.10.1-1
  167. - Updated to openhpi-2.10.1
  168. - Bump release and rebuild due to new openssl
  169. * Thu Aug 23 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-5
  170. - Bump release and rebuild because of PPC issues
  171. - Fix rebuild problems due to new glibc open macro
  172. * Fri Jul 20 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-4
  173. - Fix for hpipower segfaulting when using -b option out of range (#247279)
  174. * Tue Jul 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-3
  175. - Fixed a bug where the snmp_bc plugin didn't work in IBM BC (#247280)
  176. * Mon Jun 04 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-2.fc7
  177. - Fixed missing e2fsprogs-devel and openssl-devel build requires
  178. * Fri Mar 30 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-1.fc7
  179. - Update to openhpi-2.8.1
  180. * Thu Feb 08 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-3.fc7
  181. - Fixed some silly bugs in the specfile
  182. * Wed Feb 07 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-2.fc7
  183. - Bump and rebuild.
  184. * Tue Feb 06 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-1.fc7
  185. - Update to openhpi-2.8.0
  186. * Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-7.fc7
  187. - Rebuilt due to new net-snmp-5.4
  188. - Small specfile updates
  189. * Fri Sep 29 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-6
  190. - Fixed file conflicts for openhpi-switcher (#205226)
  191. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-5.1
  192. - rebuild
  193. * Mon Jul 10 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-5
  194. - Had to disable sysfs support due to new libsysfs and incompatible API.
  195. - Added missing ncurses-devel buildrequires
  196. * Wed Jun 07 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-4
  197. - Rebuilt with final memset patch
  198. - Added missing pkgconfig buildprereq (#191935)
  199. * Fri May 26 2006 Radek Vokal <rvokal@redhat.com> - 2.4.1-2
  200. - rebuilt for new libnetsnmp and net-snmp-config changes
  201. * Wed May 24 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-1
  202. - Fixed buggy use of memset throughout the code
  203. - Made the package build and install properly
  204. * Fri May 19 2006 Phil Knirsch <pknirsch@redhat.com>
  205. - Added missing glib2-devel build prereq (#191935)
  206. - Update to latest stable version openhpi-2.4.1
  207. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.1-4.2
  208. - bump again for double-long bug on ppc(64)
  209. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.1-4.1
  210. - rebuilt for new gcc4.1 snapshot and glibc changes
  211. * Mon Jan 9 2006 Peter Jones <pjones@redhat.com> 2.2.1-4
  212. - Don't use -Werror, it doesn't build with that on ppc64 currently.
  213. * Mon Jan 06 2006 Jesse Keating <jkeating@redhat.com> 2.2.1-3
  214. - Fix to not use stict-aliasing.
  215. * Wed Jan 04 2006 Radek Vokal <rvokal@redhat.com> 2.2.1-2
  216. - Rebuilt against new libnetsnmp
  217. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  218. - rebuilt
  219. * Fri Nov 11 2005 Phil Knirsch <pknirsch@redhat.com> 2.2.1-1
  220. - Update to stable openhpi-2.2.1
  221. * Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-5
  222. - Rebuilt to link against latest openssl lib.
  223. * Mon Nov 07 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-4
  224. - Added the openhpi config file
  225. - Added missing /var/lib/openhpi dir with proper rights
  226. - Added a few missing BuildPreReqs
  227. * Thu Nov 03 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-3
  228. - Rebuild against new net-snmp libs
  229. * Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-1
  230. - Moved the pkgconfig files to the devel package (#152507)
  231. - Update to openhpi-2.0.3
  232. - Had to manually disable ipmi support for now until openhpi builds correctly
  233. against it again
  234. - Dropped net-snmp-config patch, not needed anymore
  235. * Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-5
  236. - Fixed gcc4 rebuild problems
  237. * Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-4
  238. - bump release and rebuild with gcc 4
  239. * Mon Feb 14 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-3
  240. - Rebuilt for new rpm-4.4
  241. * Mon Dec 20 2004 Phil Knirsch <pknirsch@redhat.com> 1.9.2-2
  242. - Fixed overflow in plugins/sysfs/sysfs2hpi.c
  243. - Fixed rebuild problem with latest net-snmp
  244. - Removed is_simulator patch, not needed anymore
  245. * Fri Nov 26 2004 Florian La Roche <laroche@redhat.com> 1.9.2-1
  246. - update to 1.9.2
  247. * Tue Nov 02 2004 Phil Knirsch <pknirsch@redhat.com> 1.9.1-1
  248. - Added proper BuildRequires
  249. - Drop ia64 for first build, something fishy with the compiler and warning.
  250. * Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
  251. - Initial version
  252. - Disable dummy plugin, doesn't compile
  253. - Fix missing () in snmp_bc_session.c