opencv-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661
  1. #global indice a
  2. Name: opencv
  3. Version: 2.4.9
  4. Release: 8%{?_dist_release}
  5. Summary: Collection of algorithms for computer vision
  6. Summary(ja): コンピュータビジョン用のアルゴリズム集
  7. Group: System Environment/Libraries
  8. # This is normal three clause BSD.
  9. License: BSD
  10. URL: http://opencv.org
  11. # Need to remove SIFT/SURF from source tarball, due to legal concerns
  12. # rm -f opencv-%%{version}/modules/nonfree/src/sift.cpp
  13. # rm -f opencv-%%{version}/modules/nonfree/src/surf.cpp
  14. # Removed because we don't use pre-built contribs
  15. # rm -rf 3rdparty
  16. #Source0: http://downloads.sourceforge.net/opencvlibrary/opencv-unix/%{version}/%{name}-%{version}%{?indice}.zip
  17. Source0: %{name}-clean-%{version}%{?indice}.tar.xz
  18. Source1: opencv-samples-Makefile
  19. Patch0: opencv-pkgcmake.patch
  20. #http://code.opencv.org/issues/2720
  21. Patch2: OpenCV-2.4.4-pillow.patch
  22. Patch3: opencv-2.4.9-ts_static.patch
  23. # fix/simplify cmake config install location (upstreamable)
  24. # https://bugzilla.redhat.com/1031312
  25. Patch4: opencv-2.4.7-cmake_paths.patch
  26. # relevant gst1-related patches from upstream master branch
  27. # 0550 needed slight rebasing -- rex
  28. Patch10: 0550-bomb-commit-of-gstreamer-videocapture-and-videowrite.patch
  29. Patch11: 0552-eliminated-warnings.patch
  30. Patch12: 0587-Fix-build-with-gstreamer-0.10.28.patch
  31. Patch13: 0865-gstreamer-cleaning-up-resources.patch
  32. Patch14: 0871-allow-for-arbitraty-number-of-sources-and-sinks.patch
  33. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  34. BuildRequires: libtool
  35. BuildRequires: cmake >= 2.6.3
  36. BuildRequires: chrpath
  37. %if "%{?_dist_release}" == "vl6"
  38. BuildRequires: eigen2-devel
  39. %else
  40. BuildRequires: eigen3-devel
  41. %endif
  42. BuildRequires: gtk2-devel
  43. BuildRequires: libtheora-devel
  44. BuildRequires: libvorbis-devel
  45. BuildRequires: libraw1394-devel
  46. BuildRequires: libdc1394-devel
  47. BuildRequires: jasper-devel
  48. BuildRequires: libpng-devel
  49. BuildRequires: libjpeg-devel
  50. BuildRequires: libtiff-devel
  51. %if "%{?_dist_release}" != "vl6"
  52. BuildRequires: libv4l-devel
  53. %endif
  54. BuildRequires: mesa-libGL-devel
  55. BuildRequires: gtkglext-devel
  56. BuildRequires: OpenEXR-devel
  57. #ifarch %{ix86} x86_64
  58. #BuildRequires: openni-devel
  59. #BuildRequires: openni-primesense
  60. #endif
  61. %if "%{?_dist_release}" != "vl6"
  62. %ifarch %{ix86} x86_64 ia64 ppc ppc64
  63. BuildRequires: tbb-devel
  64. %endif
  65. %endif
  66. BuildRequires: zlib-devel pkgconfig
  67. BuildRequires: python-devel
  68. BuildRequires: numpy
  69. BuildRequires: swig >= 1.3.24
  70. BuildRequires: python-sphinx
  71. #BuildRequires: ffmpeg-devel >= 0.4.9
  72. %if "%{?_dist_release}" == "vl6"
  73. BuildRequires: gstreamer-devel
  74. BuildRequires: gstreamer-plugins-base-devel
  75. %else
  76. BuildRequires: gstreamer1-devel
  77. BuildRequires: gstreamer1-plugins-base-devel
  78. %endif
  79. #BuildRequires: xine-lib-devel
  80. #BuildRequires: opencl-headers
  81. Requires: opencv-core = %{version}-%{release}
  82. %description
  83. OpenCV means Intel® Open Source Computer Vision Library. It is a collection of
  84. C functions and a few C++ classes that implement some popular Image Processing
  85. and Computer Vision algorithms.
  86. %package core
  87. Summary: OpenCV core libraries
  88. Summary(ja): OpenCV コアライブラリ
  89. Group: System Environment/Libraries
  90. %description core
  91. This package contains the OpenCV C/C++ core libraries.
  92. %package devel
  93. Summary: Development files for using the OpenCV library
  94. Summary(ja): OpenCV ライブラリを使用するための開発用ファイル
  95. Group: Development/Libraries
  96. Requires: opencv = %{version}-%{release}
  97. %description devel
  98. This package contains the OpenCV C/C++ library and header files, as well as
  99. documentation. It should be installed if you want to develop programs that
  100. will use the OpenCV library. You should consider installing opencv-devel-docs
  101. package.
  102. %package devel-docs
  103. Summary: Development files for using the OpenCV library
  104. Summary(ja): OpenCV ライブラリを使用するための開発用ドキュメント
  105. Group: Documentation
  106. Requires: opencv-devel = %{version}-%{release}
  107. BuildArch: noarch
  108. %description devel-docs
  109. This package contains the OpenCV documentation and examples programs.
  110. %package python
  111. Summary: Python bindings for apps which use OpenCV
  112. Summary(ja): OpenCV 使用するアプリケーション用の Python バインディング
  113. Group: Development/Libraries
  114. Requires: opencv = %{version}-%{release}
  115. Requires: numpy
  116. %description python
  117. This package contains Python bindings for the OpenCV library.
  118. %prep
  119. %setup -q
  120. %patch0 -p1 -b .pkgcmake
  121. %patch2 -p1 -b .pillow
  122. %patch3 -p1 -b .ts_static
  123. %patch4 -p1 -b .cmake_paths
  124. # for gst1
  125. %patch10 -p1 -b .10
  126. %patch11 -p1 -b .11
  127. %patch12 -p1 -b .12
  128. %patch13 -p1 -b .13
  129. %patch14 -p1 -b .14
  130. # fix dos end of lines
  131. sed -i 's|\r||g' samples/c/adaptiveskindetector.cpp
  132. %build
  133. # enabled by default if libraries are presents at build time:
  134. # GTK, GSTREAMER, UNICAP, 1394, V4L
  135. # non available on Fedora: FFMPEG, XINE
  136. mkdir -p build
  137. pushd build
  138. %cmake CMAKE_VERBOSE=1 \
  139. -DPYTHON_PACKAGES_PATH=%{python_sitearch} \
  140. -DCMAKE_SKIP_RPATH=ON \
  141. -DENABLE_PRECOMPILED_HEADERS:BOOL=OFF \
  142. %ifnarch x86_64 ia64
  143. -DENABLE_SSE=0 \
  144. -DENABLE_SSE2=0 \
  145. %endif
  146. -DENABLE_SSE3=0 \
  147. -DCMAKE_BUILD_TYPE=ReleaseWithDebInfo \
  148. -DBUILD_TEST=1 \
  149. -DBUILD_opencv_java=0 \
  150. -DBUILD_opencv_nonfree=0 \
  151. -DBUILD_opencv_gpu=0 \
  152. -DWITH_FFMPEG=0 \
  153. -DWITH_GSTREAMER_1_X=1 \
  154. -DWITH_OPENGL=1 \
  155. -DWITH_OPENMP=1 \
  156. %if "%{?_dist_release}" == "vl6"
  157. -DWITH_V4L=0 \
  158. %else
  159. %ifarch %{ix86} x86_64 ia64
  160. -DWITH_TBB=1 -DTBB_LIB_DIR=%{_libdir} \
  161. %endif
  162. %endif
  163. -DWITH_XINE=0 \
  164. -DINSTALL_C_EXAMPLES=1 \
  165. -DINSTALL_PYTHON_EXAMPLES=1 \
  166. ..
  167. #{?_without_gstreamer:-DWITH_GSTREAMER=0} \
  168. #%{?_with_cuda: \
  169. # -DCUDA_TOOLKIT_ROOT_DIR=%{?_cuda_topdir} \
  170. # -DCUDA_VERBOSE_BUILD=1 \
  171. # -DCUDA_PROPAGATE_HOST_FLAGS=0 \
  172. #} \
  173. #%ifarch %{ix86} x86_64
  174. #%{?_with_openni: \
  175. # -DWITH_OPENNI=ON \
  176. #} \
  177. #%endif
  178. # -DOPENCL_INCLUDE_DIR=${_includedir}/CL \
  179. make VERBOSE=1 %{?_smp_mflags}
  180. popd
  181. %install
  182. rm -rf %{buildroot}
  183. rm -rf __devel-doc
  184. pushd build
  185. make install DESTDIR=%{buildroot} INSTALL="install -p" CPPROG="cp -p"
  186. find %{buildroot} -name '*.la' -delete
  187. rm -f %{buildroot}%{_datadir}/OpenCV/samples/c/build_all.sh \
  188. %{buildroot}%{_datadir}/OpenCV/samples/c/cvsample.dsp \
  189. %{buildroot}%{_datadir}/OpenCV/samples/c/cvsample.vcproj \
  190. %{buildroot}%{_datadir}/OpenCV/samples/c/facedetect.cmd
  191. install -pm644 %{SOURCE1} %{buildroot}%{_datadir}/OpenCV/samples/c/GNUmakefile
  192. # remove unnecessary documentation
  193. rm -rf %{buildroot}%{_datadir}/OpenCV/doc
  194. popd
  195. %check
  196. # Check fails since we don't support most video
  197. # read/write capability and we don't provide a display
  198. # ARGS=-V increases output verbosity
  199. # Make test is unavailble as of 2.3.1
  200. %if 0
  201. #ifnarch ppc64
  202. pushd build
  203. LD_LIBRARY_PATH=%{_builddir}/%{tar_name}-%{version}/lib:$LD_LIBARY_PATH make test ARGS=-V || :
  204. popd
  205. %endif
  206. %clean
  207. rm -rf %{buildroot}
  208. %post core -p /sbin/ldconfig
  209. %postun core -p /sbin/ldconfig
  210. %post -p /sbin/ldconfig
  211. %postun -p /sbin/ldconfig
  212. %files
  213. %doc LICENSE README.md
  214. %{_bindir}/opencv_*
  215. %{_libdir}/libopencv_calib3d.so.2.4*
  216. %{_libdir}/libopencv_contrib.so.2.4*
  217. %{_libdir}/libopencv_features2d.so.2.4*
  218. %{_libdir}/libopencv_highgui.so.2.4*
  219. %{_libdir}/libopencv_legacy.so.2.4*
  220. %{_libdir}/libopencv_objdetect.so.2.4*
  221. #{_libdir}/libopencv_ocl.so.2.4*
  222. %{_libdir}/libopencv_stitching.so.2.4*
  223. %{_libdir}/libopencv_superres.so.2.4*
  224. %{_libdir}/libopencv_ts.so.2.4*
  225. %{_libdir}/libopencv_videostab.so.2.4*
  226. %dir %{_datadir}/OpenCV
  227. %{_datadir}/OpenCV/haarcascades
  228. %{_datadir}/OpenCV/lbpcascades
  229. %files core
  230. %{_libdir}/libopencv_core.so.2.4*
  231. %{_libdir}/libopencv_flann.so.2.4*
  232. %{_libdir}/libopencv_imgproc.so.2.4*
  233. %{_libdir}/libopencv_ml.so.2.4*
  234. %{_libdir}/libopencv_photo.so.2.4*
  235. %{_libdir}/libopencv_video.so.2.4*
  236. %files devel
  237. %{_includedir}/opencv
  238. %{_includedir}/opencv2
  239. %{_libdir}/lib*.so
  240. %{_libdir}/pkgconfig/opencv.pc
  241. %dir %{_libdir}/OpenCV/
  242. %{_libdir}/OpenCV/*.cmake
  243. %files devel-docs
  244. %doc doc/*.{htm,png,jpg}
  245. %doc %{_datadir}/OpenCV/samples
  246. %files python
  247. %{python_sitearch}/cv.py*
  248. %{python_sitearch}/cv2.so
  249. %changelog
  250. * Mon Mar 27 2017 Daisuke SUZUKI <daisuke@vinelinux.org> 2.4.9-8
  251. - use eigen2 on Vine Linux 6.x
  252. - disable tbb/v4l on Vine Linux 6.x
  253. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 2.4.9-7
  254. - rebuild with gcc-5.4.0
  255. * Wed Mar 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-6
  256. - built with tbb
  257. - moved main package to System Environment/Libraries Group
  258. * Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.4.9-5
  259. - Initial build for Vine Linux
  260. * Tue Nov 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-4
  261. - rebuild (openexr)
  262. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.9-3
  263. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  264. * Fri Jul 25 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.9-2
  265. - backport support for GStreamer 1 (#1123078)
  266. * Thu Jul 03 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.9-1
  267. - Update to 2.4.9
  268. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.7-7
  269. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  270. * Sat Apr 26 2014 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-6
  271. - revert pkgcmake2 patch (#1070428)
  272. * Fri Jan 17 2014 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-5
  273. - Fix opencv_ocl isn't part of -core
  274. * Thu Jan 16 2014 Christopher Meng <rpm@cicku.me> - 2.4.7-4
  275. - Enable OpenCL support.
  276. - SPEC small cleanup.
  277. * Wed Nov 27 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-3
  278. - rebuild (openexr)
  279. * Mon Nov 18 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.7-2
  280. - OpenCV cmake configuration broken (#1031312)
  281. * Wed Nov 13 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.7-1
  282. - Update to 2.4.7
  283. * Sun Sep 08 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.6.1-2
  284. - rebuild (openexr)
  285. * Wed Jul 24 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.6.1-1
  286. - Update to 2.4.6.1
  287. * Thu May 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.5-1
  288. - Update to 2.4.5-clean
  289. - Spec file clean-up
  290. - Split core libraries into a sub-package
  291. * Sat May 11 2013 François Cami <fcami@fedoraproject.org> - 2.4.4-3
  292. - change project URL.
  293. * Tue Apr 02 2013 Tom Callaway <spot@fedoraproject.org> - 2.4.4-2
  294. - make clean source without SIFT/SURF
  295. * Sat Mar 23 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-1
  296. - Update to 2.4.4a
  297. - Fix ttb-devel architecture conditionals
  298. * Sun Mar 10 2013 Rex Dieter <rdieter@fedoraproject.org> 2.4.4-0.2.beta
  299. - rebuild (OpenEXR)
  300. * Mon Feb 18 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.4-0.1.beta
  301. - Update to 2.4.4 beta
  302. - Drop python-imaging also from requires
  303. - Drop merged patch for additionals codecs
  304. - Disable the java binding for now (untested)
  305. * Fri Jan 25 2013 Honza Horak <hhorak@redhat.com> - 2.4.3-7
  306. - Do not build with 1394 libs in rhel
  307. * Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 2.4.3-6
  308. - rebuild due to "jpeg8-ABI" feature drop
  309. * Sun Jan 20 2013 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-5
  310. - Add more FourCC for gstreamer - rhbz#812628
  311. - Allow to use python-pillow - rhbz#895767
  312. * Mon Nov 12 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-3
  313. - Switch Build Type to ReleaseWithDebInfo to avoid -03
  314. * Sun Nov 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.3-2
  315. - Disable SSE3 and allow --with sse3 build conditional.
  316. - Disable gpu module as we don't build cuda
  317. - Update to 2.4.3
  318. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.2-2
  319. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  320. * Mon Jul 09 2012 Honza Horak <hhorak@redhat.com> - 2.4.2-1
  321. - Update to 2.4.2
  322. * Fri Jun 29 2012 Honza Horak <hhorak@redhat.com> - 2.4.1-2
  323. - Fixed cmake script for generating opencv.pc file
  324. - Fixed OpenCVConfig script file
  325. * Mon Jun 04 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.4.1-1
  326. - Update to 2.4.1
  327. - Rework dependencies - rhbz#828087
  328. Re-enable using --with tbb,opennpi,eigen2,eigen3
  329. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-8
  330. - Rebuilt for c++ ABI breakage
  331. * Mon Jan 16 2012 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-7
  332. - Update gcc46 patch for ARM FTBFS
  333. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-6
  334. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  335. * Mon Dec 05 2011 Adam Jackson <ajax@redhat.com> 2.3.1-5
  336. - Rebuild for new libpng
  337. * Thu Oct 20 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-4
  338. - Rebuilt for tbb silent ABI change
  339. * Mon Oct 10 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-3
  340. - Update to 2.3.1a
  341. * Mon Sep 26 2011 Dan Horák <dan[at]danny.cz> - 2.3.1-2
  342. - openni is exclusive for x86/x86_64
  343. * Fri Aug 19 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.3.1-1
  344. - Update to 2.3.1
  345. - Add BR openni-devel python-sphinx
  346. - Remove deprecated cmake options
  347. - Add --with cuda conditional (wip)
  348. - Disable make test (unavailable)
  349. * Thu May 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-6
  350. - Backport fixes from branch 2.2 to date
  351. * Tue May 17 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-5
  352. - Re-enable v4l on f15
  353. - Remove unused cmake options
  354. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-3
  355. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  356. * Wed Feb 02 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-2
  357. - Fix with gcc46
  358. - Disable V4L as V4L1 is disabled for Fedora 15
  359. * Thu Jan 06 2011 Nicolas Chauvet <kwizart@gmail.com> - 2.2.0-1
  360. - Update to 2.2.0
  361. - Disable -msse and -msse2 on x86_32
  362. * Wed Aug 25 2010 Rex Dieter <rdieter@fedoraproject.org> - 2.1.0-5
  363. - -devel: include OpenCVConfig.cmake (#627359)
  364. * Thu Jul 22 2010 Dan Horák <dan[at]danny.cz> - 2.1.0-4
  365. - TBB is available only on x86/x86_64 and ia64
  366. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 2.1.0-3
  367. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  368. * Fri Jun 25 2010 Nicolas Chauvet <kwizart@gmail.com> - 2.1.0-2
  369. - Move samples from main to -devel
  370. - Fix spurious permission
  371. - Add BR tbb-devel
  372. - Fix CFLAGS
  373. * Fri Apr 23 2010 Nicolas Chauvet <kwizart@fedoraproject.org> - 2.1.0-1
  374. - Update to 2.1.0
  375. - Update libdir patch
  376. * Tue Apr 13 2010 Karel Klic <kklic@redhat.com> - 2.0.0-10
  377. - Fix nonstandard executable permissions
  378. * Tue Mar 09 2010 Karel Klic <kklic@redhat.com> - 2.0.0-9
  379. - apply the previously added patch
  380. * Mon Mar 08 2010 Karel Klic <kklic@redhat.com> - 2.0.0-8
  381. - re-enable testing on CMake build system
  382. - fix memory corruption in the gaussian random number generator
  383. * Sat Feb 27 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-7
  384. - replaced BR unicap-devel by libucil-devel (unicap split)
  385. * Thu Feb 25 2010 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-6
  386. - use cmake build system
  387. - applications renamed to opencv_xxx instead of opencv-xxx
  388. - add devel-docs subpackage #546605
  389. - add OpenCVConfig.cmake
  390. - enable openmp build
  391. - enable old SWIG based python wrappers
  392. - opencv package is a good boy and use global instead of define
  393. * Tue Feb 16 2010 Karel Klic <kklic@redhat.com> - 2.0.0-5
  394. - Set CXXFLAXS without -match=i386 for i386 architecture #565074
  395. * Sat Jan 09 2010 Rakesh Pandit <rakesh@fedoraproject.org> - 2.0.0-4
  396. - Updated opencv-samples-Makefile (Thanks Scott Tsai) #553697
  397. * Wed Jan 06 2010 Karel Klic <kklic@redhat.com> - 2.0.0-3
  398. - Fixed spec file issues detected by rpmlint
  399. * Sun Dec 06 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-2
  400. - Fix autotools scripts (missing LBP features) - #544167
  401. * Fri Nov 27 2009 Haïkel Guémar <karlthered@gmail.com> - 2.0.0-1
  402. - Updated to 2.0.0
  403. - Removed upstream-ed patches
  404. - Ugly hack (added cvconfig.h)
  405. - Disable %%check on ppc64
  406. * Thu Sep 10 2009 Karsten Hopp <karsten@redhat.com> - 1.1.0-0.7.pre1
  407. - fix build on s390x where we don't have libraw1394 and devel
  408. * Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.6.pre1
  409. - Fix typo I introduced that prevented build on i386/i586
  410. * Thu Jul 30 2009 Haïkel Guémar <karlthered@gmail.com> - 1.1.0.0.5.pre1
  411. - Added 1394 libs and unicap support
  412. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.0-0.4.pre1
  413. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  414. * Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.3.pre1
  415. - Build with gstreamer support - #491223
  416. - Backport gcc43 fix from trunk
  417. * Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.2.pre1
  418. - Fix FTBFS #511705
  419. * Fri Apr 24 2009 kwizart < kwizart at gmail.com > - 1.1.0-0.1.pre1
  420. - Update to 1.1pre1
  421. - Disable CXXFLAGS hardcoded optimization
  422. - Add BR: python-imaging, numpy
  423. - Disable make check failure for now
  424. * Wed Apr 22 2009 kwizart < kwizart at gmail.com > - 1.0.0-14
  425. - Fix for gcc44
  426. - Enable BR jasper-devel
  427. - Disable ldconfig run on python modules (uneeded)
  428. - Prevent timestamp change on install
  429. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-13
  430. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  431. * Mon Dec 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 1.0.0-12
  432. - fix URL field
  433. * Fri Dec 19 2008 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.0.0-11
  434. - Adopt latest python spec rules.
  435. - Rebuild for Python 2.6 once again.
  436. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.0-10
  437. - Rebuild for Python 2.6
  438. * Thu May 22 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.0.0-9
  439. - fix license tag
  440. * Sun May 11 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-8
  441. - Adjust library order in opencv.pc.in (BZ 445937).
  442. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.0-7
  443. - Autorebuild for GCC 4.3
  444. * Sun Feb 10 2008 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-6
  445. - Rebuild for gcc43.
  446. * Tue Aug 28 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.0.0-5
  447. - Rebuild for selinux ppc32 issue.
  448. * Wed Aug 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-4
  449. - Mass rebuild.
  450. * Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-3
  451. - Fix %%{_datadir}/opencv/samples ownership.
  452. - Adjust timestamp of cvconfig.h.in to avoid re-running autoheader.
  453. * Thu Mar 22 2007 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-2
  454. - Move all of the python module to pyexecdir (BZ 233128).
  455. - Activate the testsuite.
  456. * Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 1.0.0-1
  457. - Upstream update.
  458. * Mon Dec 11 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-4
  459. - Remove python-abi.
  460. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.9.9-3
  461. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  462. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-2
  463. - Stop configure.in from hacking CXXFLAGS.
  464. - Activate testsuite.
  465. - Let *-devel require pkgconfig.
  466. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.9-1
  467. - Upstream update.
  468. - Don't BR: autotools.
  469. - Install samples' Makefile as GNUmakefile.
  470. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-18
  471. - Un'%%ghost *.pyo.
  472. - Separate %%{pythondir} from %%{pyexecdir}.
  473. * Thu Sep 21 2006 Ralf Corsépius <rc040203@freenet.de> - 0.9.7-17
  474. - Rebuild for FC6.
  475. - BR: libtool.
  476. * Fri Mar 17 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-16
  477. - Rebuild.
  478. * Wed Mar 8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-15
  479. - Force a re-run of Autotools by calling autoreconf.
  480. * Wed Mar 8 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-14
  481. - Added build dependency on Autotools.
  482. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-13
  483. - Changed intrinsics patch so that it matches upstream.
  484. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-12
  485. - More intrinsics patch fixing.
  486. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-11
  487. - Don't do "make check" because it doesn't run any tests anyway.
  488. - Back to main intrinsics patch.
  489. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-10
  490. - Using simple intrinsincs patch.
  491. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-9
  492. - Still more fixing of intrinsics patch for Python bindings on x86_64.
  493. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-8
  494. - Again fixed intrinsics patch so that Python modules build on x86_64.
  495. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-7
  496. - Fixed intrinsics patch so that it works.
  497. * Tue Mar 7 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-6
  498. - Fixed Python bindings location on x86_64.
  499. * Mon Mar 6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-5
  500. - SSE2 support on x86_64.
  501. * Mon Mar 6 2006 Simon Perreault <nomis80@nomis80.org> - 0.9.7-4
  502. - Rebuild
  503. * Sun Oct 16 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-3
  504. - Removed useless sample compilation makefiles/project files and replaced them
  505. with one that works on Fedora Core.
  506. - Removed shellbang from Python modules.
  507. * Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-2
  508. - Made FFMPEG dependency optional (needs to be disabled for inclusion in FE).
  509. * Mon Oct 10 2005 Simon Perreault <nomis80@nomis80.org> - 0.9.7-1
  510. - Initial package.