libsigc++-vl.spec 8.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269
  1. %define name libsigc++
  2. %define version 2.10.2
  3. %define release 1%{?_dist_release}
  4. %define lib_name sigc++-2.0
  5. %define _unpackaged_files_terminate_build 1
  6. Summary: The Typesafe Signal Framework for C++
  7. Summary(ja): C++ 用の型安全なシグナルフレームワーク
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Group: System Environment/Libraries
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: LGPLv2
  15. URL: https://github.com/libsigcplusplus/libsigcplusplus
  16. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  17. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  18. Buildroot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: gcc-c++
  20. BuildRequires: m4
  21. %description
  22. This library implements a full callback system for use in widget libraries,
  23. abstract interfaces, and general programming. Originally part of the Gtk--
  24. widget set, %{name} is now a seperate library to provide for more general
  25. use. It is the most complete library of its kind with the ablity to connect
  26. an abstract callback to a class method, function, or function object. It
  27. contains adaptor classes for connection of dissimilar callbacks and has an
  28. ease of use unmatched by other C++ callback libraries.
  29. Package gtkmm2, which is a C++ binding to the GTK2 library, uses libsigc++.
  30. %package devel
  31. Summary: development tools for the Typesafe Signal Framework for C++
  32. Group: Development/Libraries
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: pkgconfig
  35. %description devel
  36. The %{name}-devel package contains the static libraries and header files
  37. needed for development with %{name}.
  38. %package examples
  39. Summary: examples and tests for the Typesafe Signal Framework for C++
  40. Group: Development/Libraries
  41. Requires: %{name}-devel = %{version}-%{release}
  42. %description examples
  43. The %{name}-devel package contains source code of example and test
  44. programs for %{name}.
  45. %prep
  46. %setup -q
  47. %build
  48. %configure --disable-static --enable-silent-rules
  49. make %{_smp_mflags}
  50. %install
  51. rm -rf $RPM_BUILD_ROOT
  52. make install DESTDIR=$RPM_BUILD_ROOT
  53. # removed unpackage files
  54. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  55. mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
  56. cp -a examples tests $RPM_BUILD_ROOT%{_libdir}/%{lib_name}
  57. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .libs |xargs -r rm -rf
  58. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type d -name .deps |xargs -r rm -rf
  59. find $RPM_BUILD_ROOT%{_libdir}/%{lib_name} -type f |xargs file |
  60. grep -E '(relocatable|executable|shell script)' |cut -d: -f1 |xargs -r rm -f
  61. for i in $RPM_BUILD_ROOT%{_libdir}/%{lib_name}/{examples,tests}/Makefile; do
  62. rm -f $i.*
  63. done
  64. rm -rf docs-toinstall
  65. mkdir -p docs-to-install
  66. cp -pr $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0/* docs-to-install/
  67. rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-2.0
  68. # devhelp path fix
  69. sed -i 's/doc\/%{name}-2.0/doc\/%{name}-devel-%{version}/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/%{name}-2.0/%{name}-2.0.devhelp2
  70. #sed -i 's/html\/..\/..\/index\.html/html\/index\.html/g' $RPM_BUILD_ROOT%{_datadir}/devhelp/books/libglademm-%{ver}/libglademm-%{ver}.devhelp
  71. %post -p /sbin/ldconfig
  72. %postun -p /sbin/ldconfig
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75. %files
  76. %defattr(-,root,root,755)
  77. %license COPYING
  78. %doc AUTHORS README NEWS ChangeLog TODO
  79. %attr(755,root,root) %{_libdir}/lib*.so.*
  80. %files devel
  81. %defattr(-,root,root,755)
  82. %{_includedir}/*
  83. %{_libdir}/%{lib_name}/include
  84. %{_libdir}/pkgconfig/*.pc
  85. #{_libdir}/lib*.la
  86. %{_libdir}/lib*.so
  87. %{_datadir}/devhelp/books/%{name}-2.0/*
  88. %doc docs-to-install/index.html docs-to-install/images
  89. %doc docs-to-install/reference docs-to-install/tutorial
  90. %files examples
  91. %defattr(-,root,root,755)
  92. %{_libdir}/%{lib_name}/examples
  93. %{_libdir}/%{lib_name}/tests
  94. %changelog
  95. * Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.2-1
  96. - new upstream release.
  97. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10.0-1
  98. - new upstream release.
  99. * Fri Jul 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
  100. - new upstream release
  101. * Wed Jun 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-2
  102. - rebuild with gcc-5.4.0
  103. * Sat Nov 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  104. - new upstream release
  105. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.1-1
  106. - new upstream release
  107. * Sun Oct 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.11-1
  108. - new upstream release
  109. * Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.10-1
  110. - new upstream release
  111. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.2.8-2
  112. - build with rpm-4.8.1-1 for pkg-config file
  113. * Thu Sep 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.8-1
  114. - new upstream release
  115. * Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6-1
  116. - new upstream release
  117. - built with new toolchain
  118. * Sun Sep 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.4.2-1
  119. - new upstream release
  120. - remove static libraries from devel package
  121. * Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-1
  122. - new upstream release
  123. - spec in UTF-8
  124. * Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-2vl5
  125. - removed .la files from devel package
  126. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.2-1vl5
  127. - new upstream release
  128. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.17-0vl2
  129. - rebuild with new environment/toolchain
  130. * Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.17-0vl1
  131. - new upstream release
  132. * Tue Aug 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl2
  133. - rebuild with new libtool
  134. * Tue Aug 2 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.16-0vl1
  135. - new upstream release
  136. * Sat Jul 30 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.15-0vl1
  137. - new upstream release
  138. * Sat Jun 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.14-0vl1
  139. - new upstream release
  140. * Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.10-0vl1
  141. - new upstream release
  142. - added tutorial to devel package
  143. * Sun Nov 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.6-0vl1
  144. - update to 2.0.6
  145. * Sun Dec 14 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl1
  146. - update to 1.2.5
  147. - add Requires: pkgconfig
  148. * Sat Oct 4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.4-0vl3
  149. - rebuild to remove dependance <5371>
  150. - add Japanese summary
  151. - use better macros
  152. - s/Copyright/License/
  153. * Mon Nov 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl2
  154. - rebuild with new toolchain
  155. * Wed Feb 06 2002 Satoshi IWMAOTO <satoshi.iwamoto@nifty.ne.jp>
  156. - 1.0.4-0vl1
  157. - Build for Vine Linux 2.5
  158. * Wed Feb 21 2001 yoneda kenji <yoneda@n.isl.titech.ac.jp>
  159. - packaged for Vine Linux 2.1
  160. * Sat Apr 15 2000 Dmitry V. Levin <ldv@fandra.org>
  161. - updated Url and Source fileds
  162. - 1.0.0 stable release
  163. * Sat Jan 22 2000 Dmitry V. Levin <ldv@fandra.org>
  164. - filtering out -fno-rtti and -fno-exceptions options from $RPM_OPT_FLAGS
  165. - minor install section cleanup
  166. * Wed Jan 19 2000 Allan Rae <rae@lyx.org>
  167. - autogen just creates configure, not runs it, so cleaned that up too.
  168. * Wed Jan 19 2000 Dmitry V. Levin <ldv@fandra.org>
  169. - minor attr fix
  170. - removed unnecessary curly braces
  171. - fixed Herbert's adjustement
  172. * Sat Jan 15 2000 Dmitry V. Levin <ldv@fandra.org>
  173. - minor package dependence fix
  174. * Sat Dec 25 1999 Herbert Valerio Riedel <hvr@gnu.org>
  175. - fixed typo of mine
  176. - added traditional CUSTOM_RELEASE stuff
  177. - added SMP support
  178. * Thu Dec 23 1999 Herbert Valerio Riedel <hvr@gnu.org>
  179. - adjusted spec file to get tests.Makefile and examples.Makefile from scripts/
  180. * Fri Oct 22 1999 Dmitry V. Levin <ldv@fandra.org>
  181. - split into three packages: %name, %name-devel and %name-examples
  182. * Thu Aug 12 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  183. - updated source field and merged conflicts between revisions.
  184. * Tue Aug 10 1999 Dmitry V. Levin <ldv@fandra.org>
  185. - updated Prefix and BuildRoot fields
  186. * Thu Aug 5 1999 Herbert Valerio Riedel <hvr@hvrlab.dhs.org>
  187. - made sure configure works on all alphas
  188. * Wed Jul 7 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  189. - Added autoconf macro for sigc.
  190. * Fri Jun 11 1999 Karl Nelson <kenelson@ece.ucdavis.edu>
  191. - Made into a .in to keep version field up to date
  192. - Still need to do release by hand
  193. * Mon Jun 7 1999 Dmitry V. Levin <ldv@fandra.org>
  194. - added Vendor and Packager fields
  195. * Sat Jun 5 1999 Dmitry V. Levin <ldv@fandra.org>
  196. - updated to 0.8.0
  197. * Tue Jun 1 1999 Dmitry V. Levin <ldv@fandra.org>
  198. - initial revision