libgnomeprint-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423
  1. ## this could go, it's really just so we notice if the soname changes
  2. %define sover 0
  3. %define gettext_package libgnomeprint-2.2
  4. %define glib2_base_version 2.26.0
  5. %define glib2_version %{glib2_base_version}
  6. %define pango_version 1.28.2
  7. %define libxml2_version 2.7.7
  8. %define libart_lgpl_version 2.3.16
  9. %define libbonobo_version 2.32.0
  10. %define freetype_version 2.3.7
  11. %define gtk_doc_version 1.1
  12. Summary: Printing library for GNOME.
  13. Summary(ja): GNOME プリントライブラリ
  14. Name: libgnomeprint
  15. Version: 2.18.8
  16. Release: 4%{?_dist_release}
  17. License: LGPL
  18. Group: System Environment/Libraries
  19. Source: ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.18/%{name}-%{version}.tar.bz2
  20. Patch0: libgnomeprint-2.18.8-freetype-2.5.x.patch
  21. Patch1: libgnomeprint-2.18.8-cups-module.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. BuildRequires: glib2-devel >= %{glib2_version}
  24. BuildRequires: pango-devel >= %{pango_version}
  25. BuildRequires: libxml2-devel >= %{libxml2_version}
  26. BuildRequires: libart_lgpl-devel >= %{libart_lgpl_version}
  27. BuildRequires: libbonobo-devel >= %{libbonobo_version}
  28. BuildRequires: freetype2 >= %{freetype_version}
  29. BuildRequires: gtk-doc >= %{gtk_doc_version}
  30. BuildRequires: libgnomecups-devel >= 0.2.0
  31. BuildRequires: bison
  32. BuildRequires: flex
  33. Requires: libgnomecups >= 0.1.13-0vl2
  34. Requires: urw-fonts
  35. Requires: ghostscript
  36. Requires: ghostscript-fonts
  37. Requires: libxml2
  38. Requires: perl
  39. Vendor: Project Vine
  40. Distribution: Vine Linux
  41. %description
  42. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  43. applications and desktop tools to be used in conjunction with a window
  44. manager for the X Window System. The gnome-print package contains
  45. libraries and fonts needed by GNOME applications for printing.
  46. You should install the gnome-print package if you intend to use any of
  47. the GNOME applications that can print. If you would like to develop
  48. GNOME applications that can print you will also need to install the
  49. gnome-print devel package.
  50. %package devel
  51. Summary: Libraries and include files for developing GNOME applications.
  52. Summary(ja): libgnomeprint のライブラリとヘッダファイル
  53. Group: Development/Libraries
  54. Requires: %{name} = %{version}-%{release}
  55. Requires: glib2-devel >= %{glib2_version}
  56. Requires: pango-devel >= %{pango_version}
  57. Requires: libxml2-devel >= %{libxml2_version}
  58. Requires: libart_lgpl-devel >= %{libart_lgpl_version}
  59. Requires: libbonobo-devel >= %{libbonobo_version}
  60. Requires: freetype2 >= %{freetype_version}
  61. %description devel
  62. GNOME (GNU Network Object Model Environment) is a user-friendly set of
  63. applications and desktop tools to be used in conjunction with a window
  64. manager for the X Window System. The gnome-print-devel package
  65. includes the libraries and include files needed for developing
  66. applications that use the GNOME printing capabilities.
  67. You should install the gnome-print-devel package if you would like to
  68. develop GNOME applications that will use the GNOME print capabilities.
  69. You do not need to install the gnome-print-devel package if you just
  70. want to use the GNOME desktop environment.
  71. %prep
  72. %setup -q -n %{name}-%{version}
  73. %patch0 -p1 -b .ft
  74. %patch1 -p1 -b .cups
  75. %build
  76. %configure --disable-font-install --disable-gtk-doc
  77. make
  78. %install
  79. rm -rf $RPM_BUILD_ROOT
  80. # It would probably be cleaner to use install DESTDIR=$RPM_BUILD_ROOT
  81. # instead of %%makeinstall with this hack.
  82. %makeinstall
  83. # remove unpackaged files
  84. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  85. rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*.{a,la}
  86. rm -f $RPM_BUILD_ROOT%{_libdir}/libgnomeprint/%{version}/modules/*/*.{a,la}
  87. %clean
  88. rm -rf $RPM_BUILD_ROOT
  89. %post -p /sbin/ldconfig
  90. %postun -p /sbin/ldconfig
  91. %files
  92. %defattr(-, root, root)
  93. %doc AUTHORS COPYING ChangeLog NEWS README
  94. %dir %{_libdir}/libgnomeprint/%{version}
  95. %{_libdir}/libgnomeprint/%{version}/modules/*.so
  96. %{_libdir}/libgnomeprint/%{version}/modules/transports/*.so
  97. %{_libdir}/libgnomeprint/%{version}/modules/filters/*.so
  98. %{_libdir}/libgnomeprint*.so.*
  99. %{_datadir}/libgnomeprint
  100. %{_datadir}/locale/*/LC_MESSAGES/*.mo
  101. %files devel
  102. %defattr(-, root, root)
  103. %{_libdir}/libgnomeprint*.so
  104. %{_libdir}/*.a
  105. %{_includedir}/*
  106. %{_libdir}/pkgconfig/*.pc
  107. %{_datadir}/gtk-doc
  108. %changelog
  109. * Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.8-4
  110. - rebuild with libpng-1.6.12
  111. - add Patch1 (libgnomeprint-2.18.8-cups-module.patch)
  112. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.8-3
  113. - rebuild with VineSeed environment
  114. - add Patch0 (libgnomeprint-2.18.8-freetype-2.5.x.patch)
  115. * Sat Aug 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.8-2
  116. - change Requires: libxml2 instead of libxml
  117. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.8-1
  118. - new upstream release
  119. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.18.7-2
  120. - build with rpm-4.8.1-1 for pkg-config file
  121. * Thu Apr 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.7-1
  122. - new upstream release
  123. - add BuildRequires: bison, flex
  124. * Wed Mar 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.6-1
  125. - new upstream release
  126. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.5-1
  127. - new upstream release
  128. - build with gtk+2.14
  129. * Tue Mar 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1vl5
  130. - new upstream release
  131. - removed BuildRequires: automake17
  132. * Wed Dec 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.2-0vl1
  133. - new upstream release
  134. * Sun May 27 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.0-0vl2
  135. - rebuilt with new toolchain/environment
  136. * Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
  137. - new upstream release
  138. * Fri May 26 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl3
  139. - changed Group to System Environment/Libraries
  140. * Sat Apr 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
  141. - add missing filter modules to %%files
  142. - remove unneeded static modules
  143. * Wed Sep 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  144. - new upstream release
  145. * Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
  146. - new upstream release
  147. * Thu Aug 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.0-0vl1
  148. - new upstream release
  149. * Sun Jul 3 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.3-0vl1
  150. - new upstream version
  151. - drop all patches that are now upstream.
  152. * Mon Mar 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  153. - new upstream version
  154. - drop all patches that are now upstream.
  155. * Wed Mar 02 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-0vl1
  156. - new upstream release
  157. - updated patch7,8 from Fedora Development
  158. - added Japanese summary to devel package
  159. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0.1-0vl1
  160. - new upstream release
  161. - add patch7,8 from fc
  162. * Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl2
  163. - add Patch11 from bugzilla.gnome.org to support ttc font's multiple face.
  164. * Sun Nov 30 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
  165. - new upstream release
  166. * Mon Sep 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  167. - new upstream release
  168. * Sun Sep 14 2003 KAZUKI SHIMURA <rito@pos.to> 2.3.1-0vl2
  169. - Oops, spec was in Shift_JIS. Fixed.
  170. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-0vl1
  171. - new upstream release
  172. * Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1.3-0vl1
  173. - new upstream release
  174. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  175. - new upstream release
  176. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  177. - new upstream release
  178. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.8-0vl1
  179. - new upstream release
  180. * Thu Jan 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.7-0vl1
  181. - new upstream release
  182. * Sat Jan 4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.6-0vl1
  183. - new upstream release
  184. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl3
  185. - add patch1 to recognize .ttc font as TrueType font.
  186. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl2
  187. - add %%{_datadir}/libgnomeprint for %%files
  188. * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
  189. - new upstream release
  190. * Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
  191. - build for Vine Linux
  192. - new upstream release from gnome-2.1.4
  193. * Thu Aug 15 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-2
  194. - libgnomeprint-1.116.0-correctps.patch: applied to fix the invalid PostScript.
  195. * Tue Aug 13 2002 Akira TAGOH <tagoh@redhat.com> 1.116.0-1
  196. - libgnomeprint-1.116.0-perfprint.patch: applied to fix the printing
  197. performance issue. (#66715)
  198. * Fri Jul 12 2002 Akira TAGOH <tagoh@redhat.com> 1.115.0-5
  199. - includes redhat-update-gnome-font-install2 script. (#66899)
  200. - fix the install path for fontmap.
  201. - add some directory owners.
  202. * Thu Jul 11 2002 Tim Powers <timp@redhat.com>
  203. - rebuilt
  204. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  205. - 1.115.0
  206. - include gtk-doc docs
  207. - move pkg-config files to -devel package
  208. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  209. - rebuild in different environment
  210. * Wed Jun 5 2002 Havoc Pennington <hp@redhat.com>
  211. - 1.114.0
  212. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  213. - rebuild in different environment
  214. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  215. - rebuild in different environment
  216. - add bonobo-activation requires to make build system happy
  217. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  218. - 1.113.0
  219. * Fri May 3 2002 Havoc Pennington <hp@redhat.com>
  220. - rebuild for new libraries
  221. * Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
  222. - 1.112.0
  223. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  224. - 1.111.0
  225. * Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
  226. - Version 1.110.0
  227. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  228. - automake14
  229. * Mon Jan 7 2002 Havoc Pennington <hp@redhat.com>
  230. - 1.109.0.90 snap
  231. - remove .options patch which is upstream
  232. - remove .nofontmaps patch, upstream uses sysconfdir sometimes now
  233. and has --disable-font-install configure option
  234. - remove .fontmapdir, now fixed upstream
  235. * Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
  236. - rebuild due to build system fuckup
  237. * Tue Nov 27 2001 Havoc Pennington <hp@redhat.com>
  238. - cvs snap 1.106.0.90, glib 1.3.11
  239. * Sun Oct 28 2001 Havoc Pennington <hp@redhat.com>
  240. - new cvs snap, rebuild for glib 1.3.10, remove bogus gtk dep
  241. * Tue Oct 9 2001 Havoc Pennington <hp@redhat.com>
  242. - remove epoch screwup
  243. * Mon Oct 8 2001 Havoc Pennington <hp@redhat.com>
  244. - libgnomeprint package based on the gnome-print package
  245. * Mon Oct 8 2001 Havoc Pennington <hp@redhat.com>
  246. - use 0.30 tarball
  247. * Sat Sep 22 2001 Havoc Pennington <hp@redhat.com>
  248. - new cvs snap, with headers moved
  249. * Wed Aug 15 2001 Owen Taylor <otaylor@redhat.com>
  250. - Back out freetype change, for now, until we can get it in upstream.
  251. - Move gnome-print/<ver>/profiles back to datadir, and remove the %config.
  252. Making them %config doesn't seem compatible with locating them
  253. in gnome-print/<ver>.
  254. * Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-5
  255. - no replace profiles.
  256. * Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-4
  257. - Move profiles directory to /etc/gnome-print/<ver>/profiles/
  258. * Mon Aug 13 2001 Akira TAGOH <tagoh@redhat.com> 0.29-3
  259. - Add freetype support patch. (Bug#50360)
  260. * Sat Jul 21 2001 Owen Taylor <otaylor@redhat.com>
  261. - Add missing directory
  262. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  263. - Upgrade to 0.29
  264. - Don't install run-gnome-font-install (#48466), run gnome-font-install directly.
  265. - Add BuildPrereq and make -devel package require gdk-pixbuf-devel
  266. - Make libgnomeprint package require gnome-print package; otherwise
  267. packages requiring libgnomeprint might not get a runtime environment
  268. - Add Prereq on ghostscript, since run-gnome-font-install parses output of 'gs -h'
  269. * Mon Jul 16 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  270. - Kill output from run-gnome-font-install
  271. - s/Copyright/License/
  272. - Add post/postun scripts for the libgnomeprint subpackage
  273. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  274. - Bump release + rebuild.
  275. * Fri Apr 20 2001 Jonathan Blandford <jrb@redhat.com>
  276. - new version (0.28)
  277. * Thu Mar 01 2001 Owen Taylor <otaylor@redhat.com>
  278. - Rebuild for GTK+-1.2.9 include paths
  279. * Fri Feb 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  280. - langify
  281. - patch it to compile (didn't include locale.h when needed)
  282. - use %%{_tmppath}
  283. * Fri Feb 23 2001 Akira TAGOH <tagoh@redhat.com>
  284. - Fixed font problem for Japanese.
  285. - Fixed library dependency on VFlib (Bug#28331)
  286. * Wed Feb 21 2001 Philipp Knirsch <pknirsch@redhat.de>
  287. - Fixed bugzilla bug #27417, simple specfile %post fix.
  288. * Sun Feb 18 2001 Akira TAGOH <tagoh@redhat.com>
  289. - Fixed PostScript broken.
  290. - Added autoheader,automake,autoconf stuff.
  291. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  292. - add libtoolize to make porting to new archs easy
  293. * Tue Feb 06 2001 Akira TAGOH <tagoh@redhat.com>
  294. - Updated Japanese patch for Gnumeric.
  295. Created dummy .afm.
  296. * Mon Feb 05 2001 Akira TAGOH <tagoh@redhat.com>
  297. - Fixed gdk_fontset_load().
  298. - Added Japanese patch for Gnumeric.
  299. * Fri Feb 02 2001 Akira TAGOH <tagoh@redhat.com>
  300. - Added Japanese patch.
  301. Fixed Print and Preview with Japanese.
  302. * Fri Dec 29 2000 Matt Wilson <msw@redhat.com>
  303. - 0.25
  304. * Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
  305. - added "|| true" to %%post so that if font-install screws up we don't get a
  306. bad exit status. gnome-font-install expects that the directory specified by
  307. HOME env. var is writable, but it isn't always if you install with 'sudo'
  308. or the equivalent. bad. bad. bad.
  309. * Fri Aug 11 2000 Jonathan Blandford <jrb@redhat.com>
  310. - Up Epoch and release
  311. * Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
  312. - redirect %%post script output to /dev/null
  313. * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
  314. - automatic rebuild
  315. * Thu Jun 29 2000 Owen Taylor <otaylor@redhat.com>
  316. - Spec file fixes