libghc-http-client-tls-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163
  1. %define pkg_name http-client-tls
  2. %define pkg_version 0.3.5.3
  3. %define pkg_release 4%{?_dist_release}
  4. Summary: Haskell libraries: %{pkg_name} and dependent libraries
  5. Name: libghc-%{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: BSD3
  9. Group: Applications/Text
  10. URL: http://hackage.haskell.org
  11. Source0: packages
  12. Source11: basement-0.0.8.tar.gz
  13. Source12: basement.cabal
  14. Source13: blaze-builder-0.4.1.0.tar.gz
  15. Source14: blaze-builder.cabal
  16. Source15: byteable-0.1.1.tar.gz
  17. Source16: byteable.cabal
  18. Source17: cereal-0.5.7.0.tar.gz
  19. Source18: cereal.cabal
  20. Source19: cookie-0.4.4.tar.gz
  21. Source20: cookie.cabal
  22. Source21: hourglass-0.2.12.tar.gz
  23. Source22: hourglass.cabal
  24. Source23: http-types-0.12.2.tar.gz
  25. Source24: http-types.cabal
  26. Source25: mime-types-0.1.0.8.tar.gz
  27. Source26: mime-types.cabal
  28. Source27: streaming-commons-0.2.1.0.tar.gz
  29. Source28: streaming-commons.cabal
  30. Source29: transformers-compat-0.6.2.tar.gz
  31. Source30: transformers-compat.cabal
  32. Source31: memory-0.14.18.tar.gz
  33. Source32: memory.cabal
  34. Source33: socks-0.5.6.tar.gz
  35. Source34: socks.cabal
  36. Source35: exceptions-0.10.0.tar.gz
  37. Source36: exceptions.cabal
  38. Source37: pem-0.2.4.tar.gz
  39. Source38: pem.cabal
  40. Source39: cryptonite-0.25.tar.gz
  41. Source40: cryptonite.cabal
  42. Source41: asn1-types-0.3.2.tar.gz
  43. Source42: asn1-types.cabal
  44. Source43: http-client-0.5.14.tar.gz
  45. Source44: http-client.cabal
  46. Source45: asn1-encoding-0.9.5.tar.gz
  47. Source46: asn1-encoding.cabal
  48. Source47: asn1-parse-0.9.4.tar.gz
  49. Source48: asn1-parse.cabal
  50. Source49: x509-1.7.5.tar.gz
  51. Source50: x509.cabal
  52. Source51: x509-store-1.6.7.tar.gz
  53. Source52: x509-store.cabal
  54. Source53: x509-validation-1.6.11.tar.gz
  55. Source54: x509-validation.cabal
  56. Source55: x509-system-1.6.6.tar.gz
  57. Source56: x509-system.cabal
  58. Source57: tls-1.4.1.tar.gz
  59. Source58: tls.cabal
  60. Source59: connection-0.2.8.tar.gz
  61. Source60: connection.cabal
  62. Source61: http-client-tls-0.3.5.3.tar.gz
  63. Source62: http-client-tls.cabal
  64. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  65. BuildRequires: ghc haskell-platform
  66. BuildRequires: libffi-devel gmp-devel zlib-devel
  67. BuildRequires: libghc-data-default-class
  68. BuildRequires: libghc-semigroups
  69. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  70. Requires: ghc haskell-platform
  71. Requires: haskell-platform-dep
  72. Requires: libghc-data-default-class
  73. Requires: libghc-semigroups
  74. Vendor: Project Vine
  75. Distribution: Vine Linux
  76. Packager: ara_t
  77. %description
  78. Haskell libraries: %{pkg_name} and dependent libraries
  79. %prep
  80. %{__rm} -rf ${RPM_BUILD_ROOT}
  81. %build
  82. %ghc_pkg_init
  83. cd %{_builddir}
  84. for pkg in `cat %{SOURCE0}`; do
  85. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  86. pushd ${pkg}
  87. %ghc_fix_dependencies ${pkg}
  88. %cabal_configure2 %{name} ${pkg}
  89. %cabal_build
  90. %cabal_haddock
  91. %cabal_copy_resister %{name}_${pkg}
  92. popd
  93. done
  94. %clean
  95. %{__rm} -rf ${RPM_BUILD_ROOT}
  96. %post
  97. %ghc_pkg_recache
  98. %postun
  99. %ghc_pkg_recache
  100. %files
  101. %defattr(-, root, root)
  102. %{_libdir}/ghc-%{ghc_version}/
  103. %{_libdir}/ghc-lib/
  104. %{_datadir}/
  105. %changelog
  106. * Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 0.3.5.3-4
  107. - build using ghc-8.6.3
  108. * Thu Aug 09 2018 Toshiaki Ara <ara_t@384.jp> 0.3.5.3-3
  109. - rebuild with ghc-8.4.3-2
  110. * Fri Jul 20 2018 Toshiaki Ara <ara_t@384.jp> 0.3.5.3-2
  111. - build using ghc-8.4.3
  112. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.3.5.3-1
  113. - update to 0.3.5.3
  114. - rebuild using ghc-8.4.2
  115. - rewrite using macro
  116. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.3.5.1-1
  117. - update to 0.3.5.1
  118. - build using ghc-8.2.2
  119. * Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 0.3.3.1-1
  120. - update to 0.3.3.1
  121. - build using ghc-8.0.2
  122. * Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.2.4.1-1
  123. - update to 0.2.4.1
  124. - build using ghc-8.0.1
  125. * Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.2.2-3
  126. - rebuilt
  127. * Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.2.2-2
  128. - correct SPEC file
  129. * Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.2.2-1
  130. - new package