lyx-vl.spec 9.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348
  1. %define pkg_name lyx
  2. %define pkg_version 2.3.3
  3. %define pkg_release 1%{?_dist_release}
  4. %define _fontdir %{_datadir}/fonts/%{name}
  5. %define texmf %{_datadir}/texmf
  6. %define build_texmf %{buildroot}%{texmf}
  7. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash 2>/dev/null
  8. Summary: WYSIWYM (What You See Is What You Mean) word processor with LaTeX output
  9. Summary(ja): LaTeX 形式で保存できるワードプロセッサ
  10. Name: %{pkg_name}
  11. Version: %{pkg_version}
  12. Release: %{pkg_release}
  13. License: GPLv2 or GPLv3
  14. Group: Applications/Editors
  15. URL: http://www.lyx.org/
  16. Source0: ftp://ftp.lyx.org/pub/lyx/stable/2.3.x/lyx-%{version}.tar.xz
  17. # Source0: ftp://ftp.lyx.org/pub/lyx/stable/lyx-%{version}-2.tar.xz
  18. Source1: lyxrc.dist
  19. Source10: lyx.desktop
  20. ## upstreamable patches
  21. # submitted, but upstream rejected it. we currently agree to disagree.
  22. # Patch50: lyx-2.0.6-xdg_open.patch
  23. Patch50: lyx-2.3.0-xdg_open.patch
  24. ## vine
  25. # reverted checkLatex to lyx-1.6.5
  26. Patch100: lyx-2.3.0-configurepy-vine.patch
  27. BuildRequires: enchant-devel
  28. BuildRequires: hunspell-devel
  29. BuildRequires: libboost-devel
  30. BuildRequires: libboost-filesystem
  31. BuildRequires: libboost-signals
  32. BuildRequires: libboost-regex
  33. BuildRequires: desktop-file-utils
  34. BuildRequires: gettext
  35. BuildRequires: python
  36. BuildRequires: xorg-x11-devel
  37. BuildRequires: qt5-qtbase-devel
  38. BuildRequires: qt5-qtsvg-devel
  39. BuildRequires: libpng-devel
  40. BuildRequires: glib2-devel
  41. BuildRequires: zlib-devel
  42. BuildRequires: bc
  43. Requires(post): texlive-common
  44. Requires(postun): texlive-common
  45. Requires: ghostscript
  46. Requires: python
  47. Requires: %{name}-fonts = %{version}-%{release}
  48. Requires: xdg-utils
  49. Requires: rcs
  50. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  51. Vendor: Project Vine
  52. Distribution: Vine Linux
  53. %description
  54. LyX is a modern approach to writing documents which breaks with the
  55. obsolete "typewriter paradigm" of most other document preparation
  56. systems.
  57. It is designed for people who want professional quality output
  58. with a minimum of time and effort, without becoming specialists in
  59. typesetting.
  60. The major innovation in LyX is WYSIWYM (What You See Is What You Mean).
  61. That is, the author focuses on content, not on the details of formatting.
  62. This allows for greater productivity, and leaves the final typesetting
  63. to the backends (like LaTeX) that are specifically designed for the task.
  64. With LyX, the author can concentrate on the contents of his writing,
  65. and let the computer take care of the rest.
  66. This is LyX built with the Qt frontend.
  67. %description -l ja
  68. LaTeX形式で出力もできるワードプロセッサです。数式の入力も簡単にできます。
  69. 特別な知識が無くても、最小限の努力でプロ並の出力を得られるように設計
  70. してあります。
  71. %package fonts
  72. Summary: Lyx/MathML fonts
  73. Group: User Interface/X
  74. # The actual license says "The author of these fonts, Basil K. Malyshev, has
  75. # kindly granted permission to use and modify these fonts."
  76. # One of the font files (wasy10) is separately licensed GPL+.
  77. License: Copyright only and GPL+
  78. Obsoletes: latex-xft-fonts
  79. BuildArch: noarch
  80. %description fonts
  81. A collection of Math symbol fonts for %{name}.
  82. %prep
  83. %setup -q
  84. %patch50 -b .xdg_open
  85. %patch100 -b .vine
  86. %build
  87. %{configure} \
  88. --disable-dependency-tracking \
  89. --disable-rpath \
  90. --enable-build-type=release \
  91. --disable-debug \
  92. --enable-optimization="%{optflags}" \
  93. --without-included-boost \
  94. --disable-stdlib-debug \
  95. --with-enchant \
  96. --with-hunspell \
  97. --enable-qt5 \
  98. ;
  99. %{__make} %{?_smp_mflags}
  100. %install
  101. %{__rm} -rf ${RPM_BUILD_ROOT}
  102. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  103. # misc/extras
  104. %{__install} -p -m644 -D %{SOURCE1} %{buildroot}%{_datadir}/lyx/lyxrc.dist
  105. # Set up the lyx-specific class files where TeX can see them
  106. %{__mkdir_p} %{build_texmf}/tex/latex
  107. %{__mv} %{buildroot}%{_datadir}/lyx/tex %{build_texmf}/tex/latex/lyx
  108. # desktop & icon
  109. desktop-file-install --vendor="vine" \
  110. --dir="${RPM_BUILD_ROOT}%{_datadir}/applications" %{SOURCE10}
  111. %__install -p -D -m644 lib/images/lyx.png \
  112. %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/lyx.png
  113. %{__rm} -f ${RPM_BUILD_ROOT}%{_datadir}/applications/lyx.desktop
  114. # ghost'd files
  115. touch %{buildroot}%{_datadir}/lyx/lyxrc.defaults
  116. touch %{buildroot}%{_datadir}/lyx/{packages,textclass}.lst
  117. # fonts
  118. %{__install} -m 0755 -d %{buildroot}%{_fontdir}
  119. %{__mv} %{buildroot}%{_datadir}/lyx/fonts/*.ttf %{buildroot}%{_fontdir}/
  120. %{__rm} -rf %{buildroot}%{_datadir}/lyx/fonts
  121. %find_lang %{name}
  122. %check
  123. # tests/test_filetools error bogus ( see http://bugzilla.redhat.com/723938 )
  124. %{__make} -k check || :
  125. %clean
  126. %{__rm} -rf ${RPM_BUILD_ROOT}
  127. %post
  128. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  129. %postun
  130. if [ $1 -eq 0 ] ; then
  131. %{exec_texhash} >& /dev/null
  132. update-desktop-database -q &> /dev/null
  133. touch --no-create %{_datadir}/icons/hicolor &> /dev/null
  134. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  135. fi
  136. %posttrans
  137. %{exec_texhash} >& /dev/null
  138. update-desktop-database -q &> /dev/null
  139. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  140. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  141. %post fonts
  142. %{__font_install_post} %{_fontdir}
  143. %postun fonts
  144. %{__font_install_postun} %{_fontdir}
  145. %files -f %{name}.lang
  146. %defattr(-,root,root,-)
  147. %doc ANNOUNCE COPYING README UPGRADING NEWS lib/CREDITS
  148. %{_bindir}/*
  149. %{_datadir}/lyx/
  150. %{texmf}/tex/latex/lyx/
  151. %{_datadir}/applications/*.desktop
  152. %{_datadir}/icons/hicolor/*/*/*
  153. %{_mandir}/man*/*
  154. %config(noreplace) %{_datadir}/lyx/lyxrc.dist
  155. %ghost %{_datadir}/lyx/lyxrc.defaults
  156. %ghost %{_datadir}/lyx/*.lst
  157. %ghost %{_datadir}/lyx/doc/LaTeXConfig.lyx
  158. %files fonts
  159. %defattr(-,root,root,-)
  160. %dir %{_fontdir}/
  161. %{_fontdir}/*.ttf
  162. %changelog
  163. * Tue Oct 29 2019 Toshiaki Ara <ara_t@384.jp> 2.3.3-1
  164. - update to 2.3.3
  165. * Tue Jan 29 2019 Toshiaki Ara <ara_t@384.jp> 2.3.2-1
  166. - update to 2.3.2
  167. * Sun Oct 07 2018 Toshiaki Ara <ara_t@384.jp> 2.3.1-1
  168. - update to 2.3.1
  169. * Fri Jun 08 2018 Toshiaki Ara <ara_t@384.jp> 2.3.0-1
  170. - update to 2.3.0
  171. - update Patch50 and Patch100
  172. * Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 2.2.3-1
  173. - new upstream release
  174. - update Patch50 (lyx-2.2.3-xdg_open.patch)
  175. - add BuildRequires: bc
  176. - use qt5 instead of qt4
  177. - add --enable-qt5 option
  178. - add BuildRequires: qt5-qtbase-devel, qt5-qtsvg-devel
  179. - drop BuildRequires: qt4-devel
  180. - delete unused options
  181. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.6-1
  182. - update to 2.0.6
  183. - update Patch50 (lyx-2.0.6-xdg_open.patch)
  184. * Sun Mar 11 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-2
  185. - rebuild with hunspell-devel
  186. * Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.2-1
  187. - new upstream release
  188. - added subpackage "lyx-fonts"
  189. - added Obsoletes: latex-xft-fonts
  190. * Sat Oct 01 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-2
  191. - applied lyx-2.0.1-configurepy-vine.patch
  192. - reverted checkLatex to lyx-1.6.5
  193. * Fri Sep 09 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.1-1
  194. - new upstream release
  195. * Sat Jun 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
  196. - new upstream release
  197. - dropped BuildRequires: aspell-devel
  198. - added BuildRequires:
  199. - libboost-regex
  200. - enchant-devel
  201. - hunspell-devel
  202. * Thu Dec 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.8-1
  203. - new upstream release
  204. * Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.7-1
  205. - new upstream release
  206. - TeX Live 2009
  207. - dropped Requires: xdvik, dvipdfmx
  208. * Sun Jan 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.5-1
  209. - new upstream release
  210. - updated Patch0: lyx-1.6.5-xdg_open.patch
  211. * Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.3-1
  212. - new upstream release
  213. - dropped old source files
  214. - change License: GPLv2+
  215. - added lyx.desktop
  216. - added BuildRequires:
  217. - aspell-devel
  218. - desktop-file-utils
  219. - gettext
  220. - python
  221. - qt4-devel
  222. - zlib-devel
  223. - libboost-devel
  224. - libboost-filesystem
  225. - libboost-signals
  226. - libpng-devel
  227. - glib2-devel
  228. - added Requires:
  229. - ghostscript
  230. - dvipdfmx
  231. - xdvik
  232. - qt4
  233. - xdg-utils
  234. - optimized some configure options
  235. * Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.4-1vl5
  236. - applied new versioning policy, spec in utf-8
  237. * Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
  238. - updated to 1.4.4 with the most recent CJK patch
  239. - updated Patch1
  240. * Sat Dec 30 2006 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.4.2-0vl1
  241. - base spec file : Vine Linux BTS #219
  242. * Mon Nov 6 2006 M.H
  243. - new upstream release
  244. - base spec file CJK-LyX-qt.spec and VinePlus lyx.spec
  245. * Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.4-0vl3
  246. - changed Group to Applications/Editors
  247. * Sat Jan 28 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org>
  248. - rebuild with qt-3.3.5
  249. * Sun Jun 13 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.3.4-0vl1
  250. - new upstream version
  251. - change frontend, xforms -> qt
  252. - require tetex, qt, latex-xft-fonts
  253. - change applnk file
  254. - change Group
  255. * Thu Aug 21 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.1.6fix4-0vl1
  256. - new upstream version
  257. - add mime-info
  258. - minor change in spec file
  259. * Sat Nov 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
  260. - 1.0.3_jp-4
  261. - added BuildPrereq:
  262. * Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
  263. - 1.0.3_jp-3
  264. - minor change in spec file
  265. - build for Vine Linux 2.1
  266. * Wed Jan 5 2000 Jun Nishii <jun@vinelinux.org>
  267. - change group
  268. * Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
  269. - updated to lyx-1.0.3
  270. - rebuild for Vine Linux 2.0
  271. * Wed May 5 1999 Jun Nishii <jun@vinelinux.org>
  272. - merged Japanese Documents
  273. * Tue May 4 1999 Jun Nishii <jun@vinelinux.org>
  274. - first build