lua-rex-vl.spec 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111
  1. %define luaver %(pkg-config --variable=V lua || echo missing)
  2. %define lualibdir %{_libdir}/lua/%{luaver}
  3. Name: lua-rex
  4. Version: 2.9.0
  5. Release: 1%{?_dist_release}
  6. Summary: Regular expression handling library for Lua
  7. Summary(ja): 正規表現を扱うための Lua ライブラリ
  8. Group: Development/Libraries
  9. License: MIT
  10. URL: http://rrthomas.github.io/lrexlib/
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. %global altver %(echo %{version} | sed -e 's/\\./-/g')
  14. Source0: https://github.com/rrthomas/lrexlib/archive/rel-%{altver}.tar.gz
  15. Source1: Makefile
  16. Source2: common.mak
  17. Source3: defaults.mak
  18. Source4: rex_onig.mak
  19. Source5: rex_pcre.mak
  20. Source6: rex_posix.mak
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. BuildRequires: oniguruma-devel
  23. BuildRequires: pcre-devel
  24. BuildRequires: lua-devel
  25. BuildRequires: pkgconfig
  26. BuildRequires: unzip
  27. Requires: lua = %{luaver}
  28. Provides: lrexlib = %{version}
  29. %description
  30. Lrexlib are bindings of three regular expression library APIs (POSIX, PCRE
  31. and Oniguruma) to Lua.
  32. %prep
  33. %setup -q -n lrexlib-rel-%{altver}
  34. cp -f %{SOURCE1} ./
  35. cp -f %{SOURCE2} src/
  36. cp -f %{SOURCE3} src/
  37. cp -f %{SOURCE4} src/oniguruma/
  38. cp -f %{SOURCE5} src/pcre/
  39. cp -f %{SOURCE6} src/posix/
  40. %build
  41. make %{?_smp_mflags} LD=cc MYCFLAGS='%{optflags} -DVERSION=\"%{version}\" -fPIC %(pcre-config --cflags)' build
  42. %install
  43. rm -rf $RPM_BUILD_ROOT
  44. install -d $RPM_BUILD_ROOT%{lualibdir}
  45. cp -P */*/rex_{onig,pcre,posix}.so* $RPM_BUILD_ROOT%{lualibdir}
  46. %check
  47. make %{?_smp_mflags} test
  48. %clean
  49. rm -rf $RPM_BUILD_ROOT
  50. %files
  51. %defattr(-,root,root,-)
  52. %{lualibdir}/*
  53. %license LICENSE
  54. %doc ChangeLog NEWS README doc
  55. %changelog
  56. * Sat Sep 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.9.0-7
  57. - new upstream release.
  58. - built with oniguruma-6.9.3.
  59. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-6
  60. - rebuild with pcre-8.31
  61. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 2.4.0-5
  62. - rebuilt with rpm-4.8.1-3
  63. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.0-4
  64. - rebuilt with gcc-4.4.3-3 on ppc
  65. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.0-3
  66. - rebuilt with rpm-4.8.0-3 (on ppc)
  67. * Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.0-2
  68. - added BR: unzip
  69. * Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  70. - initial build for Vine Linux
  71. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-5
  72. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  73. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-4
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  75. * Tue Dec 23 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-3
  76. - Compile shared library as PIC
  77. * Wed Dec 17 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-2
  78. - Add doc directory to documentation
  79. - Allow parallel make runs
  80. * Tue Dec 16 2008 Lubomir Rintel <lkundrak@v3.sk> - 2.4.0-1
  81. - Initial packaging