isl-vl.spec 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128
  1. Summary: Integer point manipulation library
  2. Name: isl
  3. Version: 0.16.1
  4. License: MIT
  5. Group: System Environment/Libraries
  6. URL: http://isl.gforge.inria.fr/
  7. %global libmajor 15
  8. %global libversion %{libmajor}.1.1
  9. %global oldversion 0.14.1
  10. %global oldlibmajor 13
  11. %global oldlibversion %{oldlibmajor}.1.1
  12. # Please set buildid below when building a private version of this rpm to
  13. # differentiate it from the stock rpm.
  14. #
  15. # % global buildid .local
  16. Release: 1%{?_dist_release}
  17. BuildRequires: gmp-devel
  18. BuildRequires: pkgconfig
  19. Source0: http://isl.gforge.inria.fr/isl-%{version}.tar.xz
  20. # Current gcc requires exactly 0.14.1
  21. Source1: http://isl.gforge.inria.fr/isl-%{oldversion}.tar.xz
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. %description
  26. isl is a library for manipulating sets and relations of integer points
  27. bounded by linear constraints. Supported operations on sets include
  28. intersection, union, set difference, emptiness check, convex hull,
  29. (integer) affine hull, integer projection, computing the lexicographic
  30. minimum using parametric integer programming, coalescing and parametric
  31. vertex enumeration. It also includes an ILP solver based on generalized
  32. basis reduction, transitive closures on maps (which may encode infinite
  33. graphs), dependence analysis and bounds on piecewise step-polynomials.
  34. %package devel
  35. Summary: Development for building integer point manipulation library
  36. Requires: isl == %{version}-%{release}
  37. Requires: gmp-devel
  38. Group: Development/Libraries
  39. %description devel
  40. isl is a library for manipulating sets and relations of integer points
  41. bounded by linear constraints. Supported operations on sets include
  42. intersection, union, set difference, emptiness check, convex hull,
  43. (integer) affine hull, integer projection, computing the lexicographic
  44. minimum using parametric integer programming, coalescing and parametric
  45. vertex enumeration. It also includes an ILP solver based on generalized
  46. basis reduction, transitive closures on maps (which may encode infinite
  47. graphs), dependence analysis and bounds on piecewise step-polynomials.
  48. %prep
  49. %global docdir isl-%{version}
  50. %setup -a 1 -q -n isl -c
  51. %build
  52. cd isl-%{oldversion}
  53. %configure
  54. make %{?_smp_mflags} V=1
  55. cd ..
  56. cd isl-%{version}
  57. %configure
  58. make %{?_smp_mflags} V=1
  59. %install
  60. cd isl-%{oldversion}
  61. %make_install INSTALL="install -p" install-libLTLIBRARIES
  62. cd ..
  63. cd isl-%{version}
  64. %make_install INSTALL="install -p"
  65. rm -f %{buildroot}/%{_libdir}/libisl.a
  66. rm -f %{buildroot}/%{_libdir}/libisl.la
  67. mkdir -p %{buildroot}/%{_datadir}
  68. %global gdbprettydir %{_datadir}/gdb/auto-load/%{_libdir}
  69. mkdir -p %{buildroot}/%{gdbprettydir}
  70. mv %{buildroot}/%{_libdir}/*-gdb.py* %{buildroot}/%{gdbprettydir}
  71. %check
  72. cd isl-%{oldversion}
  73. #make check
  74. cd ..
  75. cd isl-%{version}
  76. #make check
  77. %post -p /sbin/ldconfig
  78. %postun -p /sbin/ldconfig
  79. %files
  80. %{_libdir}/libisl.so.%{libmajor}
  81. %{_libdir}/libisl.so.%{libversion}
  82. %{_libdir}/libisl.so.%{oldlibmajor}
  83. %{_libdir}/libisl.so.%{oldlibversion}
  84. %{gdbprettydir}/*
  85. %license %{docdir}/LICENSE
  86. %doc %{docdir}/AUTHORS %{docdir}/ChangeLog %{docdir}/README
  87. %files devel
  88. %{_includedir}/*
  89. %{_libdir}/libisl.so
  90. %{_libdir}/pkgconfig/isl.pc
  91. %doc doc/manual.pdf
  92. %changelog
  93. * Sun Jan 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.16.1-1
  94. - new upstream rekease.
  95. * Sat Jun 25 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
  96. - initial build for Vine Linux
  97. * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.14-4
  98. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  99. * Mon Jan 5 2015 David Howells <dhowells@redhat.com> - 0.14-3
  100. - Initial packaging.