curl-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %if %{?_dist_release} != "vl6"
  3. %global with_http2 1
  4. %endif
  5. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  6. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  7. Name: curl
  8. Version: 7.68.0
  9. Release: 1%{?_dist_release}
  10. License: MIT
  11. Group: Applications/Internet
  12. URL: http://curl.haxx.se/
  13. Source: http://curl.haxx.se/download/%{name}-%{version}.tar.xz
  14. # avoid reporting spurious error in the HTTP2 framing layer (#1690971)
  15. Patch2: 0002-curl-7.65.3-h2-framing-layer-error.patch
  16. # patch making libcurl multilib ready
  17. Patch101: 0101-curl-7.32.0-multilib.patch
  18. # prevent configure script from discarding -g in CFLAGS (#496778)
  19. Patch102: 0102-curl-7.36.0-debug.patch
  20. # migrate tests/http_pipe.py to Python 3
  21. Patch103: 0103-curl-7.59.0-python3.patch
  22. # use localhost6 instead of ip6-localhost in the curl test-suite
  23. Patch104: 0104-curl-7.19.7-localhost6.patch
  24. # prevent valgrind from reporting false positives on x86_64
  25. Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  27. BuildRequires: openssl-devel
  28. BuildRequires: gnutls-devel
  29. BuildRequires: libidn-devel zlib-devel
  30. BuildRequires: openldap-devel
  31. BuildRequires: openssh-server
  32. BuildRequires: openssh-clients
  33. BuildRequires: pkgconfig
  34. %if "%{?_dist_release}" != "vl6"
  35. BuildRequires: libssh2-devel
  36. %endif
  37. %if 0%{?with_http2}
  38. BuildRequires: libnghttp2-devel
  39. %endif
  40. Requires: ca-certificates
  41. Vendor: Project Vine
  42. Distribution: Vine Linux
  43. Packager: daisuke
  44. %description
  45. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  46. Dict servers, using any of the supported protocols. cURL is designed
  47. to work without user interaction or any kind of interactivity. cURL
  48. offers many useful capabilities, like proxy support, user
  49. authentication, FTP upload, HTTP post, and file transfer resume.
  50. %package devel
  51. Summary: Files needed for building applications with libcurl.
  52. Group: Development/Libraries
  53. Requires: %{name} = %{version}-%{release}
  54. Requires: openssl-devel libidn-devel zlib-devel
  55. %description devel
  56. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  57. Dict servers, using any of the supported protocols. The curl-devel
  58. package includes files needed for developing applications which can
  59. use cURL's capabilities internally.
  60. #'
  61. ## to build compat32 for x86_64 architecture support
  62. %package -n compat32-%{name}
  63. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  64. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  65. Group: System Environment/Libraries
  66. %description -n compat32-%{name}
  67. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  68. Dict servers, using any of the supported protocols. cURL is designed
  69. to work without user interaction or any kind of interactivity. cURL
  70. offers many useful capabilities, like proxy support, user
  71. authentication, FTP upload, HTTP post, and file transfer resume.
  72. %package -n compat32-%{name}-devel
  73. Summary: Files needed for building applications with libcurl.
  74. Group: Development/Libraries
  75. %description -n compat32-%{name}-devel
  76. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  77. Dict servers, using any of the supported protocols. The curl-devel
  78. package includes files needed for developing applications which can
  79. use cURL's capabilities internally.
  80. #'
  81. %prep
  82. %setup -q
  83. # upstream patches
  84. # Fedora patches
  85. %patch101 -p1
  86. %patch102 -p1
  87. #patch103 -p1
  88. %patch104 -p1
  89. %patch105 -p1
  90. # make tests/*.py use Python 3
  91. sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
  92. # regenerate Makefile.in files
  93. aclocal -I m4
  94. automake
  95. # disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
  96. # with errno 98: Address already in use' in Koji environment), and test 1801
  97. # <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
  98. # and test 1900, which is flaky and covers a deprecated feature of libcurl
  99. # <https://github.com/curl/curl/pull/2705>
  100. printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
  101. # disable test 1319 on ppc64 (server times out)
  102. %ifarch ppc64
  103. echo "1319" >> tests/data/DISABLED
  104. %endif
  105. # temporarily disable test 582 on s390x (client times out)
  106. %ifarch s390x
  107. echo "582" >> tests/data/DISABLED
  108. %endif
  109. # adapt test 323 for updated OpenSSL
  110. sed -e 's/^35$/35,52/' -i tests/data/test323
  111. %build
  112. %configure \
  113. --with-ssl=%{_prefix} \
  114. --with-libidn \
  115. --enable-ipv6 \
  116. --enable-threaded-resolver \
  117. --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  118. %if "%{?_dist_release}" != "vl6"
  119. --with-libssh2 \
  120. %endif
  121. %if 0%{?with_http2}
  122. --with-nghttp2 \
  123. %endif
  124. --enable-ldaps \
  125. --disable-static \
  126. --enable-hidden-symbols
  127. make %{?_smp_mflags}
  128. %install
  129. rm -rf $RPM_BUILD_ROOT
  130. make DESTDIR=$RPM_BUILD_ROOT install
  131. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  132. %clean
  133. rm -rf $RPM_BUILD_ROOT
  134. %post -p /sbin/ldconfig
  135. %postun -p /sbin/ldconfig
  136. %files
  137. %defattr(-,root,root)
  138. %{!?_licensedir:%global license %%doc}
  139. %license COPYING
  140. %doc CHANGES README
  141. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  142. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  143. %doc docs/TheArtOfHttpScripting docs/TODO
  144. %{_bindir}/curl
  145. #{_datadir}/curl/*
  146. %{_libdir}/*.so.*
  147. %{_mandir}/man1/*.1*
  148. %files devel
  149. %defattr(-,root,root)
  150. %{_bindir}/curl-config
  151. %{_includedir}/curl
  152. %{_libdir}/*.so
  153. %{_libdir}/pkgconfig/*.pc
  154. %{_mandir}/man1/curl-config.1*
  155. %{_mandir}/man3/*
  156. %{_datadir}/aclocal/libcurl.m4
  157. ## to build compat32 for x86_64 architecture support
  158. %if %{build_compat32}
  159. %files -n compat32-%{name}
  160. %defattr(-,root,root)
  161. %{_libdir}/*.so.*
  162. %files -n compat32-%{name}-devel
  163. %defattr(-,root,root)
  164. %{_libdir}/*.so
  165. %{_libdir}/pkgconfig/*.pc
  166. %endif
  167. %changelog
  168. * Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.68.0-1
  169. - new upstream release.
  170. * Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.66.0-1
  171. - new upstream release.
  172. - dropped Patch1 and 2: fixed in upstream.
  173. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
  174. - new upstream release.
  175. - updated patches.
  176. - imported Patch1, 2 and 105 from rawhide.
  177. * Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
  178. - new upstream release.
  179. - imported patches from rawhide.
  180. * Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
  181. - new upstream release.
  182. - imported Patch1 and 103 from rawhide.
  183. * Wed Feb 7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
  184. - new upstream release with security fix
  185. - update patch101
  186. * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
  187. - new upstream release.
  188. - updated Patch101-104.
  189. - dropped Patch107.
  190. * Mon May 1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
  191. - new upstream release.
  192. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
  193. - new upstream release.
  194. * Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
  195. - new upstream release.
  196. * Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
  197. - new upstream release.
  198. - disabled HTTP/2 on Vine6.
  199. * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
  200. - added HTTP/2 support.
  201. * Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
  202. - new upstream release with security fix.
  203. * Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
  204. - new upstream release.
  205. * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
  206. - new upstream release
  207. - built with openssl 1.0.2g
  208. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
  209. - new upstream release with security fix .
  210. - removed Patch108 (fixed in upstream).
  211. * Sun Nov 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
  212. - new upstream release with security fix
  213. * Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
  214. - new upstream release
  215. - add libcurl.m4 to -devel package
  216. * Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
  217. - new upstream release
  218. - import upstream/fedora patches
  219. - disable libssh2 on Vine Linux 6
  220. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
  221. - new upstream reelase
  222. * Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
  223. - update to 7.28.0
  224. - add configure options
  225. - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
  226. - add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
  227. - use ca-certificates package
  228. - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
  229. - R: ca-certificates
  230. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
  231. - new upstream release
  232. * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
  233. - add patch100 for fix CVE-2011-2192 (gssapi)
  234. - add Vendor/Distri tags
  235. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  236. - rebuild with openssl-1.0.0c
  237. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  238. - rebuilt with rpm-4.8.1 for pkg-config
  239. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  240. - new upstream release
  241. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  242. - new upstream release with security fix
  243. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  244. - added compat32 subpackages
  245. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  246. - new upstream release
  247. - use "_smp_mflags" flag
  248. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  249. - rebuild with openldap-2.4.11
  250. - add BR: openldap-devel
  251. - remove static library
  252. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  253. - new upstream release with security fix (CVE-2009-0037)
  254. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  255. - new upstream release
  256. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  257. - new upstream release
  258. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  259. - new upstream release
  260. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  261. - new upstream release
  262. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  263. - new upstream release
  264. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  265. - rebuilt with openssl-0.9.8e
  266. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  267. - new upstream release
  268. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  269. - new upstream release
  270. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  271. - new upstream release
  272. - add pkgconfig file to devel package
  273. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  274. - new upstream release
  275. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  276. - new upstream release
  277. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  278. - new upstream release
  279. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  280. - added libidn, zlib in Requires
  281. - added libidn-devel, zlib-devel in BuildPrereq
  282. - added zlib-devel in curl-devel's Requires
  283. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  284. - added openssl-devel, libidn-devel in curl-devel's Requires
  285. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  286. - new upstream release
  287. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  288. - new upstream release
  289. - rebuild with openssl-0.9.7d
  290. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  291. - upstream release
  292. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  293. - add %%{_datadir}/curl/* to %%files section
  294. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  295. - source upgrade
  296. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  297. - source upgrade
  298. - add PreReq: ldconfig
  299. - add %%{_libdir}/*.la to %%files devel section
  300. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  301. - build for VineSeed
  302. - add Requires: openssl
  303. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  304. - automated rebuild
  305. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  306. - 7.9.2
  307. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  308. - include curl-config in curl-devel
  309. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  310. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  311. - added openssl-devel build req
  312. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  313. - built for the distro
  314. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  315. - upgrade to curl-7.7.2.
  316. - enable IPv6.
  317. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  318. - rebuilt against openssl-0.9.6-1
  319. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  320. - fixed mising ldconfigs
  321. - updated to 7.5.2, bug fixes
  322. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  323. - updated to 7.5.1
  324. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  325. - update to 7.4.1 to fix bug #20337, problems with curl -c
  326. - not using patch anymore, it's included in the new source. Keeping
  327. for reference
  328. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  329. - fix bogus req in -devel package
  330. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  331. - devel package needed defattr so that root owns the files
  332. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  333. - update to 7.3
  334. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  335. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  336. - enable SSL support
  337. - fix packager tag
  338. - move buildroot to %%{_tmppath}
  339. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  340. - fixed vendor tag for bug #15028
  341. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  342. - rebuilt
  343. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  344. - workaround alpha build problems with optimizations
  345. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  346. - rebuilt
  347. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  348. - put man pages in correct place
  349. - use %%makeinstall
  350. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  351. - updated to 6.5.2
  352. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  353. - updated sources to 6.2
  354. - gzip man page
  355. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  356. - changed group
  357. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  358. - changelog started
  359. - general cleanups, changed prefix to /usr, added manpage to files section
  360. - including in Powertools