cups-filters-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486
  1. # we build CUPS also with relro
  2. %global _hardened_build 1
  3. Summary: OpenPrinting CUPS filters and backends
  4. Name: cups-filters
  5. Version: 1.25.11
  6. Release: 1%{?_dist_release}
  7. Group: System Environment/Base
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: tomop
  11. # For a breakdown of the licensing, see COPYING file
  12. # GPLv2: filters: commandto*, imagetoraster, pdftops, rasterto*,
  13. # imagetopdf, pstopdf, texttopdf
  14. # backends: parallel, serial
  15. # GPLv2+: filters: gstopxl, textonly, texttops, imagetops, foomatic-rip
  16. # GPLv3: filters: bannertopdf
  17. # GPLv3+: filters: urftopdf, rastertopdf
  18. # LGPLv2+: utils: cups-browsed
  19. # MIT: filters: gstoraster, pdftoijs, pdftoopvp, pdftopdf, pdftoraster
  20. License: GPLv2 and GPLv2+ and GPLv3 and GPLv3+ and LGPLv2+ and MIT and BSD with advertising
  21. URL: https://wiki.linuxfoundation.org/openprinting/cups-filters
  22. Source0: http://openprinting.org/download/cups-filters/cups-filters-%{version}.tar.xz
  23. Requires: cups
  24. Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
  25. # Obsolete cups-php (bug #971741)
  26. Obsoletes: cups-php < 1:1.6.0-1
  27. # Don't Provide it because we don't build the php module
  28. #Provides: cups-php = 1:1.6.0-1
  29. BuildRequires: cups-devel
  30. # pdftopdf
  31. BuildRequires: qpdf-devel
  32. # pdftops
  33. BuildRequires: poppler-utils
  34. # pdftoijs, pdftoopvp, pdftoraster, gstoraster
  35. BuildRequires: poppler-devel
  36. BuildRequires: libjpeg-devel
  37. BuildRequires: libpng-devel
  38. BuildRequires: libtiff-devel
  39. BuildRequires: zlib-devel
  40. BuildRequires: pkgconfig dbus-devel
  41. # libijs
  42. BuildRequires: ghostscript-devel
  43. BuildRequires: freetype2-devel
  44. BuildRequires: fontconfig-devel
  45. BuildRequires: lcms2-devel
  46. # cups-browsed
  47. BuildRequires: avahi-devel avahi-glib-devel
  48. # Make sure we get postscriptdriver tags.
  49. BuildRequires: python-cups
  50. # Testing font for test scripts.
  51. BuildRequires: TrueType-dejavu
  52. # autogen.sh
  53. BuildRequires: autoconf
  54. BuildRequires: automake
  55. BuildRequires: libtool
  56. Requires: poppler-utils
  57. # pstopdf
  58. Requires: bc grep sed
  59. # cups-browsed
  60. #Requires(post): systemd
  61. #Requires(preun): systemd
  62. #Requires(postun): systemd
  63. # Ghostscript CUPS filters live here since Ghostscript 9.08.
  64. Provides: ghostscript-cups = 9.08
  65. Obsoletes: ghostscript-cups < 9.08
  66. %package libs
  67. Summary: OpenPrinting CUPS filters and backends - cupsfilters and fontembed libraries
  68. Group: System Environment/Libraries
  69. # LGPLv2: libcupsfilters
  70. # MIT: libfontembed
  71. License: LGPLv2 and MIT
  72. %package devel
  73. Summary: OpenPrinting CUPS filters and backends - development environment
  74. Group: Development/Libraries
  75. License: LGPLv2 and MIT
  76. Requires: cups-filters-libs%{?_isa} = %{version}-%{release}
  77. %description
  78. Contains backends, filters, and other software that was
  79. once part of the core CUPS distribution but is no longer maintained by
  80. Apple Inc. In addition it contains additional filters developed
  81. independently of Apple, especially filters for the PDF-centric printing
  82. workflow introduced by OpenPrinting.
  83. %description libs
  84. This package provides cupsfilters and fontembed libraries.
  85. %description devel
  86. This is the development package for OpenPrinting CUPS filters and backends.
  87. %prep
  88. %setup -q
  89. %build
  90. # work-around Rpath
  91. ./autogen.sh
  92. # --with-pdftops=hybrid - use Poppler's pdftops instead of Ghostscript for
  93. # Brother, Minolta, and Konica Minolta to work around
  94. # bugs in the printer's PS interpreters
  95. # --with-rcdir=no - don't install SysV init script
  96. export IJS_CFLAGS="-I/usr/include/ijs"
  97. export IJS_LIBS="-lijs"
  98. %configure --disable-static \
  99. --disable-silent-rules \
  100. --disable-mutool \
  101. --with-pdftops=hybrid \
  102. --enable-dbus \
  103. --with-rcdir=%{_sysconfdir} \
  104. --with-test-font-path=/usr/share/fonts/TrueType-dejavu/DejaVuSans.ttf
  105. make %{?_smp_mflags}
  106. %install
  107. make install DESTDIR=%{buildroot}
  108. # https://fedoraproject.org/wiki/Packaging_tricks#With_.25doc
  109. mkdir __doc
  110. mv %{buildroot}%{_datadir}/doc/cups-filters/* __doc
  111. rm -rf %{buildroot}%{_datadir}/doc/cups-filters
  112. # Don't ship libtool la files.
  113. rm -f %{buildroot}%{_libdir}/lib*.la
  114. # Not sure what is this good for.
  115. rm -f %{buildroot}%{_bindir}/ttfread
  116. # systemd unit file
  117. #mkdir -p %{buildroot}%{_unitdir}
  118. #install -p -m 644 utils/cups-browsed.service %{buildroot}%{_unitdir}
  119. # SysV initscripts
  120. rm -rf %{buildroot}%{_sysconfdir}/rc{0,2,3,5}.d
  121. rm -rf %{buildroot}%{_sysconfdir}/rc.d
  122. mkdir -p %{buildroot}%{_sysconfdir}/rc.d
  123. mv -f %{buildroot}%{_sysconfdir}/init.d %{buildroot}%{_sysconfdir}/rc.d/
  124. for f in %{buildroot}%{_cups_serverbin}/filter/*; do
  125. if [ -f $f ]; then
  126. chmod 755 $f
  127. fi
  128. done
  129. %check
  130. make check
  131. %post
  132. #%systemd_post cups-browsed.service
  133. # Initial installation
  134. if [ $1 -eq 1 ] ; then
  135. IN=%{_sysconfdir}/cups/cupsd.conf
  136. OUT=%{_sysconfdir}/cups/cups-browsed.conf
  137. keyword=BrowsePoll
  138. # We can remove this after few releases, it's just for the introduction of cups-browsed.
  139. if [ -f "$OUT" ]; then
  140. echo -e "\n# NOTE: This file is not part of CUPS. You need to start & enable cups-browsed service." >> "$OUT"
  141. fi
  142. # move BrowsePoll from cupsd.conf to cups-browsed.conf
  143. if [ -f "$IN" ] && grep -iq ^$keyword "$IN"; then
  144. if ! grep -iq ^$keyword "$OUT"; then
  145. (cat >> "$OUT" <<EOF
  146. # Settings automatically moved from cupsd.conf by RPM package:
  147. EOF
  148. ) || :
  149. (grep -i ^$keyword "$IN" >> "$OUT") || :
  150. #systemctl enable cups-browsed.service >/dev/null 2>&1 || :
  151. fi
  152. sed -i -e "s,^$keyword,#$keyword directive moved to cups-browsed.conf\n#$keyword,i" "$IN" || :
  153. fi
  154. fi
  155. %preun
  156. #%systemd_preun cups-browsed.service
  157. %postun
  158. #%systemd_postun_with_restart cups-browsed.service
  159. %post libs
  160. /sbin/ldconfig
  161. %postun libs
  162. /sbin/ldconfig
  163. %files
  164. %license COPYING
  165. %doc __doc/README __doc/AUTHORS __doc/NEWS
  166. %config(noreplace) %{_sysconfdir}/cups/cups-browsed.conf
  167. %{_bindir}/driverless
  168. %{_bindir}/foomatic-rip
  169. %attr(-,root,root) %{_cups_serverbin}/filter/*
  170. %exclude %{_cups_serverbin}/filter/pdftoraster
  171. %attr(0755,root,root) %{_cups_serverbin}/backend/beh
  172. %attr(0755,root,root) %{_cups_serverbin}/backend/cups-brf
  173. %attr(0755,root,root) %{_cups_serverbin}/backend/driverless
  174. %attr(0755,root,root) %{_cups_serverbin}/backend/implicitclass
  175. %attr(0755,root,root) %{_cups_serverbin}/backend/parallel
  176. # Serial backend needs to run as root (bug #212577#c4).
  177. %attr(0700,root,root) %{_cups_serverbin}/backend/serial
  178. %attr(0755,root,root) %{_cups_serverbin}/driver/driverless
  179. %{_datadir}/cups/banners
  180. %{_datadir}/cups/braille
  181. %{_datadir}/cups/charsets
  182. %{_datadir}/cups/data/*
  183. # this needs to be in the main package because of cupsfilters.drv
  184. %{_datadir}/cups/drv/*
  185. %{_datadir}/cups/mime/*
  186. %{_datadir}/ppd/*
  187. %{_datadir}/cups/ppdc/*
  188. %{_sbindir}/cups-browsed
  189. #%{_unitdir}/cups-browsed.service
  190. %{_initdir}/cups-browsed
  191. %{_mandir}/man1/driverless.1.gz
  192. %{_mandir}/man1/foomatic-rip.1.gz
  193. %{_mandir}/man8/cups-browsed.8.gz
  194. %{_mandir}/man5/cups-browsed.conf.5.gz
  195. %files libs
  196. %license __doc/COPYING
  197. %doc fontembed/README
  198. %{_libdir}/libcupsfilters.so.*
  199. %{_libdir}/libfontembed.so.*
  200. %files devel
  201. %{_includedir}/cupsfilters
  202. %{_includedir}/fontembed
  203. %{_datadir}/cups/ppdc/escp.h
  204. %{_libdir}/pkgconfig/libcupsfilters.pc
  205. %{_libdir}/pkgconfig/libfontembed.pc
  206. %{_libdir}/libcupsfilters.so
  207. %{_libdir}/libfontembed.so
  208. %changelog
  209. * Mon Oct 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.25.11-1
  210. - new upstream release.
  211. - built with poppler-0.81.0.
  212. * Tue Sep 04 2018 Toshiaki Ara <ara_t@384.jp> 1.18.0-3
  213. - rebuild with qpdf-8.1.0
  214. * Tue Jan 30 2018 Toshiaki Ara <ara_t@384.jp> 1.18.0-2
  215. - rebuild with qpdf-7.0.1
  216. * Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.18.0-1
  217. - new upstream release.
  218. * Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.0-1
  219. - new upstream release.
  220. * Tue May 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.3-2
  221. - rebuilt with poppler-0.43.0.
  222. * Tue May 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.3-1
  223. - new upstream release.
  224. * Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.76-3
  225. - rebuild with poppler-0.43.0
  226. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.76-2
  227. - rebuild with poppler-0.37.0
  228. * Sun Oct 4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.76-1
  229. - new upstream release.
  230. * Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.54-2
  231. - rebuild with poppler-0.26.2
  232. * Sun Jun 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.54-1
  233. - new upstream release.
  234. * Fri May 16 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.53-1
  235. - update to 1.0.53
  236. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.43-1
  237. - new upstream release.
  238. - initial build for Vine Linux.
  239. * Tue Nov 19 2013 Tim Waugh <twaugh@redhat.com> - 1.0.41-4
  240. - Adjust filter costs so application/vnd.adobe-read-postscript input
  241. doesn't go via pstotiff (bug #1008166).
  242. * Thu Nov 14 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.41-3
  243. - Fix memory leaks in cups-browsed (bug #1027317).
  244. * Wed Nov 6 2013 Tim Waugh <twaugh@redhat.com> - 1.0.41-2
  245. - Include dbus so that colord support works (bug #1026928).
  246. * Wed Oct 30 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.41-1
  247. - 1.0.41 - PPD-less printing support
  248. * Mon Oct 21 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-4
  249. - Fix socket leaks in the BrowsePoll code (bug #1021512).
  250. * Wed Oct 16 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-3
  251. - Ship the gstoraster MIME conversion rule now we provide that filter
  252. (bug #1019261).
  253. * Fri Oct 11 2013 Tim Waugh <twaugh@redhat.com> - 1.0.40-2
  254. - Fix PDF landscape printing (bug #768811).
  255. * Fri Oct 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.40-1
  256. - 1.0.40
  257. - Use new "hybrid" pdftops renderer.
  258. * Thu Oct 03 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.39-1
  259. - 1.0.39
  260. - Removed obsolete patches "pdf-landscape" and "browsepoll-notifications"
  261. * Tue Oct 1 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-4
  262. - Use IPP notifications for BrowsePoll when possible (bug #975241).
  263. * Tue Oct 1 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-3
  264. - Fixes for some printf-type format mismatches (bug #1014093).
  265. * Tue Sep 17 2013 Tim Waugh <twaugh@redhat.com> - 1.0.38-2
  266. - Fix landscape printing for PDFs (bug #768811).
  267. * Wed Sep 04 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.38-1
  268. - 1.0.38
  269. * Thu Aug 29 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.37-1
  270. - 1.0.37.
  271. * Tue Aug 27 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.36-5
  272. - Added build dependency - font required for running tests
  273. * Tue Aug 27 2013 Jaromír Končický <jkoncick@redhat.com> - 1.0.36-4
  274. - Added checking phase (make check)
  275. * Wed Aug 21 2013 Tim Waugh <twaugh@redhat.com> - 1.0.36-3
  276. - Upstream patch to re-work filter costs (bug #998977). No longer need
  277. text filter costs patch as paps gets used by default now if
  278. installed.
  279. * Mon Aug 19 2013 Marek Kasik <mkasik@redhat.com> - 1.0.36-2
  280. - Rebuild (poppler-0.24.0)
  281. * Tue Aug 13 2013 Tim Waugh <twaugh@redhat.com> - 1.0.36-1
  282. - 1.0.36.
  283. * Tue Aug 13 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-7
  284. - Upstream patch to move in filters from ghostscript.
  285. * Tue Jul 30 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-6
  286. - Set cost for text filters to 200 so that the paps filter gets
  287. preference for the time being (bug #988909).
  288. * Wed Jul 24 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-5
  289. - Handle page-label when printing n-up as well.
  290. * Tue Jul 23 2013 Tim Waugh <twaugh@redhat.com> - 1.0.35-4
  291. - Added support for page-label (bug #987515).
  292. * Thu Jul 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-3
  293. - Rebuild (qpdf-5.0.0)
  294. * Mon Jul 01 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-2
  295. - add cups-browsed(8) and cups-browsed.conf(5)
  296. - don't reverse lookup IP address in URI (#975822)
  297. * Wed Jun 26 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.35-1
  298. - 1.0.35
  299. * Mon Jun 24 2013 Marek Kasik <mkasik@redhat.com> - 1.0.34-9
  300. - Rebuild (poppler-0.22.5)
  301. * Wed Jun 19 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-8
  302. - fix the note we add in cups-browsed.conf
  303. * Wed Jun 12 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-7
  304. - Obsolete cups-php (#971741)
  305. * Wed Jun 05 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-6
  306. - one more cups-browsed leak fixed (#959682)
  307. * Wed Jun 05 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-5
  308. - perl is actually not required by pstopdf, because the calling is in dead code
  309. * Mon Jun 03 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-4
  310. - fix resource leaks and other problems found by Coverity & Valgrind (#959682)
  311. * Wed May 15 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-3
  312. - ship ppdc/pcl.h because of cupsfilters.drv
  313. * Tue May 07 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-2
  314. - pstopdf requires bc (#960315)
  315. * Thu Apr 11 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.34-1
  316. - 1.0.34
  317. * Fri Apr 05 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.33-1
  318. - 1.0.33
  319. - removed cups-filters-1.0.32-null-info.patch, accepted by upstream
  320. * Thu Apr 04 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.32-2
  321. - fixed segfault when info is NULL
  322. * Thu Apr 04 2013 Fridolin Pokorny <fpokorny@redhat.com> - 1.0.32-1
  323. - 1.0.32
  324. * Fri Mar 29 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-3
  325. - add note to cups-browsed.conf
  326. * Thu Mar 28 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-2
  327. - check cupsd.conf existence prior to grepping it (#928816)
  328. * Fri Mar 22 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.31-1
  329. - 1.0.31
  330. * Tue Mar 19 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-4
  331. - revert previous change
  332. * Wed Mar 13 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-3
  333. - don't ship banners for now (#919489)
  334. * Tue Mar 12 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-2
  335. - move BrowsePoll from cupsd.conf to cups-browsed.conf in %%post
  336. * Fri Mar 08 2013 Jiri Popelka <jpopelka@redhat.com> - 1.0.30-1
  337. - 1.0.30: CUPS browsing and broadcasting in cups-browsed
  338. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.29-4
  339. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  340. * Sat Jan 19 2013 Rex Dieter <rdieter@fedoraproject.org> 1.0.29-3
  341. - backport upstream buildfix for poppler-0.22.x
  342. * Fri Jan 18 2013 Adam Tkac <atkac redhat com> - 1.0.29-2
  343. - rebuild due to "jpeg8-ABI" feature drop
  344. * Thu Jan 03 2013 Jiri Popelka <jpopelka@redhat.com> 1.0.29-1
  345. - 1.0.29
  346. * Wed Jan 02 2013 Jiri Popelka <jpopelka@redhat.com> 1.0.28-1
  347. - 1.0.28: cups-browsed daemon and service
  348. * Thu Nov 29 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.25-1
  349. - 1.0.25
  350. * Fri Sep 07 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.24-1
  351. - 1.0.24
  352. * Wed Aug 22 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.23-1
  353. - 1.0.23: old pdftopdf removed
  354. * Tue Aug 21 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.22-1
  355. - 1.0.22: new pdftopdf (uses qpdf instead of poppler)
  356. * Wed Aug 08 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-4
  357. - rebuild
  358. * Thu Aug 02 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-3
  359. - commented multiple licensing breakdown (#832130)
  360. - verbose build output
  361. * Thu Aug 02 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-2
  362. - BuildRequires: poppler-cpp-devel (to build against poppler-0.20)
  363. * Mon Jul 23 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.20-1
  364. - 1.0.20
  365. * Tue Jul 17 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.19-1
  366. - 1.0.19
  367. * Wed May 30 2012 Jiri Popelka <jpopelka@redhat.com> 1.0.18-1
  368. - initial spec file